aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/ecore/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/ecore/doc/Makefile.am')
-rw-r--r--libraries/ecore/doc/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/libraries/ecore/doc/Makefile.am b/libraries/ecore/doc/Makefile.am
new file mode 100644
index 0000000..09ce976
--- /dev/null
+++ b/libraries/ecore/doc/Makefile.am
@@ -0,0 +1,33 @@
1MAINTAINERCLEANFILES = Makefile.in ecore.dox
2
3.PHONY: doc
4
5PACKAGE_DOCNAME = $(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc
6
7if EFL_BUILD_DOC
8
9doc-clean:
10 rm -rf html/ latex/ man/ xml/ $(top_builddir)/$(PACKAGE_DOCNAME).tar*
11
12doc: all doc-clean
13 $(efl_doxygen)
14 cp $(srcdir)/img/* html/
15 cp $(srcdir)/img/* latex/
16 rm -rf $(PACKAGE_DOCNAME).tar*
17 mkdir -p $(PACKAGE_DOCNAME)/doc
18 cp -R html/ latex/ man/ $(PACKAGE_DOCNAME)/doc
19 tar cf $(PACKAGE_DOCNAME).tar $(PACKAGE_DOCNAME)/
20 bzip2 -9 $(PACKAGE_DOCNAME).tar
21 rm -rf $(PACKAGE_DOCNAME)/
22 mv $(PACKAGE_DOCNAME).tar.bz2 $(top_builddir)
23
24clean-local: doc-clean
25
26else
27
28doc:
29 @echo "Documentation not built. Run ./configure --help"
30
31endif
32
33EXTRA_DIST = Doxyfile.in $(wildcard img/*.*) e.css head.html foot.html ecore.dox.in