aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/eina/src/modules/mp/pass_through/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/eina/src/modules/mp/pass_through/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/eina/src/modules/mp/pass_through/Makefile.am')
-rw-r--r--libraries/eina/src/modules/mp/pass_through/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/libraries/eina/src/modules/mp/pass_through/Makefile.am b/libraries/eina/src/modules/mp/pass_through/Makefile.am
new file mode 100644
index 0000000..8f48974
--- /dev/null
+++ b/libraries/eina/src/modules/mp/pass_through/Makefile.am
@@ -0,0 +1,29 @@
1MAINTAINERCLEANFILES = Makefile.in
2
3AM_CPPFLAGS = \
4-I. \
5-I$(top_srcdir)/src/include \
6-I$(top_builddir)/src/include \
7-I$(top_srcdir)/src/lib \
8-I$(top_builddir)/src/lib \
9@EINA_CPPFLAGS@ \
10@EFL_EINA_BUILD@
11
12controllerdir = $(libdir)//eina/modules/mp/pass_through/$(MODULE_ARCH)
13controller_LTLIBRARIES = module.la
14
15module_la_SOURCES = \
16eina_pass_through.c
17
18module_la_CFLAGS = @EINA_CFLAGS@
19module_la_LIBADD = $(top_builddir)/src/lib/libeina.la @EINA_LIBS@
20module_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -module -avoid-version
21module_la_LIBTOOLFLAGS = --tag=disable-static
22
23install-data-hook:
24 rm -f $(DESTDIR)$(controllerdir)/$(controller_LTLIBRARIES)
25uninstall-hook:
26 rm -f $(DESTDIR)$(controllerdir)/module.*
27
28clean-local:
29 rm -rf *.gcno