aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/edje/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/edje/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/edje/Makefile.am')
-rw-r--r--libraries/edje/Makefile.am101
1 files changed, 101 insertions, 0 deletions
diff --git a/libraries/edje/Makefile.am b/libraries/edje/Makefile.am
new file mode 100644
index 0000000..4d02ab0
--- /dev/null
+++ b/libraries/edje/Makefile.am
@@ -0,0 +1,101 @@
1ACLOCAL_AMFLAGS = -I m4
2
3SUBDIRS = data src utils doc
4
5MAINTAINERCLEANFILES = \
6Makefile.in \
7aclocal.m4 \
8compile \
9config.guess \
10config.h.in \
11config.h.in~ \
12config.sub \
13configure \
14depcomp \
15install-sh \
16ltmain.sh \
17missing \
18$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \
19$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \
20$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \
21m4/libtool.m4 \
22m4/lt~obsolete.m4 \
23m4/ltoptions.m4 \
24m4/ltsugar.m4 \
25m4/ltversion.m4
26
27### this is all fine and great - but edje should not be going and installing
28### data in another software's data dir - it's just wrong. not to mention this
29### also breaks make distcheck...
30# if test "x${vimdir}" != "x"; then \
31# $(mkinstalldirs) $(DESTDIR)$(vimdir)/syntax; \
32# cp -p $(srcdir)/data/edc.vim $(DESTDIR)$(vimdir)/syntax/; \
33# fi
34
35bin_SCRIPTS =
36
37EXTRA_DIST = \
38AUTHORS \
39COPYING \
40autogen.sh \
41edje.pc.in \
42edje.spec \
43edje.spec.in \
44README
45
46pkgconfigdir = $(libdir)/pkgconfig
47pkgconfig_DATA = edje.pc
48
49.PHONY: doc coverage
50
51# Documentation
52
53doc:
54 @echo "entering doc/"
55 make -C doc doc
56
57# Unit tests
58
59if EFL_ENABLE_TESTS
60
61check-local:
62 @./src/tests/edje_suite
63
64else
65
66check-local:
67 @echo "reconfigure with --enable-tests"
68
69endif
70
71# Coverage report
72
73if EFL_ENABLE_COVERAGE
74lcov-reset:
75 @rm -rf coverage
76 @find . -name "*.gcda" -exec rm {} \;
77 @lcov --directory . --zerocounters
78
79lcov-report:
80 @mkdir coverage
81 @lcov --compat-libtool --directory $(top_srcdir)/src --capture --output-file coverage/coverage.info
82 @lcov -l coverage/coverage.info |grep "\\.h" |cut -d " " -f 2 > coverage/remove
83 @lcov -r coverage/coverage.info `cat coverage/remove` > coverage/coverage.cleaned.info
84 @rm coverage/remove
85 @mv coverage/coverage.cleaned.info coverage/coverage.info
86 @genhtml -t "$(PACKAGE_STRING)" -o coverage coverage/coverage.info
87
88coverage:
89 @make lcov-reset
90 @make check
91 @make lcov-report
92else
93lcov-reset:
94 @echo "reconfigure with --enable-coverage"
95
96lcov-report:
97 @echo "reconfigure with --enable-coverage"
98
99coverage:
100 @echo "reconfigure with --enable-tests --enable-coverage"
101endif