aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/ecore/src/tests/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/ecore/src/tests/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/ecore/src/tests/Makefile.am')
-rw-r--r--libraries/ecore/src/tests/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/libraries/ecore/src/tests/Makefile.am b/libraries/ecore/src/tests/Makefile.am
new file mode 100644
index 0000000..bfd20d9
--- /dev/null
+++ b/libraries/ecore/src/tests/Makefile.am
@@ -0,0 +1,37 @@
1MAINTAINERCLEANFILES = Makefile.in
2
3AM_CPPFLAGS = \
4-I$(top_srcdir)/src/lib/ecore \
5-I$(top_srcdir)/src/lib/ecore_con \
6-I$(top_srcdir)/src/lib/ecore_x \
7@EINA_CFLAGS@ \
8@CHECK_CFLAGS@
9
10if EFL_ENABLE_TESTS
11
12noinst_PROGRAMS = ecore_suite
13
14check_PROGRAMS = ecore_suite
15
16ecore_suite_SOURCES = \
17ecore_suite.c \
18ecore_test_ecore.c \
19ecore_test_ecore_con.c \
20ecore_test_ecore_x.c \
21ecore_suite.h
22
23ecore_suite_LDADD = \
24@CHECK_LIBS@ \
25@EINA_LIBS@ \
26$(top_builddir)/src/lib/ecore/libecore.la \
27$(top_builddir)/src/lib/ecore_con/libecore_con.la
28
29if BUILD_ECORE_X
30ecore_suite_LDADD += \
31$(top_builddir)/src/lib/ecore_x/libecore_x.la
32endif
33
34endif
35
36clean-local:
37 rm -rf *.gcno *.gcda