aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/ecore/src/lib/ecore_imf/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/ecore/src/lib/ecore_imf/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/ecore/src/lib/ecore_imf/Makefile.am')
-rw-r--r--libraries/ecore/src/lib/ecore_imf/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/libraries/ecore/src/lib/ecore_imf/Makefile.am b/libraries/ecore/src/lib/ecore_imf/Makefile.am
new file mode 100644
index 0000000..10f6c2f
--- /dev/null
+++ b/libraries/ecore/src/lib/ecore_imf/Makefile.am
@@ -0,0 +1,28 @@
1MAINTAINERCLEANFILES = Makefile.in
2
3AM_CPPFLAGS = \
4-I$(top_srcdir)/src/lib/ecore \
5-DPACKAGE_LIB_DIR=\"$(libdir)\" \
6@EFL_ECORE_IMF_BUILD@ \
7@EVIL_CFLAGS@ \
8@EINA_CFLAGS@
9
10AM_CFLAGS = @WIN32_CFLAGS@
11
12lib_LTLIBRARIES = libecore_imf.la
13includes_HEADERS = Ecore_IMF.h
14includesdir = $(includedir)/ecore-@VMAJ@
15
16libecore_imf_la_SOURCES = \
17ecore_imf.c \
18ecore_imf_context.c \
19ecore_imf_module.c
20
21libecore_imf_la_LIBADD = \
22$(top_builddir)/src/lib/ecore/libecore.la \
23@EINA_LIBS@ \
24@EVIL_LIBS@
25
26libecore_imf_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @release_info@
27
28EXTRA_DIST = ecore_imf_private.h