aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/OpenSim/Services/Connectors/GridUser/GridUserServiceConnector.cs (unfollow)
Commit message (Collapse)AuthorFilesLines
2012-05-09Where necessary, rename OpenSim/Services/Connectors/*.cs files to reflect ↵Justin Clark-Casey (justincc)1-290/+0
the actual class names. This is usually because the file name was singular (*Service*) but the class name was plural (*Services*). This is to make configuration easier rather than having to look in the c# code itself to find the slightly different name of the connector. This does not affect existing configuration since the files are being renamed rather than the classes.
2012-02-07Add url to logging if SynchronousRestFormsRequester.MakRequest() throws an ↵Justin Clark-Casey (justincc)1-6/+9
exception in service connectors
2012-01-16Allow retrival of multiple user records in one operation, analog to presenceMelanie1-0/+60
2011-04-12Moved 3 request handlers from OpenSim.Framework.Servers.HttpServer up to ↵Diva Canto1-1/+0
OpenSim.Framework -- just pasted them in WebUtil. This is so that code that uses the Service connectors don't need to include the HttpServer dll -- that was odd.
2010-09-29Part two of the previous commit, making IGridUserService.LoggedOut() more ↵John Hurliman1-1/+1
flexible without changing current behavior
2010-09-29Made IGridUserService.SetLastPosition() more flexible to allow different ↵John Hurliman1-1/+1
possible implementations. This doesn't change any behavior or any Robust code, but it simplifies the SimianGrid connector by using the standard OpenSim interface for setting last position now
2010-06-05* Bug fix in TP home: typo in unpacking of GridUserInfo.Diva Canto1-2/+0
* Bug fix in TPs across neighboring regions: bug was introduced when getting rid of crashed sessions.
2010-05-20Removed sessionID from GridUserservice again. Removed parcel crossing ↵Diva Canto1-2/+2
detection from Robust connector. Fixed Simian to continue to send those location updates upon parcel crossing, without changing the interface.
2010-05-20* Added sessionID to IGridUserService.SetLastPosition(), as some connectors ↵unknown1-1/+1
will want to track position against sessionID instead of userID * Updated SimianPresenceServiceConnector to use the new LoggedOut/SetHome/etc methods and only update session position on parcel crossing
2010-05-07GridUserService in place. Replaces the contrived concept of storing user's ↵Diva Canto1-2/+194
home and position info in the presence service. WARNING: I violated a taboo by deleting 2 migration files and simplifying the original table creation for Presence. This should not cause any problems to anyone, though. Things will work with the new simplified table, as well as with the previous contrived one. If there are any problems, solving them is as easy as dropping the presence table and deleting its row in the migrations table. The presence info only exists during a user's session anyway. BTW, the Meshing files want to be committed too -- EOFs.
2010-03-10Formatting cleanup. Add copyright notices.Jeff Ames1-2/+2
2010-03-05Justin, I must have been dyslexic when I wrote UserGridService as the name ↵Diva Canto1-2/+2
for it. GridUserService makes more sense; it's the user of the grid, "grid user". I changed it everywhere.
2010-03-05add initial UserGrid service classes as per diva's directionJustin Clark-Casey (justincc)1-6/+7
this will initially store home location data instead of the presence service compiles but not enough to actually test yet
2009-06-01Minor: Change OpenSim to OpenSimulator in older copyright headers and ↵Jeff Ames1-1/+1
LICENSE.txt.
2009-02-06This changeset is the step 1 of 2 in refactoringDr Scofield1-1/+1
OpenSim.Region.Environment into a "framework" part and a modules only part. This first changeset refactors OpenSim.Region.Environment.Scenes, OpenSim.Region.Environment.Interfaces, and OpenSim.Region.Interfaces into OpenSim.Region.Framework.{Interfaces,Scenes} leaving only region modules in OpenSim.Region.Environment. The next step will be to move region modules up from OpenSim.Region.Environment.Modules to OpenSim.Region.CoreModules and then sort out which modules are really core modules and which should move out to forge. I've been very careful to NOT BREAK anything. i hope i've succeeded. as this is the work of a whole week i hope i managed to keep track with the applied patches of the last week --- could any of you that did check in stuff have a look at whether it survived? thx!
2008-04-21* Optimised using statements and namespace references across entire project ↵Adam Frisby1-6/+0
(this took a while to run).
2008-04-17Update svn properties. Add copyright info to some source files.Jeff Ames1-1/+28
2008-03-31Update svn properties.Jeff Ames1-16/+16
2008-03-30**Big ass update warning**Adam Frisby1-0/+16
* Renamed plugin console message, to send a message to a plugin, use either "plugin <message>", or any unrecognised message will be sent ("plugin" sends explicitly) This replaces the old "script <message>". * Terrain commands - "terrain <command>" now works again. "Script terrain <command>" does not. Many of the commands have now been reimplemented, eg load-tile. However some have new syntax. * New console command handler, you can now use things like "terrain help" or "terrain save help". See TerrainModule.cs for an example of how to use the new "Commander" class. * Commander class - advanced processing of console input and also enables a script API to be generated from registered console commands.