diff options
Diffstat (limited to 'libraries/ode-0.9/ode/src/Makefile.am')
-rw-r--r-- | libraries/ode-0.9/ode/src/Makefile.am | 207 |
1 files changed, 207 insertions, 0 deletions
diff --git a/libraries/ode-0.9/ode/src/Makefile.am b/libraries/ode-0.9/ode/src/Makefile.am new file mode 100644 index 0000000..1b0cf19 --- /dev/null +++ b/libraries/ode-0.9/ode/src/Makefile.am | |||
@@ -0,0 +1,207 @@ | |||
1 | AM_CXXFLAGS = @ARCHFLAGS@ -I$(top_srcdir)/include -I$(top_builddir)/include | ||
2 | AM_CPPFLAGS = @ARCHFLAGS@ -I$(top_srcdir)/include -I$(top_builddir)/include | ||
3 | AM_CFLAGS = @ARCHFLAGS@ -I$(top_srcdir)/include -I$(top_builddir)/include | ||
4 | lib_LIBRARIES = libode.a | ||
5 | libode_a_CPPFLAGS = -O2 | ||
6 | |||
7 | libode_a_CPPFLAGS += -fPIC | ||
8 | |||
9 | # Fake an executable in order to get a shared library | ||
10 | # Note the elegant and cunning way to trick Autotools to install a program | ||
11 | # in a lib directory. --Rodrigo | ||
12 | traplibdir=$(libdir) | ||
13 | EXEEXT=@so_ext@ | ||
14 | traplib_PROGRAMS=libode | ||
15 | libode_SOURCES= | ||
16 | libode_DEPENDENCIES = libfast.a libode.a | ||
17 | libode_LDFLAGS= @SHARED_LDFLAGS@ | ||
18 | if USE_SONAME | ||
19 | libode_LDFLAGS+=-Wl,-soname,@ODE_SONAME@ | ||
20 | endif | ||
21 | libode_LDADD=$(libode_a_OBJECTS) $(libfast_a_OBJECTS) | ||
22 | |||
23 | if OPCODE | ||
24 | libode_DEPENDENCIES+= libOPCODE.a | ||
25 | libode_LDADD+=$(libOPCODE_a_OBJECTS) | ||
26 | endif | ||
27 | |||
28 | |||
29 | if GIMPACT | ||
30 | libode_DEPENDENCIES+= libGIMPACT.a | ||
31 | libode_LDADD+=$(libGIMPACT_a_OBJECTS) | ||
32 | endif | ||
33 | |||
34 | |||
35 | # convenience library to simulate per object cflags | ||
36 | noinst_LIBRARIES= libfast.a | ||
37 | libfast_a_CFLAGS= -O1 | ||
38 | libfast_a_SOURCES= fastldlt.c fastltsolve.c fastdot.c fastlsolve.c | ||
39 | |||
40 | libfast_a_CFLAGS += -fPIC | ||
41 | |||
42 | libode_a_DEPENDENCIES = libfast.a | ||
43 | libode_a_LIBADD= $(libfast_a_OBJECTS) | ||
44 | |||
45 | libode_a_SOURCES = objects.h \ | ||
46 | obstack.cpp \ | ||
47 | collision_util.cpp \ | ||
48 | obstack.h \ | ||
49 | array.cpp \ | ||
50 | collision_util.h \ | ||
51 | ode.cpp \ | ||
52 | array.h \ | ||
53 | error.cpp \ | ||
54 | odemath.cpp \ | ||
55 | collision_kernel.cpp \ | ||
56 | export-dif.cpp \ | ||
57 | quickstep.cpp \ | ||
58 | collision_kernel.h \ | ||
59 | quickstep.h \ | ||
60 | collision_quadtreespace.cpp \ | ||
61 | rotation.cpp \ | ||
62 | collision_space.cpp \ | ||
63 | collision_space_internal.h \ | ||
64 | collision_cylinder_box.cpp \ | ||
65 | collision_cylinder_sphere.cpp \ | ||
66 | collision_cylinder_plane.cpp \ | ||
67 | sphere.cpp \ | ||
68 | box.cpp \ | ||
69 | capsule.cpp \ | ||
70 | plane.cpp \ | ||
71 | ray.cpp \ | ||
72 | cylinder.cpp \ | ||
73 | convex.cpp \ | ||
74 | joint.cpp \ | ||
75 | stack.h \ | ||
76 | collision_std.h \ | ||
77 | joint.h \ | ||
78 | step.cpp \ | ||
79 | collision_transform.cpp \ | ||
80 | lcp.cpp \ | ||
81 | step.h \ | ||
82 | collision_transform.h \ | ||
83 | lcp.h \ | ||
84 | stepfast.cpp \ | ||
85 | mass.cpp \ | ||
86 | testing.cpp \ | ||
87 | mat.cpp \ | ||
88 | testing.h \ | ||
89 | mat.h \ | ||
90 | timer.cpp \ | ||
91 | matrix.cpp \ | ||
92 | util.cpp \ | ||
93 | memory.cpp \ | ||
94 | util.h \ | ||
95 | misc.cpp \ | ||
96 | heightfield.cpp \ | ||
97 | heightfield.h | ||
98 | |||
99 | |||
100 | |||
101 | ################################### | ||
102 | # G I M P A C T S T U F F | ||
103 | ################################### | ||
104 | |||
105 | |||
106 | if GIMPACT | ||
107 | noinst_LIBRARIES+= libGIMPACT.a | ||
108 | libGIMPACT_a_CPPFLAGS= -O2 -fno-strict-aliasing -fPIC | ||
109 | |||
110 | libode_a_SOURCES+= collision_trimesh_gimpact.cpp | ||
111 | |||
112 | libGIMPACT_a_SOURCES = \ | ||
113 | @TOPDIR@/GIMPACT/src/gim_boxpruning.cpp \ | ||
114 | @TOPDIR@/GIMPACT/src/gim_contact.cpp \ | ||
115 | @TOPDIR@/GIMPACT/src/gim_math.cpp \ | ||
116 | @TOPDIR@/GIMPACT/src/gim_memory.cpp \ | ||
117 | @TOPDIR@/GIMPACT/src/gim_tri_tri_overlap.cpp \ | ||
118 | @TOPDIR@/GIMPACT/src/gim_trimesh.cpp \ | ||
119 | @TOPDIR@/GIMPACT/src/gim_trimesh_capsule_collision.cpp \ | ||
120 | @TOPDIR@/GIMPACT/src/gim_trimesh_ray_collision.cpp \ | ||
121 | @TOPDIR@/GIMPACT/src/gim_trimesh_sphere_collision.cpp \ | ||
122 | @TOPDIR@/GIMPACT/src/gim_trimesh_trimesh_collision.cpp \ | ||
123 | @TOPDIR@/GIMPACT/src/gimpact.cpp | ||
124 | |||
125 | libode_a_DEPENDENCIES+=libGIMPACT.a | ||
126 | libode_a_LIBADD+= $(libGIMPACT_a_OBJECTS) | ||
127 | AM_CXXFLAGS += -I@TOPDIR@/GIMPACT/include -DdTRIMESH_ENABLED -DdTRIMESH_GIMPACT | ||
128 | AM_CFLAGS += -I@TOPDIR@/GIMPACT/include -DdTRIMESH_ENABLED -DdTRIMESH_GIMPACT | ||
129 | |||
130 | libode_a_SOURCES+= collision_trimesh_trimesh.cpp \ | ||
131 | collision_trimesh_sphere.cpp \ | ||
132 | collision_trimesh_ray.cpp \ | ||
133 | collision_trimesh_opcode.cpp \ | ||
134 | collision_trimesh_box.cpp \ | ||
135 | collision_trimesh_ccylinder.cpp \ | ||
136 | collision_trimesh_distance.cpp \ | ||
137 | collision_trimesh_internal.h \ | ||
138 | collision_cylinder_trimesh.cpp \ | ||
139 | collision_trimesh_plane.cpp | ||
140 | endif | ||
141 | |||
142 | |||
143 | |||
144 | ################################# | ||
145 | # O P C O D E S T U F F | ||
146 | ################################# | ||
147 | |||
148 | |||
149 | if OPCODE | ||
150 | noinst_LIBRARIES+= libOPCODE.a | ||
151 | libOPCODE_a_CPPFLAGS= -O2 -fno-strict-aliasing -fPIC | ||
152 | |||
153 | |||
154 | libOPCODE_a_SOURCES= @TOPDIR@/OPCODE/OPC_AABBCollider.cpp \ | ||
155 | @TOPDIR@/OPCODE/OPC_AABBTree.cpp \ | ||
156 | @TOPDIR@/OPCODE/OPC_BaseModel.cpp \ | ||
157 | @TOPDIR@/OPCODE/OPC_BoxPruning.cpp \ | ||
158 | @TOPDIR@/OPCODE/OPC_Collider.cpp \ | ||
159 | @TOPDIR@/OPCODE/OPC_Common.cpp \ | ||
160 | @TOPDIR@/OPCODE/OPC_HybridModel.cpp \ | ||
161 | @TOPDIR@/OPCODE/OPC_LSSCollider.cpp \ | ||
162 | @TOPDIR@/OPCODE/OPC_MeshInterface.cpp \ | ||
163 | @TOPDIR@/OPCODE/OPC_Model.cpp \ | ||
164 | @TOPDIR@/OPCODE/OPC_OBBCollider.cpp \ | ||
165 | @TOPDIR@/OPCODE/Opcode.cpp \ | ||
166 | @TOPDIR@/OPCODE/OPC_OptimizedTree.cpp \ | ||
167 | @TOPDIR@/OPCODE/OPC_Picking.cpp \ | ||
168 | @TOPDIR@/OPCODE/OPC_PlanesCollider.cpp \ | ||
169 | @TOPDIR@/OPCODE/OPC_RayCollider.cpp \ | ||
170 | @TOPDIR@/OPCODE/OPC_SphereCollider.cpp \ | ||
171 | @TOPDIR@/OPCODE/OPC_SweepAndPrune.cpp \ | ||
172 | @TOPDIR@/OPCODE/OPC_TreeBuilders.cpp \ | ||
173 | @TOPDIR@/OPCODE/OPC_TreeCollider.cpp \ | ||
174 | @TOPDIR@/OPCODE/OPC_VolumeCollider.cpp \ | ||
175 | @TOPDIR@/OPCODE/Ice/IceAABB.cpp \ | ||
176 | @TOPDIR@/OPCODE/Ice/IceContainer.cpp \ | ||
177 | @TOPDIR@/OPCODE/Ice/IceHPoint.cpp \ | ||
178 | @TOPDIR@/OPCODE/Ice/IceIndexedTriangle.cpp \ | ||
179 | @TOPDIR@/OPCODE/Ice/IceMatrix3x3.cpp \ | ||
180 | @TOPDIR@/OPCODE/Ice/IceMatrix4x4.cpp \ | ||
181 | @TOPDIR@/OPCODE/Ice/IceOBB.cpp \ | ||
182 | @TOPDIR@/OPCODE/Ice/IcePlane.cpp \ | ||
183 | @TOPDIR@/OPCODE/Ice/IcePoint.cpp \ | ||
184 | @TOPDIR@/OPCODE/Ice/IceRandom.cpp \ | ||
185 | @TOPDIR@/OPCODE/Ice/IceRay.cpp \ | ||
186 | @TOPDIR@/OPCODE/Ice/IceRevisitedRadix.cpp \ | ||
187 | @TOPDIR@/OPCODE/Ice/IceSegment.cpp \ | ||
188 | @TOPDIR@/OPCODE/Ice/IceTriangle.cpp \ | ||
189 | @TOPDIR@/OPCODE/Ice/IceUtils.cpp | ||
190 | libode_a_DEPENDENCIES+=libOPCODE.a | ||
191 | |||
192 | libode_a_LIBADD+= $(libOPCODE_a_OBJECTS) | ||
193 | AM_CXXFLAGS += -I@TOPDIR@/OPCODE -I@TOPDIR@/OPCODE/Ice -DdTRIMESH_ENABLED -DdTRIMESH_OPCODE | ||
194 | AM_CFLAGS += -I@TOPDIR@/OPCODE -I@TOPDIR@/OPCODE/Ice -DdTRIMESH_ENABLED -DdTRIMESH_OPCODE | ||
195 | libode_a_SOURCES+= collision_trimesh_trimesh.cpp \ | ||
196 | collision_trimesh_sphere.cpp \ | ||
197 | collision_trimesh_ray.cpp \ | ||
198 | collision_trimesh_opcode.cpp \ | ||
199 | collision_trimesh_box.cpp \ | ||
200 | collision_trimesh_ccylinder.cpp \ | ||
201 | collision_trimesh_distance.cpp \ | ||
202 | collision_trimesh_internal.h \ | ||
203 | collision_cylinder_trimesh.cpp \ | ||
204 | collision_trimesh_plane.cpp | ||
205 | endif | ||
206 | |||
207 | |||