From fa004431e6dc454f1ceacace1234c39bb19f7d89 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Sat, 5 Jun 2010 02:19:12 -0700
Subject: Rewrote the radar code to fix some basic issues
i.e. avatars stuck as typing, appearing multiple times, or spamming
the chat notify (also added a ban button while I was there)
---
linden/indra/newview/CMakeLists.txt | 2 +
linden/indra/newview/app_settings/settings.xml | 11 +
linden/indra/newview/llnetmap.cpp | 4 +-
linden/indra/newview/llviewermessage.cpp | 13 +-
linden/indra/newview/panelradar.cpp | 672 ++++++++++++---------
linden/indra/newview/panelradar.h | 64 +-
linden/indra/newview/panelradarentry.cpp | 85 +++
linden/indra/newview/panelradarentry.h | 83 +++
.../skins/default/xui/en-us/panel_radar.xml | 32 +-
9 files changed, 627 insertions(+), 339 deletions(-)
create mode 100644 linden/indra/newview/panelradarentry.cpp
create mode 100644 linden/indra/newview/panelradarentry.h
(limited to 'linden')
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 70d4257..6be53a4 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -461,6 +461,7 @@ set(viewer_SOURCE_FILES
llxmlrpctransaction.cpp
noise.cpp
panelradar.cpp
+ panelradarentry.cpp
pipeline.cpp
primbackup.cpp
rlvhandler.cpp
@@ -894,6 +895,7 @@ set(viewer_HEADER_FILES
macmain.h
noise.h
panelradar.h
+ panelradarentry.h
pipeline.h
primbackup.h
randgauss.h
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml
index 89cf2ab..85665cf 100644
--- a/linden/indra/newview/app_settings/settings.xml
+++ b/linden/indra/newview/app_settings/settings.xml
@@ -48,6 +48,17 @@
Value
+ ChatDistance
+
CmdLineCacheLocation