From 45ae4881525730eece3298d3c88984ce0599a106 Mon Sep 17 00:00:00 2001
From: Nemurimasu Neiro
Date: Mon, 6 Sep 2010 00:04:56 +0000
Subject: use setenv instead of putenv
putenv requires that the string not be freed
---
linden/indra/llmedia/llmediaimplgstreamer.cpp | 12 ++++--------
1 file changed, 4 insertions(+), 8 deletions(-)
(limited to 'linden')
diff --git a/linden/indra/llmedia/llmediaimplgstreamer.cpp b/linden/indra/llmedia/llmediaimplgstreamer.cpp
index 2bfe4ea..7af9c9a 100644
--- a/linden/indra/llmedia/llmediaimplgstreamer.cpp
+++ b/linden/indra/llmedia/llmediaimplgstreamer.cpp
@@ -188,9 +188,6 @@ bool LLMediaImplGStreamer::startup (LLMediaManagerData* init_data)
// Protect against GStreamer resetting the locale, yuck.
static std::string saved_locale;
saved_locale = setlocale(LC_ALL, NULL);
-#if LL_DARWIN
- setenv("GST_PLUGIN_SYSTEM_PATH", "lib/gstreamer-plugins", TRUE);
-#endif
if (0 == gst_init_check(NULL, NULL, NULL))
{
LL_WARNS("MediaImpl") << "GStreamer library failed to initialize and load standard plugins." << LL_ENDL;
@@ -294,7 +291,6 @@ void LLMediaImplGStreamer::set_gst_plugin_path()
// Search both Imprudence and Imprudence\lib\gstreamer-plugins.
// But we also want to search the path the user has set, if any.
std::string plugin_path =
- "GST_PLUGIN_PATH=" +
#if LL_WINDOWS
imp_dir + "\\lib\\gstreamer-plugins" +
#elif LL_DARWIN
@@ -307,9 +303,9 @@ void LLMediaImplGStreamer::set_gst_plugin_path()
// Place GST_PLUGIN_PATH in the environment settings
#if LL_WINDOWS
- put_result = _putenv( (char*)plugin_path.c_str() );
+ put_result = _putenv_s( "GST_PLUGIN_PATH", (char*)plugin_path.c_str() );
#elif LL_DARWIN
- put_result = putenv( (char*)plugin_path.c_str() );
+ put_result = setenv( "GST_PLUGIN_PATH", (char*)plugin_path.c_str(), 1 );
#endif
if( put_result == -1 )
@@ -324,9 +320,9 @@ void LLMediaImplGStreamer::set_gst_plugin_path()
// Don't load system plugins. We only want to use ours, to avoid conflicts.
#if LL_WINDOWS
- put_result = _putenv( "GST_PLUGIN_SYSTEM_PATH=\"\"" );
+ put_result = _putenv_s( "GST_PLUGIN_SYSTEM_PATH", "" );
#elif LL_DARWIN
- put_result = putenv( "GST_PLUGIN_SYSTEM_PATH=\"\"" );
+ put_result = setenv( "GST_PLUGIN_SYSTEM_PATH", "", 1 );
#endif
if( put_result == -1 )
--
cgit v1.1
From c01c71d3b22b9acb983c238b608401f7d032ef9b Mon Sep 17 00:00:00 2001
From: Nemurimasu Neiro
Date: Mon, 6 Sep 2010 05:11:05 +0000
Subject: store our password in the Mac OS keychain
much more secure than XORing against a MAC address :)
---
linden/indra/newview/CMakeLists.txt | 2 ++
linden/indra/newview/llstartup.cpp | 45 ++++++++++++++++++++++++++++++++++---
2 files changed, 44 insertions(+), 3 deletions(-)
(limited to 'linden')
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 995ef7e..313ed9f 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -955,11 +955,13 @@ if (DARWIN)
find_library(APPKIT_LIBRARY AppKit)
find_library(COCOA_LIBRARY Cocoa)
find_library(IOKIT_LIBRARY IOKit)
+ find_library(SECURITY_LIBRARY SECURITY)
set(viewer_LIBRARIES
${COCOA_LIBRARY}
${AGL_LIBRARY}
${IOKIT_LIBRARY}
+ ${SECURITY_LIBRARY}
)
# Add resource files to the project.
diff --git a/linden/indra/newview/llstartup.cpp b/linden/indra/newview/llstartup.cpp
index 6622740..606262f 100644
--- a/linden/indra/newview/llstartup.cpp
+++ b/linden/indra/newview/llstartup.cpp
@@ -2935,17 +2935,29 @@ std::string LLStartUp::loadPasswordFromDisk()
return hashed_password;
}
+ // UUID is 16 bytes, written into ASCII is 32 characters
+ // without trailing \0
+ const S32 HASHED_LENGTH = 32;
+
std::string filepath = gDirUtilp->getExpandedFilename(LL_PATH_USER_SETTINGS,
"password.dat");
LLFILE* fp = LLFile::fopen(filepath, "rb"); /* Flawfinder: ignore */
if (!fp)
{
+#if LL_DARWIN
+ UInt32 passwordLength;
+ char *passwordData;
+ OSStatus stat = SecKeychainFindGenericPassword(NULL, 10, "Imprudence", 0, NULL, &passwordLength, (void**)&passwordData, NULL);
+ if (stat == noErr)
+ {
+ if (passwordLength == HASHED_LENGTH)
+ hashed_password.assign(passwordData, HASHED_LENGTH);
+ SecKeychainItemFreeContent(NULL, passwordData);
+ }
+#endif
return hashed_password;
}
- // UUID is 16 bytes, written into ASCII is 32 characters
- // without trailing \0
- const S32 HASHED_LENGTH = 32;
U8 buffer[HASHED_LENGTH+1];
if (1 != fread(buffer, HASHED_LENGTH, 1, fp))
@@ -2969,6 +2981,10 @@ std::string LLStartUp::loadPasswordFromDisk()
{
hashed_password.assign((char*)buffer);
}
+#if LL_DARWIN
+ // we're migrating to the keychain
+ LLFile::remove(filepath);
+#endif
return hashed_password;
}
@@ -2977,6 +2993,19 @@ std::string LLStartUp::loadPasswordFromDisk()
// static
void LLStartUp::savePasswordToDisk(const std::string& hashed_password)
{
+#if LL_DARWIN
+ SecKeychainItemRef keychainItem;
+ OSStatus status = SecKeychainFindGenericPassword(NULL, 10, "Imprudence", 0, NULL, NULL, NULL, &keychainItem);
+ if (status == noErr)
+ {
+ SecKeychainItemModifyAttributesAndData(keychainItem, NULL, hashed_password.length(), hashed_password.c_str());
+ CFRelease(keychainItem);
+ }
+ else
+ {
+ SecKeychainAddGenericPassword(NULL, 10, "Imprudence", 0, NULL, hashed_password.length(), hashed_password.c_str(), NULL);
+ }
+#else
std::string filepath = gDirUtilp->getExpandedFilename(LL_PATH_USER_SETTINGS,
"password.dat");
LLFILE* fp = LLFile::fopen(filepath, "wb"); /* Flawfinder: ignore */
@@ -3000,12 +3029,22 @@ void LLStartUp::savePasswordToDisk(const std::string& hashed_password)
}
fclose(fp);
+#endif
}
// static
void LLStartUp::deletePasswordFromDisk()
{
+#if LL_DARWIN
+ SecKeychainItemRef keychainItem;
+ OSStatus status = SecKeychainFindGenericPassword(NULL, 10, "Imprudence", 0, NULL, NULL, NULL, &keychainItem);
+ if (status == noErr)
+ {
+ SecKeychainItemDelete(keychainItem);
+ CFRelease(keychainItem);
+ }
+#endif
std::string filepath = gDirUtilp->getExpandedFilename(LL_PATH_USER_SETTINGS,
"password.dat");
LLFile::remove(filepath);
--
cgit v1.1
From 0819763a22fa70a3808197ed5bedf0a98ccf1293 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Wed, 8 Sep 2010 01:17:37 -0700
Subject: Replace '>' glyph in cascading menus with a proper triangle(backport
from Viewer 2)
---
linden/indra/llui/llmenugl.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
(limited to 'linden')
diff --git a/linden/indra/llui/llmenugl.cpp b/linden/indra/llui/llmenugl.cpp
index e00700a..8bca58a 100644
--- a/linden/indra/llui/llmenugl.cpp
+++ b/linden/indra/llui/llmenugl.cpp
@@ -102,7 +102,7 @@ const S32 TEAROFF_SEPARATOR_HEIGHT_PIXELS = 10;
const S32 MENU_ITEM_PADDING = 4;
const std::string BOOLEAN_TRUE_PREFIX( "X" );
-const std::string BRANCH_SUFFIX( ">" );
+const std::string BRANCH_SUFFIX( "\xE2\x96\xB6" ); // U+25B6 BLACK RIGHT-POINTING TRIANGLE
const std::string ARROW_UP ("^^^^^^^");
const std::string ARROW_DOWN("vvvvvvv");
--
cgit v1.1
From 30fdc31be51f2e2f2629fded97658464ac37702b Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Wed, 8 Sep 2010 04:17:38 -0700
Subject: Increased max settable value for RenderVolumeLODFactor from 2 to 4
---
.../newview/skins/default/xui/en-us/panel_preferences_graphics1.xml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
(limited to 'linden')
diff --git a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
index 153a111..72a6438 100644
--- a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
+++ b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
@@ -286,7 +286,7 @@
Value
0
+ ResetFocusOnSelfClick
+
RezWithLandGroup
+ ShowGroupNameInChatIM
+
ShowMiniMapRadar
GoAction
@@ -6245,7 +6245,7 @@
Type
String
Value
- DejaVuSansCondensed.ttf
+ DroidSans.ttf
FontSansSerifBundledFallback
@@ -6256,7 +6256,7 @@
Type
String
Value
- DejaVuSansCondensed.ttf
+ DroidSans.ttf
FontSansSerifBold
@@ -6267,7 +6267,7 @@
Type
String
Value
- DejaVuSansCondensed-Bold.ttf
+ DroidSans-Bold.ttf
FontSansSerifFallback
diff --git a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_fonts.xml b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_fonts.xml
index 869063f..3a27bd1 100644
--- a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_fonts.xml
+++ b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_fonts.xml
@@ -12,29 +12,29 @@
top="-30" left="20" bottom="0" right="-20"
follows="top|left|bottom|right">
-
+
+ Droid Sans
+
+
+
DejaVu Sans Condensed
-
- Liberation Sans (classic Imprudence font)
-
-
Delicious
-
- Droid Sans
+
+ Liberation Sans (classic Imprudence font)
-
+
Preview: The quick brown fox jumped over the lazy dog. :)
-
+
Preview: The quick brown fox jumped over the lazy dog. :)
@@ -42,7 +42,7 @@
Preview: The quick brown fox jumped over the lazy dog. :)
-
+
Preview: The quick brown fox jumped over the lazy dog. :)
--
cgit v1.1
From d5996a3f7cd632fea70087a8558a41e6650d8c7b Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Fri, 10 Sep 2010 21:45:29 -0500
Subject: Added libhunspell-1.2.dylib to Mac manifest.
---
linden/indra/newview/viewer_manifest.py | 1 +
1 file changed, 1 insertion(+)
(limited to 'linden')
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index 7e0afd8..f66fa5b 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -544,6 +544,7 @@ class DarwinManifest(ViewerManifest):
if self.prefix(src="../../libraries/universal-darwin/lib_release", dst="MacOS/"):
self.path("libndofdev.dylib")
+ self.path("libhunspell-1.2.dylib")
self.path("libopenal.1.dylib")
self.path("libalut.0.dylib")
--
cgit v1.1
From 5b584eafadb0898ba23bf17ccb30e6d2d557c74a Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Fri, 10 Sep 2010 21:12:20 -0700
Subject: Fix for crash on bad teleports
---
linden/indra/newview/llvoavatar.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
(limited to 'linden')
diff --git a/linden/indra/newview/llvoavatar.cpp b/linden/indra/newview/llvoavatar.cpp
index 513d43c..c8b26be 100644
--- a/linden/indra/newview/llvoavatar.cpp
+++ b/linden/indra/newview/llvoavatar.cpp
@@ -8401,7 +8401,7 @@ LLBBox LLVOAvatar::getHUDBBox() const
{
attachment_map_t::const_iterator curiter = iter++;
LLViewerJointAttachment* attachment = curiter->second;
- if (attachment->getIsHUDAttachment() && attachment->getObject())
+ if (attachment && attachment->getIsHUDAttachment() && attachment->getObject())
{
LLViewerObject* hud_object = attachment->getObject();
--
cgit v1.1
From 4f52590436f86e2bb8f889adcc02b6db99eb2f30 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Fri, 10 Sep 2010 23:21:15 -0700
Subject: Updated artwork package to include dark and gemini skins (also
updated windows installers)
---
linden/install.xml | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
(limited to 'linden')
diff --git a/linden/install.xml b/linden/install.xml
index cf1598a..af1b275 100755
--- a/linden/install.xml
+++ b/linden/install.xml
@@ -179,30 +179,30 @@
darwin
md5sum
- 1b49f2873e70195f79a064bc5e9275cd
+ 56ddb01842a11b8f7e401d411fdc730e
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100829.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
linux
md5sum
- 1b49f2873e70195f79a064bc5e9275cd
+ 56ddb01842a11b8f7e401d411fdc730e
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100829.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
linux64
md5sum
- 1b49f2873e70195f79a064bc5e9275cd
+ 56ddb01842a11b8f7e401d411fdc730e
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100829.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
windows
md5sum
- 1b49f2873e70195f79a064bc5e9275cd
+ 56ddb01842a11b8f7e401d411fdc730e
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100829.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
--
cgit v1.1
From a1307555f61252d373b976334df8ea5385a44e97 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Fri, 10 Sep 2010 23:57:26 -0700
Subject: Added the dark and gemini skins to the skins panel (note: revert
before skin selection is merged in)
---
linden/indra/newview/llpanelskins.cpp | 18 ++++++++++
linden/indra/newview/llpanelskins.h | 2 ++
.../default/xui/en-us/panel_preferences_skins.xml | 41 ++++++++++++++++++----
3 files changed, 55 insertions(+), 6 deletions(-)
(limited to 'linden')
diff --git a/linden/indra/newview/llpanelskins.cpp b/linden/indra/newview/llpanelskins.cpp
index 26de356..831adc8 100644
--- a/linden/indra/newview/llpanelskins.cpp
+++ b/linden/indra/newview/llpanelskins.cpp
@@ -60,6 +60,8 @@ BOOL LLPanelSkins::postBuild()
getChild("classic_preview")->setClickedCallback(onClickClassic, this);
getChild("silver_preview")->setClickedCallback(onClickSilver, this);
+ getChild("dark_preview")->setClickedCallback(onClickDark, this);
+ getChild("gemini_preview")->setClickedCallback(onClickGemini, this);
refresh();
return TRUE;
@@ -108,3 +110,19 @@ void LLPanelSkins::onClickSilver(void* data)
gSavedSettings.setString("SkinCurrent", "silver");
self->getChild("skin_selection")->setValue("silver");
}
+
+//static
+void LLPanelSkins::onClickDark(void* data)
+{
+ LLPanelSkins* self = (LLPanelSkins*)data;
+ gSavedSettings.setString("SkinCurrent", "dark");
+ self->getChild("skin_selection")->setValue("dark");
+}
+
+//static
+void LLPanelSkins::onClickGemini(void* data)
+{
+ LLPanelSkins* self = (LLPanelSkins*)data;
+ gSavedSettings.setString("SkinCurrent", "gemini");
+ self->getChild("skin_selection")->setValue("gemini");
+}
diff --git a/linden/indra/newview/llpanelskins.h b/linden/indra/newview/llpanelskins.h
index 8fd282f..8dbd556 100644
--- a/linden/indra/newview/llpanelskins.h
+++ b/linden/indra/newview/llpanelskins.h
@@ -51,6 +51,8 @@ private:
static void onSelectSkin(LLUICtrl* ctrl, void* data);
static void onClickClassic(void* data);
static void onClickSilver(void* data);
+ static void onClickDark(void* data);
+ static void onClickGemini(void* data);
private:
std::string mSkin;
diff --git a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
index f0b789e..0611ce3 100644
--- a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
+++ b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
@@ -2,21 +2,50 @@
-
- Select a Skin (Requires Restart):
-
+ Select a skin (requires restart).
+
Default
-
+
Silver
+
+ Dark
+
+
+ Gemini
+
-
-
+
+
+
+
+
+
+
+ (Please see the skin folders for information and credits)
+
+
--
cgit v1.1
From b987829d0cc2fad2e09e1c90a251a56ab1ca5250 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Fri, 10 Sep 2010 23:58:07 -0700
Subject: Fixed crash when right clicking a landmark and selecting 'About
Landmark'. TODO: fix duplicate LM request that shouldn't happen
---
linden/indra/newview/llpanelplace.cpp | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
(limited to 'linden')
diff --git a/linden/indra/newview/llpanelplace.cpp b/linden/indra/newview/llpanelplace.cpp
index d7939b9..eb3d17d 100644
--- a/linden/indra/newview/llpanelplace.cpp
+++ b/linden/indra/newview/llpanelplace.cpp
@@ -383,14 +383,14 @@ void LLPanelPlace::displayParcelInfo(const LLVector3& pos_region,
std::string url = gAgent.getRegion()->getCapability("RemoteParcelRequest");
if (!url.empty())
{
- body["location"] = ll_sd_from_vector3(pos_region);
+ body["location"] = ll_sd_from_vector3(mPosRegion);
if (!region_id.isNull())
{
body["region_id"] = region_id;
}
- if (!pos_global.isExactlyZero())
+ if (!mPosGlobal.isExactlyZero())
{
- U64 region_handle = to_region_handle(pos_global);
+ U64 region_handle = to_region_handle(mPosGlobal);
body["region_handle"] = ll_sd_from_U64(region_handle);
}
LLHTTPClient::post(url, body, new LLRemoteParcelRequestResponder(this->getHandle()));
--
cgit v1.1
From eb11df5e07e2fe235b496a437d0f6cb0a62469ab Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Sat, 11 Sep 2010 00:02:14 -0700
Subject: Disabled highlight for own name color by default to avoid confusion
---
linden/indra/newview/app_settings/settings.xml | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
(limited to 'linden')
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml
index cae420d..8e7c029 100644
--- a/linden/indra/newview/app_settings/settings.xml
+++ b/linden/indra/newview/app_settings/settings.xml
@@ -13,7 +13,7 @@
Type
Boolean
Value
- 1
+ 0
HighlightFriendsChat
@@ -51,7 +51,7 @@
Type
Boolean
Value
- 1
+ 0
OwnNameChatColor
--
cgit v1.1
From b40a6c3b57968e97b06c2eec0eeb9c0f2e393b04 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Sat, 11 Sep 2010 00:04:29 -0700
Subject: Made the default friend chat color the same color as friends' glyph
in the mini-map
---
linden/indra/newview/app_settings/settings.xml | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
(limited to 'linden')
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml
index 8e7c029..11220ed 100644
--- a/linden/indra/newview/app_settings/settings.xml
+++ b/linden/indra/newview/app_settings/settings.xml
@@ -36,9 +36,9 @@
Color4
Value
- 0.699999988079
- 0.899999976158
- 0.699999988079
+ 1.0
+ 1.0
+ 0.0
1
--
cgit v1.1
From c8f15cf380f910fb3b642b3089b0fd461e9fc883 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Sat, 11 Sep 2010 00:08:34 -0700
Subject: Fixed color picker size being too tiny for the label
---
.../skins/default/xui/en-us/panel_preferences_advanced.xml | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
(limited to 'linden')
diff --git a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
index b344d14..38033a3 100644
--- a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
+++ b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
@@ -180,10 +180,10 @@
initial_value="true" label="Show chat messages from friends in a different color" left="12"
mouse_opaque="true" name="HighlightFriendsChat" radio_style="false" width="270"/>
-
+ enabled="true" follows="left|top" height="67" label="Friends" left_delta="68"
+ mouse_opaque="true" name="FriendsChatColor" width="65" />
-
+ enabled="true" follows="left|top" height="67" label="Own Name" left_delta="68"
+ mouse_opaque="true" name="OwnNameChatColor" width="65" />
--
cgit v1.1
From da5df21793b3a5457e029b92951aa4833257daeb Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Sat, 11 Sep 2010 00:08:59 -0700
Subject: Changed version to Experimental 2010.09.11
---
linden/indra/newview/app_settings/viewerversion.xml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
(limited to 'linden')
diff --git a/linden/indra/newview/app_settings/viewerversion.xml b/linden/indra/newview/app_settings/viewerversion.xml
index 3b1a7df..f5fb533 100644
--- a/linden/indra/newview/app_settings/viewerversion.xml
+++ b/linden/indra/newview/app_settings/viewerversion.xml
@@ -20,6 +20,6 @@ need to be changed manually - MC
-
+
--
cgit v1.1
From 46238e721b3812a0d00c929377208ff4db9cf7c1 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Sat, 11 Sep 2010 01:44:41 -0700
Subject: Updated the artwork package to fix a few items that were out of date
---
linden/install.xml | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
(limited to 'linden')
diff --git a/linden/install.xml b/linden/install.xml
index af1b275..6332244 100755
--- a/linden/install.xml
+++ b/linden/install.xml
@@ -179,30 +179,30 @@
darwin
md5sum
- 56ddb01842a11b8f7e401d411fdc730e
+ cb6e2d7c09bbacefd0a1f98fd20fa5b6
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100911.tar.bz2
linux
md5sum
- 56ddb01842a11b8f7e401d411fdc730e
+ cb6e2d7c09bbacefd0a1f98fd20fa5b6
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100911.tar.bz2
linux64
md5sum
- 56ddb01842a11b8f7e401d411fdc730e
+ cb6e2d7c09bbacefd0a1f98fd20fa5b6
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100911.tar.bz2
windows
md5sum
- 56ddb01842a11b8f7e401d411fdc730e
+ cb6e2d7c09bbacefd0a1f98fd20fa5b6
url
- http://imprudenceviewer.org/download/extras/imprudence-artwork-20100910.tar.bz2
+ http://imprudenceviewer.org/download/extras/imprudence-artwork-20100911.tar.bz2
--
cgit v1.1