From 35df5441d3e2789663532c948731aff3a1e04728 Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Mon, 14 Jun 2010 12:04:49 +0200
Subject: llmediaplugins first step
---
linden/doc/LICENSE-logos.txt | 23 +
linden/doc/contributions.txt | 7 +-
linden/etc/message.xml | 16 +
linden/indra/CMakeLists.txt | 10 +-
linden/indra/cmake/00-Common.cmake | 4 +-
linden/indra/cmake/FindNDOF.cmake | 39 +
linden/indra/cmake/GStreamer010Plugin.cmake | 39 +
linden/indra/cmake/Glui.cmake | 28 +
linden/indra/cmake/Glut.cmake | 19 +
linden/indra/cmake/LLAudio.cmake | 2 -
linden/indra/cmake/LLMedia.cmake | 13 -
linden/indra/cmake/LLPlugin.cmake | 8 +
linden/indra/cmake/MediaPluginBase.cmake | 8 +
linden/indra/cmake/Mozlib.cmake | 47 -
linden/indra/cmake/NDOF.cmake | 32 +-
linden/indra/cmake/OPENAL.cmake | 13 +-
linden/indra/cmake/OPENAL.cmake.imp | 115 ++
linden/indra/cmake/PluginAPI.cmake | 16 +
linden/indra/cmake/QuickTimePlugin.cmake | 46 +
linden/indra/cmake/WebKitLibPlugin.cmake | 55 +
...den%2findra%2fcmake%2fCopyWinLibs.cmake.rej.txt | 257 +++
linden/indra/llaudio/CMakeLists.txt | 43 +-
linden/indra/llaudio/audioengine.cpp | 1904 -----------------
linden/indra/llaudio/audioengine.h | 466 -----
linden/indra/llaudio/audioengine_fmod.cpp | 1093 ----------
linden/indra/llaudio/audioengine_fmod.h | 161 --
linden/indra/llaudio/audioengine_openal.cpp | 574 ------
linden/indra/llaudio/audioengine_openal.h | 114 -
linden/indra/llaudio/listener.cpp | 153 --
linden/indra/llaudio/listener.h | 80 -
linden/indra/llaudio/listener_ds3d.h | 76 -
linden/indra/llaudio/listener_fmod.cpp | 143 --
linden/indra/llaudio/listener_fmod.h | 67 -
linden/indra/llaudio/listener_openal.cpp | 125 --
linden/indra/llaudio/listener_openal.h | 68 -
linden/indra/llaudio/llaudiodecodemgr.cpp | 62 +-
linden/indra/llaudio/llaudioengine.cpp | 1801 ++++++++++++++++
linden/indra/llaudio/llaudioengine.h | 457 ++++
linden/indra/llaudio/llaudioengine_fmod.cpp | 766 +++++++
linden/indra/llaudio/llaudioengine_fmod.h | 129 ++
linden/indra/llaudio/llaudioengine_openal.cpp | 546 +++++
linden/indra/llaudio/llaudioengine_openal.h | 114 +
linden/indra/llaudio/lllistener.cpp | 142 ++
linden/indra/llaudio/lllistener.h | 78 +
linden/indra/llaudio/lllistener_ds3d.h | 74 +
linden/indra/llaudio/lllistener_fmod.cpp | 131 ++
linden/indra/llaudio/lllistener_fmod.h | 64 +
linden/indra/llaudio/lllistener_openal.cpp | 116 ++
linden/indra/llaudio/lllistener_openal.h | 64 +
linden/indra/llaudio/llstreamingaudio.h | 56 +
linden/indra/llaudio/llstreamingaudio_fmod.cpp | 362 ++++
linden/indra/llaudio/llstreamingaudio_fmod.h | 68 +
linden/indra/llaudio/llvorbisdecode.cpp | 326 +++
linden/indra/llaudio/llvorbisdecode.h | 42 +
linden/indra/llaudio/llvorbisencode.cpp | 505 +++++
linden/indra/llaudio/llvorbisencode.h | 64 +
linden/indra/llaudio/llwindgen.h | 136 ++
linden/indra/llaudio/vorbisdecode.cpp | 326 ---
linden/indra/llaudio/vorbisdecode.h | 42 -
linden/indra/llaudio/vorbisencode.h | 53 -
linden/indra/llaudio/windgen.h | 136 --
linden/indra/llcommon/CMakeLists.txt | 2 +
linden/indra/llcommon/llerrorcontrol.h | 1 +
linden/indra/llcommon/llprocesslauncher.cpp | 346 ++++
linden/indra/llcommon/llprocesslauncher.h | 86 +
linden/indra/llinventory/llparcel.cpp | 125 ++
linden/indra/llinventory/llparcel.h | 25 +
linden/indra/llmath/CMakeLists.txt | 1 +
linden/indra/llmath/llmath.h | 10 +-
linden/indra/llmath/llvolume.cpp | 8 +-
linden/indra/llmath/llvolume.h | 10 +-
linden/indra/llmath/v3math.h | 4 +-
linden/indra/llmedia/CMakeLists.txt | 79 -
linden/indra/llmedia/llgstplaythread.cpp | 54 -
linden/indra/llmedia/llgstplaythread.h | 62 -
linden/indra/llmedia/llmediabase.h | 265 ---
linden/indra/llmedia/llmediaemitter.h | 104 -
linden/indra/llmedia/llmediaimplcommon.cpp | 552 -----
linden/indra/llmedia/llmediaimplcommon.h | 164 --
linden/indra/llmedia/llmediaimplexample1.cpp | 231 ---
linden/indra/llmedia/llmediaimplexample1.h | 73 -
linden/indra/llmedia/llmediaimplexample2.cpp | 198 --
linden/indra/llmedia/llmediaimplexample2.h | 76 -
linden/indra/llmedia/llmediaimplfactory.cpp | 105 -
linden/indra/llmedia/llmediaimplfactory.h | 100 -
linden/indra/llmedia/llmediaimplgstreamer.h | 164 --
.../indra/llmedia/llmediaimplgstreamervidplug.cpp | 448 ----
linden/indra/llmedia/llmediaimplgstreamervidplug.h | 106 -
linden/indra/llmedia/llmediaimplllmozlib.cpp | 624 ------
linden/indra/llmedia/llmediaimplllmozlib.h | 127 --
linden/indra/llmedia/llmediaimplquicktime.cpp | 657 ------
linden/indra/llmedia/llmediaimplquicktime.h | 112 -
linden/indra/llmedia/llmediaimplregister.h | 60 -
linden/indra/llmedia/llmediamanager.cpp | 295 ---
linden/indra/llmedia/llmediamanager.h | 127 --
linden/indra/llmedia/llmediaobserver.h | 116 --
linden/indra/llmessage/tests/commtest.h | 83 +
linden/indra/llmessage/tests/llcurl_stub.cpp | 100 +
.../llmessage/tests/llhttpclientadapter_test.cpp | 170 ++
.../tests/lltemplatemessagedispatcher_test.cpp | 165 ++
.../llmessage/tests/lltesthttpclientadapter.cpp | 67 +
.../llmessage/tests/lltesthttpclientadapter.h | 63 +
.../indra/llmessage/tests/lltestmessagesender.cpp | 44 +
linden/indra/llmessage/tests/lltestmessagesender.h | 57 +
.../tests/lltrustedmessageservice_test.cpp | 146 ++
linden/indra/llmessage/tests/networkio.h | 116 ++
.../indra/llmessage/tests/test_llsdmessage_peer.py | 153 ++
linden/indra/llplugin/CMakeLists.txt | 55 +
linden/indra/llplugin/llpluginclassmedia.cpp | 1162 +++++++++++
linden/indra/llplugin/llpluginclassmedia.h | 352 ++++
linden/indra/llplugin/llpluginclassmediaowner.h | 82 +
linden/indra/llplugin/llplugininstance.cpp | 172 ++
linden/indra/llplugin/llplugininstance.h | 104 +
linden/indra/llplugin/llpluginmessage.cpp | 442 ++++
linden/indra/llplugin/llpluginmessage.h | 142 ++
linden/indra/llplugin/llpluginmessageclasses.h | 57 +
linden/indra/llplugin/llpluginmessagepipe.cpp | 316 +++
linden/indra/llplugin/llpluginmessagepipe.h | 92 +
linden/indra/llplugin/llpluginprocesschild.cpp | 490 +++++
linden/indra/llplugin/llpluginprocesschild.h | 112 +
linden/indra/llplugin/llpluginprocessparent.cpp | 714 +++++++
linden/indra/llplugin/llpluginprocessparent.h | 169 ++
linden/indra/llplugin/llpluginsharedmemory.cpp | 506 +++++
linden/indra/llplugin/llpluginsharedmemory.h | 130 ++
linden/indra/llplugin/slplugin/CMakeLists.txt | 55 +
linden/indra/llplugin/slplugin/slplugin.cpp | 288 +++
linden/indra/llplugin/slplugin/slplugin_info.plist | 12 +
linden/indra/llui/CMakeLists.txt | 15 +-
linden/indra/llui/llbutton.cpp | 5 +
linden/indra/llui/llbutton.h | 3 +-
linden/indra/llui/llfloater.cpp | 8 +-
linden/indra/llui/llfocusmgr.cpp | 84 +-
linden/indra/llui/llfocusmgr.h | 49 +-
linden/indra/llui/lliconctrl.cpp | 6 +
linden/indra/llui/lliconctrl.h | 2 +
linden/indra/llui/llmultisliderctrl.cpp | 3 -
linden/indra/llui/llpanel.cpp | 19 +-
linden/indra/llui/llpanel.h | 3 +
linden/indra/llui/llsliderctrl.cpp | 2 -
linden/indra/llui/llspinctrl.cpp | 1 -
linden/indra/llui/lltextparser.cpp | 48 +-
linden/indra/llui/lltextparser.h | 7 +-
linden/indra/llui/llui.cpp | 1 -
linden/indra/llui/lluictrl.cpp | 55 +-
linden/indra/llui/lluictrl.h | 26 +-
linden/indra/llui/llview.cpp | 7 +-
linden/indra/llui/llview.h | 14 +-
linden/indra/llvfs/CMakeLists.txt | 2 +-
linden/indra/llvfs/lldir.cpp | 6 +
linden/indra/llvfs/lldir.h | 6 +
linden/indra/llvfs/lldir_linux.cpp | 43 +-
linden/indra/llvfs/lldir_linux.h | 3 +
linden/indra/llvfs/lldir_mac.cpp | 15 +
linden/indra/llvfs/lldir_mac.h | 3 +
linden/indra/llvfs/lldir_solaris.cpp | 2 +
linden/indra/llvfs/lldir_win32.cpp | 15 +
linden/indra/llvfs/lldir_win32.h | 3 +
linden/indra/llwindow/CMakeLists.txt | 14 +-
linden/indra/media_plugins/CMakeLists.txt | 11 +
linden/indra/media_plugins/base/CMakeLists.txt | 41 +
.../indra/media_plugins/base/media_plugin_base.cpp | 155 ++
.../indra/media_plugins/base/media_plugin_base.exp | 1 +
.../indra/media_plugins/base/media_plugin_base.h | 112 +
linden/indra/media_plugins/example/CMakeLists.txt | 74 +
.../media_plugins/example/media_plugin_example.cpp | 488 +++++
.../media_plugins/gstreamer010/CMakeLists.txt | 71 +
.../gstreamer010/llmediaimplgstreamer.h | 57 +
.../gstreamer010/llmediaimplgstreamer_syms.cpp | 171 ++
.../gstreamer010/llmediaimplgstreamer_syms.h | 78 +
.../gstreamer010/llmediaimplgstreamer_syms_raw.inc | 51 +
.../llmediaimplgstreamer_syms_rawv.inc | 5 +
.../llmediaimplgstreamertriviallogging.h | 53 +
.../gstreamer010/llmediaimplgstreamervidplug.cpp | 532 +++++
.../gstreamer010/llmediaimplgstreamervidplug.h | 109 +
.../gstreamer010/media_plugin_gstreamer010.cpp | 1202 +++++++++++
.../gstreamer010/media_plugin_gstreamer010.cpp~ | 1219 +++++++++++
.../indra/media_plugins/quicktime/CMakeLists.txt | 83 +
.../quicktime/media_plugin_quicktime.cpp | 985 +++++++++
linden/indra/media_plugins/webkit/CMakeLists.txt | 82 +
.../media_plugins/webkit/media_plugin_webkit.cpp | 932 +++++++++
linden/indra/newview/CMakeLists.txt | 100 +-
linden/indra/newview/app_settings/settings.xml | 35 +-
linden/indra/newview/chatbar_as_cmdline.cpp | 4 +-
linden/indra/newview/floatervoicelicense.cpp | 4 +-
linden/indra/newview/floatervoicelicense.h | 8 +-
linden/indra/newview/llagent.cpp | 6 +
linden/indra/newview/llappviewer.cpp | 20 +-
linden/indra/newview/llappviewerlinux.cpp | 2 +-
linden/indra/newview/llappviewermacosx.cpp | 4 +-
linden/indra/newview/llassetuploadresponders.cpp | 5 +-
linden/indra/newview/llaudiosourcevo.h | 2 +-
linden/indra/newview/llchatbar.cpp | 2 +-
linden/indra/newview/llcommandhandler.cpp | 6 +-
linden/indra/newview/llcommandhandler.h | 10 +-
linden/indra/newview/llfirstuse.cpp | 4 +-
linden/indra/newview/llfloaterabout.cpp | 27 +-
linden/indra/newview/llfloateravatarinfo.cpp | 2 +-
linden/indra/newview/llfloaterchat.cpp | 54 +-
linden/indra/newview/llfloaterchat.h | 2 +
linden/indra/newview/llfloaterclassified.cpp | 2 +-
linden/indra/newview/llfloaterevent.cpp | 2 +-
linden/indra/newview/llfloatergroupinfo.cpp | 2 +-
linden/indra/newview/llfloaterhandler.cpp | 4 +-
linden/indra/newview/llfloaterhandler.h | 2 +-
linden/indra/newview/llfloaterhtmlhelp.h | 90 -
linden/indra/newview/llfloaterhtmlsimple.cpp | 6 +-
linden/indra/newview/llfloaterhud.cpp | 4 +-
linden/indra/newview/llfloaterhud.h | 4 +-
linden/indra/newview/llfloaterland.cpp | 12 +
linden/indra/newview/llfloaterland.h | 3 +
linden/indra/newview/llfloatermediabrowser.cpp | 398 ++++
linden/indra/newview/llfloatermediabrowser.h | 102 +
linden/indra/newview/llfloaterobjectiminfo.cpp | 6 +-
linden/indra/newview/llfloaterparcel.cpp | 2 +-
linden/indra/newview/llfloaterpreference.cpp | 8 +-
linden/indra/newview/llfloatertos.cpp | 33 +-
linden/indra/newview/llfloatertos.h | 7 +-
linden/indra/newview/llfloaterurlentry.cpp | 2 +-
linden/indra/newview/llhoverview.cpp | 3 +-
linden/indra/newview/llhoverview.h | 3 +
linden/indra/newview/llhudview.cpp | 13 +-
linden/indra/newview/llhudview.h | 2 +-
linden/indra/newview/llimpanel.cpp | 2 +-
linden/indra/newview/llloginhandler.cpp | 2 +-
linden/indra/newview/llloginhandler.h | 2 +-
linden/indra/newview/llmediactrl.cpp | 1201 +++++++++++
linden/indra/newview/llmediactrl.h | 201 ++
linden/indra/newview/llmediaremotectrl.cpp | 57 +-
linden/indra/newview/llmimetypes.cpp | 24 +
linden/indra/newview/llmimetypes.h | 6 +
linden/indra/newview/lloverlaybar.cpp | 17 +-
linden/indra/newview/llpanelaudioprefs.cpp | 4 +-
linden/indra/newview/llpanelavatar.cpp | 60 +-
linden/indra/newview/llpanelavatar.h | 16 +-
linden/indra/newview/llpanelclassified.cpp | 2 +-
linden/indra/newview/llpaneldebug.cpp | 2 +-
linden/indra/newview/llpaneldirfind.cpp | 42 +-
linden/indra/newview/llpaneldirfind.h | 15 +-
linden/indra/newview/llpaneldirgroups.cpp | 1 +
linden/indra/newview/llpanelface.cpp | 33 +-
linden/indra/newview/llpanellandaudio.cpp | 195 ++
linden/indra/newview/llpanellandaudio.h | 63 +
linden/indra/newview/llpanellandmedia.cpp | 292 ++-
linden/indra/newview/llpanellandmedia.h | 25 +-
linden/indra/newview/llpanellogin.cpp | 55 +-
linden/indra/newview/llpanellogin.h | 8 +-
linden/indra/newview/llpanelmediahud.cpp | 667 ++++++
linden/indra/newview/llpanelmediahud.h | 110 +
linden/indra/newview/llpanelpermissions.cpp | 2 +-
linden/indra/newview/llpanelweb.cpp | 65 +-
linden/indra/newview/llprefsvoice.cpp | 4 +-
linden/indra/newview/llpreviewscript.cpp | 14 +-
linden/indra/newview/llpreviewsound.cpp | 2 +-
linden/indra/newview/llselectmgr.cpp | 11 +-
linden/indra/newview/llstartup.cpp | 37 +-
linden/indra/newview/llstatusbar.cpp | 2 +-
linden/indra/newview/lltoolcomp.cpp | 4 -
linden/indra/newview/lltoolcomp.h | 1 +
linden/indra/newview/lltoolgun.cpp | 7 +-
linden/indra/newview/lltoolgun.h | 2 +
linden/indra/newview/lltoolmgr.cpp | 14 +-
linden/indra/newview/lltoolmorph.cpp | 2 +-
linden/indra/newview/lltoolpie.cpp | 208 +-
linden/indra/newview/lltoolpie.h | 1 +
linden/indra/newview/lltoolplacer.cpp | 2 +-
linden/indra/newview/llurldispatcher.cpp | 22 +-
linden/indra/newview/llurldispatcher.h | 6 +-
linden/indra/newview/llvieweraudio.cpp | 3 +-
linden/indra/newview/llviewercontrol.cpp | 19 +-
linden/indra/newview/llviewergesture.cpp | 2 +-
linden/indra/newview/llviewerimagelist.cpp | 2 +-
linden/indra/newview/llviewerkeyboard.cpp | 2 +-
linden/indra/newview/llviewermedia.cpp | 1390 ++++++++-----
linden/indra/newview/llviewermedia.h | 200 +-
.../indra/newview/llviewermedia_streamingaudio.cpp | 169 ++
.../indra/newview/llviewermedia_streamingaudio.h | 69 +
linden/indra/newview/llviewermediafocus.cpp | 359 ++++
linden/indra/newview/llviewermediafocus.h | 91 +
linden/indra/newview/llviewermediaobserver.h | 71 +
linden/indra/newview/llviewermenu.cpp | 34 +-
linden/indra/newview/llviewermenufile.cpp | 2 +-
linden/indra/newview/llviewermessage.cpp | 8 +-
linden/indra/newview/llviewerobject.cpp | 2 +-
linden/indra/newview/llviewerparcelmedia.cpp | 350 +++-
linden/indra/newview/llviewerparcelmedia.h | 31 +-
.../indra/newview/llviewerparcelmediaautoplay.cpp | 2 +-
linden/indra/newview/llviewerparcelmediaautoplay.h | 1 -
linden/indra/newview/llviewerparcelmgr.cpp | 80 +-
linden/indra/newview/llviewerparcelmgr.h | 5 +
linden/indra/newview/llviewerregion.cpp | 6 +-
linden/indra/newview/llviewertexteditor.cpp | 2 +-
linden/indra/newview/llviewerwindow.cpp | 58 +-
linden/indra/newview/llvoavatar.cpp | 17 +-
linden/indra/newview/llvovolume.cpp | 2 +-
linden/indra/newview/llweb.cpp | 2 +-
.../newview/mozilla-powerpc-darwin-readme.txt | 71 -
linden/indra/newview/pipeline.cpp | 2 +-
.../newview/skins/default/textures/textures.xml | 20 +-
.../skins/default/xui/en-us/floater_about_land.xml | 744 +++++--
.../default/xui/en-us/floater_media_browser.xml | 21 +-
.../newview/skins/default/xui/en-us/mime_types.xml | 456 ----
.../skins/default/xui/en-us/mime_types_linux.xml | 445 ++++
.../skins/default/xui/en-us/mime_types_mac.xml | 445 ++++
.../skins/default/xui/en-us/mime_types_windows.xml | 445 ++++
.../newview/skins/default/xui/en-us/panel_bars.xml | 3 -
.../newview/skins/default/xui/en-us/panel_hud.xml | 4 +
.../skins/default/xui/en-us/panel_media_hud.xml | 68 +
linden/indra/newview/viewer_manifest.py | 126 +-
linden/indra/newview/viewer_manifest.py~ | 1176 +++++++++++
linden/indra/test_apps/llplugintest/CMakeLists.txt | 378 ++++
linden/indra/test_apps/llplugintest/bookmarks.txt | 28 +
.../test_apps/llplugintest/demo_media_plugin.cpp | 472 +++++
.../test_apps/llplugintest/demo_media_plugin_2.cpp | 578 ++++++
.../indra/test_apps/llplugintest/demo_plugin.cpp | 220 ++
.../test_apps/llplugintest/llmediaplugintest.cpp | 2179 ++++++++++++++++++++
.../test_apps/llplugintest/llmediaplugintest.h | 201 ++
.../test_apps/llplugintest/media_mappings.txt | 3 +
.../test_apps/llplugintest/media_plugin_test.cpp | 511 +++++
.../test_apps/llplugintest/media_simple_test.cpp | 460 +++++
.../indra/test_apps/llplugintest/plugin_host.cpp | 92 +
.../llplugintest/plugin_process_launcher.cpp | 197 ++
linden/install.xml | 23 +-
322 files changed, 35699 insertions(+), 12802 deletions(-)
create mode 100644 linden/doc/LICENSE-logos.txt
create mode 100644 linden/indra/cmake/FindNDOF.cmake
create mode 100644 linden/indra/cmake/GStreamer010Plugin.cmake
create mode 100644 linden/indra/cmake/Glui.cmake
create mode 100644 linden/indra/cmake/Glut.cmake
delete mode 100644 linden/indra/cmake/LLMedia.cmake
create mode 100644 linden/indra/cmake/LLPlugin.cmake
create mode 100644 linden/indra/cmake/MediaPluginBase.cmake
create mode 100644 linden/indra/cmake/OPENAL.cmake.imp
create mode 100644 linden/indra/cmake/PluginAPI.cmake
create mode 100644 linden/indra/cmake/QuickTimePlugin.cmake
create mode 100644 linden/indra/cmake/WebKitLibPlugin.cmake
create mode 100644 linden/indra/cmake/linden%2findra%2fcmake%2fCopyWinLibs.cmake.rej.txt
delete mode 100644 linden/indra/llaudio/audioengine.cpp
delete mode 100644 linden/indra/llaudio/audioengine.h
delete mode 100644 linden/indra/llaudio/audioengine_fmod.cpp
delete mode 100644 linden/indra/llaudio/audioengine_fmod.h
delete mode 100644 linden/indra/llaudio/audioengine_openal.cpp
delete mode 100644 linden/indra/llaudio/audioengine_openal.h
delete mode 100644 linden/indra/llaudio/listener_openal.cpp
delete mode 100644 linden/indra/llaudio/listener_openal.h
create mode 100644 linden/indra/llaudio/llaudioengine.cpp
create mode 100644 linden/indra/llaudio/llaudioengine.h
create mode 100644 linden/indra/llaudio/llaudioengine_fmod.cpp
create mode 100644 linden/indra/llaudio/llaudioengine_fmod.h
create mode 100644 linden/indra/llaudio/llaudioengine_openal.cpp
create mode 100644 linden/indra/llaudio/llaudioengine_openal.h
create mode 100644 linden/indra/llaudio/lllistener.cpp
create mode 100644 linden/indra/llaudio/lllistener.h
create mode 100644 linden/indra/llaudio/lllistener_ds3d.h
create mode 100644 linden/indra/llaudio/lllistener_fmod.cpp
create mode 100644 linden/indra/llaudio/lllistener_fmod.h
create mode 100644 linden/indra/llaudio/lllistener_openal.cpp
create mode 100644 linden/indra/llaudio/lllistener_openal.h
create mode 100644 linden/indra/llaudio/llstreamingaudio.h
create mode 100644 linden/indra/llaudio/llstreamingaudio_fmod.cpp
create mode 100644 linden/indra/llaudio/llstreamingaudio_fmod.h
create mode 100644 linden/indra/llaudio/llvorbisdecode.cpp
create mode 100644 linden/indra/llaudio/llvorbisdecode.h
create mode 100644 linden/indra/llaudio/llvorbisencode.cpp
create mode 100644 linden/indra/llaudio/llvorbisencode.h
create mode 100644 linden/indra/llaudio/llwindgen.h
delete mode 100644 linden/indra/llaudio/vorbisdecode.cpp
delete mode 100644 linden/indra/llaudio/vorbisdecode.h
delete mode 100644 linden/indra/llaudio/vorbisencode.h
delete mode 100644 linden/indra/llaudio/windgen.h
create mode 100644 linden/indra/llcommon/llprocesslauncher.cpp
create mode 100644 linden/indra/llcommon/llprocesslauncher.h
delete mode 100644 linden/indra/llmedia/CMakeLists.txt
delete mode 100644 linden/indra/llmedia/llgstplaythread.cpp
delete mode 100644 linden/indra/llmedia/llgstplaythread.h
delete mode 100644 linden/indra/llmedia/llmediabase.h
delete mode 100644 linden/indra/llmedia/llmediaemitter.h
delete mode 100644 linden/indra/llmedia/llmediaimplcommon.cpp
delete mode 100644 linden/indra/llmedia/llmediaimplcommon.h
delete mode 100644 linden/indra/llmedia/llmediaimplexample1.cpp
delete mode 100644 linden/indra/llmedia/llmediaimplexample1.h
delete mode 100644 linden/indra/llmedia/llmediaimplexample2.cpp
delete mode 100644 linden/indra/llmedia/llmediaimplexample2.h
delete mode 100644 linden/indra/llmedia/llmediaimplfactory.cpp
delete mode 100644 linden/indra/llmedia/llmediaimplfactory.h
delete mode 100644 linden/indra/llmedia/llmediaimplgstreamer.h
delete mode 100644 linden/indra/llmedia/llmediaimplgstreamervidplug.cpp
delete mode 100644 linden/indra/llmedia/llmediaimplgstreamervidplug.h
delete mode 100644 linden/indra/llmedia/llmediaimplllmozlib.cpp
delete mode 100644 linden/indra/llmedia/llmediaimplllmozlib.h
delete mode 100644 linden/indra/llmedia/llmediaimplquicktime.cpp
delete mode 100644 linden/indra/llmedia/llmediaimplquicktime.h
delete mode 100644 linden/indra/llmedia/llmediaimplregister.h
delete mode 100644 linden/indra/llmedia/llmediamanager.cpp
delete mode 100644 linden/indra/llmedia/llmediamanager.h
delete mode 100644 linden/indra/llmedia/llmediaobserver.h
create mode 100644 linden/indra/llmessage/tests/commtest.h
create mode 100644 linden/indra/llmessage/tests/llcurl_stub.cpp
create mode 100644 linden/indra/llmessage/tests/llhttpclientadapter_test.cpp
create mode 100644 linden/indra/llmessage/tests/lltemplatemessagedispatcher_test.cpp
create mode 100644 linden/indra/llmessage/tests/lltesthttpclientadapter.cpp
create mode 100644 linden/indra/llmessage/tests/lltesthttpclientadapter.h
create mode 100644 linden/indra/llmessage/tests/lltestmessagesender.cpp
create mode 100644 linden/indra/llmessage/tests/lltestmessagesender.h
create mode 100644 linden/indra/llmessage/tests/lltrustedmessageservice_test.cpp
create mode 100644 linden/indra/llmessage/tests/networkio.h
create mode 100644 linden/indra/llmessage/tests/test_llsdmessage_peer.py
create mode 100644 linden/indra/llplugin/CMakeLists.txt
create mode 100644 linden/indra/llplugin/llpluginclassmedia.cpp
create mode 100644 linden/indra/llplugin/llpluginclassmedia.h
create mode 100644 linden/indra/llplugin/llpluginclassmediaowner.h
create mode 100644 linden/indra/llplugin/llplugininstance.cpp
create mode 100644 linden/indra/llplugin/llplugininstance.h
create mode 100644 linden/indra/llplugin/llpluginmessage.cpp
create mode 100644 linden/indra/llplugin/llpluginmessage.h
create mode 100644 linden/indra/llplugin/llpluginmessageclasses.h
create mode 100644 linden/indra/llplugin/llpluginmessagepipe.cpp
create mode 100644 linden/indra/llplugin/llpluginmessagepipe.h
create mode 100644 linden/indra/llplugin/llpluginprocesschild.cpp
create mode 100644 linden/indra/llplugin/llpluginprocesschild.h
create mode 100644 linden/indra/llplugin/llpluginprocessparent.cpp
create mode 100644 linden/indra/llplugin/llpluginprocessparent.h
create mode 100644 linden/indra/llplugin/llpluginsharedmemory.cpp
create mode 100644 linden/indra/llplugin/llpluginsharedmemory.h
create mode 100644 linden/indra/llplugin/slplugin/CMakeLists.txt
create mode 100644 linden/indra/llplugin/slplugin/slplugin.cpp
create mode 100644 linden/indra/llplugin/slplugin/slplugin_info.plist
create mode 100644 linden/indra/media_plugins/CMakeLists.txt
create mode 100644 linden/indra/media_plugins/base/CMakeLists.txt
create mode 100644 linden/indra/media_plugins/base/media_plugin_base.cpp
create mode 100644 linden/indra/media_plugins/base/media_plugin_base.exp
create mode 100644 linden/indra/media_plugins/base/media_plugin_base.h
create mode 100644 linden/indra/media_plugins/example/CMakeLists.txt
create mode 100644 linden/indra/media_plugins/example/media_plugin_example.cpp
create mode 100644 linden/indra/media_plugins/gstreamer010/CMakeLists.txt
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamer.h
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamer_syms.cpp
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamer_syms.h
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamer_syms_raw.inc
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamer_syms_rawv.inc
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamertriviallogging.h
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamervidplug.cpp
create mode 100644 linden/indra/media_plugins/gstreamer010/llmediaimplgstreamervidplug.h
create mode 100644 linden/indra/media_plugins/gstreamer010/media_plugin_gstreamer010.cpp
create mode 100755 linden/indra/media_plugins/gstreamer010/media_plugin_gstreamer010.cpp~
create mode 100644 linden/indra/media_plugins/quicktime/CMakeLists.txt
create mode 100644 linden/indra/media_plugins/quicktime/media_plugin_quicktime.cpp
create mode 100644 linden/indra/media_plugins/webkit/CMakeLists.txt
create mode 100644 linden/indra/media_plugins/webkit/media_plugin_webkit.cpp
delete mode 100644 linden/indra/newview/llfloaterhtmlhelp.h
create mode 100644 linden/indra/newview/llfloatermediabrowser.cpp
create mode 100644 linden/indra/newview/llfloatermediabrowser.h
create mode 100644 linden/indra/newview/llmediactrl.cpp
create mode 100644 linden/indra/newview/llmediactrl.h
create mode 100644 linden/indra/newview/llpanellandaudio.cpp
create mode 100644 linden/indra/newview/llpanellandaudio.h
create mode 100644 linden/indra/newview/llpanelmediahud.cpp
create mode 100644 linden/indra/newview/llpanelmediahud.h
create mode 100644 linden/indra/newview/llviewermedia_streamingaudio.cpp
create mode 100644 linden/indra/newview/llviewermedia_streamingaudio.h
create mode 100644 linden/indra/newview/llviewermediafocus.cpp
create mode 100644 linden/indra/newview/llviewermediafocus.h
create mode 100644 linden/indra/newview/llviewermediaobserver.h
create mode 100644 linden/indra/newview/skins/default/xui/en-us/mime_types_linux.xml
create mode 100644 linden/indra/newview/skins/default/xui/en-us/mime_types_mac.xml
create mode 100644 linden/indra/newview/skins/default/xui/en-us/mime_types_windows.xml
create mode 100644 linden/indra/newview/skins/default/xui/en-us/panel_hud.xml
create mode 100644 linden/indra/newview/skins/default/xui/en-us/panel_media_hud.xml
create mode 100755 linden/indra/newview/viewer_manifest.py~
create mode 100644 linden/indra/test_apps/llplugintest/CMakeLists.txt
create mode 100644 linden/indra/test_apps/llplugintest/bookmarks.txt
create mode 100644 linden/indra/test_apps/llplugintest/demo_media_plugin.cpp
create mode 100644 linden/indra/test_apps/llplugintest/demo_media_plugin_2.cpp
create mode 100644 linden/indra/test_apps/llplugintest/demo_plugin.cpp
create mode 100644 linden/indra/test_apps/llplugintest/llmediaplugintest.cpp
create mode 100644 linden/indra/test_apps/llplugintest/llmediaplugintest.h
create mode 100644 linden/indra/test_apps/llplugintest/media_mappings.txt
create mode 100644 linden/indra/test_apps/llplugintest/media_plugin_test.cpp
create mode 100644 linden/indra/test_apps/llplugintest/media_simple_test.cpp
create mode 100644 linden/indra/test_apps/llplugintest/plugin_host.cpp
create mode 100644 linden/indra/test_apps/llplugintest/plugin_process_launcher.cpp
mode change 100755 => 100644 linden/install.xml
(limited to 'linden')
diff --git a/linden/doc/LICENSE-logos.txt b/linden/doc/LICENSE-logos.txt
new file mode 100644
index 0000000..e63c48e
--- /dev/null
+++ b/linden/doc/LICENSE-logos.txt
@@ -0,0 +1,23 @@
+COPYRIGHT AND PERMISSION NOTICE
+
+Second Life(TM) Viewer Artwork. Copyright (C) 2008 Linden Research, Inc.
+
+Linden Research, Inc. ("Linden Lab") licenses the Second Life viewer
+artwork and other works in the files distributed with this Notice under
+the Creative Commons Attribution-Share Alike 3.0 License, available at
+http://creativecommons.org/licenses/by-sa/3.0/legalcode. For the license
+summary, see http://creativecommons.org/licenses/by-sa/3.0/.
+
+Notwithstanding the foregoing, all of Linden Lab's trademarks, including
+but not limited to the Second Life brand name and Second Life Eye-in-Hand
+logo, are subject to our trademark policy at
+http://secondlife.com/corporate/trademark/.
+
+If you distribute any copies or adaptations of the Second Life viewer
+artwork or any other works in these files, you must include this Notice
+and clearly identify any changes made to the original works. Include
+this Notice and information where copyright notices are usually included,
+for example, after your own copyright notice acknowledging your use of
+the Second Life viewer artwork, in a text file distributed with your
+program, in your application's About window, or on a credits page for
+your work.
diff --git a/linden/doc/contributions.txt b/linden/doc/contributions.txt
index c3d5e59..329fc28 100644
--- a/linden/doc/contributions.txt
+++ b/linden/doc/contributions.txt
@@ -85,11 +85,6 @@ Alissa Sabre
VWR-7087
VWR-7153
VWR-7168
-<<<<<<< HEAD
-=======
- VWR-7087
- VWR-7086
->>>>>>> origin/next
VWR-9190
VWR-10728
VWR-12620
@@ -558,6 +553,8 @@ TBBle Kurosawa
VWR-1892
Teardrops Fall
VWR-5366
+Techwolf Lupindo
+ SNOW-334
tenebrous pau
VWR-247
Tharax Ferraris
diff --git a/linden/etc/message.xml b/linden/etc/message.xml
index dd149dd..6598344 100644
--- a/linden/etc/message.xml
+++ b/linden/etc/message.xml
@@ -377,7 +377,23 @@
trusted-sender
true
+
+ ParcelMediaURLFilter
+
+ ParcelNavigateMedia
+
+
ParcelObjectOwnersReply