From b3c39a47e76f595fd953d9ccffc58b0dfb8359db Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Thu, 10 Sep 2009 02:38:36 -0500
Subject: Updated Grid Manager from Meerkat's SVN (as of r215).
---
linden/indra/llvfs/lldir.cpp | 12 +-
linden/indra/llvfs/lldir.h | 4 +-
linden/indra/newview/CMakeLists.txt | 12 -
.../indra/newview/app_settings/default_grids.xml | 14 -
linden/indra/newview/authentication_controller.cpp | 80 -----
linden/indra/newview/authentication_controller.h | 42 ---
linden/indra/newview/authentication_floater.cpp | 75 -----
linden/indra/newview/authentication_floater.h | 35 ---
linden/indra/newview/authentication_model.cpp | 111 -------
linden/indra/newview/authentication_model.h | 53 ----
linden/indra/newview/controllerlogin.cpp | 142 ---------
linden/indra/newview/controllerlogin.h | 55 ----
linden/indra/newview/controllerpasswords.cpp | 41 ---
linden/indra/newview/controllerpasswords.h | 37 ---
linden/indra/newview/floaterlogin.cpp | 348 +++++++--------------
linden/indra/newview/floaterlogin.h | 26 +-
linden/indra/newview/hippoGridManager.cpp | 5 +-
linden/indra/newview/hippoGridManager.h | 344 ++++++++++----------
linden/indra/newview/llfloaterworldmap.cpp | 4 +-
linden/indra/newview/llpanellogin.cpp | 49 +--
linden/indra/newview/llprefsim.cpp | 4 +-
linden/indra/newview/llstartup.cpp | 17 +-
linden/indra/newview/prefpanelpasswords.cpp | 40 ---
linden/indra/newview/prefpanelpasswords.h | 30 --
.../skins/default/xui/en-us/floater_login.xml | 208 ++++++++----
25 files changed, 478 insertions(+), 1310 deletions(-)
delete mode 100644 linden/indra/newview/authentication_controller.cpp
delete mode 100644 linden/indra/newview/authentication_controller.h
delete mode 100644 linden/indra/newview/authentication_floater.cpp
delete mode 100644 linden/indra/newview/authentication_floater.h
delete mode 100644 linden/indra/newview/authentication_model.cpp
delete mode 100644 linden/indra/newview/authentication_model.h
delete mode 100644 linden/indra/newview/controllerlogin.cpp
delete mode 100644 linden/indra/newview/controllerlogin.h
delete mode 100644 linden/indra/newview/controllerpasswords.cpp
delete mode 100644 linden/indra/newview/controllerpasswords.h
delete mode 100644 linden/indra/newview/prefpanelpasswords.cpp
delete mode 100644 linden/indra/newview/prefpanelpasswords.h
(limited to 'linden')
diff --git a/linden/indra/llvfs/lldir.cpp b/linden/indra/llvfs/lldir.cpp
index 1dc00dd..c9af311 100644
--- a/linden/indra/llvfs/lldir.cpp
+++ b/linden/indra/llvfs/lldir.cpp
@@ -520,19 +520,23 @@ std::string LLDir::getForbiddenFileChars()
return "\\/:*?\"<>|";
}
-void LLDir::setLindenUserDir(const std::string &first, const std::string &last)
+void LLDir::setLindenUserDir(const std::string &grid, const std::string &first, const std::string &last)
{
// if both first and last aren't set, assume we're grabbing the cached dir
if (!first.empty() && !last.empty())
{
// some platforms have case-sensitive filesystems, so be
// utterly consistent with our firstname/lastname case.
+ std::string gridlower(grid);
+ LLStringUtil::toLower(gridlower);
std::string firstlower(first);
LLStringUtil::toLower(firstlower);
std::string lastlower(last);
LLStringUtil::toLower(lastlower);
mLindenUserDir = getOSUserAppDir();
mLindenUserDir += mDirDelimiter;
+ mLindenUserDir += gridlower;
+ mLindenUserDir += "-";
mLindenUserDir += firstlower;
mLindenUserDir += "_";
mLindenUserDir += lastlower;
@@ -557,19 +561,23 @@ void LLDir::setChatLogsDir(const std::string &path)
}
}
-void LLDir::setPerAccountChatLogsDir(const std::string &first, const std::string &last)
+void LLDir::setPerAccountChatLogsDir(const std::string &grid, const std::string &first, const std::string &last)
{
// if both first and last aren't set, assume we're grabbing the cached dir
if (!first.empty() && !last.empty())
{
// some platforms have case-sensitive filesystems, so be
// utterly consistent with our firstname/lastname case.
+ std::string gridlower(grid);
+ LLStringUtil::toLower(gridlower);
std::string firstlower(first);
LLStringUtil::toLower(firstlower);
std::string lastlower(last);
LLStringUtil::toLower(lastlower);
mPerAccountChatLogsDir = getChatLogsDir();
mPerAccountChatLogsDir += mDirDelimiter;
+ mPerAccountChatLogsDir += gridlower;
+ mPerAccountChatLogsDir += "-";
mPerAccountChatLogsDir += firstlower;
mPerAccountChatLogsDir += "_";
mPerAccountChatLogsDir += lastlower;
diff --git a/linden/indra/llvfs/lldir.h b/linden/indra/llvfs/lldir.h
index b041afc..4ab5d85 100644
--- a/linden/indra/llvfs/lldir.h
+++ b/linden/indra/llvfs/lldir.h
@@ -119,8 +119,8 @@ class LLDir
static std::string getForbiddenFileChars();
virtual void setChatLogsDir(const std::string &path); // Set the chat logs dir to this user's dir
- virtual void setPerAccountChatLogsDir(const std::string &first, const std::string &last); // Set the per user chat log directory.
- virtual void setLindenUserDir(const std::string &first, const std::string &last); // Set the linden user dir to this user's dir
+ virtual void setPerAccountChatLogsDir(const std::string &grid, const std::string &first, const std::string &last); // Set the per user chat log directory.
+ virtual void setLindenUserDir(const std::string &grid, const std::string &first, const std::string &last); // Set the linden user dir to this user's dir
virtual void setSkinFolder(const std::string &skin_folder);
virtual bool setCacheDir(const std::string &path);
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index cd725d2..0a4ee82 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -61,11 +61,6 @@ include_directories(
)
set(viewer_SOURCE_FILES
- authentication_controller.cpp
- authentication_floater.cpp
- authentication_model.cpp
- controllerlogin.cpp
- controllerpasswords.cpp
floaterlogin.cpp
hippoGridManager.cpp
hippoLimits.cpp
@@ -442,7 +437,6 @@ set(viewer_SOURCE_FILES
llxmlrpctransaction.cpp
noise.cpp
pipeline.cpp
- prefpanelpasswords.cpp
primbackup.cpp
rlvhandler.cpp
rlvhelper.cpp
@@ -471,11 +465,6 @@ endif (LINUX)
set(viewer_HEADER_FILES
CMakeLists.txt
ViewerInstall.cmake
- authentication_controller.h
- authentication_floater.h
- authentication_model.h
- controllerlogin.h
- controllerpasswords.h
floaterlogin.h
hippoGridManager.h
hippoLimits.h
@@ -859,7 +848,6 @@ set(viewer_HEADER_FILES
macmain.h
noise.h
pipeline.h
- prefpanelpasswords.h
primbackup.h
randgauss.h
VertexCache.h
diff --git a/linden/indra/newview/app_settings/default_grids.xml b/linden/indra/newview/app_settings/default_grids.xml
index dabcb0b..05d8bed 100644
--- a/linden/indra/newview/app_settings/default_grids.xml
+++ b/linden/indra/newview/app_settings/default_grids.xml
@@ -10,20 +10,6 @@
default_grids_version0
-
-
-