From 56bf45f3493689b5eb60cf99580adf11d6b02508 Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Sun, 13 Mar 2011 09:16:20 +0100
Subject: fix voice doesn't kick in.
also fixed some LL_INFOS that should be LL_WARNS in the voice client.
---
linden/indra/newview/llvoiceclient.cpp | 22 ++++++++++------------
1 file changed, 10 insertions(+), 12 deletions(-)
(limited to 'linden/indra')
diff --git a/linden/indra/newview/llvoiceclient.cpp b/linden/indra/newview/llvoiceclient.cpp
index 5517ca2..c05f685 100644
--- a/linden/indra/newview/llvoiceclient.cpp
+++ b/linden/indra/newview/llvoiceclient.cpp
@@ -1537,12 +1537,10 @@ void LLVoiceClient::start()
void LLVoiceClient::stateMachine()
{
- if(gDisconnected)
- {
- // The viewer has been disconnected from the sim. Disable voice.
- setVoiceEnabled(false);
- }
-
+
+ // Disable voice as long as the viewer is disconnected from the sim (login/relog)
+ setVoiceEnabled(!gDisconnected);
+
if(mVoiceEnabled)
{
updatePosition();
@@ -1559,7 +1557,7 @@ void LLVoiceClient::stateMachine()
if(!mConnected)
{
// if voice was turned off after the daemon was launched but before we could connect to it, we may need to issue a kill.
- LL_INFOS("Voice") << "Disabling voice before connection to daemon, terminating." << LL_ENDL;
+ LL_WARNS("Voice") << "Disabling voice before connection to daemon, terminating." << LL_ENDL;
killGateway();
}
@@ -1764,7 +1762,7 @@ void LLVoiceClient::stateMachine()
}
else
{
- LL_INFOS("Voice") << exe_path << " not found." << LL_ENDL;
+ LL_WARNS("Voice") << exe_path << " not found." << LL_ENDL;
mVoiceEnabled = false;
}
}
@@ -3783,7 +3781,7 @@ void LLVoiceClient::loginResponse(int statusCode, std::string &statusString, std
if ( statusCode == 401 )
{
// Login failure which is probably caused by the delay after a user's password being updated.
- LL_INFOS("Voice") << "Account.Login response failure (" << statusCode << "): " << statusString << LL_ENDL;
+ LL_WARNS("Voice") << "Account.Login response failure (" << statusCode << "): " << statusString << LL_ENDL;
setState(stateLoginRetry);
}
else if(statusCode != 0)
@@ -3961,7 +3959,7 @@ void LLVoiceClient::sessionAddedEvent(
}
else
{
- LL_INFOS("Voice") << "Could not generate caller id from uri, using hash of uri " << session->mSIPURI << LL_ENDL;
+ LL_WARNS("Voice") << "Could not generate caller id from uri, using hash of uri " << session->mSIPURI << LL_ENDL;
setUUIDFromStringHash(session->mCallerID, session->mSIPURI);
session->mSynthesizedCallerID = true;
@@ -4479,7 +4477,7 @@ void LLVoiceClient::participantUpdatedEvent(
}
else
{
- LL_INFOS("Voice") << "unknown session " << sessionHandle << LL_ENDL;
+ LL_WARNS("Voice") << "unknown session " << sessionHandle << LL_ENDL;
}
}
@@ -5073,7 +5071,7 @@ void LLVoiceClient::parcelChanged()
else
{
// The transition to stateNoChannel needs to kick this off again.
- LL_INFOS("Voice") << "not logged in yet, deferring" << LL_ENDL;
+ LL_WARNS("Voice") << "not logged in yet, deferring" << LL_ENDL;
}
}
--
cgit v1.1
From b543f291fcf945330fd5a533cc7235c20d7cb4c5 Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Sun, 13 Mar 2011 15:19:55 +0100
Subject: Henri Beauchamps version of Sione Lomus media filter patch.
from http://sldev.free.fr/ : "MediaFilter_v3: based on code by Sione Lomu with a couple of bugfixes by Tonya Souther, this improved patch brings media and streaming audio URLs filtering (to prevent IP ripping by so-called security systems which violate the SL TOS by catching your IP and associating your various avatars with it, thus violating your anonimity). Beside empowering your viewer with allow/deny/blacklist/whitelist functions per domain, this improved patch makes the difference between external servers (domains names filtering) and in-world servers (scripted objects with built-in HTTP servers). I also fixed various bugs, security holes and shortcomings, refactored the code and improved it, and added a whitelist/blacklist erasing function."
Imprudence changes: added "MediaFilter" debug to be able to inspect the full url and media texture uuid
---
linden/indra/newview/CMakeLists.txt | 2 +
linden/indra/newview/app_settings/logcontrol.xml | 1 +
linden/indra/newview/app_settings/settings.xml | 27 ++
linden/indra/newview/lloverlaybar.cpp | 21 +-
linden/indra/newview/lloverlaybar.h | 4 +
linden/indra/newview/llstartup.cpp | 2 +
linden/indra/newview/llviewercontrol.cpp | 3 +-
linden/indra/newview/llviewermenu.cpp | 9 +
linden/indra/newview/llviewerparcelmedia.cpp | 397 ++++++++++++++++++++-
linden/indra/newview/llviewerparcelmedia.h | 24 +-
linden/indra/newview/llviewerparcelmgr.cpp | 12 +-
.../default/xui/en-us/floater_media_filter.xml | 61 ++++
.../skins/default/xui/en-us/menu_viewer.xml | 5 +
.../skins/default/xui/en-us/notifications.xml | 50 +++
linden/indra/newview/slfloatermediafilter.cpp | 350 ++++++++++++++++++
linden/indra/newview/slfloatermediafilter.h | 70 ++++
16 files changed, 1025 insertions(+), 13 deletions(-)
create mode 100644 linden/indra/newview/skins/default/xui/en-us/floater_media_filter.xml
create mode 100644 linden/indra/newview/slfloatermediafilter.cpp
create mode 100644 linden/indra/newview/slfloatermediafilter.h
(limited to 'linden/indra')
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index dedced0..9a4e2ed 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -498,6 +498,7 @@ set(viewer_SOURCE_FILES
rlvmultistringsearch.cpp
rlvextensions.cpp
rlvfloaterbehaviour.cpp
+ slfloatermediafilter.cpp
viewertime.cpp
viewerversion.cpp
windlightsettingsupdate.cpp
@@ -967,6 +968,7 @@ set(viewer_HEADER_FILES
rlvmultistringsearch.h
rlvextensions.h
rlvfloaterbehaviour.h
+ slfloatermediafilter.h
VertexCache.h
VorbisFramework.h
viewertime.h
diff --git a/linden/indra/newview/app_settings/logcontrol.xml b/linden/indra/newview/app_settings/logcontrol.xml
index 51bb456..c9e9127 100644
--- a/linden/indra/newview/app_settings/logcontrol.xml
+++ b/linden/indra/newview/app_settings/logcontrol.xml
@@ -58,6 +58,7 @@
+ MediaFilter
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml
index 59c2982..2a508ee 100644
--- a/linden/indra/newview/app_settings/settings.xml
+++ b/linden/indra/newview/app_settings/settings.xml
@@ -7990,6 +7990,33 @@
Value
3.0
+ MediaEnableFilter
+
+ MediaFilterRect
+
MediaOnAPrimUI