From b2b8a6b924a93794821a1a20f4dd965400e53688 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Wed, 1 Sep 2010 17:34:49 -0700
Subject: Moved chatbar commandline options into their own window, cleaned up
more stuff
---
linden/indra/newview/CMakeLists.txt | 2 +
linden/indra/newview/app_settings/settings.xml | 40 +++----
linden/indra/newview/chatbar_as_cmdline.cpp | 129 ++++++++++-----------
linden/indra/newview/floatercommandline.cpp | 84 ++++++++++++++
linden/indra/newview/floatercommandline.h | 55 +++++++++
linden/indra/newview/lggautocorrectfloater.cpp | 9 +-
linden/indra/newview/llprefsadvanced.cpp | 111 ++----------------
linden/indra/newview/llprefsadvanced.h | 22 +---
.../default/xui/en-us/floater_command_line.xml | 108 +++++++++++++++++
.../skins/default/xui/en-us/notifications.xml | 12 +-
.../xui/en-us/panel_preferences_advanced.xml | 117 ++-----------------
11 files changed, 364 insertions(+), 325 deletions(-)
create mode 100644 linden/indra/newview/floatercommandline.cpp
create mode 100644 linden/indra/newview/floatercommandline.h
create mode 100644 linden/indra/newview/skins/default/xui/en-us/floater_command_line.xml
(limited to 'linden/indra')
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 1a900c4..c047a0f 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -78,6 +78,7 @@ set(viewer_SOURCE_FILES
emeraldboobutils.cpp
floaterao.cpp
floaterbusy.cpp
+ floatercommandline.cpp
floatergriddefault.cpp
floatergridmanager.cpp
floaterlocalassetbrowse.cpp
@@ -514,6 +515,7 @@ set(viewer_HEADER_FILES
emeraldboobutils.h
floaterao.h
floaterbusy.h
+ floatercommandline.h
floatergriddefault.h
floatergridmanager.h
floaterlocalassetbrowse.h
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml
index 7071de2..f096811 100644
--- a/linden/indra/newview/app_settings/settings.xml
+++ b/linden/indra/newview/app_settings/settings.xml
@@ -1312,7 +1312,7 @@
- EmeraldCmdLine
+ CmdLineChatbarEnabled
- EmeraldCmdLineMapToKeepPos
+ CmdLineChatbarMapToKeepPos
- EmeraldCmdLineAO
+ CmdLineChatbarAO
- EmeraldCmdLineAutocorrect
+ CmdLineChatbarAutocorrect
- EmeraldCmdLineMedia
+ CmdLineChatbarMedia
- EmeraldCmdLineMusic
+ CmdLineChatbarMusic
- EmeraldCmdLineClearChat
+ CmdLineChatbarClearChat
- EmeraldCmdLineHeight
+ CmdLineChatbarHeight
- EmeraldCmdLinePos
+ CmdLineChatbarPos
- EmeraldCmdLineGround
+ CmdLineChatbarGround
- EmeraldCmdLineTeleportHome
+ CmdLineChatbarTeleportHome
- EmeraldCmdLineRezPlatform
+ CmdLineChatbarRezPlatform
- EmeraldCmdLinePlatformSize
+ CmdLineChatbarPlatformSize
- EmeraldCmdLineMapTo
+ CmdLineChatbarMapTo
- EmeraldCmdLineDrawDistance
+ CmdLineChatbarDrawDistance
- EmeraldCmdTeleportToCam
+ CmdLineChatbarTeleportToCam
- EmeraldCmdLineKeyToName
+ CmdLineChatbarKeyToName
- EmeraldCmdLineOfferTp
+ CmdLineChatbarOfferTp
- EmeraldCmdLineCalc
+ CmdLineChatbarCalc
- EmeraldCmdLineTP2
+ CmdLineChatbarTP2