From 798d367d54a6c6379ad355bd8345fa40e31e7fe9 Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Sat, 6 Sep 2008 18:24:57 -0500
Subject: Second Life viewer sources 1.21.0-RC
---
linden/indra/win_updater/CMakeLists.txt | 30 +++
linden/indra/win_updater/win_updater.vcproj | 194 ----------------
linden/indra/win_updater/win_updater_vc8.vcproj | 295 ------------------------
linden/indra/win_updater/win_updater_vc9.vcproj | 293 -----------------------
4 files changed, 30 insertions(+), 782 deletions(-)
create mode 100644 linden/indra/win_updater/CMakeLists.txt
delete mode 100644 linden/indra/win_updater/win_updater.vcproj
delete mode 100644 linden/indra/win_updater/win_updater_vc8.vcproj
delete mode 100644 linden/indra/win_updater/win_updater_vc9.vcproj
(limited to 'linden/indra/win_updater')
diff --git a/linden/indra/win_updater/CMakeLists.txt b/linden/indra/win_updater/CMakeLists.txt
new file mode 100644
index 0000000..6379d7c
--- /dev/null
+++ b/linden/indra/win_updater/CMakeLists.txt
@@ -0,0 +1,30 @@
+# -*- cmake -*-
+
+project(win_updater)
+
+include(00-Common)
+include(LLCommon)
+include(Linking)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ )
+
+set(win_updater_SOURCE_FILES updater.cpp)
+
+set(win_updater_HEADER_FILES CMakeLists.txt)
+
+set_source_files_properties(${win_updater_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND win_updater_SOURCE_FILES ${win_updater_HEADER_FILES})
+
+add_executable(windows-updater WIN32 ${win_updater_SOURCE_FILES})
+
+target_link_libraries(windows-updater wininet)
+
+set_target_properties(windows-updater
+ PROPERTIES
+ LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
+ LINK_FLAGS_DEBUG "/NODEFAULTLIB:\"LIBCMT;MSVCRTD\""
+ )
diff --git a/linden/indra/win_updater/win_updater.vcproj b/linden/indra/win_updater/win_updater.vcproj
deleted file mode 100644
index 5ec6249..0000000
--- a/linden/indra/win_updater/win_updater.vcproj
+++ /dev/null
@@ -1,194 +0,0 @@
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
diff --git a/linden/indra/win_updater/win_updater_vc8.vcproj b/linden/indra/win_updater/win_updater_vc8.vcproj
deleted file mode 100644
index e6c2772..0000000
--- a/linden/indra/win_updater/win_updater_vc8.vcproj
+++ /dev/null
@@ -1,295 +0,0 @@
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
diff --git a/linden/indra/win_updater/win_updater_vc9.vcproj b/linden/indra/win_updater/win_updater_vc9.vcproj
deleted file mode 100644
index 0d704f4..0000000
--- a/linden/indra/win_updater/win_updater_vc9.vcproj
+++ /dev/null
@@ -1,293 +0,0 @@
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
--
cgit v1.1