From 0e86bfee3d1dd0e42fef23293242f52793f08583 Mon Sep 17 00:00:00 2001
From: Robin Cornelius
Date: Sat, 9 Oct 2010 10:20:10 +0100
Subject: Fix some STL errors highlighted by MSVC debug
---
linden/indra/llrender/llfontregistry.cpp | 2 +-
linden/indra/llui/lllineeditor.cpp | 11 ++++++++++-
2 files changed, 11 insertions(+), 2 deletions(-)
diff --git a/linden/indra/llrender/llfontregistry.cpp b/linden/indra/llrender/llfontregistry.cpp
index 2140dbd..9792a91 100644
--- a/linden/indra/llrender/llfontregistry.cpp
+++ b/linden/indra/llrender/llfontregistry.cpp
@@ -107,7 +107,7 @@ bool removeSubString(std::string& str, const std::string& substr)
size_t pos = str.find(substr);
if (pos != string::npos)
{
- str.replace(pos,substr.length(),(const char *)NULL, 0);
+ str.erase(pos,substr.length());
return true;
}
return false;
diff --git a/linden/indra/llui/lllineeditor.cpp b/linden/indra/llui/lllineeditor.cpp
index e73b287..a3785e4 100644
--- a/linden/indra/llui/lllineeditor.cpp
+++ b/linden/indra/llui/lllineeditor.cpp
@@ -416,7 +416,16 @@ void LLLineEditor::setText(const LLStringExplicit &new_text)
setCursor(llmin((S32)mText.length(), getCursor()));
// Set current history line to end of history.
- mCurrentHistoryLine = mLineHistory.end() - 1;
+ // RC Fix, its really not safe to just take 1 of the end itterator, if end==begin
+ // that leaves an invalid state upseting the secure STL checks
+ if(mLineHistory.empty())
+ {
+ mCurrentHistoryLine = mLineHistory.begin();
+ }
+ else
+ {
+ mCurrentHistoryLine = mLineHistory.end() - 1;
+ }
mPrevText = mText;
}
--
cgit v1.1
From db2e458145f8b04012b295656f1aa68b448fc7bf Mon Sep 17 00:00:00 2001
From: Robin Cornelius
Date: Sat, 9 Oct 2010 10:22:23 +0100
Subject: Add a fall back to find NSIS on win64
---
linden/indra/newview/viewer_manifest.py | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index 7563268..f01cd7a 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -517,8 +517,12 @@ class WindowsManifest(ViewerManifest):
# We use the Unicode version of NSIS, available from
# http://www.scratchpaper.com/
- NSIS_path = 'C:\\Program Files\\NSIS\\Unicode\\makensis.exe'
- self.run_command('"' + proper_windows_path(NSIS_path) + '" ' + self.dst_path_of(tempfile))
+ try:
+ NSIS_path = 'C:\\Program Files\\NSIS\\Unicode\\makensis.exe'
+ self.run_command('"' + proper_windows_path(NSIS_path) + '" ' + self.dst_path_of(tempfile))
+ except:
+ NSIS_path = 'C:\\Program Files (x86)\\NSIS\\Unicode\\makensis.exe'
+ self.run_command('"' + proper_windows_path(NSIS_path) + '" ' + self.dst_path_of(tempfile))
# self.remove(self.dst_path_of(tempfile))
# If we're on a build machine, sign the code using our Authenticode certificate. JC
sign_py = 'C:\\buildscripts\\code-signing\\sign.py'
--
cgit v1.1
From 795d263a3acf18d12d67309d235390093e902853 Mon Sep 17 00:00:00 2001
From: Robin Cornelius
Date: Sat, 9 Oct 2010 10:23:52 +0100
Subject: Fix tab/space issues in viewer_manifest.py
---
linden/indra/newview/viewer_manifest.py | 22 +++++++++++-----------
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index f01cd7a..ff59aec 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -845,7 +845,7 @@ class LinuxManifest(ViewerManifest):
self.path("wrapper.sh","imprudence")
self.path("handle_secondlifeprotocol.sh")
self.path("register_secondlifeprotocol.sh")
- self.path("getvoice.sh")
+ self.path("getvoice.sh")
self.end_prefix("linux_tools")
self.gather_documents()
@@ -974,7 +974,7 @@ class Linux_i686Manifest(LinuxManifest):
self.path("libgstvideo-0.10.so.0")
# Gstreamer plugin dependencies
- self.path("libfaad.so.0")
+ self.path("libfaad.so.0")
self.path("libogg.so.0")
self.path("libtheora.so.0")
self.path("libvorbis.so.0")
@@ -1124,7 +1124,7 @@ class Linux_x86_64Manifest(LinuxManifest):
self.path("libgstdecodebin2.so")
self.path("libgstdecodebin.so")
self.path("libgstesd.so")
- self.path("libgstfaad.so")
+ self.path("libgstfaad.so")
self.path("libgstffmpeg.so")
self.path("libgstffmpegcolorspace.so")
self.path("libgstgnomevfs.so")
@@ -1162,14 +1162,14 @@ class Linux_x86_64Manifest(LinuxManifest):
self.path("libortp.so")
self.path("libvivoxsdk.so")
self.end_prefix("lib32")
-
- # 32bit libs needed for voice
- if self.prefix("../../libraries/x86_64-linux/lib_release_client/32bit-compat", dst="lib32"):
- self.path("libalut.so")
- self.path("libidn.so.11")
- self.path("libopenal.so.1")
- # self.path("libortp.so")
- self.path("libuuid.so.1")
+
+ # 32bit libs needed for voice
+ if self.prefix("../../libraries/x86_64-linux/lib_release_client/32bit-compat", dst="lib32"):
+ self.path("libalut.so")
+ self.path("libidn.so.11")
+ self.path("libopenal.so.1")
+ # self.path("libortp.so")
+ self.path("libuuid.so.1")
self.end_prefix("lib32")
if __name__ == "__main__":
--
cgit v1.1
From d7a6cb400ed230630aff5f6145aaa10687a5b1e0 Mon Sep 17 00:00:00 2001
From: Robin Cornelius
Date: Sat, 9 Oct 2010 10:30:11 +0100
Subject: Use all those cores for compile
---
linden/indra/cmake/00-Common.cmake | 1 +
1 file changed, 1 insertion(+)
diff --git a/linden/indra/cmake/00-Common.cmake b/linden/indra/cmake/00-Common.cmake
index 3497ec9..032a3cf 100644
--- a/linden/indra/cmake/00-Common.cmake
+++ b/linden/indra/cmake/00-Common.cmake
@@ -55,6 +55,7 @@ if (WINDOWS)
/Zc:forScope
/nologo
/Oy-
+ /MP
)
if(MSVC80 OR MSVC90)
--
cgit v1.1
From 1866bc2af39189c17b636970d4df7edc983c1830 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Sat, 9 Oct 2010 03:27:47 -0700
Subject: Applied RLVa-1.1.2-Imprudence.patch by Kitty Barnett
---
linden/indra/llxml/llcontrol.cpp | 9 +
linden/indra/newview/CMakeLists.txt | 3 +-
linden/indra/newview/app_settings/settings.xml | 55 +-
linden/indra/newview/llagent.cpp | 119 +-
linden/indra/newview/llagent.h | 4 -
linden/indra/newview/llappviewer.cpp | 14 +-
linden/indra/newview/llchatbar.cpp | 15 +-
linden/indra/newview/llfirstuse.cpp | 15 -
linden/indra/newview/llfirstuse.h | 4 -
linden/indra/newview/llfloaterabout.cpp | 6 +-
linden/indra/newview/llfloateractivespeakers.cpp | 6 +-
linden/indra/newview/llfloateranimpreview.cpp | 1 +
linden/indra/newview/llfloateravatarpicker.cpp | 4 +
linden/indra/newview/llfloaterbeacons.cpp | 4 +-
linden/indra/newview/llfloaterchat.cpp | 4 +
linden/indra/newview/llfloaterinspect.cpp | 4 +-
linden/indra/newview/llfloaterland.cpp | 4 +
linden/indra/newview/llfloatermap.cpp | 4 +
linden/indra/newview/llfloaterobjectiminfo.cpp | 4 +-
linden/indra/newview/llfloaterproperties.cpp | 5 +-
linden/indra/newview/llfloaterregioninfo.cpp | 4 +
linden/indra/newview/llfloaterreporter.cpp | 6 +-
linden/indra/newview/llfloatersettingsdebug.cpp | 4 +-
linden/indra/newview/llfloaterteleporthistory.cpp | 30 +-
linden/indra/newview/llfloaterworldmap.cpp | 12 +-
linden/indra/newview/llgesturemgr.cpp | 1 +
linden/indra/newview/llglsandbox.cpp | 8 +-
linden/indra/newview/llhoverview.cpp | 20 +-
linden/indra/newview/llhudeffectlookat.cpp | 5 +-
linden/indra/newview/llhudtext.cpp | 3 +
linden/indra/newview/llimpanel.cpp | 14 +-
linden/indra/newview/llimview.cpp | 6 +-
linden/indra/newview/llinventoryactions.cpp | 9 +
linden/indra/newview/llinventorybridge.cpp | 66 +-
linden/indra/newview/llinventorybridge.h | 35 +
linden/indra/newview/llinventorymodel.cpp | 4 +
linden/indra/newview/llinventoryview.cpp | 4 +
linden/indra/newview/llmaniptranslate.cpp | 4 +
linden/indra/newview/llnetmap.cpp | 8 +-
linden/indra/newview/llnotify.cpp | 2 +-
linden/indra/newview/lloverlaybar.cpp | 4 +
linden/indra/newview/llpanelavatar.cpp | 4 +
linden/indra/newview/llpanelclassified.cpp | 4 +
linden/indra/newview/llpanelcontents.cpp | 4 +-
linden/indra/newview/llpaneldisplay.cpp | 4 +
linden/indra/newview/llpanelinventory.cpp | 17 +-
linden/indra/newview/llpanelland.cpp | 4 +
linden/indra/newview/llpanellogin.cpp | 4 +-
linden/indra/newview/llpanelobject.cpp | 4 +-
linden/indra/newview/llpanelpermissions.cpp | 6 +-
linden/indra/newview/llpanelpick.cpp | 4 +
linden/indra/newview/llprefsim.cpp | 4 +
linden/indra/newview/llpreviewscript.cpp | 3 +
linden/indra/newview/llselectmgr.cpp | 15 +
linden/indra/newview/llstartup.cpp | 14 +-
linden/indra/newview/llstatusbar.cpp | 6 +-
linden/indra/newview/lltoolbar.cpp | 4 +
linden/indra/newview/lltooldraganddrop.cpp | 28 +-
linden/indra/newview/lltoolface.cpp | 9 +-
linden/indra/newview/lltoolgrab.cpp | 28 +-
linden/indra/newview/lltoolpie.cpp | 117 +-
linden/indra/newview/lltoolplacer.cpp | 8 +-
linden/indra/newview/lltoolselect.cpp | 5 +-
linden/indra/newview/lltracker.cpp | 11 +-
linden/indra/newview/llviewercontrol.cpp | 20 -
linden/indra/newview/llviewerdisplay.cpp | 4 +
linden/indra/newview/llviewermenu.cpp | 102 +-
linden/indra/newview/llviewermessage.cpp | 127 +-
linden/indra/newview/llviewerobject.cpp | 22 +
linden/indra/newview/llviewertexteditor.cpp | 12 +-
linden/indra/newview/llviewerwindow.cpp | 36 +-
linden/indra/newview/llvoavatar.cpp | 58 +-
linden/indra/newview/llvoavatar.h | 3 +
linden/indra/newview/llvovolume.cpp | 4 +
linden/indra/newview/llworldmapview.cpp | 7 +-
linden/indra/newview/panelradar.cpp | 6 +-
linden/indra/newview/pipeline.cpp | 4 +
linden/indra/newview/rlvdefines.h | 217 +-
linden/indra/newview/rlvevent.h | 227 --
linden/indra/newview/rlvextensions.cpp | 109 +-
linden/indra/newview/rlvextensions.h | 33 +-
linden/indra/newview/rlvfloaterbehaviour.cpp | 17 +
linden/indra/newview/rlvfloaterbehaviour.h | 18 +-
linden/indra/newview/rlvhandler.cpp | 3737 ++++++++++----------
linden/indra/newview/rlvhandler.h | 321 +-
linden/indra/newview/rlvhelper.cpp | 649 +++-
linden/indra/newview/rlvhelper.h | 206 +-
linden/indra/newview/rlvmultistringsearch.cpp | 16 +
linden/indra/newview/rlvmultistringsearch.h | 16 +
.../skins/default/xui/en-us/menu_viewer.xml | 8 +-
90 files changed, 3941 insertions(+), 2878 deletions(-)
delete mode 100644 linden/indra/newview/rlvevent.h
diff --git a/linden/indra/llxml/llcontrol.cpp b/linden/indra/llxml/llcontrol.cpp
index 1d1f024..452167e 100644
--- a/linden/indra/llxml/llcontrol.cpp
+++ b/linden/indra/llxml/llcontrol.cpp
@@ -1099,6 +1099,15 @@ U32 LLControlGroup::loadFromFile(const std::string& filename, bool set_default_v
}
*/
+// [RLVa:KB] - Checked: 2010-06-20 (RLVa-1.1.2a) | Added: RLVa-1.1.2a
+ // HACK-RLVa: bad code but it's just a temporary measure to provide a smooth changeover from the old to the new rebranded settings
+ if ( (name.length() >= 14) && (0 == name.find("RestrainedLife")) )
+ {
+ // Transparently convert the old settings name to the new one while preserving the user override
+ name = "RestrainedLove" + name.substr(14);
+ }
+// [/RLVa:KB]
+
// If the control exists just set the value from the input file.
LLControlVariable* existing_control = getControl(name);
if(existing_control)
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 9260b75..9ac2d57 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -486,6 +486,7 @@ set(viewer_SOURCE_FILES
primbackup.cpp
rlvhandler.cpp
rlvhelper.cpp
+ rlvcommon.cpp
rlvmultistringsearch.cpp
rlvextensions.cpp
rlvfloaterbehaviour.cpp
@@ -937,9 +938,9 @@ set(viewer_HEADER_FILES
primbackup.h
randgauss.h
rlvdefines.h
- rlvevent.h
rlvhandler.h
rlvhelper.h
+ rlvcommon.h
rlvmultistringsearch.h
rlvextensions.h
rlvfloaterbehaviour.h
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml
index d33285d..3be4ed4 100644
--- a/linden/indra/newview/app_settings/settings.xml
+++ b/linden/indra/newview/app_settings/settings.xml
@@ -1784,10 +1784,10 @@
- RestrainedLife
+ RestrainedLove
- RestrainedLifeDebug
+ RestrainedLoveDebug
- RestrainedLifeNoSetEnv
+ RestrainedLoveNoSetEnv
- RestrainedLifeForbidGiveToRLV
+ RestrainedLoveForbidGiveToRLV
+ RLVaEnableCompositeFolders
+
RLVaEnableLegacyNaming