diff options
Diffstat (limited to 'linden')
-rw-r--r-- | linden/indra/CMakeLists.txt | 8 | ||||
-rw-r--r-- | linden/indra/cmake/libgcrypt.cmake | 4 | ||||
-rw-r--r-- | linden/indra/cmake/libgpg-error.cmake | 4 | ||||
-rw-r--r-- | linden/indra/cmake/libotr.cmake | 2 | ||||
-rw-r--r-- | linden/indra/libgcrypt/CMakeLists.txt | 53 | ||||
-rw-r--r-- | linden/indra/libgpg-error/CMakeLists.txt | 45 | ||||
-rw-r--r-- | linden/indra/libotr/CMakeLists.txt | 34 | ||||
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 10 | ||||
-rw-r--r-- | linden/indra/newview/viewerinfo.cpp | 4 |
9 files changed, 55 insertions, 109 deletions
diff --git a/linden/indra/CMakeLists.txt b/linden/indra/CMakeLists.txt index de5dee8..d30e376 100644 --- a/linden/indra/CMakeLists.txt +++ b/linden/indra/CMakeLists.txt | |||
@@ -38,18 +38,14 @@ add_subdirectory(cmake) | |||
38 | # [$PLOTR$] | 38 | # [$PLOTR$] |
39 | if (WINDOWS) | 39 | if (WINDOWS) |
40 | add_subdirectory(${LIBS_OPEN_PREFIX}gpg.vs) | 40 | add_subdirectory(${LIBS_OPEN_PREFIX}gpg.vs) |
41 | add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) | ||
42 | add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) | ||
43 | endif (WINDOWS) | 41 | endif (WINDOWS) |
44 | 42 | ||
45 | # if ON will cause linux to link in static OTR like windows does | 43 | # if ON will cause linux to link in static OTR like windows does |
46 | # if off will use the systems libotr.so but won't be fully compatible with windows version | 44 | # if off will use the systems libotr.so but won't be fully compatible with windows version |
47 | set(STATIC_LIBOTR_ETC 1) | 45 | set(STATIC_LIBOTR_ETC 1) |
48 | 46 | ||
49 | if (NOT WINDOWS) | 47 | add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) |
50 | add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) | 48 | add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) |
51 | add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) | ||
52 | endif (NOT WINDOWS) | ||
53 | # [/$PLOTR$] | 49 | # [/$PLOTR$] |
54 | 50 | ||
55 | add_subdirectory(${LIBS_OPEN_PREFIX}llaudio) | 51 | add_subdirectory(${LIBS_OPEN_PREFIX}llaudio) |
diff --git a/linden/indra/cmake/libgcrypt.cmake b/linden/indra/cmake/libgcrypt.cmake index 057addf..4d19467 100644 --- a/linden/indra/cmake/libgcrypt.cmake +++ b/linden/indra/cmake/libgcrypt.cmake | |||
@@ -1,10 +1,10 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | set(LIBGCRYPT_INCLUDE_DIRS | 3 | set(LIBGCRYPT_INCLUDE_DIRS |
4 | ${CMAKE_CURRENT_SOURCE_DIR}/../libgcrypt/libgcrypt-1.2.2/include | 4 | ${CMAKE_BINARY_DIR}/libgcrypt/include |
5 | ) | 5 | ) |
6 | 6 | ||
7 | set(LIBGCRYPT_LIBRARIES | 7 | set(LIBGCRYPT_LIBRARIES |
8 | gcrypt | 8 | ${CMAKE_BINARY_DIR}/libgcrypt/lib/libgcrypt.a |
9 | ) | 9 | ) |
10 | 10 | ||
diff --git a/linden/indra/cmake/libgpg-error.cmake b/linden/indra/cmake/libgpg-error.cmake index b83adee..417ad19 100644 --- a/linden/indra/cmake/libgpg-error.cmake +++ b/linden/indra/cmake/libgpg-error.cmake | |||
@@ -1,10 +1,10 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | set(LIBGPG-ERROR_INCLUDE_DIRS | 3 | set(LIBGPG-ERROR_INCLUDE_DIRS |
4 | ${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0/include | 4 | ${CMAKE_BINARY_DIR}/libgpg-error/include |
5 | ) | 5 | ) |
6 | 6 | ||
7 | set(LIBGPG-ERROR_LIBRARIES | 7 | set(LIBGPG-ERROR_LIBRARIES |
8 | gpg-error | 8 | ${CMAKE_BINARY_DIR}/libgpg-error/lib/libgpg-error.a |
9 | ) | 9 | ) |
10 | 10 | ||
diff --git a/linden/indra/cmake/libotr.cmake b/linden/indra/cmake/libotr.cmake index 3c07be2..30544f8 100644 --- a/linden/indra/cmake/libotr.cmake +++ b/linden/indra/cmake/libotr.cmake | |||
@@ -4,5 +4,5 @@ set(LIBOTR_INCLUDE_DIRS | |||
4 | ) | 4 | ) |
5 | 5 | ||
6 | set(LIBOTR_LIBRARIES | 6 | set(LIBOTR_LIBRARIES |
7 | libotr | 7 | otr |
8 | ) | 8 | ) |
diff --git a/linden/indra/libgcrypt/CMakeLists.txt b/linden/indra/libgcrypt/CMakeLists.txt index 1b6794c..9235a70 100644 --- a/linden/indra/libgcrypt/CMakeLists.txt +++ b/linden/indra/libgcrypt/CMakeLists.txt | |||
@@ -1,12 +1,12 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | project(libgcrypt) | ||
4 | |||
5 | include(00-Common) | 3 | include(00-Common) |
6 | include(libgpg-error) | 4 | include(libgpg-error) |
7 | include(libgcrypt) | 5 | include(libgcrypt) |
8 | include(Linking) | 6 | include(Linking) |
9 | 7 | ||
8 | project(gcrypt) | ||
9 | |||
10 | if (WINDOWS) | 10 | if (WINDOWS) |
11 | include_directories( | 11 | include_directories( |
12 | ../gpg.vs/inc.vs | 12 | ../gpg.vs/inc.vs |
@@ -17,7 +17,7 @@ if (WINDOWS) | |||
17 | libgcrypt-1.2.2/mpi/generic | 17 | libgcrypt-1.2.2/mpi/generic |
18 | ) | 18 | ) |
19 | 19 | ||
20 | set(libgcrypt_SOURCE_FILES | 20 | set(gcrypt_SOURCE_FILES |
21 | libgcrypt-1.2.2/src/ath.c | 21 | libgcrypt-1.2.2/src/ath.c |
22 | libgcrypt-1.2.2/src/global.c | 22 | libgcrypt-1.2.2/src/global.c |
23 | libgcrypt-1.2.2/src/misc.c | 23 | libgcrypt-1.2.2/src/misc.c |
@@ -83,7 +83,7 @@ set(libgcrypt_SOURCE_FILES | |||
83 | libgcrypt-1.2.2/mpi/generic/udiv-w-sdiv.c | 83 | libgcrypt-1.2.2/mpi/generic/udiv-w-sdiv.c |
84 | ) | 84 | ) |
85 | 85 | ||
86 | set(libgcrypt_HEADER_FILES | 86 | set(gcrypt_HEADER_FILES |
87 | CMakeLists.txt | 87 | CMakeLists.txt |
88 | 88 | ||
89 | libgcrypt-1.2.2/src/ath.h | 89 | libgcrypt-1.2.2/src/ath.h |
@@ -108,53 +108,30 @@ set(libgcrypt_HEADER_FILES | |||
108 | libgcrypt-1.2.2/mpi/generic/mpi-asm-defs.h | 108 | libgcrypt-1.2.2/mpi/generic/mpi-asm-defs.h |
109 | ) | 109 | ) |
110 | 110 | ||
111 | set_source_files_properties(${libgcrypt_HEADER_FILES} | 111 | set_source_files_properties(${gcrypt_HEADER_FILES} |
112 | PROPERTIES HEADER_FILE_ONLY TRUE) | 112 | PROPERTIES HEADER_FILE_ONLY TRUE) |
113 | 113 | ||
114 | list(APPEND libgcrypt_SOURCE_FILES ${libgcrypt_HEADER_FILES}) | 114 | list(APPEND gcrypt_SOURCE_FILES ${gcrypt_HEADER_FILES}) |
115 | 115 | ||
116 | add_library (libgcrypt ${libgcrypt_SOURCE_FILES}) | 116 | add_library (gcrypt ${gcrypt_SOURCE_FILES}) |
117 | target_link_libraries( | ||
118 | gcrypt | ||
119 | ) | ||
117 | 120 | ||
118 | else (WINDOWS) | 121 | else (WINDOWS) |
119 | 122 | ||
120 | include(ExternalProject) | 123 | include(ExternalProject) |
121 | 124 | ||
122 | include_directories( | ||
123 | ${LIBGPG-ERROR_INCLUDE_DIRS} | ||
124 | libgcrypt-1.2.2/src | ||
125 | libgcrypt-1.2.2/mpi | ||
126 | libgcrypt-1.2.2/mpi/generic | ||
127 | libgcrypt-1.2.2 | ||
128 | ) | ||
129 | |||
130 | # Gotta fake a DOWNLOAD_COMMAND to work around a bug in cmake before 2.8.3. | 125 | # Gotta fake a DOWNLOAD_COMMAND to work around a bug in cmake before 2.8.3. |
131 | externalproject_add(EP_libgcrypt | 126 | externalproject_add(gcrypt |
132 | DEPENDS EP_libgpg-error | 127 | DEPENDS gpg-error |
133 | DOWNLOAD_COMMAND "" | 128 | DOWNLOAD_COMMAND "" |
134 | PREFIX ${CMAKE_CURRENT_SOURCE_DIR}/../libgcrypt/libgcrypt-1.2.2 | 129 | PREFIX ${CMAKE_BINARY_DIR}/libgcrypt |
135 | SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../libgcrypt/libgcrypt-1.2.2 | 130 | SOURCE_DIR ${CMAKE_SOURCE_DIR}/libgcrypt/libgcrypt-1.2.2 |
136 | CONFIGURE_COMMAND <SOURCE_DIR>/configure -prefix=<INSTALL_DIR> --with-gpg-error-prefix=${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0 | 131 | CONFIGURE_COMMAND <SOURCE_DIR>/configure -prefix=<INSTALL_DIR> --with-gpg-error-prefix=${CMAKE_BINARY_DIR}/libgpg-error |
137 | BUILD_COMMAND ${MAKE} | ||
138 | BUILD_IN_SOURCE 1 | ||
139 | INSTALL_COMMAND make install | 132 | INSTALL_COMMAND make install |
140 | ) | 133 | ) |
141 | 134 | ||
142 | link_directories(${LIBGCRYPT_LIBRARIES}) | ||
143 | include_directories(${LIBGCRYPT_INCLUDE_DIRS}) | ||
144 | |||
145 | add_library(libgcrypt STATIC IMPORTED) | ||
146 | |||
147 | # Happy this is not needed, but leaving it around for reference. | ||
148 | #set_target_properties(libgcrypt PROPERTIES | ||
149 | # IMPORTED_LOCATION ${CMAKE_CURRENT_SOURCE_DIR}/../libgcrypt/libgcrypt-1.2.2/lib/libgcrypt.a | ||
150 | # ) | ||
151 | |||
152 | # This wont work until 2.8.4 sigh | ||
153 | #add_dependencies(libgcrypt EP_libgcrypt) | ||
154 | |||
155 | endif (WINDOWS) | 135 | endif (WINDOWS) |
156 | 136 | ||
157 | target_link_libraries( | ||
158 | libgcrypt | ||
159 | ) | ||
160 | 137 | ||
diff --git a/linden/indra/libgpg-error/CMakeLists.txt b/linden/indra/libgpg-error/CMakeLists.txt index b3db72e..a0e6202 100644 --- a/linden/indra/libgpg-error/CMakeLists.txt +++ b/linden/indra/libgpg-error/CMakeLists.txt | |||
@@ -1,13 +1,13 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | project(libgpg-error) | ||
4 | |||
5 | include(00-Common) | 3 | include(00-Common) |
6 | include(libgpg-error) | 4 | include(libgpg-error) |
7 | include(Linking) | 5 | include(Linking) |
8 | 6 | ||
9 | if (WINDOWS) | 7 | if (WINDOWS) |
10 | 8 | ||
9 | project(gpg-error) | ||
10 | |||
11 | include_directories( | 11 | include_directories( |
12 | ../gpg.vs/inc.vs | 12 | ../gpg.vs/inc.vs |
13 | ../gpg.vs/libgpg-error-1.1.vs/custom | 13 | ../gpg.vs/libgpg-error-1.1.vs/custom |
@@ -25,7 +25,7 @@ set(libgpg-error_SOURCE_FILES | |||
25 | libgpg-error-1.0/src/strsource.c | 25 | libgpg-error-1.0/src/strsource.c |
26 | ) | 26 | ) |
27 | 27 | ||
28 | set(libgpg-error_HEADER_FILES | 28 | set(gpg-error_HEADER_FILES |
29 | CMakeLists.txt | 29 | CMakeLists.txt |
30 | 30 | ||
31 | libgpg-error-1.0/src/err-codes.h | 31 | libgpg-error-1.0/src/err-codes.h |
@@ -34,49 +34,28 @@ set(libgpg-error_HEADER_FILES | |||
34 | libgpg-error-1.0/src/gpg-error.h | 34 | libgpg-error-1.0/src/gpg-error.h |
35 | ) | 35 | ) |
36 | 36 | ||
37 | set_source_files_properties(${libgpg-error_HEADER_FILES} | 37 | set_source_files_properties(${gpg-error_HEADER_FILES} |
38 | PROPERTIES HEADER_FILE_ONLY TRUE) | 38 | PROPERTIES HEADER_FILE_ONLY TRUE) |
39 | 39 | ||
40 | list(APPEND libgpg-error_SOURCE_FILES ${libgpg-error_HEADER_FILES}) | 40 | list(APPEND gpg-error_SOURCE_FILES ${gpg-error_HEADER_FILES}) |
41 | 41 | ||
42 | add_library (libgpg-error ${libgpg-error_SOURCE_FILES}) | 42 | add_library (gpg-error ${gpg-error_SOURCE_FILES}) |
43 | target_link_libraries( | ||
44 | gpg-error | ||
45 | ) | ||
43 | 46 | ||
44 | else (WINDOWS) | 47 | else (WINDOWS) |
45 | 48 | ||
46 | include(ExternalProject) | 49 | include(ExternalProject) |
47 | 50 | ||
48 | include_directories( | ||
49 | libgpg-error-1.0/src | ||
50 | libgpg-error-1.0 | ||
51 | ) | ||
52 | |||
53 | # Gotta fake a DOWNLOAD_COMMAND to work around a bug in cmake before 2.8.3. | 51 | # Gotta fake a DOWNLOAD_COMMAND to work around a bug in cmake before 2.8.3. |
54 | externalproject_add(EP_libgpg-error | 52 | externalproject_add(gpg-error |
55 | DOWNLOAD_COMMAND "" | 53 | DOWNLOAD_COMMAND "" |
56 | PREFIX ${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0 | 54 | PREFIX ${CMAKE_BINARY_DIR}/libgpg-error |
57 | SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0 | 55 | SOURCE_DIR ${CMAKE_SOURCE_DIR}/libgpg-error/libgpg-error-1.0 |
58 | CONFIGURE_COMMAND <SOURCE_DIR>/configure -prefix=<INSTALL_DIR> | 56 | CONFIGURE_COMMAND <SOURCE_DIR>/configure -prefix=<INSTALL_DIR> |
59 | BUILD_COMMAND ${MAKE} | ||
60 | BUILD_IN_SOURCE 1 | ||
61 | INSTALL_COMMAND make install | 57 | INSTALL_COMMAND make install |
62 | ) | 58 | ) |
63 | 59 | ||
64 | link_directories(${LIBGPG-ERROR_LIBRARIES}) | ||
65 | include_directories(${LIBGPG-ERROR_INCLUDE_DIRS}) | ||
66 | |||
67 | add_library(libgpg-error STATIC IMPORTED) | ||
68 | |||
69 | # Happy this is not needed, but leaving it around for reference. | ||
70 | #set_target_properties(libgpg-error PROPERTIES | ||
71 | # IMPORTED_LOCATION ${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0/lib/libgpg-error.a | ||
72 | # ) | ||
73 | |||
74 | # This wont work until 2.8.4 sigh | ||
75 | #add_dependencies(libgpg-error EP_libgpg-error) | ||
76 | |||
77 | endif (WINDOWS) | 60 | endif (WINDOWS) |
78 | 61 | ||
79 | target_link_libraries( | ||
80 | libgpg-error | ||
81 | ) | ||
82 | |||
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt index 282535f..ca818a1 100644 --- a/linden/indra/libotr/CMakeLists.txt +++ b/linden/indra/libotr/CMakeLists.txt | |||
@@ -1,8 +1,11 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | project(libgpg-error) | 3 | project(otr) |
4 | project(libgcrypt) | 4 | |
5 | project(libotr) | 5 | include(00-Common) |
6 | include(libgpg-error) | ||
7 | include(libgcrypt) | ||
8 | include(Linking) | ||
6 | 9 | ||
7 | if (WINDOWS) | 10 | if (WINDOWS) |
8 | include_directories( | 11 | include_directories( |
@@ -16,11 +19,10 @@ else (WINDOWS) | |||
16 | include_directories( | 19 | include_directories( |
17 | ${LIBGPG-ERROR_INCLUDE_DIRS} | 20 | ${LIBGPG-ERROR_INCLUDE_DIRS} |
18 | ${LIBGCRYPT_INCLUDE_DIRS} | 21 | ${LIBGCRYPT_INCLUDE_DIRS} |
19 | ../libgcrypt/libgcrypt-1.2.2/src | ||
20 | ) | 22 | ) |
21 | endif (WINDOWS) | 23 | endif (WINDOWS) |
22 | 24 | ||
23 | set(libotr_SOURCE_FILES | 25 | set(otr_SOURCE_FILES |
24 | libotr-3.2.0/src/auth.c | 26 | libotr-3.2.0/src/auth.c |
25 | libotr-3.2.0/src/b64.c | 27 | libotr-3.2.0/src/b64.c |
26 | libotr-3.2.0/src/context.c | 28 | libotr-3.2.0/src/context.c |
@@ -34,7 +36,7 @@ set(libotr_SOURCE_FILES | |||
34 | libotr-3.2.0/src/userstate.c | 36 | libotr-3.2.0/src/userstate.c |
35 | ) | 37 | ) |
36 | 38 | ||
37 | set(libotr_HEADER_FILES | 39 | set(otr_HEADER_FILES |
38 | CMakeLists.txt | 40 | CMakeLists.txt |
39 | 41 | ||
40 | libotr-3.2.0/src/auth.h | 42 | libotr-3.2.0/src/auth.h |
@@ -53,22 +55,16 @@ set(libotr_HEADER_FILES | |||
53 | libotr-3.2.0/src/version.h | 55 | libotr-3.2.0/src/version.h |
54 | ) | 56 | ) |
55 | 57 | ||
56 | set_source_files_properties(${libotr_HEADER_FILES} | 58 | set_source_files_properties(${otr_HEADER_FILES} |
57 | PROPERTIES HEADER_FILE_ONLY TRUE) | 59 | PROPERTIES HEADER_FILE_ONLY TRUE) |
58 | 60 | ||
59 | list(APPEND libotr_SOURCE_FILES ${libotr_HEADER_FILES}) | 61 | list(APPEND libotr_SOURCE_FILES ${otr_HEADER_FILES}) |
60 | 62 | ||
61 | add_library (libotr ${libotr_SOURCE_FILES}) | 63 | add_library (otr ${otr_SOURCE_FILES}) |
62 | target_link_libraries(libotr | 64 | target_link_libraries(otr |
63 | gcrypt | 65 | ${LIBGCRYPT_LIBRARIES} |
64 | gpg-error | 66 | ${LIBGPG-ERROR_LIBRARIES} |
65 | ) | 67 | ) |
66 | 68 | ||
67 | # Not sure if either or both are needed, does not seem to hurt. | 69 | add_dependencies(otr gcrypt) |
68 | # Still does not make things build in the right sequence. sigh | ||
69 | if (NOT WINDOWS) | ||
70 | add_dependencies(libotr EP_libgcrpt) | ||
71 | else (NOT WINDOWS) | ||
72 | add_dependencies(libotr libgcrypt) | ||
73 | endif (NOT WINDOWS) | ||
74 | 70 | ||
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index fa306a5..84efa1e 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -93,8 +93,8 @@ if (WINDOWS) | |||
93 | ) | 93 | ) |
94 | endif (WINDOWS) | 94 | endif (WINDOWS) |
95 | include_directories( | 95 | include_directories( |
96 | ../libgpg-error/libgpg-error-1.0/src | 96 | ${LIBGPG-ERROR_INCLUDE_DIRS} |
97 | ../libgcrypt/libgcrypt-1.2.2/src | 97 | ${LIBGCRYPT_INCLUDE_DIRS} |
98 | ../libotr/libotr-3.2.0/src | 98 | ../libotr/libotr-3.2.0/src |
99 | ) | 99 | ) |
100 | # [/$PLOTR$] | 100 | # [/$PLOTR$] |
@@ -1074,8 +1074,8 @@ if (LINUX) | |||
1074 | if (STATIC_LIBOTR_ETC) # defined in .../linden/indra/CMakeLists.txt | 1074 | if (STATIC_LIBOTR_ETC) # defined in .../linden/indra/CMakeLists.txt |
1075 | set(viewer_LIBRARIES | 1075 | set(viewer_LIBRARIES |
1076 | Xinerama | 1076 | Xinerama |
1077 | #gpg-error | 1077 | ${LIBGPG-ERROR_LDBRARIES} |
1078 | #gcrypt # to build libotr from source and statically link in libgcrypt and libgpg-error | 1078 | ${LIBGCRYPT-ERROR_LDBRARIES} |
1079 | ) | 1079 | ) |
1080 | else (STATIC_LIBOTR_ETC) # below for dynamically linked, unmodified libotr | 1080 | else (STATIC_LIBOTR_ETC) # below for dynamically linked, unmodified libotr |
1081 | set(viewer_LIBRARIES | 1081 | set(viewer_LIBRARIES |
@@ -1446,8 +1446,6 @@ if (WINDOWS) | |||
1446 | else (WINDOWS) | 1446 | else (WINDOWS) |
1447 | if (STATIC_LIBOTR_ETC) | 1447 | if (STATIC_LIBOTR_ETC) |
1448 | set(otr_link_libs ${LIBOTR_LIBRARIES} | 1448 | set(otr_link_libs ${LIBOTR_LIBRARIES} |
1449 | ${LIBGCRYPT_LIBRARIES} | ||
1450 | ${LIBGPG-ERROR_LIBRARIES} | ||
1451 | ) # statically linked libotr, built from source | 1449 | ) # statically linked libotr, built from source |
1452 | else (STATIC_LIBOTR_ETC) | 1450 | else (STATIC_LIBOTR_ETC) |
1453 | set(otr_link_libs ${OTR_LIBRARY} | 1451 | set(otr_link_libs ${OTR_LIBRARY} |
diff --git a/linden/indra/newview/viewerinfo.cpp b/linden/indra/newview/viewerinfo.cpp index 89ce564..ebc7436 100644 --- a/linden/indra/newview/viewerinfo.cpp +++ b/linden/indra/newview/viewerinfo.cpp | |||
@@ -34,8 +34,8 @@ namespace ViewerInfo | |||
34 | const std::string VARNT = ""; | 34 | const std::string VARNT = ""; |
35 | const S32 MAJOR = 1; | 35 | const S32 MAJOR = 1; |
36 | const S32 MINOR = 4; | 36 | const S32 MINOR = 4; |
37 | const S32 PATCH = 0; | 37 | const S32 PATCH = 1; |
38 | const S32 RLEAS = 1; // increment for each beta/RC/release | 38 | const S32 RLEAS = 2; // increment for each beta/RC/release |
39 | const std::string EXTRA = "beta 1"; | 39 | const std::string EXTRA = "beta 1"; |
40 | 40 | ||
41 | // Mac OS X bundle identifier. Should match the one in Info.plist. | 41 | // Mac OS X bundle identifier. Should match the one in Info.plist. |