diff options
Diffstat (limited to 'linden/indra')
-rw-r--r-- | linden/indra/cmake/DBusGlib.cmake | 29 | ||||
-rw-r--r-- | linden/indra/cmake/GStreamer.cmake | 2 | ||||
-rw-r--r-- | linden/indra/llmedia/llmediaimplgstreamer.cpp | 2 | ||||
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 4 |
4 files changed, 4 insertions, 33 deletions
diff --git a/linden/indra/cmake/DBusGlib.cmake b/linden/indra/cmake/DBusGlib.cmake deleted file mode 100644 index cfc4ccd..0000000 --- a/linden/indra/cmake/DBusGlib.cmake +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | # -*- cmake -*- | ||
2 | include(Prebuilt) | ||
3 | |||
4 | if (STANDALONE) | ||
5 | include(FindPkgConfig) | ||
6 | |||
7 | pkg_check_modules(DBUSGLIB REQUIRED dbus-glib-1) | ||
8 | |||
9 | elseif (LINUX) | ||
10 | use_prebuilt_binary(dbusglib) | ||
11 | set(DBUSGLIB_FOUND ON FORCE BOOL) | ||
12 | set(DBUSGLIB_INCLUDE_DIRS | ||
13 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/glib-2.0 | ||
14 | ) | ||
15 | # We don't need to explicitly link against dbus-glib itself, because | ||
16 | # the viewer probes for the system's copy at runtime. | ||
17 | set(DBUSGLIB_LIBRARIES | ||
18 | gobject-2.0 | ||
19 | glib-2.0 | ||
20 | ) | ||
21 | endif (STANDALONE) | ||
22 | |||
23 | if (DBUSGLIB_FOUND) | ||
24 | set(DBUSGLIB ON CACHE BOOL "Build with dbus-glib message bus support.") | ||
25 | endif (DBUSGLIB_FOUND) | ||
26 | |||
27 | if (DBUSGLIB) | ||
28 | add_definitions(-DLL_DBUS_ENABLED=1) | ||
29 | endif (DBUSGLIB) | ||
diff --git a/linden/indra/cmake/GStreamer.cmake b/linden/indra/cmake/GStreamer.cmake index 10d5207..4369445 100644 --- a/linden/indra/cmake/GStreamer.cmake +++ b/linden/indra/cmake/GStreamer.cmake | |||
@@ -15,6 +15,8 @@ elseif (LINUX) | |||
15 | set(GSTREAMER_INCLUDE_DIRS | 15 | set(GSTREAMER_INCLUDE_DIRS |
16 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/gstreamer-0.10 | 16 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/gstreamer-0.10 |
17 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/glib-2.0 | 17 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/glib-2.0 |
18 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/glib-2.0/glib | ||
19 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/glib-2.0/gobject | ||
18 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/libxml2 | 20 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/libxml2 |
19 | ) | 21 | ) |
20 | # We don't need to explicitly link against gstreamer itself, because | 22 | # We don't need to explicitly link against gstreamer itself, because |
diff --git a/linden/indra/llmedia/llmediaimplgstreamer.cpp b/linden/indra/llmedia/llmediaimplgstreamer.cpp index 6fdaf43..d889f6f 100644 --- a/linden/indra/llmedia/llmediaimplgstreamer.cpp +++ b/linden/indra/llmedia/llmediaimplgstreamer.cpp | |||
@@ -666,4 +666,4 @@ bool LLMediaImplGStreamer::setVolume(float volume) | |||
666 | 666 | ||
667 | 667 | ||
668 | 668 | ||
669 | ///#endif // LL_GSTREAMER_ENABLED \ No newline at end of file | 669 | ///#endif // LL_GSTREAMER_ENABLED |
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 8d70751..0205ceb 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -5,7 +5,6 @@ project(viewer) | |||
5 | include(00-Common) | 5 | include(00-Common) |
6 | include(Boost) | 6 | include(Boost) |
7 | include(BuildVersion) | 7 | include(BuildVersion) |
8 | include(DBusGlib) | ||
9 | include(DirectX) | 8 | include(DirectX) |
10 | include(ELFIO) | 9 | include(ELFIO) |
11 | include(FMOD) | 10 | include(FMOD) |
@@ -876,7 +875,6 @@ endif (DARWIN) | |||
876 | 875 | ||
877 | if (LINUX) | 876 | if (LINUX) |
878 | LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) | 877 | LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) |
879 | LIST(APPEND viewer_SOURCE_FILES llappviewerlinux_api_dbus.cpp) | ||
880 | LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) | 878 | LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) |
881 | 879 | ||
882 | set(viewer_LIBRARIES | 880 | set(viewer_LIBRARIES |
@@ -1388,7 +1386,7 @@ target_link_libraries(imprudence-bin | |||
1388 | ${viewer_LIBRARIES} | 1386 | ${viewer_LIBRARIES} |
1389 | ${BOOST_PROGRAM_OPTIONS_LIBRARY} | 1387 | ${BOOST_PROGRAM_OPTIONS_LIBRARY} |
1390 | ${BOOST_REGEX_LIBRARY} | 1388 | ${BOOST_REGEX_LIBRARY} |
1391 | ${DBUSGLIB_LIBRARIES} | 1389 | ${BOOST_SIGNALS_LIBRARY} |
1392 | ${OPENGL_LIBRARIES} | 1390 | ${OPENGL_LIBRARIES} |
1393 | ${FMODWRAPPER_LIBRARY} | 1391 | ${FMODWRAPPER_LIBRARY} |
1394 | ${OPENGL_LIBRARIES} | 1392 | ${OPENGL_LIBRARIES} |