diff options
Diffstat (limited to '')
-rw-r--r-- | linden/indra/cmake/Audio.cmake | 16 | ||||
-rw-r--r-- | linden/indra/cmake/LLWindow.cmake | 3 | ||||
-rw-r--r-- | linden/indra/llcommon/CMakeLists.txt | 10 | ||||
-rw-r--r-- | linden/indra/llmessage/CMakeLists.txt | 10 | ||||
-rw-r--r-- | linden/indra/newview/llvoavatar.cpp | 6 |
5 files changed, 39 insertions, 6 deletions
diff --git a/linden/indra/cmake/Audio.cmake b/linden/indra/cmake/Audio.cmake index d23bc2f..10d11bb 100644 --- a/linden/indra/cmake/Audio.cmake +++ b/linden/indra/cmake/Audio.cmake | |||
@@ -32,6 +32,12 @@ else (STANDALONE) | |||
32 | set(VORBISENC_LIBRARIES vorbisenc) | 32 | set(VORBISENC_LIBRARIES vorbisenc) |
33 | set(VORBISFILE_LIBRARIES vorbisfile) | 33 | set(VORBISFILE_LIBRARIES vorbisfile) |
34 | endif (WINDOWS) | 34 | endif (WINDOWS) |
35 | if(LINUX AND ${ARCH} STREQUAL "x86_64") | ||
36 | set(VORBIS_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib) | ||
37 | set(VORBISENC_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib) | ||
38 | set(VORBISFILE_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib) | ||
39 | set(OGG_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib) | ||
40 | endif(LINUX AND ${ARCH} STREQUAL "x86_64") | ||
35 | endif (STANDALONE) | 41 | endif (STANDALONE) |
36 | 42 | ||
37 | link_directories( | 43 | link_directories( |
@@ -40,3 +46,13 @@ link_directories( | |||
40 | ${VORBISFILE_LIBRARY_DIRS} | 46 | ${VORBISFILE_LIBRARY_DIRS} |
41 | ${OGG_LIBRARY_DIRS} | 47 | ${OGG_LIBRARY_DIRS} |
42 | ) | 48 | ) |
49 | |||
50 | if(NOT vorbis_link_msg) | ||
51 | set(vorbis_link_msg ON CACHE BOOL "ogg vorbis linked from:\n") | ||
52 | message("ogg vorbis linked from:\n" | ||
53 | ${VORBIS_LIBRARY_DIRS} "\n" | ||
54 | ${VORBISENC_LIBRARY_DIRS} "\n" | ||
55 | ${VORBISFILE_LIBRARY_DIRS} "\n" | ||
56 | ${OGG_LIBRARY_DIRS} "\n" | ||
57 | ) | ||
58 | endif(NOT vorbis_link_msg) | ||
diff --git a/linden/indra/cmake/LLWindow.cmake b/linden/indra/cmake/LLWindow.cmake index 1023693..345359a 100644 --- a/linden/indra/cmake/LLWindow.cmake +++ b/linden/indra/cmake/LLWindow.cmake | |||
@@ -45,4 +45,7 @@ else (SERVER AND LINUX) | |||
45 | comdlg32 | 45 | comdlg32 |
46 | ) | 46 | ) |
47 | endif (WINDOWS) | 47 | endif (WINDOWS) |
48 | if (LINUX) | ||
49 | list(APPEND LLWINDOW_LIBRARIES fontconfig) | ||
50 | endif (LINUX) | ||
48 | endif (SERVER AND LINUX) | 51 | endif (SERVER AND LINUX) |
diff --git a/linden/indra/llcommon/CMakeLists.txt b/linden/indra/llcommon/CMakeLists.txt index ed04ca6..b6015a8 100644 --- a/linden/indra/llcommon/CMakeLists.txt +++ b/linden/indra/llcommon/CMakeLists.txt | |||
@@ -200,7 +200,7 @@ set_source_files_properties(${llcommon_HEADER_FILES} | |||
200 | list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES}) | 200 | list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES}) |
201 | 201 | ||
202 | add_library (llcommon SHARED ${llcommon_SOURCE_FILES}) | 202 | add_library (llcommon SHARED ${llcommon_SOURCE_FILES}) |
203 | target_link_libraries( | 203 | set (llcommon_link_LIBRARIES |
204 | llcommon | 204 | llcommon |
205 | ${APRUTIL_LIBRARIES} | 205 | ${APRUTIL_LIBRARIES} |
206 | ${APR_LIBRARIES} | 206 | ${APR_LIBRARIES} |
@@ -218,3 +218,11 @@ if (DARWIN) | |||
218 | INSTALL_NAME_DIR "@executable_path/../Resources" | 218 | INSTALL_NAME_DIR "@executable_path/../Resources" |
219 | ) | 219 | ) |
220 | endif (DARWIN) | 220 | endif (DARWIN) |
221 | |||
222 | if (LINUX) | ||
223 | list(APPEND llcommon_link_LIBRARIES rt) | ||
224 | endif (LINUX) | ||
225 | |||
226 | target_link_libraries( | ||
227 | ${llcommon_link_LIBRARIES} | ||
228 | ) | ||
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt index b3f2b4c..61b6418 100644 --- a/linden/indra/llmessage/CMakeLists.txt +++ b/linden/indra/llmessage/CMakeLists.txt | |||
@@ -208,13 +208,21 @@ set_source_files_properties(${llmessage_HEADER_FILES} | |||
208 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) | 208 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) |
209 | 209 | ||
210 | add_library (llmessage ${llmessage_SOURCE_FILES}) | 210 | add_library (llmessage ${llmessage_SOURCE_FILES}) |
211 | target_link_libraries( | 211 | set (llmessage_link_LIBRARIES |
212 | llmessage | 212 | llmessage |
213 | ${CURL_LIBRARIES} | 213 | ${CURL_LIBRARIES} |
214 | ${CARES_LIBRARIES} | 214 | ${CARES_LIBRARIES} |
215 | ${OPENSSL_LIBRARIES} | 215 | ${OPENSSL_LIBRARIES} |
216 | ${CRYPTO_LIBRARIES} | 216 | ${CRYPTO_LIBRARIES} |
217 | ${XMLRPCEPI_LIBRARIES} | 217 | ${XMLRPCEPI_LIBRARIES} |
218 | ) | ||
219 | if (LINUX) | ||
220 | list(APPEND llmessage_link_LIBRARIES pthread) | ||
221 | endif (LINUX) | ||
222 | |||
223 | target_link_libraries( | ||
224 | ${llmessage_link_LIBRARIES} | ||
225 | |||
218 | ) | 226 | ) |
219 | 227 | ||
220 | IF (NOT LINUX AND VIEWER) | 228 | IF (NOT LINUX AND VIEWER) |
diff --git a/linden/indra/newview/llvoavatar.cpp b/linden/indra/newview/llvoavatar.cpp index 3ba94fa..ed51a24 100644 --- a/linden/indra/newview/llvoavatar.cpp +++ b/linden/indra/newview/llvoavatar.cpp | |||
@@ -8754,7 +8754,6 @@ void LLVOAvatar::processAvatarAppearance( LLMessageSystem* mesgsys ) | |||
8754 | 8754 | ||
8755 | if( !param ) | 8755 | if( !param ) |
8756 | { | 8756 | { |
8757 | llwarns << "Number of params in AvatarAppearance msg does not match number of params in avatar xml file." << llendl; | ||
8758 | break; | 8757 | break; |
8759 | } | 8758 | } |
8760 | 8759 | ||
@@ -8796,10 +8795,9 @@ void LLVOAvatar::processAvatarAppearance( LLMessageSystem* mesgsys ) | |||
8796 | } | 8795 | } |
8797 | } | 8796 | } |
8798 | 8797 | ||
8799 | S32 expected_tweakable_count = getVisualParamCountInGroup(VISUAL_PARAM_GROUP_TWEAKABLE); // don't worry about VISUAL_PARAM_GROUP_TWEAKABLE_NO_TRANSMIT | 8798 | while( param && (param->getGroup() != VISUAL_PARAM_GROUP_TWEAKABLE) ) |
8800 | if (num_blocks != expected_tweakable_count) | ||
8801 | { | 8799 | { |
8802 | llinfos << "Number of params in AvatarAppearance msg (" << num_blocks << ") does not match number of tweakable params in avatar xml file (" << expected_tweakable_count << "). Processing what we can. Object: " << getID() << llendl; | 8800 | param = getNextVisualParam(); |
8803 | } | 8801 | } |
8804 | 8802 | ||
8805 | if (params_changed) | 8803 | if (params_changed) |