aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/newview')
-rw-r--r--linden/indra/newview/CMakeLists.txt14
-rw-r--r--linden/indra/newview/emeraldboobutils.cpp1
-rw-r--r--linden/indra/newview/llagent.cpp4
-rw-r--r--linden/indra/newview/llappviewer.h2
-rw-r--r--linden/indra/newview/llfeaturemanager.cpp1
-rw-r--r--linden/indra/newview/llfloaterabout.cpp1
-rw-r--r--linden/indra/newview/llfloaterregioninfo.cpp6
-rw-r--r--linden/indra/newview/llfloaterregioninfo.h2
-rw-r--r--linden/indra/newview/llfolderview.h2
-rw-r--r--linden/indra/newview/llhomelocationresponder.cpp5
-rw-r--r--linden/indra/newview/llhomelocationresponder.h2
-rw-r--r--linden/indra/newview/llinventorybridge.h2
-rw-r--r--linden/indra/newview/llpanelinventory.cpp5
-rw-r--r--linden/indra/newview/llspatialpartition.cpp6
-rw-r--r--linden/indra/newview/llviewerassetstorage.h1
-rw-r--r--linden/indra/newview/llwatchdog.h3
-rwxr-xr-xlinden/indra/newview/viewer_manifest.py55
17 files changed, 89 insertions, 23 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 77de749..dff759e 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -1541,11 +1541,23 @@ if (INSTALL)
1541 include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake) 1541 include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake)
1542endif (INSTALL) 1542endif (INSTALL)
1543 1543
1544ADD_VIEWER_BUILD_TEST(llagentaccess viewer) 1544#ADD_VIEWER_BUILD_TEST(llagentaccess viewer)
1545 1545
1546# Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py 1546# Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py
1547if (WINDOWS) 1547if (WINDOWS)
1548 1548
1549 get_target_property(BUILT_LLCOMMON llcommon LOCATION)
1550 add_custom_command(
1551 TARGET ${VIEWER_BINARY_NAME} POST_BUILD
1552 COMMAND ${CMAKE_COMMAND}
1553 ARGS
1554 -E
1555 copy_if_different
1556 ${BUILT_LLCOMMON}
1557 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}
1558 COMMENT "Copying llcommon.dll to the runtime folder."
1559 )
1560
1549 get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) 1561 get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION)
1550 add_custom_command( 1562 add_custom_command(
1551 TARGET ${VIEWER_BINARY_NAME} POST_BUILD 1563 TARGET ${VIEWER_BINARY_NAME} POST_BUILD
diff --git a/linden/indra/newview/emeraldboobutils.cpp b/linden/indra/newview/emeraldboobutils.cpp
index f68d6a7..f440940 100644
--- a/linden/indra/newview/emeraldboobutils.cpp
+++ b/linden/indra/newview/emeraldboobutils.cpp
@@ -1,3 +1,4 @@
1#include "linden_common.h"
1#include "emeraldboobutils.h" 2#include "emeraldboobutils.h"
2 3
3std::ostream &operator<<(std::ostream &os, const EmeraldGlobalBoobConfig &v) 4std::ostream &operator<<(std::ostream &os, const EmeraldGlobalBoobConfig &v)
diff --git a/linden/indra/newview/llagent.cpp b/linden/indra/newview/llagent.cpp
index 8109196..5a1700a 100644
--- a/linden/indra/newview/llagent.cpp
+++ b/linden/indra/newview/llagent.cpp
@@ -5573,7 +5573,7 @@ class LLAgentDropGroupViewerNode : public LLHTTPNode
5573 !input.has("body") ) 5573 !input.has("body") )
5574 { 5574 {
5575 //what to do with badly formed message? 5575 //what to do with badly formed message?
5576 response->status(400); 5576 response->statusUnknownError(400);
5577 response->result(LLSD("Invalid message parameters")); 5577 response->result(LLSD("Invalid message parameters"));
5578 } 5578 }
5579 5579
@@ -5646,7 +5646,7 @@ class LLAgentDropGroupViewerNode : public LLHTTPNode
5646 else 5646 else
5647 { 5647 {
5648 //what to do with badly formed message? 5648 //what to do with badly formed message?
5649 response->status(400); 5649 response->statusUnknownError(400);
5650 response->result(LLSD("Invalid message parameters")); 5650 response->result(LLSD("Invalid message parameters"));
5651 } 5651 }
5652 } 5652 }
diff --git a/linden/indra/newview/llappviewer.h b/linden/indra/newview/llappviewer.h
index 9d72457..7b3230a 100644
--- a/linden/indra/newview/llappviewer.h
+++ b/linden/indra/newview/llappviewer.h
@@ -33,6 +33,8 @@
33#ifndef LL_LLAPPVIEWER_H 33#ifndef LL_LLAPPVIEWER_H
34#define LL_LLAPPVIEWER_H 34#define LL_LLAPPVIEWER_H
35 35
36#include "llsys.h" // LLOSInfo
37
36class LLTextureCache; 38class LLTextureCache;
37class LLImageDecodeThread; 39class LLImageDecodeThread;
38class LLTextureFetch; 40class LLTextureFetch;
diff --git a/linden/indra/newview/llfeaturemanager.cpp b/linden/indra/newview/llfeaturemanager.cpp
index 54da31b..bf43fcf 100644
--- a/linden/indra/newview/llfeaturemanager.cpp
+++ b/linden/indra/newview/llfeaturemanager.cpp
@@ -62,7 +62,6 @@
62// externs 62// externs
63// 63//
64extern LLMemoryInfo gSysMemory; 64extern LLMemoryInfo gSysMemory;
65extern LLCPUInfo gSysCPU;
66 65
67#if LL_DARWIN 66#if LL_DARWIN
68const char FEATURE_TABLE_FILENAME[] = "featuretable_mac.txt"; 67const char FEATURE_TABLE_FILENAME[] = "featuretable_mac.txt";
diff --git a/linden/indra/newview/llfloaterabout.cpp b/linden/indra/newview/llfloaterabout.cpp
index 5c037d6..f7163ee 100644
--- a/linden/indra/newview/llfloaterabout.cpp
+++ b/linden/indra/newview/llfloaterabout.cpp
@@ -68,7 +68,6 @@
68#include "lldxhardware.h" 68#include "lldxhardware.h"
69#endif 69#endif
70 70
71extern LLCPUInfo gSysCPU;
72extern LLMemoryInfo gSysMemory; 71extern LLMemoryInfo gSysMemory;
73extern U32 gPacketsIn; 72extern U32 gPacketsIn;
74 73
diff --git a/linden/indra/newview/llfloaterregioninfo.cpp b/linden/indra/newview/llfloaterregioninfo.cpp
index 8ae3fa2..d4ffe22 100644
--- a/linden/indra/newview/llfloaterregioninfo.cpp
+++ b/linden/indra/newview/llfloaterregioninfo.cpp
@@ -908,7 +908,7 @@ BOOL LLPanelRegionOpenSettingsInfo::postBuild()
908 initHelpBtn("show_tags_help", "HelpShowTags"); 908 initHelpBtn("show_tags_help", "HelpShowTags");
909 initHelpBtn("allow_parcel_windlight_help", "HelpAllowParcelWindLight"); 909 initHelpBtn("allow_parcel_windlight_help", "HelpAllowParcelWindLight");
910 910
911 childSetAction("apply_ors_btn", sendUpdate, this); 911 childSetAction("apply_ors_btn", onClickOrs, this);
912 912
913 refreshFromRegion(gAgent.getRegion()); 913 refreshFromRegion(gAgent.getRegion());
914 914
@@ -926,12 +926,12 @@ BOOL LLPanelRegionOpenSettingsInfo::postBuild()
926// strings[7] = restrict pushobject 926// strings[7] = restrict pushobject
927// strings[8] = 'Y' - allow parcel subdivide, 'N' - not 927// strings[8] = 'Y' - allow parcel subdivide, 'N' - not
928// strings[9] = 'Y' - block parcel search, 'N' - allow 928// strings[9] = 'Y' - block parcel search, 'N' - allow
929void LLPanelRegionOpenSettingsInfo::sendUpdate(void* userdata) 929void LLPanelRegionOpenSettingsInfo::onClickOrs(void* userdata)
930{ 930{
931 LLPanelRegionOpenSettingsInfo* self; 931 LLPanelRegionOpenSettingsInfo* self;
932 self = (LLPanelRegionOpenSettingsInfo*)userdata; 932 self = (LLPanelRegionOpenSettingsInfo*)userdata;
933 933
934 llinfos << "LLPanelRegionOpenSettingsInfo::sendUpdate()" << llendl; 934 llinfos << "LLPanelRegionOpenSettingsInfo::onClickOrs()" << llendl;
935 935
936 LLSD body; 936 LLSD body;
937 std::string url = gAgent.getRegion()->getCapability("DispatchOpenRegionSettings"); 937 std::string url = gAgent.getRegion()->getCapability("DispatchOpenRegionSettings");
diff --git a/linden/indra/newview/llfloaterregioninfo.h b/linden/indra/newview/llfloaterregioninfo.h
index ee01c7c..ae0c993 100644
--- a/linden/indra/newview/llfloaterregioninfo.h
+++ b/linden/indra/newview/llfloaterregioninfo.h
@@ -188,7 +188,7 @@ public:
188 virtual BOOL postBuild(); 188 virtual BOOL postBuild();
189 189
190protected: 190protected:
191 static void sendUpdate(void* userdata); 191 static void onClickOrs(void* userdata);
192}; 192};
193 193
194///////////////////////////////////////////////////////////////////////////// 194/////////////////////////////////////////////////////////////////////////////
diff --git a/linden/indra/newview/llfolderview.h b/linden/indra/newview/llfolderview.h
index 9fad72e..40da669 100644
--- a/linden/indra/newview/llfolderview.h
+++ b/linden/indra/newview/llfolderview.h
@@ -97,7 +97,7 @@ public:
97 virtual void move( LLFolderViewEventListener* parent_listener ) = 0; 97 virtual void move( LLFolderViewEventListener* parent_listener ) = 0;
98 virtual BOOL isItemCopyable() const = 0; 98 virtual BOOL isItemCopyable() const = 0;
99 virtual BOOL copyToClipboard() const = 0; 99 virtual BOOL copyToClipboard() const = 0;
100 virtual void cutToClipboard() = 0; 100 virtual BOOL cutToClipboard() const = 0;
101 virtual BOOL isClipboardPasteable() const = 0; 101 virtual BOOL isClipboardPasteable() const = 0;
102 virtual void pasteFromClipboard() = 0; 102 virtual void pasteFromClipboard() = 0;
103 virtual void buildContextMenu(LLMenuGL& menu, U32 flags) = 0; 103 virtual void buildContextMenu(LLMenuGL& menu, U32 flags) = 0;
diff --git a/linden/indra/newview/llhomelocationresponder.cpp b/linden/indra/newview/llhomelocationresponder.cpp
index e609237..c00d8e7 100644
--- a/linden/indra/newview/llhomelocationresponder.cpp
+++ b/linden/indra/newview/llhomelocationresponder.cpp
@@ -105,7 +105,8 @@ void LLHomeLocationResponder::result( const LLSD& content )
105 } 105 }
106} 106}
107 107
108void LLHomeLocationResponder::error( const LLSD& content ) 108void LLHomeLocationResponder::error( U32 status, const std::string& reason )
109{ 109{
110 llinfos << "received error(" << ll_pretty_print_sd( content ) << ")" << llendl; 110 llinfos << "received error(" << reason << ")" << llendl;
111} 111}
112
diff --git a/linden/indra/newview/llhomelocationresponder.h b/linden/indra/newview/llhomelocationresponder.h
index 1e222cd..3a1d8eb 100644
--- a/linden/indra/newview/llhomelocationresponder.h
+++ b/linden/indra/newview/llhomelocationresponder.h
@@ -42,7 +42,7 @@
42class LLHomeLocationResponder : public LLHTTPClient::Responder 42class LLHomeLocationResponder : public LLHTTPClient::Responder
43{ 43{
44 virtual void result( const LLSD& content ); 44 virtual void result( const LLSD& content );
45 virtual void error( const LLSD& content ); 45 virtual void error( U32 status, const std::string& reason );
46}; 46};
47 47
48#endif 48#endif
diff --git a/linden/indra/newview/llinventorybridge.h b/linden/indra/newview/llinventorybridge.h
index 2004678..5a53aa5 100644
--- a/linden/indra/newview/llinventorybridge.h
+++ b/linden/indra/newview/llinventorybridge.h
@@ -221,7 +221,7 @@ public:
221 virtual void move(LLFolderViewEventListener* new_parent_bridge) {} 221 virtual void move(LLFolderViewEventListener* new_parent_bridge) {}
222 virtual BOOL isItemCopyable() const { return FALSE; } 222 virtual BOOL isItemCopyable() const { return FALSE; }
223 virtual BOOL copyToClipboard() const { return FALSE; } 223 virtual BOOL copyToClipboard() const { return FALSE; }
224 virtual void cutToClipboard() {} 224 virtual BOOL cutToClipboard() const { return FALSE; }
225 virtual BOOL isClipboardPasteable() const; 225 virtual BOOL isClipboardPasteable() const;
226 virtual void pasteFromClipboard() {} 226 virtual void pasteFromClipboard() {}
227 void getClipboardEntries(bool show_asset_id, std::vector<std::string> &items, 227 void getClipboardEntries(bool show_asset_id, std::vector<std::string> &items,
diff --git a/linden/indra/newview/llpanelinventory.cpp b/linden/indra/newview/llpanelinventory.cpp
index 9cd2759..277ab15 100644
--- a/linden/indra/newview/llpanelinventory.cpp
+++ b/linden/indra/newview/llpanelinventory.cpp
@@ -145,7 +145,7 @@ public:
145 virtual void move(LLFolderViewEventListener* parent_listener); 145 virtual void move(LLFolderViewEventListener* parent_listener);
146 virtual BOOL isItemCopyable() const; 146 virtual BOOL isItemCopyable() const;
147 virtual BOOL copyToClipboard() const; 147 virtual BOOL copyToClipboard() const;
148 virtual void cutToClipboard(); 148 virtual BOOL cutToClipboard() const;
149 virtual BOOL isClipboardPasteable() const; 149 virtual BOOL isClipboardPasteable() const;
150 virtual void pasteFromClipboard(); 150 virtual void pasteFromClipboard();
151 virtual void buildContextMenu(LLMenuGL& menu, U32 flags); 151 virtual void buildContextMenu(LLMenuGL& menu, U32 flags);
@@ -594,8 +594,9 @@ BOOL LLTaskInvFVBridge::copyToClipboard() const
594 return FALSE; 594 return FALSE;
595} 595}
596 596
597void LLTaskInvFVBridge::cutToClipboard() 597BOOL LLTaskInvFVBridge::cutToClipboard() const
598{ 598{
599 return FALSE;
599} 600}
600 601
601BOOL LLTaskInvFVBridge::isClipboardPasteable() const 602BOOL LLTaskInvFVBridge::isClipboardPasteable() const
diff --git a/linden/indra/newview/llspatialpartition.cpp b/linden/indra/newview/llspatialpartition.cpp
index c1d5ff3..d9fa5b5 100644
--- a/linden/indra/newview/llspatialpartition.cpp
+++ b/linden/indra/newview/llspatialpartition.cpp
@@ -826,7 +826,7 @@ class LLSpatialSetStateDiff : public LLSpatialSetState
826public: 826public:
827 LLSpatialSetStateDiff(U32 state) : LLSpatialSetState(state) { } 827 LLSpatialSetStateDiff(U32 state) : LLSpatialSetState(state) { }
828 828
829 virtual void traverse(const LLSpatialGroup::TreeNode* n) 829 virtual void traverse(const LLSpatialGroup::OctreeNode* n)
830 { 830 {
831 LLSpatialGroup* group = (LLSpatialGroup*) n->getListener(0); 831 LLSpatialGroup* group = (LLSpatialGroup*) n->getListener(0);
832 832
@@ -885,7 +885,7 @@ class LLSpatialClearStateDiff : public LLSpatialClearState
885public: 885public:
886 LLSpatialClearStateDiff(U32 state) : LLSpatialClearState(state) { } 886 LLSpatialClearStateDiff(U32 state) : LLSpatialClearState(state) { }
887 887
888 virtual void traverse(const LLSpatialGroup::TreeNode* n) 888 virtual void traverse(const LLSpatialGroup::OctreeNode* n)
889 { 889 {
890 LLSpatialGroup* group = (LLSpatialGroup*) n->getListener(0); 890 LLSpatialGroup* group = (LLSpatialGroup*) n->getListener(0);
891 891
@@ -1519,7 +1519,7 @@ public:
1519 return false; 1519 return false;
1520 } 1520 }
1521 1521
1522 virtual void traverse(const LLSpatialGroup::TreeNode* n) 1522 virtual void traverse(const LLSpatialGroup::OctreeNode* n)
1523 { 1523 {
1524 LLSpatialGroup* group = (LLSpatialGroup*) n->getListener(0); 1524 LLSpatialGroup* group = (LLSpatialGroup*) n->getListener(0);
1525 1525
diff --git a/linden/indra/newview/llviewerassetstorage.h b/linden/indra/newview/llviewerassetstorage.h
index 15c11c7..512b590 100644
--- a/linden/indra/newview/llviewerassetstorage.h
+++ b/linden/indra/newview/llviewerassetstorage.h
@@ -47,6 +47,7 @@ public:
47 LLViewerAssetStorage(LLMessageSystem *msg, LLXferManager *xfer, 47 LLViewerAssetStorage(LLMessageSystem *msg, LLXferManager *xfer,
48 LLVFS *vfs); 48 LLVFS *vfs);
49 49
50 using LLAssetStorage::storeAssetData;
50 virtual void storeAssetData( 51 virtual void storeAssetData(
51 const LLTransactionID& tid, 52 const LLTransactionID& tid,
52 LLAssetType::EType atype, 53 LLAssetType::EType atype,
diff --git a/linden/indra/newview/llwatchdog.h b/linden/indra/newview/llwatchdog.h
index ed7d5bd..1a10e33 100644
--- a/linden/indra/newview/llwatchdog.h
+++ b/linden/indra/newview/llwatchdog.h
@@ -64,9 +64,10 @@ public:
64 64
65 /* virtual */ bool isAlive() const; 65 /* virtual */ bool isAlive() const;
66 /* virtual */ void reset(); 66 /* virtual */ void reset();
67 /* virtual */ void start(const std::string& state); 67 /* virtual */ void start() { start(""); };
68 /* virtual */ void stop(); 68 /* virtual */ void stop();
69 69
70 void start(const std::string& state);
70 void setTimeout(F32 d); 71 void setTimeout(F32 d);
71 void ping(const std::string& state); 72 void ping(const std::string& state);
72 const std::string& getState() {return mPingState; } 73 const std::string& getState() {return mPingState; }
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index cc22748..f9c34d6 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -230,7 +230,7 @@ class WindowsManifest(ViewerManifest):
230 self.path("LICENSE-libraries.txt") 230 self.path("LICENSE-libraries.txt")
231 self.end_prefix("../..") 231 self.end_prefix("../..")
232 232
233 233
234 self.path("imprudence.url") 234 self.path("imprudence.url")
235 235
236 # Plugin host application 236 # Plugin host application
@@ -252,6 +252,14 @@ class WindowsManifest(ViewerManifest):
252 self.path("libhunspell.dll") 252 self.path("libhunspell.dll")
253 self.end_prefix() 253 self.end_prefix()
254 254
255 # Get llcommon and deps.
256 if self.prefix(src=self.args['configuration'], dst=""):
257 self.path('libapr-1.dll')
258 self.path('libaprutil-1.dll')
259 self.path('libapriconv-1.dll')
260 self.path('llcommon.dll')
261 self.end_prefix()
262
255 # For textures 263 # For textures
256 if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""): 264 if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""):
257 self.path("openjpeg.dll") 265 self.path("openjpeg.dll")
@@ -731,14 +739,51 @@ class DarwinManifest(ViewerManifest):
731 self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") 739 self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice")
732 #self.path("vivox-runtime/universal-darwin/SLVoiceAgent.app", "SLVoiceAgent.app") 740 #self.path("vivox-runtime/universal-darwin/SLVoiceAgent.app", "SLVoiceAgent.app")
733 741
742 libdir = "../../libraries/universal-darwin/lib_release"
743 dylibs = {}
744
745 #for lib in "llkdu", "llcommon":
746 for lib in "llcommon":
747 libfile = "lib%s.dylib" % lib
748 try:
749 self.path(self.find_existing_file(os.path.join(os.pardir,
750 lib,
751 self.args['configuration'],
752 libfile),
753 os.path.join(libdir, libfile)),
754 dst=libfile)
755 except RuntimeError:
756 print "Skipping %s" % libfile
757 dylibs[lib] = False
758 else:
759 dylibs[lib] = True
760
761 for libfile in ("libapr-1.0.3.7.dylib",
762 "libaprutil-1.0.3.8.dylib",
763 "libexpat.0.5.0.dylib"):
764 self.path(os.path.join(libdir, libfile), libfile)
765
734 #libfmodwrapper.dylib 766 #libfmodwrapper.dylib
735 #self.path(self.args['configuration'] + "/libfmodwrapper.dylib", "libfmodwrapper.dylib") 767 #self.path(self.args['configuration'] + "/libfmodwrapper.dylib", "libfmodwrapper.dylib")
736 768
737 # our apps 769 # our apps
738# self.path("../mac_crash_logger/" + self.args['configuration'] + "/mac-crash-logger.app", "mac-crash-logger.app") 770# self.path("../mac_crash_logger/" + self.args['configuration'] + "/mac-crash-logger.app", "mac-crash-logger.app")
739 self.path("../mac_updater/" + self.args['configuration'] + "/mac-updater.app", "mac-updater.app") 771 self.path("../mac_updater/" + self.args['configuration'] + "/mac-updater.app", "mac-updater.app")
740 772
741 # plugin launcher 773 # our apps dependencies on shared libs
774 mac_crash_logger_res_path = self.dst_path_of("mac-crash-logger.app/Contents/Resources")
775 mac_updater_res_path = self.dst_path_of("mac-updater.app/Contents/Resources")
776 for libfile in ("libllcommon.dylib",
777 "libapr-1.0.3.7.dylib",
778 "libaprutil-1.0.3.8.dylib",
779 "libexpat.0.5.0.dylib"):
780 target_lib = os.path.join('../../..', libfile)
781 self.run_command("ln -sf %(target)r %(link)r" %
782 {'target': target_lib,
783 'link' : os.path.join(mac_crash_logger_res_path, libfile)}
784 )
785
786 # plugin launcher
742 self.path("../llplugin/slplugin/" + self.args['configuration'] + "/SLPlugin", "SLPlugin") 787 self.path("../llplugin/slplugin/" + self.args['configuration'] + "/SLPlugin", "SLPlugin")
743 788
744 # plugins 789 # plugins
@@ -952,6 +997,8 @@ class Linux_i686Manifest(LinuxManifest):
952 else: 997 else:
953 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") 998 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin")
954 999
1000 self.path("../llcommon/libllcommon.so", "lib/libllcommon.so")
1001
955 if (not self.standalone()) and self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"): 1002 if (not self.standalone()) and self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"):
956 self.path("libapr-1.so.0") 1003 self.path("libapr-1.so.0")
957 self.path("libaprutil-1.so.0") 1004 self.path("libaprutil-1.so.0")
@@ -1072,6 +1119,8 @@ class Linux_x86_64Manifest(LinuxManifest):
1072 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") 1119 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin")
1073# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin") 1120# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin")
1074 1121
1122 self.path("../llcommon/libllcommon.so", "lib64/libllcommon.so")
1123
1075 self.path("linux_tools/launch_url.sh","launch_url.sh") 1124 self.path("linux_tools/launch_url.sh","launch_url.sh")
1076 if self.prefix("res-sdl"): 1125 if self.prefix("res-sdl"):
1077 self.path("*") 1126 self.path("*")