diff options
Diffstat (limited to 'linden/indra/newview')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 7 | ||||
-rw-r--r-- | linden/indra/newview/llappviewer.cpp | 3 | ||||
-rw-r--r-- | linden/indra/newview/llaudiosourcevo.cpp | 2 | ||||
-rw-r--r-- | linden/indra/newview/llfloaterabout.cpp | 5 | ||||
-rw-r--r-- | linden/indra/newview/llpreviewsound.cpp | 3 | ||||
-rw-r--r-- | linden/indra/newview/llstartup.cpp | 44 | ||||
-rw-r--r-- | linden/indra/newview/llviewermessage.cpp | 3 | ||||
-rw-r--r-- | linden/indra/newview/llviewertexteditor.cpp | 3 | ||||
-rw-r--r-- | linden/indra/newview/llvoavatar.cpp | 11 | ||||
-rw-r--r-- | linden/indra/newview/skins/default/xui/en-us/floater_instant_message_group.xml | 164 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 25 |
11 files changed, 158 insertions, 112 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index ddf6897..4bfbf02 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -8,6 +8,7 @@ include(BuildVersion) | |||
8 | include(DirectX) | 8 | include(DirectX) |
9 | include(ELFIO) | 9 | include(ELFIO) |
10 | include(FMOD) | 10 | include(FMOD) |
11 | include(OPENAL) | ||
11 | include(FindOpenGL) | 12 | include(FindOpenGL) |
12 | include(LLAudio) | 13 | include(LLAudio) |
13 | include(LLCharacter) | 14 | include(LLCharacter) |
@@ -56,6 +57,7 @@ include_directories( | |||
56 | ${LLXML_INCLUDE_DIRS} | 57 | ${LLXML_INCLUDE_DIRS} |
57 | ${LSCRIPT_INCLUDE_DIRS} | 58 | ${LSCRIPT_INCLUDE_DIRS} |
58 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile | 59 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile |
60 | ${GSTREAMER_INCLUDE_DIRS} | ||
59 | ) | 61 | ) |
60 | 62 | ||
61 | set(viewer_SOURCE_FILES | 63 | set(viewer_SOURCE_FILES |
@@ -1239,6 +1241,11 @@ set_source_files_properties(${viewer_CHARACTER_FILES} | |||
1239 | 1241 | ||
1240 | list(APPEND viewer_SOURCE_FILES ${viewer_CHARACTER_FILES}) | 1242 | list(APPEND viewer_SOURCE_FILES ${viewer_CHARACTER_FILES}) |
1241 | 1243 | ||
1244 | |||
1245 | if (OPENAL) | ||
1246 | set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS -DLL_OPENAL) | ||
1247 | endif (OPENAL) | ||
1248 | |||
1242 | if (FMOD) | 1249 | if (FMOD) |
1243 | set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS -DLL_FMOD) | 1250 | set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS -DLL_FMOD) |
1244 | 1251 | ||
diff --git a/linden/indra/newview/llappviewer.cpp b/linden/indra/newview/llappviewer.cpp index 14214b5..2cf418e 100644 --- a/linden/indra/newview/llappviewer.cpp +++ b/linden/indra/newview/llappviewer.cpp | |||
@@ -1179,7 +1179,8 @@ bool LLAppViewer::cleanup() | |||
1179 | 1179 | ||
1180 | llinfos << "Global stuff deleted" << llendflush; | 1180 | llinfos << "Global stuff deleted" << llendflush; |
1181 | 1181 | ||
1182 | #if !LL_RELEASE_FOR_DOWNLOAD | 1182 | #if (!defined(LL_FMOD)) || (!LL_RELEASE_FOR_DOWNLOAD) |
1183 | // OpenAL likes to crash on exit if we *don't* explicitly shut it down. | ||
1183 | if (gAudiop) | 1184 | if (gAudiop) |
1184 | { | 1185 | { |
1185 | gAudiop->shutdown(); | 1186 | gAudiop->shutdown(); |
diff --git a/linden/indra/newview/llaudiosourcevo.cpp b/linden/indra/newview/llaudiosourcevo.cpp index e668078..9c25d94 100644 --- a/linden/indra/newview/llaudiosourcevo.cpp +++ b/linden/indra/newview/llaudiosourcevo.cpp | |||
@@ -39,7 +39,7 @@ | |||
39 | #include "llviewerparcelmgr.h" | 39 | #include "llviewerparcelmgr.h" |
40 | 40 | ||
41 | LLAudioSourceVO::LLAudioSourceVO(const LLUUID &sound_id, const LLUUID& owner_id, const F32 gain, LLViewerObject *objectp) | 41 | LLAudioSourceVO::LLAudioSourceVO(const LLUUID &sound_id, const LLUUID& owner_id, const F32 gain, LLViewerObject *objectp) |
42 | : LLAudioSource(sound_id, owner_id, gain), | 42 | : LLAudioSource(sound_id, owner_id, gain, LLAudioEngine::AUDIO_TYPE_SFX), |
43 | mObjectp(objectp), | 43 | mObjectp(objectp), |
44 | mActualGain(gain) | 44 | mActualGain(gain) |
45 | { | 45 | { |
diff --git a/linden/indra/newview/llfloaterabout.cpp b/linden/indra/newview/llfloaterabout.cpp index af436c5..4953410 100644 --- a/linden/indra/newview/llfloaterabout.cpp +++ b/linden/indra/newview/llfloaterabout.cpp | |||
@@ -41,6 +41,7 @@ | |||
41 | 41 | ||
42 | #include "llcurl.h" | 42 | #include "llcurl.h" |
43 | #include "llimagej2c.h" | 43 | #include "llimagej2c.h" |
44 | #include "audioengine.h" | ||
44 | 45 | ||
45 | #include "llviewertexteditor.h" | 46 | #include "llviewertexteditor.h" |
46 | #include "llviewercontrol.h" | 47 | #include "llviewercontrol.h" |
@@ -200,6 +201,10 @@ LLFloaterAbout::LLFloaterAbout() | |||
200 | support.append( LLImageJ2C::getEngineInfo() ); | 201 | support.append( LLImageJ2C::getEngineInfo() ); |
201 | support.append("\n"); | 202 | support.append("\n"); |
202 | 203 | ||
204 | support.append("Audio Driver Version: "); | ||
205 | support.append( gAudiop ? gAudiop->getDriverName(true) : "(none)" ); | ||
206 | support.append("\n"); | ||
207 | |||
203 | LLMediaManager *mgr = LLMediaManager::getInstance(); | 208 | LLMediaManager *mgr = LLMediaManager::getInstance(); |
204 | if (mgr) | 209 | if (mgr) |
205 | { | 210 | { |
diff --git a/linden/indra/newview/llpreviewsound.cpp b/linden/indra/newview/llpreviewsound.cpp index 9ba6fd5..6b79bfb 100644 --- a/linden/indra/newview/llpreviewsound.cpp +++ b/linden/indra/newview/llpreviewsound.cpp | |||
@@ -106,7 +106,6 @@ void LLPreviewSound::auditionSound( void *userdata ) | |||
106 | if(item && gAudiop) | 106 | if(item && gAudiop) |
107 | { | 107 | { |
108 | LLVector3d lpos_global = gAgent.getPositionGlobal(); | 108 | LLVector3d lpos_global = gAgent.getPositionGlobal(); |
109 | F32 volume = gSavedSettings.getBOOL("MuteSounds") ? 0.f : SOUND_GAIN * gSavedSettings.getF32("AudioLevelSFX"); | 109 | gAudiop->triggerSound(item->getAssetUUID(), gAgent.getID(), SOUND_GAIN, LLAudioEngine::AUDIO_TYPE_UI, lpos_global); |
110 | gAudiop->triggerSound(item->getAssetUUID(), gAgent.getID(), volume, lpos_global); | ||
111 | } | 110 | } |
112 | } | 111 | } |
diff --git a/linden/indra/newview/llstartup.cpp b/linden/indra/newview/llstartup.cpp index 6371f2b..c863d19 100644 --- a/linden/indra/newview/llstartup.cpp +++ b/linden/indra/newview/llstartup.cpp | |||
@@ -45,6 +45,10 @@ | |||
45 | # include "audioengine_fmod.h" | 45 | # include "audioengine_fmod.h" |
46 | #endif | 46 | #endif |
47 | 47 | ||
48 | #ifdef LL_OPENAL | ||
49 | #include "audioengine_openal.h" | ||
50 | #endif | ||
51 | |||
48 | #include "llares.h" | 52 | #include "llares.h" |
49 | #include "llcachename.h" | 53 | #include "llcachename.h" |
50 | #include "llviewercontrol.h" | 54 | #include "llviewercontrol.h" |
@@ -579,10 +583,28 @@ bool idle_startup() | |||
579 | 583 | ||
580 | if (FALSE == gSavedSettings.getBOOL("NoAudio")) | 584 | if (FALSE == gSavedSettings.getBOOL("NoAudio")) |
581 | { | 585 | { |
582 | #ifdef LL_FMOD | ||
583 | gAudiop = (LLAudioEngine *) new LLAudioEngine_FMOD(); | ||
584 | #else | ||
585 | gAudiop = NULL; | 586 | gAudiop = NULL; |
587 | |||
588 | #ifdef LL_OPENAL | ||
589 | if (!gAudiop | ||
590 | #if !LL_WINDOWS | ||
591 | && NULL == getenv("LL_BAD_OPENAL_DRIVER") | ||
592 | #endif // !LL_WINDOWS | ||
593 | ) | ||
594 | { | ||
595 | gAudiop = (LLAudioEngine *) new LLAudioEngine_OpenAL(); | ||
596 | } | ||
597 | #endif | ||
598 | |||
599 | #ifdef LL_FMOD | ||
600 | if (!gAudiop | ||
601 | #if !LL_WINDOWS | ||
602 | && NULL == getenv("LL_BAD_FMOD_DRIVER") | ||
603 | #endif // !LL_WINDOWS | ||
604 | ) | ||
605 | { | ||
606 | gAudiop = (LLAudioEngine *) new LLAudioEngine_FMOD(); | ||
607 | } | ||
586 | #endif | 608 | #endif |
587 | 609 | ||
588 | if (gAudiop) | 610 | if (gAudiop) |
@@ -595,15 +617,21 @@ bool idle_startup() | |||
595 | void* window_handle = NULL; | 617 | void* window_handle = NULL; |
596 | #endif | 618 | #endif |
597 | bool init = gAudiop->init(kAUDIO_NUM_SOURCES, window_handle); | 619 | bool init = gAudiop->init(kAUDIO_NUM_SOURCES, window_handle); |
598 | if(!init) | 620 | if(init) |
621 | { | ||
622 | gAudiop->setMuted(TRUE); | ||
623 | } | ||
624 | else | ||
599 | { | 625 | { |
600 | LL_WARNS("AppInit") << "Unable to initialize audio engine" << LL_ENDL; | 626 | LL_WARNS("AppInit") << "Unable to initialize audio engine" << LL_ENDL; |
627 | delete gAudiop; | ||
628 | gAudiop = NULL; | ||
601 | } | 629 | } |
602 | gAudiop->setMuted(TRUE); | ||
603 | } | 630 | } |
604 | } | 631 | } |
605 | 632 | ||
606 | LL_INFOS("AppInit") << "Audio Engine Initialized." << LL_ENDL; | 633 | LL_INFOS("AppInit") << "Audio Engine Initialized." << LL_ENDL; |
634 | |||
607 | 635 | ||
608 | if (LLTimer::knownBadTimer()) | 636 | if (LLTimer::knownBadTimer()) |
609 | { | 637 | { |
@@ -750,6 +778,12 @@ bool idle_startup() | |||
750 | gLoginMenuBarView->setVisible( TRUE ); | 778 | gLoginMenuBarView->setVisible( TRUE ); |
751 | gLoginMenuBarView->setEnabled( TRUE ); | 779 | gLoginMenuBarView->setEnabled( TRUE ); |
752 | 780 | ||
781 | // DEV-16927. The following code removes errant keystrokes that happen while the window is being | ||
782 | // first made visible. | ||
783 | #ifdef _WIN32 | ||
784 | MSG msg; | ||
785 | while( PeekMessage( &msg, /*All hWnds owned by this thread */ NULL, WM_KEYFIRST, WM_KEYLAST, PM_REMOVE ) ); | ||
786 | #endif | ||
753 | timeout.reset(); | 787 | timeout.reset(); |
754 | return FALSE; | 788 | return FALSE; |
755 | } | 789 | } |
diff --git a/linden/indra/newview/llviewermessage.cpp b/linden/indra/newview/llviewermessage.cpp index 3c7a0ab..28ca198 100644 --- a/linden/indra/newview/llviewermessage.cpp +++ b/linden/indra/newview/llviewermessage.cpp | |||
@@ -3308,8 +3308,7 @@ void process_sound_trigger(LLMessageSystem *msg, void **) | |||
3308 | return; | 3308 | return; |
3309 | } | 3309 | } |
3310 | 3310 | ||
3311 | F32 volume = gSavedSettings.getBOOL("MuteSounds") ? 0.f : (gain * gSavedSettings.getF32("AudioLevelSFX")); | 3311 | gAudiop->triggerSound(sound_id, owner_id, gain, LLAudioEngine::AUDIO_TYPE_SFX, pos_global); |
3312 | gAudiop->triggerSound(sound_id, owner_id, volume, pos_global); | ||
3313 | } | 3312 | } |
3314 | 3313 | ||
3315 | void process_preload_sound(LLMessageSystem *msg, void **user_data) | 3314 | void process_preload_sound(LLMessageSystem *msg, void **user_data) |
diff --git a/linden/indra/newview/llviewertexteditor.cpp b/linden/indra/newview/llviewertexteditor.cpp index 8a55b3f..1dda1ca 100644 --- a/linden/indra/newview/llviewertexteditor.cpp +++ b/linden/indra/newview/llviewertexteditor.cpp | |||
@@ -1402,8 +1402,7 @@ void LLViewerTextEditor::openEmbeddedSound( LLInventoryItem* item ) | |||
1402 | const F32 SOUND_GAIN = 1.0f; | 1402 | const F32 SOUND_GAIN = 1.0f; |
1403 | if(gAudiop) | 1403 | if(gAudiop) |
1404 | { | 1404 | { |
1405 | F32 volume = gSavedSettings.getBOOL("MuteSounds") ? 0.f : (SOUND_GAIN * gSavedSettings.getF32("AudioLevelSFX")); | 1405 | gAudiop->triggerSound(item->getAssetUUID(), gAgentID, SOUND_GAIN, LLAudioEngine::AUDIO_TYPE_UI, lpos_global); |
1406 | gAudiop->triggerSound(item->getAssetUUID(), gAgentID, volume, lpos_global); | ||
1407 | } | 1406 | } |
1408 | showCopyToInvDialog( item ); | 1407 | showCopyToInvDialog( item ); |
1409 | } | 1408 | } |
diff --git a/linden/indra/newview/llvoavatar.cpp b/linden/indra/newview/llvoavatar.cpp index e480eb3..327cd57 100644 --- a/linden/indra/newview/llvoavatar.cpp +++ b/linden/indra/newview/llvoavatar.cpp | |||
@@ -3828,10 +3828,7 @@ BOOL LLVOAvatar::updateCharacter(LLAgent &agent) | |||
3828 | // AUDIO_STEP_LO_SPEED, AUDIO_STEP_HI_SPEED, | 3828 | // AUDIO_STEP_LO_SPEED, AUDIO_STEP_HI_SPEED, |
3829 | // AUDIO_STEP_LO_GAIN, AUDIO_STEP_HI_GAIN ); | 3829 | // AUDIO_STEP_LO_GAIN, AUDIO_STEP_HI_GAIN ); |
3830 | 3830 | ||
3831 | F32 ambient_volume = gSavedSettings.getF32("AudioLevelAmbient"); | 3831 | const F32 STEP_VOLUME = 0.5f; |
3832 | F32 gain = gSavedSettings.getBOOL("MuteAmbient") | ||
3833 | ? 0.f | ||
3834 | : (.50f * ambient_volume * ambient_volume); | ||
3835 | LLUUID& step_sound_id = getStepSound(); | 3832 | LLUUID& step_sound_id = getStepSound(); |
3836 | 3833 | ||
3837 | LLVector3d foot_pos_global = gAgent.getPosGlobalFromAgent(foot_pos_agent); | 3834 | LLVector3d foot_pos_global = gAgent.getPosGlobalFromAgent(foot_pos_agent); |
@@ -3839,7 +3836,7 @@ BOOL LLVOAvatar::updateCharacter(LLAgent &agent) | |||
3839 | if (LLViewerParcelMgr::getInstance()->canHearSound(foot_pos_global) | 3836 | if (LLViewerParcelMgr::getInstance()->canHearSound(foot_pos_global) |
3840 | && !LLMuteList::getInstance()->isMuted(getID(), LLMute::flagObjectSounds)) | 3837 | && !LLMuteList::getInstance()->isMuted(getID(), LLMute::flagObjectSounds)) |
3841 | { | 3838 | { |
3842 | gAudiop->triggerSound(step_sound_id, getID(), gain, foot_pos_global); | 3839 | gAudiop->triggerSound(step_sound_id, getID(), STEP_VOLUME, LLAudioEngine::AUDIO_TYPE_AMBIENT, foot_pos_global); |
3843 | } | 3840 | } |
3844 | } | 3841 | } |
3845 | } | 3842 | } |
@@ -4819,8 +4816,8 @@ BOOL LLVOAvatar::processSingleAnimationStateChange( const LLUUID& anim_id, BOOL | |||
4819 | //else | 4816 | //else |
4820 | { | 4817 | { |
4821 | LLUUID sound_id = LLUUID(gSavedSettings.getString("UISndTyping")); | 4818 | LLUUID sound_id = LLUUID(gSavedSettings.getString("UISndTyping")); |
4822 | F32 volume = gSavedSettings.getBOOL("MuteSounds") ? 0.f : gSavedSettings.getF32("AudioLevelSFX"); | 4819 | gAudiop->triggerSound(sound_id, getID(), 1.0f, LLAudioEngine::AUDIO_TYPE_SFX, char_pos_global); |
4823 | gAudiop->triggerSound(sound_id, getID(), volume, char_pos_global); | 4820 | |
4824 | } | 4821 | } |
4825 | } | 4822 | } |
4826 | } | 4823 | } |
diff --git a/linden/indra/newview/skins/default/xui/en-us/floater_instant_message_group.xml b/linden/indra/newview/skins/default/xui/en-us/floater_instant_message_group.xml index be18c7e..72c92bd 100644 --- a/linden/indra/newview/skins/default/xui/en-us/floater_instant_message_group.xml +++ b/linden/indra/newview/skins/default/xui/en-us/floater_instant_message_group.xml | |||
@@ -1,82 +1,82 @@ | |||
1 | <?xml version="1.0" encoding="utf-8" standalone="yes" ?> | 1 | <?xml version="1.0" encoding="utf-8" standalone="yes" ?> |
2 | <floater border="true" bottom="-297" can_close="true" can_drag_on_left="false" | 2 | <floater border="true" bottom="-297" can_close="true" can_drag_on_left="false" |
3 | can_minimize="true" can_resize="true" default_tab_group="1" enabled="true" | 3 | can_minimize="true" can_resize="true" default_tab_group="1" enabled="true" |
4 | follows="left|top|right|bottom" height="296" label="(unknown)" left="1" | 4 | follows="left|top|right|bottom" height="296" label="(unknown)" left="1" |
5 | min_height="200" min_width="360" mouse_opaque="true" name="im_floater" | 5 | min_height="200" min_width="360" mouse_opaque="true" name="im_floater" |
6 | rect_control="" title="(unknown)" width="501"> | 6 | rect_control="" title="(unknown)" width="501"> |
7 | <string name="ringing"> | 7 | <string name="ringing"> |
8 | Joining Voice Chat... | 8 | Joining Voice Chat... |
9 | </string> | 9 | </string> |
10 | <string name="connected"> | 10 | <string name="connected"> |
11 | Connected, click End Call to hang up | 11 | Connected, click End Call to hang up |
12 | </string> | 12 | </string> |
13 | <string name="hang_up"> | 13 | <string name="hang_up"> |
14 | Left Voice Chat | 14 | Left Voice Chat |
15 | </string> | 15 | </string> |
16 | <string name="voice_icon"> | 16 | <string name="voice_icon"> |
17 | icn_voice-groupfocus.tga | 17 | icn_voice-groupfocus.tga |
18 | </string> | 18 | </string> |
19 | <string name="live_help_dialog" wordwrap="false"> | 19 | <string name="live_help_dialog" wordwrap="false"> |
20 | *** Welcome to Help Request *** | 20 | *** Welcome to Help Request *** |
21 | Please first check our SL Help Pages by pressing F1, or by accessing the Knowledge Base http://secondlife.com/knowledgebase/ | 21 | Please first check our SL Help Pages by pressing F1, or by accessing the Knowledge Base http://secondlife.com/knowledgebase/ |
22 | If your answer is not there, please enter your question to begin, then allow a few moments for available helpers to respond. | 22 | If your answer is not there, please enter your question to begin, then allow a few moments for available helpers to respond. |
23 | -=-=- Response times will vary, especially during peak times -=-=- | 23 | -=-=- Response times will vary, especially during peak times -=-=- |
24 | </string> | 24 | </string> |
25 | <string name="title_string"> | 25 | <string name="title_string"> |
26 | Instant Message with [NAME] | 26 | Instant Message with [NAME] |
27 | </string> | 27 | </string> |
28 | <string name="typing_start_string"> | 28 | <string name="typing_start_string"> |
29 | [NAME] is typing... | 29 | [NAME] is typing... |
30 | </string> | 30 | </string> |
31 | <string name="session_start_string"> | 31 | <string name="session_start_string"> |
32 | Starting session with [NAME], please wait. | 32 | Starting session with [NAME], please wait. |
33 | </string> | 33 | </string> |
34 | <string name="moderated_chat_label"> | 34 | <string name="moderated_chat_label"> |
35 | (Moderated: Voices off by default) | 35 | (Moderated: Voices off by default) |
36 | </string> | 36 | </string> |
37 | <string name="default_text_label"> | 37 | <string name="default_text_label"> |
38 | Click here to instant message. | 38 | Click here to instant message. |
39 | </string> | 39 | </string> |
40 | <string name="muted_text_label"> | 40 | <string name="muted_text_label"> |
41 | Your text chat has been disabled by a Group Moderator. | 41 | Your text chat has been disabled by a Group Moderator. |
42 | </string> | 42 | </string> |
43 | <layout_stack border="false" bottom="0" follows="left|top|right|bottom" height="276" left="0" | 43 | <layout_stack border="false" bottom="0" follows="left|top|right|bottom" height="276" left="0" |
44 | orientation="horizontal" tab_group="1" width="495" name="panels"> | 44 | orientation="horizontal" tab_group="1" width="495" name="panels"> |
45 | <layout_panel border="false" bottom="0" default_tab_group="1" follows="left|top|bottom|right" | 45 | <layout_panel border="false" bottom="0" default_tab_group="1" follows="left|top|bottom|right" |
46 | height="130" left="0" min_width="210" name="im_contents_panel" width="175"> | 46 | height="130" left="0" min_width="210" name="im_contents_panel" width="175"> |
47 | <button bottom="-20" follows="left|top" height="20" label="Group Info" left="5" | 47 | <button bottom="-20" follows="left|top" height="20" label="Group Info" left="5" |
48 | name="group_info_btn" tab_group="0" width="80" /> | 48 | name="group_info_btn" tab_group="0" width="80" /> |
49 | <button bottom_delta="0" enabled="false" follows="left|top" halign="right" height="20" | 49 | <button bottom_delta="0" enabled="false" follows="left|top" halign="right" height="20" |
50 | image_overlay="icn_voice-call-start.tga" image_overlay_alignment="left" | 50 | image_overlay="icn_voice-call-start.tga" image_overlay_alignment="left" |
51 | label="Join Call" left_delta="85" name="start_call_btn" pad_right="12" | 51 | label="Join Call" left_delta="85" name="start_call_btn" pad_right="12" |
52 | width="80" /> | 52 | width="80" /> |
53 | <button bottom_delta="0" follows="left|top" halign="right" height="20" | 53 | <button bottom_delta="0" follows="left|top" halign="right" height="20" |
54 | image_overlay="icn_voice-call-end.tga" image_overlay_alignment="left" | 54 | image_overlay="icn_voice-call-end.tga" image_overlay_alignment="left" |
55 | label="End Call" left_delta="0" name="end_call_btn" pad_right="12" | 55 | label="End Call" left_delta="0" name="end_call_btn" pad_right="12" |
56 | visible="false" width="80" /> | 56 | visible="false" width="80" /> |
57 | <button bottom_delta="0" follows="right|top" height="20" label="< <" | 57 | <button bottom_delta="0" follows="right|top" height="20" label="< <" |
58 | label_selected="> >" left="143" name="toggle_active_speakers_btn" | 58 | label_selected="> >" left="143" name="toggle_active_speakers_btn" |
59 | right="176" | 59 | right="176" |
60 | tool_tip="Click here to toggle a list of active participants in this IM session." | 60 | tool_tip="Click here to toggle a list of active participants in this IM session." |
61 | visible="true" width="30" /> | 61 | visible="true" width="30" /> |
62 | <text_editor type="string" length="1" bg_readonly_color="ChatHistoryBgColor" bg_writeable_color="ChatHistoryBgColor" | 62 | <text_editor type="string" length="1" bg_readonly_color="ChatHistoryBgColor" bg_writeable_color="ChatHistoryBgColor" |
63 | bottom="30" embedded_items="false" enabled="false" | 63 | bottom="30" embedded_items="false" enabled="false" |
64 | follows="left|top|right|bottom" font="SansSerif" left="4" | 64 | follows="left|top|right|bottom" font="SansSerif" left="4" |
65 | max_length="2147483647" mouse_opaque="true" name="im_history" | 65 | max_length="2147483647" mouse_opaque="true" name="im_history" |
66 | text_color="ChatHistoryTextColor" | 66 | text_color="ChatHistoryTextColor" |
67 | text_readonly_color="ChatHistoryTextColor" top="104" width="170" | 67 | text_readonly_color="ChatHistoryTextColor" top="104" width="170" |
68 | word_wrap="true" /> | 68 | word_wrap="true" /> |
69 | <line_editor bevel_style="in" border_style="line" border_thickness="1" bottom="7" | 69 | <line_editor bevel_style="in" border_style="line" border_thickness="1" bottom="7" |
70 | enabled="true" follows="left|right|bottom" font="SansSerif" height="20" | 70 | enabled="true" follows="left|right|bottom" font="SansSerif" height="20" |
71 | left="5" max_length="1022" mouse_opaque="true" name="chat_editor" | 71 | left="5" max_length="1022" mouse_opaque="true" name="chat_editor" |
72 | select_all_on_focus_received="false" select_on_focus="false" tab_group="1" | 72 | select_all_on_focus_received="false" select_on_focus="false" tab_group="1" |
73 | width="106" /> | 73 | width="106" /> |
74 | <button bottom="7" enabled="true" follows="right|bottom" font="SansSerif" | 74 | <button bottom="7" enabled="true" follows="right|bottom" font="SansSerif" |
75 | halign="center" height="20" label="Send" left="116" mouse_opaque="true" | 75 | halign="center" height="20" label="Send" left="116" mouse_opaque="true" |
76 | name="send_btn" scale_image="true" width="60" /> | 76 | name="send_btn" scale_image="true" width="60" /> |
77 | </layout_panel> | 77 | </layout_panel> |
78 | <layout_panel auto_resize="false" bottom="0" can_resize="true" | 78 | <layout_panel auto_resize="false" bottom="0" can_resize="true" |
79 | filename="panel_speaker_controls.xml" height="120" left="0" min_width="140" | 79 | filename="panel_speaker_controls.xml" height="120" left="0" min_width="140" |
80 | name="active_speakers_panel" top_delta="0" visible="false" width="140" /> | 80 | name="active_speakers_panel" top_delta="0" visible="false" width="140" /> |
81 | </layout_stack> | 81 | </layout_stack> |
82 | </floater> | 82 | </floater> |
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index 995cb68..0dfd8db 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -254,18 +254,20 @@ class WindowsManifest(ViewerManifest): | |||
254 | self.end_prefix() | 254 | self.end_prefix() |
255 | 255 | ||
256 | # Vivox runtimes | 256 | # Vivox runtimes |
257 | #if self.prefix(src="vivox-runtime/i686-win32", dst=""): | 257 | if self.prefix(src="vivox-runtime/i686-win32", dst=""): |
258 | self.path("alut.dll") | ||
259 | self.path("wrap_oal.dll") | ||
260 | |||
258 | # self.path("SLVoice.exe") | 261 | # self.path("SLVoice.exe") |
259 | # self.path("SLVoiceAgent.exe") | 262 | # self.path("SLVoiceAgent.exe") |
260 | # self.path("libeay32.dll") | 263 | # self.path("libeay32.dll") |
261 | # self.path("srtp.dll") | 264 | # self.path("srtp.dll") |
262 | # self.path("ssleay32.dll") | 265 | # self.path("ssleay32.dll") |
263 | # self.path("tntk.dll") | 266 | # self.path("tntk.dll") |
264 | # self.path("alut.dll") | ||
265 | # self.path("vivoxsdk.dll") | 267 | # self.path("vivoxsdk.dll") |
266 | # self.path("ortp.dll") | 268 | # self.path("ortp.dll") |
267 | # self.path("wrap_oal.dll") | 269 | |
268 | # self.end_prefix() | 270 | self.end_prefix() |
269 | 271 | ||
270 | # # pull in the crash logger and updater from other projects | 272 | # # pull in the crash logger and updater from other projects |
271 | # self.path(src=self.find_existing_file( # tag:"crash-logger" here as a cue to the exporter | 273 | # self.path(src=self.find_existing_file( # tag:"crash-logger" here as a cue to the exporter |
@@ -450,9 +452,10 @@ class DarwinManifest(ViewerManifest): | |||
450 | self.path("Japanese.lproj") | 452 | self.path("Japanese.lproj") |
451 | self.path("Korean.lproj") | 453 | self.path("Korean.lproj") |
452 | 454 | ||
455 | |||
453 | # SLVoice and vivox lols | 456 | # SLVoice and vivox lols |
454 | #self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") | 457 | self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") |
455 | #self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") | 458 | self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") |
456 | #self.path("vivox-runtime/universal-darwin/libortp.dylib", "libortp.dylib") | 459 | #self.path("vivox-runtime/universal-darwin/libortp.dylib", "libortp.dylib") |
457 | #self.path("vivox-runtime/universal-darwin/libvivoxsdk.dylib", "libvivoxsdk.dylib") | 460 | #self.path("vivox-runtime/universal-darwin/libvivoxsdk.dylib", "libvivoxsdk.dylib") |
458 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") | 461 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") |
@@ -684,18 +687,20 @@ class Linux_i686Manifest(LinuxManifest): | |||
684 | #self.path("libtcmalloc.so.0") - bugged | 687 | #self.path("libtcmalloc.so.0") - bugged |
685 | #self.path("libstacktrace.so.0") - probably bugged | 688 | #self.path("libstacktrace.so.0") - probably bugged |
686 | # self.path("libllkdu.so", "../bin/libllkdu.so") # llkdu goes in bin for some reason | 689 | # self.path("libllkdu.so", "../bin/libllkdu.so") # llkdu goes in bin for some reason |
690 | |||
687 | self.end_prefix("lib") | 691 | self.end_prefix("lib") |
688 | 692 | ||
689 | # Vivox runtimes | 693 | # Vivox runtimes |
690 | #if self.prefix(src="vivox-runtime/i686-linux", dst="bin"): | 694 | #if self.prefix(src="vivox-runtime/i686-linux", dst="bin"): |
691 | # self.path("SLVoice") | 695 | # self.path("SLVoice") |
692 | # self.end_prefix() | 696 | # self.end_prefix() |
693 | #if self.prefix(src="vivox-runtime/i686-linux", dst="lib"): | 697 | |
694 | # self.path("libopenal.so.1") | 698 | if self.prefix(src="vivox-runtime/i686-linux", dst="lib"): |
699 | self.path("libopenal.so.1") | ||
700 | self.path("libalut.so") | ||
695 | # self.path("libortp.so") | 701 | # self.path("libortp.so") |
696 | # self.path("libvivoxsdk.so") | 702 | # self.path("libvivoxsdk.so") |
697 | # self.path("libalut.so") | 703 | self.end_prefix("lib") |
698 | # self.end_prefix("lib") | ||
699 | 704 | ||
700 | class Linux_x86_64Manifest(LinuxManifest): | 705 | class Linux_x86_64Manifest(LinuxManifest): |
701 | def construct(self): | 706 | def construct(self): |