diff options
Diffstat (limited to 'linden/indra/newview')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 5 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 13 |
2 files changed, 0 insertions, 18 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index ddf6897..9b7a647 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -31,7 +31,6 @@ include(NDOF) | |||
31 | include(TemplateCheck) | 31 | include(TemplateCheck) |
32 | include(UI) | 32 | include(UI) |
33 | include(UnixInstall) | 33 | include(UnixInstall) |
34 | include(LLKDU) | ||
35 | include(ViewerMiscLibs) | 34 | include(ViewerMiscLibs) |
36 | 35 | ||
37 | if (WINDOWS) | 36 | if (WINDOWS) |
@@ -1272,10 +1271,6 @@ add_executable(imprudence-bin | |||
1272 | ) | 1271 | ) |
1273 | check_message_template(imprudence-bin) | 1272 | check_message_template(imprudence-bin) |
1274 | 1273 | ||
1275 | if (LLKDU_LIBRARY) | ||
1276 | add_dependencies(imprudence-bin ${LLKDU_LIBRARY}) | ||
1277 | endif (LLKDU_LIBRARY) | ||
1278 | |||
1279 | set(PACKAGE OFF CACHE BOOL | 1274 | set(PACKAGE OFF CACHE BOOL |
1280 | "Add a package target that builds an installer package.") | 1275 | "Add a package target that builds an installer package.") |
1281 | 1276 | ||
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index 62c9537..f707d15 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -183,14 +183,6 @@ class WindowsManifest(ViewerManifest): | |||
183 | # the final exe is complicated because we're not sure where it's coming from, | 183 | # the final exe is complicated because we're not sure where it's coming from, |
184 | # nor do we have a fixed name for the executable | 184 | # nor do we have a fixed name for the executable |
185 | self.path(self.find_existing_file('debug/imprudence-bin.exe', 'release/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe'), dst=self.final_exe()) | 185 | self.path(self.find_existing_file('debug/imprudence-bin.exe', 'release/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe'), dst=self.final_exe()) |
186 | # need to get the kdu dll from any of the build directories as well | ||
187 | #self.path(self.find_existing_file( | ||
188 | # *FIX:Mani we need to add support for packaging specific targets. | ||
189 | #'../llkdu/debug/llkdu.dll', | ||
190 | #'../llkdu/release/llkdu.dll', | ||
191 | #'../llkdu/relwithdebinfo/llkdu.dll', | ||
192 | #'../../libraries/i686-win32/lib/release/llkdu.dll'), | ||
193 | # dst='llkdu.dll') | ||
194 | 186 | ||
195 | self.gather_documents() | 187 | self.gather_documents() |
196 | 188 | ||
@@ -448,9 +440,6 @@ class DarwinManifest(ViewerManifest): | |||
448 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") | 440 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") |
449 | #self.path("vivox-runtime/universal-darwin/SLVoiceAgent.app", "SLVoiceAgent.app") | 441 | #self.path("vivox-runtime/universal-darwin/SLVoiceAgent.app", "SLVoiceAgent.app") |
450 | 442 | ||
451 | # llkdu dynamic library | ||
452 | # self.path("../../libraries/universal-darwin/lib_release/libllkdu.dylib", "libllkdu.dylib") | ||
453 | |||
454 | #libfmodwrapper.dylib | 443 | #libfmodwrapper.dylib |
455 | #self.path(self.args['configuration'] + "/libfmodwrapper.dylib", "libfmodwrapper.dylib") | 444 | #self.path(self.args['configuration'] + "/libfmodwrapper.dylib", "libfmodwrapper.dylib") |
456 | 445 | ||
@@ -658,7 +647,6 @@ class Linux_i686Manifest(LinuxManifest): | |||
658 | self.path("app_settings/mozilla-runtime-linux-i686") | 647 | self.path("app_settings/mozilla-runtime-linux-i686") |
659 | 648 | ||
660 | if self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"): | 649 | if self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"): |
661 | # self.path("libkdu_v42R.so") | ||
662 | # self.path("libfmod-3.75.so") | 650 | # self.path("libfmod-3.75.so") |
663 | self.path("libapr-1.so.0") | 651 | self.path("libapr-1.so.0") |
664 | self.path("libaprutil-1.so.0") | 652 | self.path("libaprutil-1.so.0") |
@@ -673,7 +661,6 @@ class Linux_i686Manifest(LinuxManifest): | |||
673 | self.path("libopenjpeg.so.2") | 661 | self.path("libopenjpeg.so.2") |
674 | #self.path("libtcmalloc.so.0") - bugged | 662 | #self.path("libtcmalloc.so.0") - bugged |
675 | #self.path("libstacktrace.so.0") - probably bugged | 663 | #self.path("libstacktrace.so.0") - probably bugged |
676 | # self.path("libllkdu.so", "../bin/libllkdu.so") # llkdu goes in bin for some reason | ||
677 | self.end_prefix("lib") | 664 | self.end_prefix("lib") |
678 | 665 | ||
679 | # Vivox runtimes | 666 | # Vivox runtimes |