diff options
Diffstat (limited to 'linden/indra/newview')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 5 | ||||
-rw-r--r-- | linden/indra/newview/Info-Imprudence.plist (renamed from linden/indra/newview/Info-SecondLife.plist) | 2 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 114 |
3 files changed, 112 insertions, 9 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 1e48d28..f971f97 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -849,7 +849,7 @@ if (DARWIN) | |||
849 | 849 | ||
850 | # Add resource files to the project. | 850 | # Add resource files to the project. |
851 | set(viewer_RESOURCE_FILES | 851 | set(viewer_RESOURCE_FILES |
852 | secondlife.icns | 852 | viewer.icns |
853 | macview.r | 853 | macview.r |
854 | gpu_table.txt | 854 | gpu_table.txt |
855 | Info-Imprudence.plist | 855 | Info-Imprudence.plist |
@@ -1393,7 +1393,6 @@ target_link_libraries(imprudence-bin | |||
1393 | ${SMARTHEAP_LIBRARY} | 1393 | ${SMARTHEAP_LIBRARY} |
1394 | ${UI_LIBRARIES} | 1394 | ${UI_LIBRARIES} |
1395 | ${NDOF_LIBRARY} | 1395 | ${NDOF_LIBRARY} |
1396 | ${QUICKTIME_LIBRARY} | ||
1397 | ${WINDOWS_LIBRARIES} | 1396 | ${WINDOWS_LIBRARIES} |
1398 | ${XMLRPCEPI_LIBRARIES} | 1397 | ${XMLRPCEPI_LIBRARIES} |
1399 | ${ZLIB_LIBRARIES} | 1398 | ${ZLIB_LIBRARIES} |
@@ -1447,7 +1446,7 @@ if (DARWIN) | |||
1447 | PROPERTIES | 1446 | PROPERTIES |
1448 | OUTPUT_NAME "${product}" | 1447 | OUTPUT_NAME "${product}" |
1449 | MACOSX_BUNDLE_INFO_STRING "info string - localize me" | 1448 | MACOSX_BUNDLE_INFO_STRING "info string - localize me" |
1450 | MACOSX_BUNDLE_ICON_FILE "secondlife.icns" | 1449 | MACOSX_BUNDLE_ICON_FILE "viewer.icns" |
1451 | MACOSX_BUNDLE_GUI_IDENTIFIER "Imprudence" | 1450 | MACOSX_BUNDLE_GUI_IDENTIFIER "Imprudence" |
1452 | MACOSX_BUNDLE_LONG_VERSION_STRING "ververver" | 1451 | MACOSX_BUNDLE_LONG_VERSION_STRING "ververver" |
1453 | MACOSX_BUNDLE_BUNDLE_NAME "Imprudence" | 1452 | MACOSX_BUNDLE_BUNDLE_NAME "Imprudence" |
diff --git a/linden/indra/newview/Info-SecondLife.plist b/linden/indra/newview/Info-Imprudence.plist index 32bba70..357d171 100644 --- a/linden/indra/newview/Info-SecondLife.plist +++ b/linden/indra/newview/Info-Imprudence.plist | |||
@@ -7,7 +7,7 @@ | |||
7 | <key>CFBundleExecutable</key> | 7 | <key>CFBundleExecutable</key> |
8 | <string>Imprudence</string> | 8 | <string>Imprudence</string> |
9 | <key>CFBundleIconFile</key> | 9 | <key>CFBundleIconFile</key> |
10 | <string>secondlife.icns</string> | 10 | <string>viewer.icns</string> |
11 | <key>CFBundleIdentifier</key> | 11 | <key>CFBundleIdentifier</key> |
12 | <string>com.secondlife.indra.viewer</string> | 12 | <string>com.secondlife.indra.viewer</string> |
13 | <key>CFBundleInfoDictionaryVersion</key> | 13 | <key>CFBundleInfoDictionaryVersion</key> |
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index 3583726..71c07b6 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -403,10 +403,51 @@ class DarwinManifest(ViewerManifest): | |||
403 | # <bundle>/Contents/MacOS/ | 403 | # <bundle>/Contents/MacOS/ |
404 | self.contents_of_tar(self.args['source']+'/mozilla-universal-darwin.tgz', 'MacOS') | 404 | self.contents_of_tar(self.args['source']+'/mozilla-universal-darwin.tgz', 'MacOS') |
405 | 405 | ||
406 | self.path("Info-SecondLife.plist", dst="Info.plist") | 406 | self.path("Info-Imprudence.plist", dst="Info.plist") |
407 | 407 | ||
408 | # copy additional libs in <bundle>/Contents/MacOS/ | 408 | # copy additional libs in <bundle>/Contents/MacOS/ |
409 | self.path("../../libraries/universal-darwin/lib_release/libndofdev.dylib", dst="MacOS/libndofdev.dylib") | 409 | if self.prefix(src="../../libraries/universal-darwin/lib_release", dst="MacOS/"): |
410 | |||
411 | self.path("libndofdev.dylib") | ||
412 | |||
413 | self.path("libopenal.1.dylib") | ||
414 | self.path("libalut.0.dylib") | ||
415 | |||
416 | self.path("libglib-2.0.dylib") | ||
417 | self.path("libgmodule-2.0.dylib") | ||
418 | self.path("libgobject-2.0.dylib") | ||
419 | self.path("libgthread-2.0.dylib") | ||
420 | |||
421 | self.path("libgstreamer-0.10.dylib") | ||
422 | self.path("libgstapp-0.10.dylib") | ||
423 | self.path("libgstaudio-0.10.dylib") | ||
424 | self.path("libgstbase-0.10.dylib") | ||
425 | self.path("libgstcdda-0.10.dylib") | ||
426 | self.path("libgstcontroller-0.10.dylib") | ||
427 | self.path("libgstdataprotocol-0.10.dylib") | ||
428 | self.path("libgstfft-0.10.dylib") | ||
429 | self.path("libgstinterfaces-0.10.dylib") | ||
430 | self.path("libgstnet-0.10.dylib") | ||
431 | self.path("libgstnetbuffer-0.10.dylib") | ||
432 | self.path("libgstpbutils-0.10.dylib") | ||
433 | self.path("libgstriff-0.10.dylib") | ||
434 | self.path("libgstrtp-0.10.dylib") | ||
435 | self.path("libgstrtsp-0.10.dylib") | ||
436 | self.path("libgstsdp-0.10.dylib") | ||
437 | self.path("libgsttag-0.10.dylib") | ||
438 | self.path("libgstvideo-0.10.dylib") | ||
439 | |||
440 | self.path("libintl.3.dylib") | ||
441 | self.path("libjpeg.62.dylib") | ||
442 | self.path("libogg.0.dylib") | ||
443 | self.path("liboil-0.3.0.dylib") | ||
444 | self.path("libpango-1.0.0.dylib") | ||
445 | self.path("libpangoft2-1.0.0.dylib") | ||
446 | self.path("libtheora.0.dylib") | ||
447 | self.path("libvorbis.0.dylib") | ||
448 | self.path("libvorbisenc.2.dylib") | ||
449 | |||
450 | self.end_prefix("../../libraries/universal-darwin/lib_release") | ||
410 | 451 | ||
411 | # replace the default theme with our custom theme (so scrollbars work). | 452 | # replace the default theme with our custom theme (so scrollbars work). |
412 | if self.prefix(src="mozilla-theme", dst="MacOS/chrome"): | 453 | if self.prefix(src="mozilla-theme", dst="MacOS/chrome"): |
@@ -432,7 +473,7 @@ class DarwinManifest(ViewerManifest): | |||
432 | self.path("featuretable_mac.txt") | 473 | self.path("featuretable_mac.txt") |
433 | self.path("SecondLife.nib") | 474 | self.path("SecondLife.nib") |
434 | 475 | ||
435 | self.path("secondlife.icns") | 476 | self.path("viewer.icns") |
436 | 477 | ||
437 | # Translations | 478 | # Translations |
438 | self.path("English.lproj") | 479 | self.path("English.lproj") |
@@ -441,9 +482,72 @@ class DarwinManifest(ViewerManifest): | |||
441 | self.path("Korean.lproj") | 482 | self.path("Korean.lproj") |
442 | 483 | ||
443 | 484 | ||
485 | if self.prefix(src="../../libraries/universal-darwin/lib_release/gstreamer-plugins", dst="lib/gstreamer-plugins"): | ||
486 | self.path("libgstaacparse.so") | ||
487 | self.path("libgstadder.so") | ||
488 | self.path("libgstaiffparse.so") | ||
489 | self.path("libgstamrparse.so") | ||
490 | self.path("libgstapp.so") | ||
491 | self.path("libgstaudioconvert.so") | ||
492 | self.path("libgstaudiorate.so") | ||
493 | self.path("libgstaudioresample.so") | ||
494 | self.path("libgstautodetect.so") | ||
495 | self.path("libgstavi.so") | ||
496 | self.path("libgstcoreelements.so") | ||
497 | self.path("libgstcoreindexers.so") | ||
498 | self.path("libgstdebug.so") | ||
499 | self.path("libgstdecodebin.so") | ||
500 | self.path("libgstdecodebin2.so") | ||
501 | self.path("libgstdeinterlace2.so") | ||
502 | self.path("libgstequalizer.so") | ||
503 | self.path("libgstffmpeg.so") | ||
504 | self.path("libgstffmpegcolorspace.so") | ||
505 | self.path("libgstffmpegscale.so") | ||
506 | self.path("libgstflac.so") | ||
507 | self.path("libgstflv.so") | ||
508 | self.path("libgstgdp.so") | ||
509 | self.path("libgsth264parse.so") | ||
510 | self.path("libgsticydemux.so") | ||
511 | self.path("libgstid3demux.so") | ||
512 | self.path("libgstinterleave.so") | ||
513 | self.path("libgstjpeg.so") | ||
514 | self.path("libgstlevel.so") | ||
515 | self.path("libgstmetadata.so") | ||
516 | self.path("libgstmpeg4videoparse.so") | ||
517 | self.path("libgstmpegdemux.so") | ||
518 | self.path("libgstmpegvideoparse.so") | ||
519 | self.path("libgstmultipart.so") | ||
520 | self.path("libgstneonhttpsrc.so") | ||
521 | self.path("libgstogg.so") | ||
522 | self.path("libgstosxaudio.so") | ||
523 | self.path("libgstosxvideosink.so") | ||
524 | self.path("libgstpango.so") | ||
525 | self.path("libgstplaybin.so") | ||
526 | self.path("libgstpng.so") | ||
527 | self.path("libgstpostproc.so") | ||
528 | self.path("libgstqtdemux.so") | ||
529 | self.path("libgstqueue2.so") | ||
530 | self.path("libgstreal.so") | ||
531 | self.path("libgstrtp.so") | ||
532 | self.path("libgstrtpmanager.so") | ||
533 | self.path("libgstrtsp.so") | ||
534 | self.path("libgstsdpelem.so") | ||
535 | self.path("libgstselector.so") | ||
536 | self.path("libgsttcp.so") | ||
537 | self.path("libgsttheora.so") | ||
538 | self.path("libgsttypefindfunctions.so") | ||
539 | self.path("libgstudp.so") | ||
540 | self.path("libgstvideoscale.so") | ||
541 | self.path("libgstvolume.so") | ||
542 | self.path("libgstvorbis.so") | ||
543 | self.path("libgstwavparse.so") | ||
544 | |||
545 | self.end_prefix("../../libraries/universal-darwin/lib_release/gstreamer-plugins") | ||
546 | |||
547 | |||
444 | # SLVoice and vivox lols | 548 | # SLVoice and vivox lols |
445 | self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") | 549 | #self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") |
446 | self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") | 550 | #self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") |
447 | #self.path("vivox-runtime/universal-darwin/libortp.dylib", "libortp.dylib") | 551 | #self.path("vivox-runtime/universal-darwin/libortp.dylib", "libortp.dylib") |
448 | #self.path("vivox-runtime/universal-darwin/libvivoxsdk.dylib", "libvivoxsdk.dylib") | 552 | #self.path("vivox-runtime/universal-darwin/libvivoxsdk.dylib", "libvivoxsdk.dylib") |
449 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") | 553 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") |