aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--linden/indra/newview/CMakeLists.txt54
-rw-r--r--linden/indra/newview/ViewerInstall.cmake2
-rw-r--r--linden/indra/newview/llappviewer.cpp20
-rwxr-xr-xlinden/indra/newview/viewer_manifest.py52
4 files changed, 64 insertions, 64 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index ae0feb6..af7812c 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -1265,15 +1265,15 @@ list(APPEND viewer_SOURCE_FILES ${viewer_HEADER_FILES})
1265set_source_files_properties(${viewer_HEADER_FILES} 1265set_source_files_properties(${viewer_HEADER_FILES}
1266 PROPERTIES HEADER_FILE_ONLY TRUE) 1266 PROPERTIES HEADER_FILE_ONLY TRUE)
1267 1267
1268add_executable(secondlife-bin 1268add_executable(imprudence-bin
1269 WIN32 1269 WIN32
1270 MACOSX_BUNDLE 1270 MACOSX_BUNDLE
1271 ${viewer_SOURCE_FILES} 1271 ${viewer_SOURCE_FILES}
1272 ) 1272 )
1273check_message_template(secondlife-bin) 1273check_message_template(imprudence-bin)
1274 1274
1275if (LLKDU_LIBRARY) 1275if (LLKDU_LIBRARY)
1276 add_dependencies(secondlife-bin ${LLKDU_LIBRARY}) 1276 add_dependencies(imprudence-bin ${LLKDU_LIBRARY})
1277endif (LLKDU_LIBRARY) 1277endif (LLKDU_LIBRARY)
1278 1278
1279set(PACKAGE OFF CACHE BOOL 1279set(PACKAGE OFF CACHE BOOL
@@ -1281,12 +1281,12 @@ set(PACKAGE OFF CACHE BOOL
1281 1281
1282if (WINDOWS) 1282if (WINDOWS)
1283 if(MSVC71) 1283 if(MSVC71)
1284 set(release_flags "/MAP:Release/secondlife-bin.map /MAPINFO:LINES") 1284 set(release_flags "/MAP:Release/imprudence-bin.map /MAPINFO:LINES")
1285 else(MSVC71) 1285 else(MSVC71)
1286 set(release_flags "/MAP:Release/secondlife-bin.map") 1286 set(release_flags "/MAP:Release/imprudence-bin.map")
1287 endif(MSVC71) 1287 endif(MSVC71)
1288 1288
1289 set_target_properties(secondlife-bin 1289 set_target_properties(imprudence-bin
1290 PROPERTIES 1290 PROPERTIES
1291 LINK_FLAGS "/debug /NODEFAULTLIB:MSVCRT /SUBSYSTEM:WINDOWS" 1291 LINK_FLAGS "/debug /NODEFAULTLIB:MSVCRT /SUBSYSTEM:WINDOWS"
1292 LINK_FLAGS_DEBUG "/NODEFAULTLIB:LIBCMT /NODEFAULTLIB:MSVCRTD" 1292 LINK_FLAGS_DEBUG "/NODEFAULTLIB:LIBCMT /NODEFAULTLIB:MSVCRTD"
@@ -1296,20 +1296,20 @@ if (WINDOWS)
1296 # sets the 'working directory' for debugging from visual studio. 1296 # sets the 'working directory' for debugging from visual studio.
1297 if (NOT UNATTENDED) 1297 if (NOT UNATTENDED)
1298 add_custom_command( 1298 add_custom_command(
1299 TARGET secondlife-bin PRE_BUILD 1299 TARGET imprudence-bin PRE_BUILD
1300 COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe 1300 COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe
1301 ARGS 1301 ARGS
1302 --solution 1302 --solution
1303 ${CMAKE_BINARY_DIR}/${CMAKE_PROJECT_NAME}.sln 1303 ${CMAKE_BINARY_DIR}/${CMAKE_PROJECT_NAME}.sln
1304 --workingdir 1304 --workingdir
1305 secondlife-bin 1305 imprudence-bin
1306 ${CMAKE_CURRENT_SOURCE_DIR} 1306 ${CMAKE_CURRENT_SOURCE_DIR}
1307 COMMENT "Setting the secondlife-bin working directory for debugging." 1307 COMMENT "Setting the imprudence-bin working directory for debugging."
1308 ) 1308 )
1309 endif (NOT UNATTENDED) 1309 endif (NOT UNATTENDED)
1310 1310
1311 add_custom_command( 1311 add_custom_command(
1312 TARGET secondlife-bin PRE_BUILD 1312 TARGET imprudence-bin PRE_BUILD
1313 COMMAND ${CMAKE_COMMAND} 1313 COMMAND ${CMAKE_COMMAND}
1314 ARGS 1314 ARGS
1315 -E 1315 -E
@@ -1320,7 +1320,7 @@ if (WINDOWS)
1320 ) 1320 )
1321 1321
1322 add_custom_command( 1322 add_custom_command(
1323 TARGET secondlife-bin PRE_BUILD 1323 TARGET imprudence-bin PRE_BUILD
1324 COMMAND ${CMAKE_COMMAND} 1324 COMMAND ${CMAKE_COMMAND}
1325 ARGS 1325 ARGS
1326 -E 1326 -E
@@ -1330,10 +1330,10 @@ if (WINDOWS)
1330 COMMENT "Copying message.xml to the runtime folder." 1330 COMMENT "Copying message.xml to the runtime folder."
1331 ) 1331 )
1332 1332
1333 add_dependencies(secondlife-bin copy_win_libs) 1333 add_dependencies(imprudence-bin copy_win_libs)
1334 1334
1335 if (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) 1335 if (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts)
1336 add_dependencies(secondlife-bin copy_win_scripts) 1336 add_dependencies(imprudence-bin copy_win_scripts)
1337 endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) 1337 endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts)
1338 1338
1339 add_custom_command( 1339 add_custom_command(
@@ -1350,7 +1350,7 @@ if (WINDOWS)
1350 --build=${CMAKE_CURRENT_BINARY_DIR} 1350 --build=${CMAKE_CURRENT_BINARY_DIR}
1351 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} 1351 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}
1352 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat 1352 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat
1353 DEPENDS secondlife-bin ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1353 DEPENDS imprudence-bin ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1354 ) 1354 )
1355 if (PACKAGE) 1355 if (PACKAGE)
1356 add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) 1356 add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat)
@@ -1358,7 +1358,7 @@ if (WINDOWS)
1358 endif (PACKAGE) 1358 endif (PACKAGE)
1359endif (WINDOWS) 1359endif (WINDOWS)
1360 1360
1361target_link_libraries(secondlife-bin 1361target_link_libraries(imprudence-bin
1362 ${LLAUDIO_LIBRARIES} 1362 ${LLAUDIO_LIBRARIES}
1363 ${LLCHARACTER_LIBRARIES} 1363 ${LLCHARACTER_LIBRARIES}
1364 ${LLIMAGE_LIBRARIES} 1364 ${LLIMAGE_LIBRARIES}
@@ -1403,13 +1403,13 @@ set(ARTWORK_DIR ${CMAKE_CURRENT_SOURCE_DIR} CACHE PATH
1403 1403
1404if (LINUX) 1404if (LINUX)
1405 add_custom_command( 1405 add_custom_command(
1406 OUTPUT secondlife-stripped 1406 OUTPUT imprudence-stripped
1407 COMMAND strip 1407 COMMAND strip
1408 ARGS --strip-debug -o secondlife-stripped secondlife-bin 1408 ARGS --strip-debug -o imprudence-stripped imprudence-bin
1409 DEPENDS secondlife-bin 1409 DEPENDS imprudence-bin
1410 ) 1410 )
1411 1411
1412 set(product SecondLife-${ARCH}-${viewer_VERSION}) 1412 set(product Imprudence-${ARCH}-${viewer_VERSION})
1413 1413
1414 add_custom_command( 1414 add_custom_command(
1415 OUTPUT ${product}.tar.bz2 1415 OUTPUT ${product}.tar.bz2
@@ -1426,7 +1426,7 @@ if (LINUX)
1426 --build=${CMAKE_CURRENT_BINARY_DIR} 1426 --build=${CMAKE_CURRENT_BINARY_DIR}
1427 --dest=${CMAKE_CURRENT_BINARY_DIR}/packaged 1427 --dest=${CMAKE_CURRENT_BINARY_DIR}/packaged
1428 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched 1428 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched
1429 DEPENDS secondlife-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1429 DEPENDS imprudence-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1430 ) 1430 )
1431 1431
1432 if (NOT INSTALL) 1432 if (NOT INSTALL)
@@ -1436,23 +1436,23 @@ if (LINUX)
1436endif (LINUX) 1436endif (LINUX)
1437 1437
1438if (DARWIN) 1438if (DARWIN)
1439 set(product "Second Life") 1439 set(product "Imprudence")
1440 set_target_properties( 1440 set_target_properties(
1441 secondlife-bin 1441 imprudence-bin
1442 PROPERTIES 1442 PROPERTIES
1443 OUTPUT_NAME "${product}" 1443 OUTPUT_NAME "${product}"
1444 MACOSX_BUNDLE_INFO_STRING "info string - localize me" 1444 MACOSX_BUNDLE_INFO_STRING "info string - localize me"
1445 MACOSX_BUNDLE_ICON_FILE "secondlife.icns" 1445 MACOSX_BUNDLE_ICON_FILE "secondlife.icns"
1446 MACOSX_BUNDLE_GUI_IDENTIFIER "Second Life" 1446 MACOSX_BUNDLE_GUI_IDENTIFIER "Imprudence"
1447 MACOSX_BUNDLE_LONG_VERSION_STRING "ververver" 1447 MACOSX_BUNDLE_LONG_VERSION_STRING "ververver"
1448 MACOSX_BUNDLE_BUNDLE_NAME "Second Life" 1448 MACOSX_BUNDLE_BUNDLE_NAME "Imprudence"
1449 MACOSX_BUNDLE_SHORT_VERSION_STRING "asdf" 1449 MACOSX_BUNDLE_SHORT_VERSION_STRING "asdf"
1450 MACOSX_BUNDLE_BUNDLE_VERSION "asdf" 1450 MACOSX_BUNDLE_BUNDLE_VERSION "asdf"
1451 MACOSX_BUNDLE_COPYRIGHT "copyright linden lab 2007 - localize me and run me through a legal wringer" 1451 MACOSX_BUNDLE_COPYRIGHT "copyright linden lab 2007 - localize me and run me through a legal wringer"
1452 ) 1452 )
1453 1453
1454 add_custom_command( 1454 add_custom_command(
1455 TARGET secondlife-bin POST_BUILD 1455 TARGET imprudence-bin POST_BUILD
1456 COMMAND ${PYTHON_EXECUTABLE} 1456 COMMAND ${PYTHON_EXECUTABLE}
1457 ARGS 1457 ARGS
1458 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1458 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
@@ -1463,7 +1463,7 @@ if (DARWIN)
1463 --artwork=${ARTWORK_DIR} 1463 --artwork=${ARTWORK_DIR}
1464 --build=${CMAKE_CURRENT_BINARY_DIR} 1464 --build=${CMAKE_CURRENT_BINARY_DIR}
1465 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app 1465 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app
1466 DEPENDS secondlife-bin ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1466 DEPENDS imprudence-bin ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1467 ) 1467 )
1468 1468
1469 if (PACKAGE) 1469 if (PACKAGE)
@@ -1481,7 +1481,7 @@ if (DARWIN)
1481 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app 1481 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app
1482 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched 1482 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched
1483 DEPENDS 1483 DEPENDS
1484 secondlife-bin 1484 imprudence-bin
1485 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1485 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1486 ) 1486 )
1487 add_dependencies(package mac-updater mac-crash-logger) 1487 add_dependencies(package mac-updater mac-crash-logger)
diff --git a/linden/indra/newview/ViewerInstall.cmake b/linden/indra/newview/ViewerInstall.cmake
index 55069ad..bc839c4 100644
--- a/linden/indra/newview/ViewerInstall.cmake
+++ b/linden/indra/newview/ViewerInstall.cmake
@@ -1,4 +1,4 @@
1install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/secondlife-bin 1install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/imprudence-bin
2 DESTINATION ${APP_BINARY_DIR} 2 DESTINATION ${APP_BINARY_DIR}
3 ) 3 )
4 4
diff --git a/linden/indra/newview/llappviewer.cpp b/linden/indra/newview/llappviewer.cpp
index 3ef3894..5b3e38d 100644
--- a/linden/indra/newview/llappviewer.cpp
+++ b/linden/indra/newview/llappviewer.cpp
@@ -293,10 +293,10 @@ BOOL gLogoutInProgress = FALSE;
293// Internal globals... that should be removed. 293// Internal globals... that should be removed.
294static std::string gArgs; 294static std::string gArgs;
295 295
296const std::string MARKER_FILE_NAME("SecondLife.exec_marker"); 296const std::string MARKER_FILE_NAME("Imprudence.exec_marker");
297const std::string ERROR_MARKER_FILE_NAME("SecondLife.error_marker"); 297const std::string ERROR_MARKER_FILE_NAME("Imprudence.error_marker");
298const std::string LLERROR_MARKER_FILE_NAME("SecondLife.llerror_marker"); 298const std::string LLERROR_MARKER_FILE_NAME("Imprudence.llerror_marker");
299const std::string LOGOUT_MARKER_FILE_NAME("SecondLife.logout_marker"); 299const std::string LOGOUT_MARKER_FILE_NAME("Imprudence.logout_marker");
300static BOOL gDoDisconnect = FALSE; 300static BOOL gDoDisconnect = FALSE;
301static std::string gLaunchFileOnQuit; 301static std::string gLaunchFileOnQuit;
302 302
@@ -1468,15 +1468,15 @@ bool LLAppViewer::initLogging()
1468 1468
1469 // Remove the last ".old" log file. 1469 // Remove the last ".old" log file.
1470 std::string old_log_file = gDirUtilp->getExpandedFilename(LL_PATH_LOGS, 1470 std::string old_log_file = gDirUtilp->getExpandedFilename(LL_PATH_LOGS,
1471 "SecondLife.old"); 1471 "Imprudence.old");
1472 LLFile::remove(old_log_file); 1472 LLFile::remove(old_log_file);
1473 1473
1474 // Rename current log file to ".old" 1474 // Rename current log file to ".old"
1475 std::string log_file = gDirUtilp->getExpandedFilename(LL_PATH_LOGS, 1475 std::string log_file = gDirUtilp->getExpandedFilename(LL_PATH_LOGS,
1476 "SecondLife.log"); 1476 "Imprudence.log");
1477 LLFile::rename(log_file, old_log_file); 1477 LLFile::rename(log_file, old_log_file);
1478 1478
1479 // Set the log file to SecondLife.log 1479 // Set the log file to Imprudence.log
1480 1480
1481 LLError::logToFile(log_file); 1481 LLError::logToFile(log_file);
1482 1482
@@ -1658,7 +1658,7 @@ bool LLAppViewer::initConfiguration()
1658 llinfos << "Command line usage:\n" << clp << llendl; 1658 llinfos << "Command line usage:\n" << clp << llendl;
1659 1659
1660 std::ostringstream msg; 1660 std::ostringstream msg;
1661 msg << "Second Life found an error parsing the command line. \n" 1661 msg << gSecondLife << " found an error parsing the command line. \n"
1662 << "Please see: http://wiki.secondlife.com/wiki/Client_parameters \n" 1662 << "Please see: http://wiki.secondlife.com/wiki/Client_parameters \n"
1663 << "Error: " << clp.getErrorMessage(); 1663 << "Error: " << clp.getErrorMessage();
1664 1664
@@ -2654,7 +2654,7 @@ bool LLAppViewer::initCache()
2654 std::string cache_dir = gDirUtilp->getOSUserAppDir(); 2654 std::string cache_dir = gDirUtilp->getOSUserAppDir();
2655 std::string new_cache_dir = gDirUtilp->getOSCacheDir(); 2655 std::string new_cache_dir = gDirUtilp->getOSCacheDir();
2656 cache_dir = cache_dir + "/cache"; 2656 cache_dir = cache_dir + "/cache";
2657 new_cache_dir = new_cache_dir + "/" + gSecondLife; 2657 new_cache_dir = new_cache_dir + "/" + "SecondLife";
2658 if (gDirUtilp->fileExists(cache_dir)) 2658 if (gDirUtilp->fileExists(cache_dir))
2659 { 2659 {
2660 gDirUtilp->setCacheDir(cache_dir); 2660 gDirUtilp->setCacheDir(cache_dir);
@@ -2947,7 +2947,7 @@ void LLAppViewer::badNetworkHandler()
2947 message << 2947 message <<
2948 "The viewer has detected mangled network data indicative\n" 2948 "The viewer has detected mangled network data indicative\n"
2949 "of a bad upstream network connection or an incomplete\n" 2949 "of a bad upstream network connection or an incomplete\n"
2950 "local installation of " << LLAppViewer::instance()->getSecondLifeTitle() << ". \n" 2950 "local installation of " << gSecondLife << ". \n"
2951 " \n" 2951 " \n"
2952 "Try uninstalling and reinstalling to see if this resolves \n" 2952 "Try uninstalling and reinstalling to see if this resolves \n"
2953 "the issue. \n" 2953 "the issue. \n"
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index fe894a7..2533e6a 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -139,9 +139,9 @@ class WindowsManifest(ViewerManifest):
139 def final_exe(self): 139 def final_exe(self):
140 if self.default_channel(): 140 if self.default_channel():
141 if self.default_grid(): 141 if self.default_grid():
142 return "SecondLife.exe" 142 return "Imprudence.exe"
143 else: 143 else:
144 return "SecondLifePreview.exe" 144 return "ImprudencePreview.exe"
145 else: 145 else:
146 return ''.join(self.channel().split()) + '.exe' 146 return ''.join(self.channel().split()) + '.exe'
147 147
@@ -150,7 +150,7 @@ class WindowsManifest(ViewerManifest):
150 super(WindowsManifest, self).construct() 150 super(WindowsManifest, self).construct()
151 # the final exe is complicated because we're not sure where it's coming from, 151 # the final exe is complicated because we're not sure where it's coming from,
152 # nor do we have a fixed name for the executable 152 # nor do we have a fixed name for the executable
153 self.path(self.find_existing_file('debug/secondlife-bin.exe', 'release/secondlife-bin.exe', 'relwithdebinfo/secondlife-bin.exe'), dst=self.final_exe()) 153 self.path(self.find_existing_file('debug/imprudence-bin.exe', 'release/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe'), dst=self.final_exe())
154 # need to get the kdu dll from any of the build directories as well 154 # need to get the kdu dll from any of the build directories as well
155 self.path(self.find_existing_file( 155 self.path(self.find_existing_file(
156 # *FIX:Mani we need to add support for packaging specific targets. 156 # *FIX:Mani we need to add support for packaging specific targets.
@@ -299,36 +299,36 @@ class WindowsManifest(ViewerManifest):
299 if self.default_channel(): 299 if self.default_channel():
300 if self.default_grid(): 300 if self.default_grid():
301 # release viewer 301 # release viewer
302 installer_file = "Second_Life_%(version_dashes)s_Setup.exe" 302 installer_file = "Imprudence_%(version_dashes)s_Setup.exe"
303 grid_vars_template = """ 303 grid_vars_template = """
304 OutFile "%(installer_file)s" 304 OutFile "%(installer_file)s"
305 !define INSTFLAGS "%(flags)s" 305 !define INSTFLAGS "%(flags)s"
306 !define INSTNAME "SecondLife" 306 !define INSTNAME "Imprudence"
307 !define SHORTCUT "Second Life" 307 !define SHORTCUT "Imprudence"
308 !define URLNAME "secondlife" 308 !define URLNAME "imprudence"
309 Caption "Second Life ${VERSION}" 309 Caption "Imprudence ${VERSION}"
310 """ 310 """
311 else: 311 else:
312 # beta grid viewer 312 # beta grid viewer
313 installer_file = "Second_Life_%(version_dashes)s_(%(grid_caps)s)_Setup.exe" 313 installer_file = "Imprudence_%(version_dashes)s_(%(grid_caps)s)_Setup.exe"
314 grid_vars_template = """ 314 grid_vars_template = """
315 OutFile "%(installer_file)s" 315 OutFile "%(installer_file)s"
316 !define INSTFLAGS "%(flags)s" 316 !define INSTFLAGS "%(flags)s"
317 !define INSTNAME "SecondLife%(grid_caps)s" 317 !define INSTNAME "Imprudence%(grid_caps)s"
318 !define SHORTCUT "Second Life (%(grid_caps)s)" 318 !define SHORTCUT "Imprudence (%(grid_caps)s)"
319 !define URLNAME "secondlife%(grid)s" 319 !define URLNAME "imprudence%(grid)s"
320 !define UNINSTALL_SETTINGS 1 320 !define UNINSTALL_SETTINGS 1
321 Caption "Second Life %(grid)s ${VERSION}" 321 Caption "Imprudence %(grid)s ${VERSION}"
322 """ 322 """
323 else: 323 else:
324 # some other channel on some grid 324 # some other channel on some grid
325 installer_file = "Second_Life_%(version_dashes)s_%(channel_oneword)s_Setup.exe" 325 installer_file = "Imprudence_%(version_dashes)s_%(channel_oneword)s_Setup.exe"
326 grid_vars_template = """ 326 grid_vars_template = """
327 OutFile "%(installer_file)s" 327 OutFile "%(installer_file)s"
328 !define INSTFLAGS "%(flags)s" 328 !define INSTFLAGS "%(flags)s"
329 !define INSTNAME "SecondLife%(channel_oneword)s" 329 !define INSTNAME "Imprudence%(channel_oneword)s"
330 !define SHORTCUT "%(channel)s" 330 !define SHORTCUT "%(channel)s"
331 !define URLNAME "secondlife" 331 !define URLNAME "imprudence"
332 !define UNINSTALL_SETTINGS 1 332 !define UNINSTALL_SETTINGS 1
333 Caption "%(channel)s ${VERSION}" 333 Caption "%(channel)s ${VERSION}"
334 """ 334 """
@@ -338,7 +338,7 @@ class WindowsManifest(ViewerManifest):
338 installer_file = installer_file % substitution_strings 338 installer_file = installer_file % substitution_strings
339 substitution_strings['installer_file'] = installer_file 339 substitution_strings['installer_file'] = installer_file
340 340
341 tempfile = "secondlife_setup_tmp.nsi" 341 tempfile = "imprudence_setup_tmp.nsi"
342 # the following replaces strings in the nsi template 342 # the following replaces strings in the nsi template
343 # it also does python-style % substitution 343 # it also does python-style % substitution
344 self.replace_in("installers/windows/installer_template.nsi", tempfile, { 344 self.replace_in("installers/windows/installer_template.nsi", tempfile, {
@@ -358,7 +358,7 @@ class WindowsManifest(ViewerManifest):
358class DarwinManifest(ViewerManifest): 358class DarwinManifest(ViewerManifest):
359 def construct(self): 359 def construct(self):
360 # copy over the build result (this is a no-op if run within the xcode script) 360 # copy over the build result (this is a no-op if run within the xcode script)
361 self.path(self.args['configuration'] + "/Second Life.app", dst="") 361 self.path(self.args['configuration'] + "/Imprudence.app", dst="")
362 362
363 if self.prefix(src="", dst="Contents"): # everything goes in Contents 363 if self.prefix(src="", dst="Contents"): # everything goes in Contents
364 # Expand the tar file containing the assorted mozilla bits into 364 # Expand the tar file containing the assorted mozilla bits into
@@ -437,16 +437,16 @@ class DarwinManifest(ViewerManifest):
437 437
438 438
439 def package_finish(self): 439 def package_finish(self):
440 channel_standin = 'Second Life' # hah, our default channel is not usable on its own 440 channel_standin = 'Imprudence' # hah, our default channel is not usable on its own
441 if not self.default_channel(): 441 if not self.default_channel():
442 channel_standin = self.channel() 442 channel_standin = self.channel()
443 443
444 imagename="SecondLife_" + '_'.join(self.args['version']) 444 imagename="Imprudence_" + '_'.join(self.args['version'])
445 445
446 # MBW -- If the mounted volume name changes, it breaks the .DS_Store's background image and icon positioning. 446 # MBW -- If the mounted volume name changes, it breaks the .DS_Store's background image and icon positioning.
447 # If we really need differently named volumes, we'll need to create multiple DS_Store file images, or use some other trick. 447 # If we really need differently named volumes, we'll need to create multiple DS_Store file images, or use some other trick.
448 448
449 volname="Second Life Installer" # DO NOT CHANGE without understanding comment above 449 volname="Imprudence Installer" # DO NOT CHANGE without understanding comment above
450 450
451 if self.default_channel(): 451 if self.default_channel():
452 if not self.default_grid(): 452 if not self.default_grid():
@@ -473,7 +473,7 @@ class DarwinManifest(ViewerManifest):
473 # Copy everything in to the mounted .dmg 473 # Copy everything in to the mounted .dmg
474 474
475 if self.default_channel() and not self.default_grid(): 475 if self.default_channel() and not self.default_grid():
476 app_name = "Second Life " + self.args['grid'] 476 app_name = "Imprudence " + self.args['grid']
477 else: 477 else:
478 app_name = channel_standin.strip() 478 app_name = channel_standin.strip()
479 479
@@ -533,7 +533,7 @@ class LinuxManifest(ViewerManifest):
533 if self.prefix("linux_tools", dst=""): 533 if self.prefix("linux_tools", dst=""):
534 self.path("client-readme.txt","README-linux.txt") 534 self.path("client-readme.txt","README-linux.txt")
535 self.path("client-readme-voice.txt","README-linux-voice.txt") 535 self.path("client-readme-voice.txt","README-linux-voice.txt")
536 self.path("wrapper.sh","secondlife") 536 self.path("wrapper.sh","imprudence")
537 self.path("handle_secondlifeprotocol.sh") 537 self.path("handle_secondlifeprotocol.sh")
538 self.path("register_secondlifeprotocol.sh") 538 self.path("register_secondlifeprotocol.sh")
539 self.end_prefix("linux_tools") 539 self.end_prefix("linux_tools")
@@ -553,7 +553,7 @@ class LinuxManifest(ViewerManifest):
553 if 'installer_name' in self.args: 553 if 'installer_name' in self.args:
554 installer_name = self.args['installer_name'] 554 installer_name = self.args['installer_name']
555 else: 555 else:
556 installer_name_components = ['SecondLife_', self.args.get('arch')] 556 installer_name_components = ['Imprudence_', self.args.get('arch')]
557 installer_name_components.extend(self.args['version']) 557 installer_name_components.extend(self.args['version'])
558 installer_name = "_".join(installer_name_components) 558 installer_name = "_".join(installer_name_components)
559 if self.default_channel(): 559 if self.default_channel():
@@ -598,7 +598,7 @@ class LinuxManifest(ViewerManifest):
598class Linux_i686Manifest(LinuxManifest): 598class Linux_i686Manifest(LinuxManifest):
599 def construct(self): 599 def construct(self):
600 super(Linux_i686Manifest, self).construct() 600 super(Linux_i686Manifest, self).construct()
601 self.path("secondlife-stripped","bin/do-not-directly-run-secondlife-bin") 601 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin")
602# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin") 602# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin")
603 self.path("linux_tools/launch_url.sh","launch_url.sh") 603 self.path("linux_tools/launch_url.sh","launch_url.sh")
604 if self.prefix("res-sdl"): 604 if self.prefix("res-sdl"):
@@ -643,7 +643,7 @@ class Linux_i686Manifest(LinuxManifest):
643class Linux_x86_64Manifest(LinuxManifest): 643class Linux_x86_64Manifest(LinuxManifest):
644 def construct(self): 644 def construct(self):
645 super(Linux_x86_64Manifest, self).construct() 645 super(Linux_x86_64Manifest, self).construct()
646 self.path("secondlife-stripped","bin/do-not-directly-run-secondlife-bin") 646 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin")
647# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin") 647# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin")
648 self.path("linux_tools/launch_url.sh","launch_url.sh") 648 self.path("linux_tools/launch_url.sh","launch_url.sh")
649 if self.prefix("res-sdl"): 649 if self.prefix("res-sdl"):