diff options
Diffstat (limited to 'linden/indra/newview/packaging/mac')
24 files changed, 497 insertions, 0 deletions
diff --git a/linden/indra/newview/packaging/mac/ConfigureDMG.scpt b/linden/indra/newview/packaging/mac/ConfigureDMG.scpt new file mode 100644 index 0000000..198ab9e --- /dev/null +++ b/linden/indra/newview/packaging/mac/ConfigureDMG.scpt | |||
@@ -0,0 +1,110 @@ | |||
1 | (* | ||
2 | |||
3 | @file ConfigureDMG.scpt | ||
4 | @author Jacek Antonelli | ||
5 | @brief Script for configuring the Mac installer disk image. | ||
6 | |||
7 | Copyright (c) 2011, Jacek Antonelli | ||
8 | |||
9 | Permission is hereby granted, free of charge, to any person | ||
10 | obtaining a copy of this software and associated documentation files | ||
11 | (the "Software"), to deal in the Software without restriction, | ||
12 | including without limitation the rights to use, copy, modify, merge, | ||
13 | publish, distribute, sublicense, and/or sell copies of the Software, | ||
14 | and to permit persons to whom the Software is furnished to do so, | ||
15 | subject to the following conditions: | ||
16 | |||
17 | The above copyright notice and this permission notice shall be | ||
18 | included in all copies or substantial portions of the Software. | ||
19 | |||
20 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, | ||
21 | EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF | ||
22 | MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND | ||
23 | NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS | ||
24 | BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN | ||
25 | ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN | ||
26 | CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE | ||
27 | SOFTWARE. | ||
28 | |||
29 | ----- | ||
30 | |||
31 | This AppleScript script configures the view options and icon layout of | ||
32 | the Mac installer disk image (DMG) as part of the packaging process. | ||
33 | See also scripts/package.py, which executes this script. | ||
34 | |||
35 | This script takes two required positional command line arguments: | ||
36 | |||
37 | 1: the name of the mounted volume (e.g. for "/Volumes/Imprudence Installer", | ||
38 | the volume name is "Imprudence Installer"). | ||
39 | 2: the name of the application file (e.g. "Imprudence.app"). | ||
40 | |||
41 | Example usage: | ||
42 | |||
43 | osascript ConfigureDMG.scpt "Imprudence Installer" "Imprudence.app" | ||
44 | |||
45 | Some preparation is necessary before running this script: | ||
46 | |||
47 | * The target disk image must be currently attached as a volume, with | ||
48 | the volume name specified by the first command line argument. | ||
49 | * The volume must contain the application file, with the file | ||
50 | name specified by the second command line argument. | ||
51 | * The volume must contain the "background.png" image file. | ||
52 | * The volume must not contain a file or folder named "Applications". | ||
53 | * It might be necessary to "Enable access for assistive devices" | ||
54 | in System Preferences > Universal Access. | ||
55 | |||
56 | *) | ||
57 | |||
58 | on run argv | ||
59 | |||
60 | -- Read the first positional argument, the volume name. | ||
61 | set volumeName to item 1 of argv | ||
62 | |||
63 | -- Read the second positional argument, the app name. | ||
64 | set appName to item 2 of argv | ||
65 | |||
66 | tell application "Finder" to tell disk volumeName | ||
67 | -- Open the volume in a Finder window. | ||
68 | open | ||
69 | set theWindow to the container window | ||
70 | |||
71 | -- Tweak some options. | ||
72 | set current view of theWindow to icon view | ||
73 | set toolbar visible of theWindow to false | ||
74 | set statusbar visible of theWindow to false | ||
75 | |||
76 | -- Set window to position {150,150}, size {+600,+420}. | ||
77 | set bounds of theWindow to {150, 150, 750, 570} | ||
78 | |||
79 | -- Tweak some more options. | ||
80 | set viewOptions to the icon view options of theWindow | ||
81 | set arrangement of viewOptions to not arranged | ||
82 | set icon size of viewOptions to 128 | ||
83 | |||
84 | -- Make sure background.png is visible, so Finder can see it. | ||
85 | set bgPicPath to the quoted form of (the POSIX path of (it as alias) & "background.png") | ||
86 | do shell script ("SetFile -a v " & bgPicPath) | ||
87 | update without registering applications | ||
88 | |||
89 | -- Use background.png as the background picture. | ||
90 | set background picture of viewOptions to file "background.png" | ||
91 | |||
92 | -- Now set background.png to invisible, so the end user won't see it. | ||
93 | do shell script ("SetFile -a V " & bgPicPath) | ||
94 | |||
95 | -- Position the application file. | ||
96 | set position of item appName of theWindow to {138, 260} | ||
97 | |||
98 | -- Create and position an alias to the Applications folder. | ||
99 | set appAlias to make new alias file at theWindow to POSIX file "/Applications" | ||
100 | set name of appAlias to "Applications" | ||
101 | set position of appAlias to {470, 260} | ||
102 | |||
103 | -- Visually update the window so all the changes take effect. | ||
104 | update without registering applications | ||
105 | |||
106 | -- Pause briefly so we can admire the results. | ||
107 | delay 2 | ||
108 | end tell | ||
109 | |||
110 | end run | ||
diff --git a/linden/indra/newview/packaging/mac/English.lproj/InfoPlist.strings b/linden/indra/newview/packaging/mac/English.lproj/InfoPlist.strings new file mode 100644 index 0000000..1ebe727 --- /dev/null +++ b/linden/indra/newview/packaging/mac/English.lproj/InfoPlist.strings | |||
@@ -0,0 +1,5 @@ | |||
1 | /* Localized versions of Info.plist keys */ | ||
2 | |||
3 | CFBundleName = "Imprudence"; | ||
4 | CFBundleShortVersionString = "Imprudence 1.4.0 beta 1"; | ||
5 | CFBundleGetInfoString = "Imprudence 1.4.0 beta 1"; | ||
diff --git a/linden/indra/newview/packaging/mac/English.lproj/language.txt b/linden/indra/newview/packaging/mac/English.lproj/language.txt new file mode 100644 index 0000000..bc0aa57 --- /dev/null +++ b/linden/indra/newview/packaging/mac/English.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
en-us \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/GenerateInfoPlist.cmake b/linden/indra/newview/packaging/mac/GenerateInfoPlist.cmake new file mode 100644 index 0000000..ecbec34 --- /dev/null +++ b/linden/indra/newview/packaging/mac/GenerateInfoPlist.cmake | |||
@@ -0,0 +1,39 @@ | |||
1 | # | ||
2 | # Generate the Info.plist file from the template. | ||
3 | # Only @-style "@VARIABLES@" are substituted in the template (not "${VARIABLES}"). | ||
4 | # | ||
5 | # This script is needed because CMake has no other way to perform | ||
6 | # configure_file() as a build-time custom command. :( | ||
7 | # | ||
8 | # When running this script, you must define (-D) SOURCE_DIR and | ||
9 | # BINARY_DIR to refer to indra and the build directory respectively. | ||
10 | # (Equivalent to CMAKE_SOURCE_DIR and CMAKE_BINARY_DIR in | ||
11 | # CMakeLists.txt ) | ||
12 | # | ||
13 | |||
14 | if (NOT SOURCE_DIR) | ||
15 | message( FATAL_ERROR "You forgot to define SOURCE_DIR!" ) | ||
16 | endif (NOT SOURCE_DIR) | ||
17 | |||
18 | if (NOT BINARY_DIR) | ||
19 | message( FATAL_ERROR "You forgot to define BINARY_DIR!" ) | ||
20 | endif (NOT BINARY_DIR) | ||
21 | |||
22 | set(SCRIPTS_DIR "${SOURCE_DIR}/../scripts") | ||
23 | set(CMAKE_MODULE_PATH "${SOURCE_DIR}/cmake/" "${CMAKE_ROOT/Modules}") | ||
24 | |||
25 | include(BuildVersion) | ||
26 | build_version(viewer) | ||
27 | |||
28 | SET( BUNDLE_NAME "${viewer_NAME}" ) | ||
29 | SET( EXECUTABLE "${viewer_NAME}" ) | ||
30 | set( BUNDLE_VERSION "${viewer_VERSION}" ) | ||
31 | set( SHORT_VERSION_STRING "${viewer_NAME} ${viewer_VERSION}" ) | ||
32 | set( ICON_FILE "viewer.icns" ) | ||
33 | set( IDENTIFIER "${viewer_BUNDLE_ID}" ) | ||
34 | set( SIGNATURE "impr" ) | ||
35 | |||
36 | configure_file( | ||
37 | ${SOURCE_DIR}/newview/packaging/mac/Info.plist.in | ||
38 | ${BINARY_DIR}/newview/packaging/mac/Info.plist | ||
39 | @ONLY) | ||
diff --git a/linden/indra/newview/packaging/mac/German.lproj/language.txt b/linden/indra/newview/packaging/mac/German.lproj/language.txt new file mode 100644 index 0000000..c42e816 --- /dev/null +++ b/linden/indra/newview/packaging/mac/German.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
de \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/Info.plist.in b/linden/indra/newview/packaging/mac/Info.plist.in new file mode 100644 index 0000000..78cc6b7 --- /dev/null +++ b/linden/indra/newview/packaging/mac/Info.plist.in | |||
@@ -0,0 +1,41 @@ | |||
1 | <?xml version="1.0" encoding="UTF-8"?> | ||
2 | <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> | ||
3 | <plist version="1.0"> | ||
4 | <dict> | ||
5 | <key>CFBundleName</key> | ||
6 | <string>@BUNDLE_NAME@</string> | ||
7 | <key>CFBundleExecutable</key> | ||
8 | <string>@EXECUTABLE@</string> | ||
9 | <key>CFBundleVersion</key> | ||
10 | <string>@BUNDLE_VERSION@</string> | ||
11 | <key>CFBundleShortVersionString</key> | ||
12 | <string>@SHORT_VERSION_STRING@</string> | ||
13 | <key>CFBundleIconFile</key> | ||
14 | <string>@ICON_FILE@</string> | ||
15 | <key>CFBundleIdentifier</key> | ||
16 | <string>@IDENTIFIER@</string> | ||
17 | <key>CFBundleSignature</key> | ||
18 | <string>@SIGNATURE@</string> | ||
19 | <key>CFBundleURLTypes</key> | ||
20 | <array> | ||
21 | <dict> | ||
22 | <key>CFBundleURLName</key> | ||
23 | <string>Second Life URL</string> | ||
24 | <key>CFBundleURLSchemes</key> | ||
25 | <array> | ||
26 | <string>secondlife</string> | ||
27 | </array> | ||
28 | <key>LSIsAppleDefaultForScheme</key> | ||
29 | <true/> | ||
30 | </dict> | ||
31 | </array> | ||
32 | <key>CFBundleDevelopmentRegion</key> | ||
33 | <string>English</string> | ||
34 | <key>CFBundleInfoDictionaryVersion</key> | ||
35 | <string>6.0</string> | ||
36 | <key>CFBundlePackageType</key> | ||
37 | <string>APPL</string> | ||
38 | <key>CSResourcesFileMapped</key> | ||
39 | <true/> | ||
40 | </dict> | ||
41 | </plist> | ||
diff --git a/linden/indra/newview/packaging/mac/Japanese.lproj/language.txt b/linden/indra/newview/packaging/mac/Japanese.lproj/language.txt new file mode 100644 index 0000000..c6e3ab6 --- /dev/null +++ b/linden/indra/newview/packaging/mac/Japanese.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
ja \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/Korean.lproj/language.txt b/linden/indra/newview/packaging/mac/Korean.lproj/language.txt new file mode 100644 index 0000000..b03ec72 --- /dev/null +++ b/linden/indra/newview/packaging/mac/Korean.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
ko \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/SecondLife.nib/classes.nib b/linden/indra/newview/packaging/mac/SecondLife.nib/classes.nib new file mode 100644 index 0000000..ea58db1 --- /dev/null +++ b/linden/indra/newview/packaging/mac/SecondLife.nib/classes.nib | |||
@@ -0,0 +1,4 @@ | |||
1 | { | ||
2 | IBClasses = (); | ||
3 | IBVersion = 1; | ||
4 | } | ||
diff --git a/linden/indra/newview/packaging/mac/SecondLife.nib/info.nib b/linden/indra/newview/packaging/mac/SecondLife.nib/info.nib new file mode 100644 index 0000000..1b531de --- /dev/null +++ b/linden/indra/newview/packaging/mac/SecondLife.nib/info.nib | |||
@@ -0,0 +1,23 @@ | |||
1 | <?xml version="1.0" encoding="UTF-8"?> | ||
2 | <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> | ||
3 | <plist version="1.0"> | ||
4 | <dict> | ||
5 | <key>IBDocumentLocation</key> | ||
6 | <string>85 13 356 240 0 0 1280 1002 </string> | ||
7 | <key>IBEditorPositions</key> | ||
8 | <dict> | ||
9 | <key>29</key> | ||
10 | <string>27 314 247 44 0 0 1280 1002 </string> | ||
11 | </dict> | ||
12 | <key>IBFramework Version</key> | ||
13 | <string>362.0</string> | ||
14 | <key>IBOpenObjects</key> | ||
15 | <array> | ||
16 | <integer>191</integer> | ||
17 | </array> | ||
18 | <key>IBSystem Version</key> | ||
19 | <string>7D24</string> | ||
20 | <key>targetFramework</key> | ||
21 | <string>IBCarbonFramework</string> | ||
22 | </dict> | ||
23 | </plist> | ||
diff --git a/linden/indra/newview/packaging/mac/SecondLife.nib/objects.xib b/linden/indra/newview/packaging/mac/SecondLife.nib/objects.xib new file mode 100644 index 0000000..553b6f3 --- /dev/null +++ b/linden/indra/newview/packaging/mac/SecondLife.nib/objects.xib | |||
@@ -0,0 +1,259 @@ | |||
1 | <?xml version="1.0" standalone="yes"?> | ||
2 | <object class="NSIBObjectData"> | ||
3 | <string name="targetFramework">IBCarbonFramework</string> | ||
4 | <object name="rootObject" class="NSCustomObject" id="1"> | ||
5 | <string name="customClass">NSApplication</string> | ||
6 | </object> | ||
7 | <array count="31" name="allObjects"> | ||
8 | <object class="IBCarbonMenu" id="29"> | ||
9 | <string name="title">Imprudence</string> | ||
10 | <array count="4" name="items"> | ||
11 | <object class="IBCarbonMenuItem" id="182"> | ||
12 | <string name="title">Imprudence</string> | ||
13 | <object name="submenu" class="IBCarbonMenu" id="181"> | ||
14 | <string name="title">Imprudence</string> | ||
15 | <array count="1" name="items"> | ||
16 | <object class="IBCarbonMenuItem" id="183"> | ||
17 | <boolean name="disabled">TRUE</boolean> | ||
18 | <boolean name="updateSingleItem">TRUE</boolean> | ||
19 | <string name="title">About Imprudence</string> | ||
20 | <int name="keyEquivalentModifier">0</int> | ||
21 | <ostype name="command">abou</ostype> | ||
22 | </object> | ||
23 | </array> | ||
24 | <string name="name">_NSAppleMenu</string> | ||
25 | </object> | ||
26 | </object> | ||
27 | <object class="IBCarbonMenuItem" id="127"> | ||
28 | <string name="title">File</string> | ||
29 | <object name="submenu" class="IBCarbonMenu" id="131"> | ||
30 | <string name="title">File</string> | ||
31 | </object> | ||
32 | </object> | ||
33 | <object class="IBCarbonMenuItem" id="152"> | ||
34 | <string name="title">Edit</string> | ||
35 | <object name="submenu" class="IBCarbonMenu" id="147"> | ||
36 | <string name="title">Edit</string> | ||
37 | <array count="10" name="items"> | ||
38 | <object class="IBCarbonMenuItem" id="141"> | ||
39 | <boolean name="updateSingleItem">TRUE</boolean> | ||
40 | <string name="title">Undo</string> | ||
41 | <string name="keyEquivalent">z</string> | ||
42 | <ostype name="command">undo</ostype> | ||
43 | </object> | ||
44 | <object class="IBCarbonMenuItem" id="146"> | ||
45 | <boolean name="updateSingleItem">TRUE</boolean> | ||
46 | <string name="title">Redo</string> | ||
47 | <string name="keyEquivalent">Z</string> | ||
48 | <ostype name="command">redo</ostype> | ||
49 | </object> | ||
50 | <object class="IBCarbonMenuItem" id="142"> | ||
51 | <boolean name="separator">TRUE</boolean> | ||
52 | </object> | ||
53 | <object class="IBCarbonMenuItem" id="143"> | ||
54 | <boolean name="updateSingleItem">TRUE</boolean> | ||
55 | <string name="title">Cut</string> | ||
56 | <string name="keyEquivalent">x</string> | ||
57 | <ostype name="command">cut </ostype> | ||
58 | </object> | ||
59 | <object class="IBCarbonMenuItem" id="149"> | ||
60 | <boolean name="updateSingleItem">TRUE</boolean> | ||
61 | <string name="title">Copy</string> | ||
62 | <string name="keyEquivalent">c</string> | ||
63 | <ostype name="command">copy</ostype> | ||
64 | </object> | ||
65 | <object class="IBCarbonMenuItem" id="144"> | ||
66 | <boolean name="updateSingleItem">TRUE</boolean> | ||
67 | <string name="title">Paste</string> | ||
68 | <string name="keyEquivalent">v</string> | ||
69 | <ostype name="command">past</ostype> | ||
70 | </object> | ||
71 | <object class="IBCarbonMenuItem" id="151"> | ||
72 | <boolean name="updateSingleItem">TRUE</boolean> | ||
73 | <string name="title">Delete</string> | ||
74 | <ostype name="command">clea</ostype> | ||
75 | </object> | ||
76 | <object class="IBCarbonMenuItem" id="148"> | ||
77 | <boolean name="updateSingleItem">TRUE</boolean> | ||
78 | <string name="title">Select All</string> | ||
79 | <string name="keyEquivalent">a</string> | ||
80 | <ostype name="command">sall</ostype> | ||
81 | </object> | ||
82 | <object class="IBCarbonMenuItem" id="188"> | ||
83 | <boolean name="separator">TRUE</boolean> | ||
84 | </object> | ||
85 | <object class="IBCarbonMenuItem" id="187"> | ||
86 | <boolean name="updateSingleItem">TRUE</boolean> | ||
87 | <string name="title">Special Characters…</string> | ||
88 | <ostype name="command">chrp</ostype> | ||
89 | </object> | ||
90 | </array> | ||
91 | </object> | ||
92 | </object> | ||
93 | <object class="IBCarbonMenuItem" id="153"> | ||
94 | <string name="title">Window</string> | ||
95 | <object name="submenu" class="IBCarbonMenu" id="154"> | ||
96 | <string name="title">Window</string> | ||
97 | <array count="6" name="items"> | ||
98 | <object class="IBCarbonMenuItem" id="155"> | ||
99 | <boolean name="dynamic">TRUE</boolean> | ||
100 | <boolean name="updateSingleItem">TRUE</boolean> | ||
101 | <string name="title">Minimize Window</string> | ||
102 | <string name="keyEquivalent">m</string> | ||
103 | <ostype name="command">mini</ostype> | ||
104 | </object> | ||
105 | <object class="IBCarbonMenuItem" id="184"> | ||
106 | <boolean name="dynamic">TRUE</boolean> | ||
107 | <boolean name="updateSingleItem">TRUE</boolean> | ||
108 | <string name="title">Minimize All Windows</string> | ||
109 | <string name="keyEquivalent">m</string> | ||
110 | <int name="keyEquivalentModifier">1572864</int> | ||
111 | <ostype name="command">mina</ostype> | ||
112 | </object> | ||
113 | <object class="IBCarbonMenuItem" id="186"> | ||
114 | <boolean name="updateSingleItem">TRUE</boolean> | ||
115 | <string name="title">Zoom</string> | ||
116 | <ostype name="command">zoom</ostype> | ||
117 | </object> | ||
118 | <object class="IBCarbonMenuItem" id="156"> | ||
119 | <boolean name="separator">TRUE</boolean> | ||
120 | </object> | ||
121 | <object class="IBCarbonMenuItem" id="157"> | ||
122 | <boolean name="dynamic">TRUE</boolean> | ||
123 | <boolean name="updateSingleItem">TRUE</boolean> | ||
124 | <string name="title">Bring All to Front</string> | ||
125 | <ostype name="command">bfrt</ostype> | ||
126 | </object> | ||
127 | <object class="IBCarbonMenuItem" id="185"> | ||
128 | <boolean name="dynamic">TRUE</boolean> | ||
129 | <boolean name="updateSingleItem">TRUE</boolean> | ||
130 | <string name="title">Arrange in Front</string> | ||
131 | <int name="keyEquivalentModifier">1572864</int> | ||
132 | <ostype name="command">frnt</ostype> | ||
133 | </object> | ||
134 | </array> | ||
135 | <string name="name">_NSWindowsMenu</string> | ||
136 | </object> | ||
137 | </object> | ||
138 | </array> | ||
139 | <string name="name">_NSMainMenu</string> | ||
140 | </object> | ||
141 | <reference idRef="127"/> | ||
142 | <reference idRef="131"/> | ||
143 | <reference idRef="141"/> | ||
144 | <reference idRef="142"/> | ||
145 | <reference idRef="143"/> | ||
146 | <reference idRef="144"/> | ||
147 | <reference idRef="146"/> | ||
148 | <reference idRef="147"/> | ||
149 | <reference idRef="148"/> | ||
150 | <reference idRef="149"/> | ||
151 | <reference idRef="151"/> | ||
152 | <reference idRef="152"/> | ||
153 | <reference idRef="153"/> | ||
154 | <reference idRef="154"/> | ||
155 | <reference idRef="155"/> | ||
156 | <reference idRef="156"/> | ||
157 | <reference idRef="157"/> | ||
158 | <reference idRef="181"/> | ||
159 | <reference idRef="182"/> | ||
160 | <reference idRef="183"/> | ||
161 | <reference idRef="184"/> | ||
162 | <reference idRef="185"/> | ||
163 | <reference idRef="186"/> | ||
164 | <reference idRef="187"/> | ||
165 | <reference idRef="188"/> | ||
166 | <object class="IBCarbonRootControl" id="190"> | ||
167 | <string name="bounds">0 0 482 694 </string> | ||
168 | <string name="viewFrame">0 0 694 482 </string> | ||
169 | <array count="2" name="subviews"> | ||
170 | <object class="IBCarbonButton" id="192"> | ||
171 | <string name="bounds">442 604 462 674 </string> | ||
172 | <string name="viewFrame">604 442 70 20 </string> | ||
173 | <string name="title">OK</string> | ||
174 | <ostype name="command">ok </ostype> | ||
175 | <object name="layoutInfo" class="IBCarbonHILayoutInfo"> | ||
176 | <int name="bindingBottomKind">2</int> | ||
177 | <int name="bindingRightKind">2</int> | ||
178 | </object> | ||
179 | <int name="buttonType">1</int> | ||
180 | </object> | ||
181 | <object class="IBCarbonScrollView" id="201"> | ||
182 | <string name="bounds">20 20 422 674 </string> | ||
183 | <string name="viewFrame">20 20 654 402 </string> | ||
184 | <array count="1" name="subviews"> | ||
185 | <object class="IBCarbonTextView" id="200"> | ||
186 | <string name="bounds">20 20 422 659 </string> | ||
187 | <string name="viewFrame">0 0 639 402 </string> | ||
188 | <ostype name="controlSignature">text</ostype> | ||
189 | <int name="fontStyle">5</int> | ||
190 | <boolean name="readOnly">TRUE</boolean> | ||
191 | </object> | ||
192 | </array> | ||
193 | <boolean name="scrollHorizontally">FALSE</boolean> | ||
194 | </object> | ||
195 | </array> | ||
196 | </object> | ||
197 | <object class="IBCarbonWindow" id="191"> | ||
198 | <string name="windowRect">84 72 566 766 </string> | ||
199 | <string name="title">Release Notes</string> | ||
200 | <reference name="rootControl" idRef="190"/> | ||
201 | <boolean name="receiveUpdates">FALSE</boolean> | ||
202 | <boolean name="hasCloseBox">FALSE</boolean> | ||
203 | <boolean name="hasCollapseBox">FALSE</boolean> | ||
204 | <boolean name="hasHorizontalZoom">FALSE</boolean> | ||
205 | <boolean name="isResizable">FALSE</boolean> | ||
206 | <boolean name="hasVerticalZoom">FALSE</boolean> | ||
207 | <boolean name="liveResize">TRUE</boolean> | ||
208 | <boolean name="compositing">TRUE</boolean> | ||
209 | <int name="carbonWindowClass">4</int> | ||
210 | <int name="windowPosition">1</int> | ||
211 | <boolean name="isConstrained">FALSE</boolean> | ||
212 | </object> | ||
213 | <reference idRef="192"/> | ||
214 | <reference idRef="200"/> | ||
215 | <reference idRef="201"/> | ||
216 | </array> | ||
217 | <array count="31" name="allParents"> | ||
218 | <reference idRef="1"/> | ||
219 | <reference idRef="29"/> | ||
220 | <reference idRef="127"/> | ||
221 | <reference idRef="147"/> | ||
222 | <reference idRef="147"/> | ||
223 | <reference idRef="147"/> | ||
224 | <reference idRef="147"/> | ||
225 | <reference idRef="147"/> | ||
226 | <reference idRef="152"/> | ||
227 | <reference idRef="147"/> | ||
228 | <reference idRef="147"/> | ||
229 | <reference idRef="147"/> | ||
230 | <reference idRef="29"/> | ||
231 | <reference idRef="29"/> | ||
232 | <reference idRef="153"/> | ||
233 | <reference idRef="154"/> | ||
234 | <reference idRef="154"/> | ||
235 | <reference idRef="154"/> | ||
236 | <reference idRef="182"/> | ||
237 | <reference idRef="29"/> | ||
238 | <reference idRef="181"/> | ||
239 | <reference idRef="154"/> | ||
240 | <reference idRef="154"/> | ||
241 | <reference idRef="154"/> | ||
242 | <reference idRef="147"/> | ||
243 | <reference idRef="147"/> | ||
244 | <reference idRef="191"/> | ||
245 | <reference idRef="1"/> | ||
246 | <reference idRef="190"/> | ||
247 | <reference idRef="201"/> | ||
248 | <reference idRef="190"/> | ||
249 | </array> | ||
250 | <dictionary count="3" name="nameTable"> | ||
251 | <string>Files Owner</string> | ||
252 | <reference idRef="1"/> | ||
253 | <string>MenuBar</string> | ||
254 | <reference idRef="29"/> | ||
255 | <string>Release Notes</string> | ||
256 | <reference idRef="191"/> | ||
257 | </dictionary> | ||
258 | <unsigned_int name="nextObjectID">202</unsigned_int> | ||
259 | </object> | ||
diff --git a/linden/indra/newview/packaging/mac/background.png b/linden/indra/newview/packaging/mac/background.png new file mode 100644 index 0000000..9b0b0b2 --- /dev/null +++ b/linden/indra/newview/packaging/mac/background.png | |||
Binary files differ | |||
diff --git a/linden/indra/newview/packaging/mac/da.lproj/language.txt b/linden/indra/newview/packaging/mac/da.lproj/language.txt new file mode 100644 index 0000000..316d25d --- /dev/null +++ b/linden/indra/newview/packaging/mac/da.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
da \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/es.lproj/language.txt b/linden/indra/newview/packaging/mac/es.lproj/language.txt new file mode 100644 index 0000000..6c43814 --- /dev/null +++ b/linden/indra/newview/packaging/mac/es.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
es \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/fr.lproj/language.txt b/linden/indra/newview/packaging/mac/fr.lproj/language.txt new file mode 100644 index 0000000..717280a --- /dev/null +++ b/linden/indra/newview/packaging/mac/fr.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
fr \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/hu.lproj/language.txt b/linden/indra/newview/packaging/mac/hu.lproj/language.txt new file mode 100644 index 0000000..6c604cf --- /dev/null +++ b/linden/indra/newview/packaging/mac/hu.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
hu \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/it.lproj/language.txt b/linden/indra/newview/packaging/mac/it.lproj/language.txt new file mode 100644 index 0000000..c919714 --- /dev/null +++ b/linden/indra/newview/packaging/mac/it.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
it \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/nl.lproj/language.txt b/linden/indra/newview/packaging/mac/nl.lproj/language.txt new file mode 100644 index 0000000..d5f5c2a --- /dev/null +++ b/linden/indra/newview/packaging/mac/nl.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
nl \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/pl.lproj/language.txt b/linden/indra/newview/packaging/mac/pl.lproj/language.txt new file mode 100644 index 0000000..55239f3 --- /dev/null +++ b/linden/indra/newview/packaging/mac/pl.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
pl \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/pt.lproj/language.txt b/linden/indra/newview/packaging/mac/pt.lproj/language.txt new file mode 100644 index 0000000..9e3340e --- /dev/null +++ b/linden/indra/newview/packaging/mac/pt.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
pt \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/ru.lproj/language.txt b/linden/indra/newview/packaging/mac/ru.lproj/language.txt new file mode 100644 index 0000000..adc719b --- /dev/null +++ b/linden/indra/newview/packaging/mac/ru.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
ru \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/tr.lproj/language.txt b/linden/indra/newview/packaging/mac/tr.lproj/language.txt new file mode 100644 index 0000000..44266bf --- /dev/null +++ b/linden/indra/newview/packaging/mac/tr.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
tr \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/uk.lproj/language.txt b/linden/indra/newview/packaging/mac/uk.lproj/language.txt new file mode 100644 index 0000000..fbc658f --- /dev/null +++ b/linden/indra/newview/packaging/mac/uk.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
uk \ No newline at end of file | |||
diff --git a/linden/indra/newview/packaging/mac/zh-Hans.lproj/language.txt b/linden/indra/newview/packaging/mac/zh-Hans.lproj/language.txt new file mode 100644 index 0000000..147d659 --- /dev/null +++ b/linden/indra/newview/packaging/mac/zh-Hans.lproj/language.txt | |||
@@ -0,0 +1 @@ | |||
zh \ No newline at end of file | |||