diff options
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 100 |
1 files changed, 87 insertions, 13 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index dfd35bf..e113d05 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -21,8 +21,8 @@ include(LLImage) | |||
21 | include(LLImageJ2COJ) | 21 | include(LLImageJ2COJ) |
22 | include(LLInventory) | 22 | include(LLInventory) |
23 | include(LLMath) | 23 | include(LLMath) |
24 | include(LLMedia) | ||
25 | include(LLMessage) | 24 | include(LLMessage) |
25 | include(LLPlugin) | ||
26 | include(LLPrimitive) | 26 | include(LLPrimitive) |
27 | include(LLRender) | 27 | include(LLRender) |
28 | include(LLUI) | 28 | include(LLUI) |
@@ -31,7 +31,6 @@ include(LLWindow) | |||
31 | include(LLXML) | 31 | include(LLXML) |
32 | include(LScript) | 32 | include(LScript) |
33 | include(Linking) | 33 | include(Linking) |
34 | include(Mozlib) | ||
35 | include(NDOF) | 34 | include(NDOF) |
36 | include(GooglePerfTools) | 35 | include(GooglePerfTools) |
37 | include(TemplateCheck) | 36 | include(TemplateCheck) |
@@ -55,8 +54,8 @@ include_directories( | |||
55 | ${LLIMAGE_INCLUDE_DIRS} | 54 | ${LLIMAGE_INCLUDE_DIRS} |
56 | ${LLINVENTORY_INCLUDE_DIRS} | 55 | ${LLINVENTORY_INCLUDE_DIRS} |
57 | ${LLMATH_INCLUDE_DIRS} | 56 | ${LLMATH_INCLUDE_DIRS} |
58 | ${LLMEDIA_INCLUDE_DIRS} | ||
59 | ${LLMESSAGE_INCLUDE_DIRS} | 57 | ${LLMESSAGE_INCLUDE_DIRS} |
58 | ${LLPLUGIN_INCLUDE_DIRS} | ||
60 | ${LLPRIMITIVE_INCLUDE_DIRS} | 59 | ${LLPRIMITIVE_INCLUDE_DIRS} |
61 | ${LLRENDER_INCLUDE_DIRS} | 60 | ${LLRENDER_INCLUDE_DIRS} |
62 | ${LLUI_INCLUDE_DIRS} | 61 | ${LLUI_INCLUDE_DIRS} |
@@ -65,7 +64,6 @@ include_directories( | |||
65 | ${LLXML_INCLUDE_DIRS} | 64 | ${LLXML_INCLUDE_DIRS} |
66 | ${LSCRIPT_INCLUDE_DIRS} | 65 | ${LSCRIPT_INCLUDE_DIRS} |
67 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile | 66 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile |
68 | ${GSTREAMER_INCLUDE_DIRS} | ||
69 | ) | 67 | ) |
70 | 68 | ||
71 | set(viewer_SOURCE_FILES | 69 | set(viewer_SOURCE_FILES |
@@ -186,9 +184,8 @@ set(viewer_SOURCE_FILES | |||
186 | llfloatergroups.cpp | 184 | llfloatergroups.cpp |
187 | llfloaterhandler.cpp | 185 | llfloaterhandler.cpp |
188 | llfloaterhardwaresettings.cpp | 186 | llfloaterhardwaresettings.cpp |
189 | llfloaterhtml.cpp | ||
190 | llfloaterhtmlcurrency.cpp | 187 | llfloaterhtmlcurrency.cpp |
191 | llfloaterhtmlhelp.cpp | 188 | llfloatermediabrowser.cpp |
192 | llfloaterhtmlsimple.cpp | 189 | llfloaterhtmlsimple.cpp |
193 | llfloaterhud.cpp | 190 | llfloaterhud.cpp |
194 | llfloaterimagepreview.cpp | 191 | llfloaterimagepreview.cpp |
@@ -313,10 +310,12 @@ set(viewer_SOURCE_FILES | |||
313 | llpanelinput.cpp | 310 | llpanelinput.cpp |
314 | llpanelinventory.cpp | 311 | llpanelinventory.cpp |
315 | llpanelland.cpp | 312 | llpanelland.cpp |
313 | llpanellandaudio.cpp | ||
316 | llpanellandmedia.cpp | 314 | llpanellandmedia.cpp |
317 | llpanellandobjects.cpp | 315 | llpanellandobjects.cpp |
318 | llpanellandoptions.cpp | 316 | llpanellandoptions.cpp |
319 | llpanellogin.cpp | 317 | llpanellogin.cpp |
318 | llpanelmediahud.cpp | ||
320 | llpanelmsgs.cpp | 319 | llpanelmsgs.cpp |
321 | llpanelnetwork.cpp | 320 | llpanelnetwork.cpp |
322 | llpanelobject.cpp | 321 | llpanelobject.cpp |
@@ -422,6 +421,8 @@ set(viewer_SOURCE_FILES | |||
422 | llviewerkeyboard.cpp | 421 | llviewerkeyboard.cpp |
423 | llviewerlayer.cpp | 422 | llviewerlayer.cpp |
424 | llviewermedia.cpp | 423 | llviewermedia.cpp |
424 | llviewermediafocus.cpp | ||
425 | llviewermedia_streamingaudio.cpp | ||
425 | llviewermenu.cpp | 426 | llviewermenu.cpp |
426 | llviewermenufile.cpp | 427 | llviewermenufile.cpp |
427 | llviewermessage.cpp | 428 | llviewermessage.cpp |
@@ -468,7 +469,7 @@ set(viewer_SOURCE_FILES | |||
468 | llwearable.cpp | 469 | llwearable.cpp |
469 | llwearablelist.cpp | 470 | llwearablelist.cpp |
470 | llweb.cpp | 471 | llweb.cpp |
471 | llwebbrowserctrl.cpp | 472 | llmediactrl.cpp |
472 | llwindlightremotectrl.cpp | 473 | llwindlightremotectrl.cpp |
473 | llwind.cpp | 474 | llwind.cpp |
474 | llwlanimator.cpp | 475 | llwlanimator.cpp |
@@ -632,9 +633,8 @@ set(viewer_HEADER_FILES | |||
632 | llfloatergroups.h | 633 | llfloatergroups.h |
633 | llfloaterhandler.h | 634 | llfloaterhandler.h |
634 | llfloaterhardwaresettings.h | 635 | llfloaterhardwaresettings.h |
635 | llfloaterhtml.h | ||
636 | llfloaterhtmlcurrency.h | 636 | llfloaterhtmlcurrency.h |
637 | llfloaterhtmlhelp.h | 637 | llfloatermediabrowser.h |
638 | llfloaterhtmlsimple.h | 638 | llfloaterhtmlsimple.h |
639 | llfloaterhud.h | 639 | llfloaterhud.h |
640 | llfloaterimagepreview.h | 640 | llfloaterimagepreview.h |
@@ -758,11 +758,13 @@ set(viewer_HEADER_FILES | |||
758 | llpanelinput.h | 758 | llpanelinput.h |
759 | llpanelinventory.h | 759 | llpanelinventory.h |
760 | llpanelland.h | 760 | llpanelland.h |
761 | llpanellandaudio.h | ||
761 | llpanellandmedia.h | 762 | llpanellandmedia.h |
762 | llpanellandobjects.h | 763 | llpanellandobjects.h |
763 | llpanellandoptions.h | 764 | llpanellandoptions.h |
764 | llpanelLCD.h | 765 | llpanelLCD.h |
765 | llpanellogin.h | 766 | llpanellogin.h |
767 | llpanelmediahud.h | ||
766 | llpanelmsgs.h | 768 | llpanelmsgs.h |
767 | llpanelnetwork.h | 769 | llpanelnetwork.h |
768 | llpanelobject.h | 770 | llpanelobject.h |
@@ -869,6 +871,8 @@ set(viewer_HEADER_FILES | |||
869 | llviewerkeyboard.h | 871 | llviewerkeyboard.h |
870 | llviewerlayer.h | 872 | llviewerlayer.h |
871 | llviewermedia.h | 873 | llviewermedia.h |
874 | llviewermediaobserver.h | ||
875 | llviewermediafocus.h | ||
872 | llviewermenu.h | 876 | llviewermenu.h |
873 | llviewermenufile.h | 877 | llviewermenufile.h |
874 | llviewermessage.h | 878 | llviewermessage.h |
@@ -917,7 +921,7 @@ set(viewer_HEADER_FILES | |||
917 | llwearable.h | 921 | llwearable.h |
918 | llwearablelist.h | 922 | llwearablelist.h |
919 | llweb.h | 923 | llweb.h |
920 | llwebbrowserctrl.h | 924 | llmediactrl.h |
921 | llwind.h | 925 | llwind.h |
922 | llwindebug.h | 926 | llwindebug.h |
923 | llwindlightremotectrl.h | 927 | llwindlightremotectrl.h |
@@ -1120,6 +1124,7 @@ if (WINDOWS) | |||
1120 | if (INTEL_MEMOPS_LIBRARY) | 1124 | if (INTEL_MEMOPS_LIBRARY) |
1121 | list(APPEND viewer_LIBRARIES ${INTEL_MEMOPS_LIBRARY}) | 1125 | list(APPEND viewer_LIBRARIES ${INTEL_MEMOPS_LIBRARY}) |
1122 | endif (INTEL_MEMOPS_LIBRARY) | 1126 | endif (INTEL_MEMOPS_LIBRARY) |
1127 | use_prebuilt_binary(dbghelp) | ||
1123 | endif (WINDOWS) | 1128 | endif (WINDOWS) |
1124 | 1129 | ||
1125 | # Add the xui files. This is handy for searching for xui elements | 1130 | # Add the xui files. This is handy for searching for xui elements |
@@ -1342,6 +1347,9 @@ if (WINDOWS) | |||
1342 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat | 1347 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat |
1343 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1348 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1344 | ) | 1349 | ) |
1350 | |||
1351 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | ||
1352 | |||
1345 | if (PACKAGE) | 1353 | if (PACKAGE) |
1346 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) | 1354 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) |
1347 | add_dependencies(package windows-updater windows-crash-logger) | 1355 | add_dependencies(package windows-updater windows-crash-logger) |
@@ -1354,8 +1362,8 @@ target_link_libraries(${VIEWER_BINARY_NAME} | |||
1354 | ${LLIMAGE_LIBRARIES} | 1362 | ${LLIMAGE_LIBRARIES} |
1355 | ${LLIMAGEJ2COJ_LIBRARIES} | 1363 | ${LLIMAGEJ2COJ_LIBRARIES} |
1356 | ${LLINVENTORY_LIBRARIES} | 1364 | ${LLINVENTORY_LIBRARIES} |
1357 | ${LLMEDIA_LIBRARIES} | ||
1358 | ${LLMESSAGE_LIBRARIES} | 1365 | ${LLMESSAGE_LIBRARIES} |
1366 | ${LLPLUGIN_LIBRARIES} | ||
1359 | ${LLPRIMITIVE_LIBRARIES} | 1367 | ${LLPRIMITIVE_LIBRARIES} |
1360 | ${LLRENDER_LIBRARIES} | 1368 | ${LLRENDER_LIBRARIES} |
1361 | ${FREETYPE_LIBRARIES} | 1369 | ${FREETYPE_LIBRARIES} |
@@ -1377,7 +1385,6 @@ target_link_libraries(${VIEWER_BINARY_NAME} | |||
1377 | ${OPENGL_LIBRARIES} | 1385 | ${OPENGL_LIBRARIES} |
1378 | ${FMODWRAPPER_LIBRARY} | 1386 | ${FMODWRAPPER_LIBRARY} |
1379 | ${OPENGL_LIBRARIES} | 1387 | ${OPENGL_LIBRARIES} |
1380 | ${MOZLIB_LIBRARIES} | ||
1381 | ${JSONCPP_LIBRARIES} | 1388 | ${JSONCPP_LIBRARIES} |
1382 | ${SDL_LIBRARY} | 1389 | ${SDL_LIBRARY} |
1383 | ${SMARTHEAP_LIBRARY} | 1390 | ${SMARTHEAP_LIBRARY} |
@@ -1422,6 +1429,8 @@ if (LINUX) | |||
1422 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched | 1429 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched |
1423 | DEPENDS imprudence-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1430 | DEPENDS imprudence-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1424 | ) | 1431 | ) |
1432 | |||
1433 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_gstreamer010 media_plugin_webkit) | ||
1425 | 1434 | ||
1426 | if (NOT INSTALL) | 1435 | if (NOT INSTALL) |
1427 | add_custom_target(package ALL DEPENDS ${product}.tar.bz2) | 1436 | add_custom_target(package ALL DEPENDS ${product}.tar.bz2) |
@@ -1459,6 +1468,8 @@ if (DARWIN) | |||
1459 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app | 1468 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app |
1460 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1469 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1461 | ) | 1470 | ) |
1471 | |||
1472 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | ||
1462 | 1473 | ||
1463 | if (PACKAGE) | 1474 | if (PACKAGE) |
1464 | add_custom_target(package ALL DEPENDS ${VIEWER_BINARY_NAME}) | 1475 | add_custom_target(package ALL DEPENDS ${VIEWER_BINARY_NAME}) |
@@ -1479,11 +1490,12 @@ if (DARWIN) | |||
1479 | --build=${CMAKE_CURRENT_BINARY_DIR} | 1490 | --build=${CMAKE_CURRENT_BINARY_DIR} |
1480 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app | 1491 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app |
1481 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched | 1492 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched |
1493 | |||
1482 | DEPENDS | 1494 | DEPENDS |
1483 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1495 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1484 | ) | 1496 | ) |
1485 | 1497 | ||
1486 | 1498 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | |
1487 | add_custom_command( | 1499 | add_custom_command( |
1488 | TARGET package POST_BUILD | 1500 | TARGET package POST_BUILD |
1489 | COMMAND ${PYTHON_EXECUTABLE} | 1501 | COMMAND ${PYTHON_EXECUTABLE} |
@@ -1510,3 +1522,65 @@ if (INSTALL) | |||
1510 | endif (INSTALL) | 1522 | endif (INSTALL) |
1511 | 1523 | ||
1512 | ADD_VIEWER_BUILD_TEST(llagentaccess viewer) | 1524 | ADD_VIEWER_BUILD_TEST(llagentaccess viewer) |
1525 | |||
1526 | # Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py | ||
1527 | if (WINDOWS) | ||
1528 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) | ||
1529 | add_custom_command( | ||
1530 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1531 | COMMAND ${CMAKE_COMMAND} | ||
1532 | ARGS | ||
1533 | -E | ||
1534 | copy_if_different | ||
1535 | ${BUILT_SLPLUGIN} | ||
1536 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} | ||
1537 | COMMENT "Copying SLPlugin executable to the runtime folder." | ||
1538 | ) | ||
1539 | |||
1540 | get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) | ||
1541 | add_custom_command( | ||
1542 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1543 | COMMAND ${CMAKE_COMMAND} | ||
1544 | ARGS | ||
1545 | -E | ||
1546 | copy_if_different | ||
1547 | ${BUILT_WEBKIT_PLUGIN} | ||
1548 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | ||
1549 | COMMENT "Copying WebKit Plugin to the runtime folder." | ||
1550 | ) | ||
1551 | |||
1552 | get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) | ||
1553 | add_custom_command( | ||
1554 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1555 | COMMAND ${CMAKE_COMMAND} | ||
1556 | ARGS | ||
1557 | -E | ||
1558 | copy_if_different | ||
1559 | ${BUILT_GSTREAMER_PLUGIN} | ||
1560 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | ||
1561 | COMMENT "Copying Gstreamer Plugin to the runtime folder." | ||
1562 | ) | ||
1563 | |||
1564 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) | ||
1565 | add_custom_command( | ||
1566 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1567 | COMMAND ${CMAKE_COMMAND} | ||
1568 | ARGS | ||
1569 | -E | ||
1570 | copy_if_different | ||
1571 | ${BUILT_QUICKTIME_PLUGIN} | ||
1572 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | ||
1573 | COMMENT "Copying Quicktime Plugin to the runtime folder." | ||
1574 | ) | ||
1575 | |||
1576 | |||
1577 | |||
1578 | endif (WINDOWS) | ||
1579 | |||
1580 | if (DARWIN) | ||
1581 | # Don't do this here -- it's taken care of by viewer_manifest.py | ||
1582 | # add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1583 | # COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin/ | ||
1584 | # DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib | ||
1585 | # ) | ||
1586 | endif (DARWIN) | ||