diff options
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 14 |
1 files changed, 14 insertions, 0 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 13c972a..e50318e 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -10,7 +10,9 @@ include(DirectX) | |||
10 | include(ELFIO) | 10 | include(ELFIO) |
11 | include(FMOD) | 11 | include(FMOD) |
12 | include(OPENAL) | 12 | include(OPENAL) |
13 | include(HUNSPELL) | ||
13 | include(FindOpenGL) | 14 | include(FindOpenGL) |
15 | include(JsonCpp) | ||
14 | include(LLAddBuildTest) | 16 | include(LLAddBuildTest) |
15 | include(LLAudio) | 17 | include(LLAudio) |
16 | include(LLCharacter) | 18 | include(LLCharacter) |
@@ -44,7 +46,9 @@ endif (WINDOWS) | |||
44 | 46 | ||
45 | include_directories( | 47 | include_directories( |
46 | ${DBUSGLIB_INCLUDE_DIRS} | 48 | ${DBUSGLIB_INCLUDE_DIRS} |
49 | ${HUNSPELL_INCLUDE_DIR} | ||
47 | ${ELFIO_INCLUDE_DIR} | 50 | ${ELFIO_INCLUDE_DIR} |
51 | ${JSONCPP_INCLUDE_DIRS} | ||
48 | ${LLAUDIO_INCLUDE_DIRS} | 52 | ${LLAUDIO_INCLUDE_DIRS} |
49 | ${LLCHARACTER_INCLUDE_DIRS} | 53 | ${LLCHARACTER_INCLUDE_DIRS} |
50 | ${LLCOMMON_INCLUDE_DIRS} | 54 | ${LLCOMMON_INCLUDE_DIRS} |
@@ -65,6 +69,9 @@ include_directories( | |||
65 | ) | 69 | ) |
66 | 70 | ||
67 | set(viewer_SOURCE_FILES | 71 | set(viewer_SOURCE_FILES |
72 | lggautocorrect.cpp | ||
73 | lgghunspell_wrapper.cpp | ||
74 | lggdicdownload.cpp | ||
68 | aoremotectrl.cpp | 75 | aoremotectrl.cpp |
69 | emeraldboobutils.cpp | 76 | emeraldboobutils.cpp |
70 | floaterao.cpp | 77 | floaterao.cpp |
@@ -378,6 +385,7 @@ set(viewer_SOURCE_FILES | |||
378 | lltoolview.cpp | 385 | lltoolview.cpp |
379 | lltracker.cpp | 386 | lltracker.cpp |
380 | lltrans.cpp | 387 | lltrans.cpp |
388 | lltranslate.cpp | ||
381 | lluploaddialog.cpp | 389 | lluploaddialog.cpp |
382 | llurl.cpp | 390 | llurl.cpp |
383 | llurldispatcher.cpp | 391 | llurldispatcher.cpp |
@@ -514,6 +522,9 @@ set(viewer_HEADER_FILES | |||
514 | jcfloater_animation_list.h | 522 | jcfloater_animation_list.h |
515 | jcfloaterareasearch.h | 523 | jcfloaterareasearch.h |
516 | lightshare.h | 524 | lightshare.h |
525 | lggautocorrect.h | ||
526 | lggdicdownload.h | ||
527 | lgghunspell_wrapper.h | ||
517 | llagent.h | 528 | llagent.h |
518 | llagentaccess.h | 529 | llagentaccess.h |
519 | llagentdata.h | 530 | llagentdata.h |
@@ -816,6 +827,7 @@ set(viewer_HEADER_FILES | |||
816 | lltoolview.h | 827 | lltoolview.h |
817 | lltracker.h | 828 | lltracker.h |
818 | lltrans.h | 829 | lltrans.h |
830 | lltranslate.h | ||
819 | lluiconstants.h | 831 | lluiconstants.h |
820 | lluploaddialog.h | 832 | lluploaddialog.h |
821 | llurl.h | 833 | llurl.h |
@@ -1336,12 +1348,14 @@ target_link_libraries(${VIEWER_BINARY_NAME} | |||
1336 | ${FMODWRAPPER_LIBRARY} | 1348 | ${FMODWRAPPER_LIBRARY} |
1337 | ${OPENGL_LIBRARIES} | 1349 | ${OPENGL_LIBRARIES} |
1338 | ${MOZLIB_LIBRARIES} | 1350 | ${MOZLIB_LIBRARIES} |
1351 | ${JSONCPP_LIBRARIES} | ||
1339 | ${SDL_LIBRARY} | 1352 | ${SDL_LIBRARY} |
1340 | ${SMARTHEAP_LIBRARY} | 1353 | ${SMARTHEAP_LIBRARY} |
1341 | ${UI_LIBRARIES} | 1354 | ${UI_LIBRARIES} |
1342 | ${WINDOWS_LIBRARIES} | 1355 | ${WINDOWS_LIBRARIES} |
1343 | ${XMLRPCEPI_LIBRARIES} | 1356 | ${XMLRPCEPI_LIBRARIES} |
1344 | ${ELFIO_LIBRARIES} | 1357 | ${ELFIO_LIBRARIES} |
1358 | ${HUNSPELL_LIBRARY} | ||
1345 | ) | 1359 | ) |
1346 | 1360 | ||
1347 | build_version(viewer) | 1361 | build_version(viewer) |