aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r--linden/indra/newview/CMakeLists.txt25
1 files changed, 12 insertions, 13 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index dedced0..ff11a7f 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -36,7 +36,6 @@ include(GooglePerfTools)
36include(TemplateCheck) 36include(TemplateCheck)
37include(UI) 37include(UI)
38include(UnixInstall) 38include(UnixInstall)
39include(ViewerArtwork)
40include(ViewerMiscLibs) 39include(ViewerMiscLibs)
41 40
42if (WINDOWS) 41if (WINDOWS)
@@ -507,7 +506,7 @@ set(viewer_SOURCE_FILES
507 wlsettingsmanager.cpp 506 wlsettingsmanager.cpp
508 ) 507 )
509 508
510set(VIEWER_BINARY_NAME "imprudence-bin" CACHE STRING 509set(VIEWER_BINARY_NAME "meta-impy-bin" CACHE STRING
511 "The name of the viewer executable to create.") 510 "The name of the viewer executable to create.")
512 511
513if (LINUX) 512if (LINUX)
@@ -1000,8 +999,8 @@ if (DARWIN)
1000 viewer.icns 999 viewer.icns
1001 macview.r 1000 macview.r
1002 gpu_table.txt 1001 gpu_table.txt
1003 Info-Imprudence.plist 1002 Info-meta-impy.plist
1004 Imprudence.nib/ 1003 meta-impy.nib/
1005 # CMake doesn't seem to support Xcode language variants well just yet 1004 # CMake doesn't seem to support Xcode language variants well just yet
1006 English.lproj/InfoPlist.strings 1005 English.lproj/InfoPlist.strings
1007 English.lproj/language.txt 1006 English.lproj/language.txt
@@ -1067,7 +1066,7 @@ if (WINDOWS)
1067 res/arrowdrag.cur 1066 res/arrowdrag.cur
1068 res/circleandline.cur 1067 res/circleandline.cur
1069 res/imp_icon.ico 1068 res/imp_icon.ico
1070 res/imprudence_icon.png 1069 res/meta-impy_icon.png
1071 res/llarrow.cur 1070 res/llarrow.cur
1072 res/llarrowdrag.cur 1071 res/llarrowdrag.cur
1073 res/llarrowdragmulti.cur 1072 res/llarrowdragmulti.cur
@@ -1428,13 +1427,13 @@ set(ARTWORK_DIR ${CMAKE_CURRENT_SOURCE_DIR} CACHE PATH
1428 1427
1429if (LINUX) 1428if (LINUX)
1430 add_custom_command( 1429 add_custom_command(
1431 OUTPUT imprudence-stripped 1430 OUTPUT meta-impy-stripped
1432 COMMAND strip 1431 COMMAND strip
1433 ARGS --strip-debug -o imprudence-stripped ${VIEWER_BINARY_NAME} 1432 ARGS --strip-debug -o meta-impy-stripped ${VIEWER_BINARY_NAME}
1434 DEPENDS imprudence-bin 1433 DEPENDS meta-impy-bin
1435 ) 1434 )
1436 1435
1437 set(product Imprudence-${ARCH}-${viewer_VERSION}) 1436 set(product meta-impy-${ARCH}-${viewer_VERSION})
1438 1437
1439 add_custom_command( 1438 add_custom_command(
1440 OUTPUT ${product}.tar.bz2 1439 OUTPUT ${product}.tar.bz2
@@ -1453,7 +1452,7 @@ if (LINUX)
1453 --build=${CMAKE_CURRENT_BINARY_DIR} 1452 --build=${CMAKE_CURRENT_BINARY_DIR}
1454 --dest=${CMAKE_CURRENT_BINARY_DIR}/packaged 1453 --dest=${CMAKE_CURRENT_BINARY_DIR}/packaged
1455 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched 1454 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched
1456 DEPENDS imprudence-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1455 DEPENDS meta-impy-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1457 ) 1456 )
1458 1457
1459 add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_gstreamer010 media_plugin_webkit) 1458 add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_gstreamer010 media_plugin_webkit)
@@ -1465,16 +1464,16 @@ if (LINUX)
1465endif (LINUX) 1464endif (LINUX)
1466 1465
1467if (DARWIN) 1466if (DARWIN)
1468 set(product "Imprudence") 1467 set(product "meta-impy")
1469 set_target_properties( 1468 set_target_properties(
1470 ${VIEWER_BINARY_NAME} 1469 ${VIEWER_BINARY_NAME}
1471 PROPERTIES 1470 PROPERTIES
1472 OUTPUT_NAME "${product}" 1471 OUTPUT_NAME "${product}"
1473 MACOSX_BUNDLE_INFO_STRING "info string - localize me" 1472 MACOSX_BUNDLE_INFO_STRING "info string - localize me"
1474 MACOSX_BUNDLE_ICON_FILE "viewer.icns" 1473 MACOSX_BUNDLE_ICON_FILE "viewer.icns"
1475 MACOSX_BUNDLE_GUI_IDENTIFIER "Imprudence" 1474 MACOSX_BUNDLE_GUI_IDENTIFIER "meta-impy"
1476 MACOSX_BUNDLE_LONG_VERSION_STRING "ververver" 1475 MACOSX_BUNDLE_LONG_VERSION_STRING "ververver"
1477 MACOSX_BUNDLE_BUNDLE_NAME "Imprudence" 1476 MACOSX_BUNDLE_BUNDLE_NAME "meta-impy"
1478 MACOSX_BUNDLE_SHORT_VERSION_STRING "asdf" 1477 MACOSX_BUNDLE_SHORT_VERSION_STRING "asdf"
1479 MACOSX_BUNDLE_BUNDLE_VERSION "asdf" 1478 MACOSX_BUNDLE_BUNDLE_VERSION "asdf"
1480 MACOSX_BUNDLE_COPYRIGHT "copyright linden lab 2007 - localize me and run me through a legal wringer" 1479 MACOSX_BUNDLE_COPYRIGHT "copyright linden lab 2007 - localize me and run me through a legal wringer"