diff options
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 24 |
1 files changed, 13 insertions, 11 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 4e7f200..9ccaac8 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1373,17 +1373,19 @@ if (WINDOWS) | |||
1373 | 1373 | ||
1374 | # sets the 'working directory' for debugging from visual studio. | 1374 | # sets the 'working directory' for debugging from visual studio. |
1375 | if (NOT UNATTENDED) | 1375 | if (NOT UNATTENDED) |
1376 | add_custom_command( | 1376 | if (NOT self.using_express) |
1377 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD | 1377 | add_custom_command( |
1378 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe | 1378 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD |
1379 | ARGS | 1379 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe |
1380 | --solution | 1380 | ARGS |
1381 | ${CMAKE_BINARY_DIR}/${CMAKE_PROJECT_NAME}.sln | 1381 | --solution |
1382 | --workingdir | 1382 | ${CMAKE_BINARY_DIR}/${CMAKE_PROJECT_NAME}.sln |
1383 | ${VIEWER_BINARY_NAME} | 1383 | --workingdir |
1384 | ${CMAKE_CURRENT_SOURCE_DIR} | 1384 | ${VIEWER_BINARY_NAME} |
1385 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." | 1385 | ${CMAKE_CURRENT_SOURCE_DIR} |
1386 | ) | 1386 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." |
1387 | ) | ||
1388 | endif (NOT self.using_express) | ||
1387 | endif (NOT UNATTENDED) | 1389 | endif (NOT UNATTENDED) |
1388 | 1390 | ||
1389 | add_custom_command( | 1391 | add_custom_command( |