diff options
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 113 |
1 files changed, 100 insertions, 13 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 1a6ad30..fb67423 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -21,8 +21,8 @@ include(LLImage) | |||
21 | include(LLImageJ2COJ) | 21 | include(LLImageJ2COJ) |
22 | include(LLInventory) | 22 | include(LLInventory) |
23 | include(LLMath) | 23 | include(LLMath) |
24 | include(LLMedia) | ||
25 | include(LLMessage) | 24 | include(LLMessage) |
25 | include(LLPlugin) | ||
26 | include(LLPrimitive) | 26 | include(LLPrimitive) |
27 | include(LLRender) | 27 | include(LLRender) |
28 | include(LLUI) | 28 | include(LLUI) |
@@ -31,7 +31,6 @@ include(LLWindow) | |||
31 | include(LLXML) | 31 | include(LLXML) |
32 | include(LScript) | 32 | include(LScript) |
33 | include(Linking) | 33 | include(Linking) |
34 | include(Mozlib) | ||
35 | include(NDOF) | 34 | include(NDOF) |
36 | include(GooglePerfTools) | 35 | include(GooglePerfTools) |
37 | include(TemplateCheck) | 36 | include(TemplateCheck) |
@@ -55,8 +54,8 @@ include_directories( | |||
55 | ${LLIMAGE_INCLUDE_DIRS} | 54 | ${LLIMAGE_INCLUDE_DIRS} |
56 | ${LLINVENTORY_INCLUDE_DIRS} | 55 | ${LLINVENTORY_INCLUDE_DIRS} |
57 | ${LLMATH_INCLUDE_DIRS} | 56 | ${LLMATH_INCLUDE_DIRS} |
58 | ${LLMEDIA_INCLUDE_DIRS} | ||
59 | ${LLMESSAGE_INCLUDE_DIRS} | 57 | ${LLMESSAGE_INCLUDE_DIRS} |
58 | ${LLPLUGIN_INCLUDE_DIRS} | ||
60 | ${LLPRIMITIVE_INCLUDE_DIRS} | 59 | ${LLPRIMITIVE_INCLUDE_DIRS} |
61 | ${LLRENDER_INCLUDE_DIRS} | 60 | ${LLRENDER_INCLUDE_DIRS} |
62 | ${LLUI_INCLUDE_DIRS} | 61 | ${LLUI_INCLUDE_DIRS} |
@@ -65,7 +64,6 @@ include_directories( | |||
65 | ${LLXML_INCLUDE_DIRS} | 64 | ${LLXML_INCLUDE_DIRS} |
66 | ${LSCRIPT_INCLUDE_DIRS} | 65 | ${LSCRIPT_INCLUDE_DIRS} |
67 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile | 66 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile |
68 | ${GSTREAMER_INCLUDE_DIRS} | ||
69 | ) | 67 | ) |
70 | 68 | ||
71 | set(viewer_SOURCE_FILES | 69 | set(viewer_SOURCE_FILES |
@@ -186,9 +184,8 @@ set(viewer_SOURCE_FILES | |||
186 | llfloatergroups.cpp | 184 | llfloatergroups.cpp |
187 | llfloaterhandler.cpp | 185 | llfloaterhandler.cpp |
188 | llfloaterhardwaresettings.cpp | 186 | llfloaterhardwaresettings.cpp |
189 | llfloaterhtml.cpp | ||
190 | llfloaterhtmlcurrency.cpp | 187 | llfloaterhtmlcurrency.cpp |
191 | llfloaterhtmlhelp.cpp | 188 | llfloatermediabrowser.cpp |
192 | llfloaterhtmlsimple.cpp | 189 | llfloaterhtmlsimple.cpp |
193 | llfloaterhud.cpp | 190 | llfloaterhud.cpp |
194 | llfloaterimagepreview.cpp | 191 | llfloaterimagepreview.cpp |
@@ -313,10 +310,12 @@ set(viewer_SOURCE_FILES | |||
313 | llpanelinput.cpp | 310 | llpanelinput.cpp |
314 | llpanelinventory.cpp | 311 | llpanelinventory.cpp |
315 | llpanelland.cpp | 312 | llpanelland.cpp |
313 | llpanellandaudio.cpp | ||
316 | llpanellandmedia.cpp | 314 | llpanellandmedia.cpp |
317 | llpanellandobjects.cpp | 315 | llpanellandobjects.cpp |
318 | llpanellandoptions.cpp | 316 | llpanellandoptions.cpp |
319 | llpanellogin.cpp | 317 | llpanellogin.cpp |
318 | llpanelmediahud.cpp | ||
320 | llpanelmsgs.cpp | 319 | llpanelmsgs.cpp |
321 | llpanelnetwork.cpp | 320 | llpanelnetwork.cpp |
322 | llpanelobject.cpp | 321 | llpanelobject.cpp |
@@ -422,6 +421,8 @@ set(viewer_SOURCE_FILES | |||
422 | llviewerkeyboard.cpp | 421 | llviewerkeyboard.cpp |
423 | llviewerlayer.cpp | 422 | llviewerlayer.cpp |
424 | llviewermedia.cpp | 423 | llviewermedia.cpp |
424 | llviewermediafocus.cpp | ||
425 | llviewermedia_streamingaudio.cpp | ||
425 | llviewermenu.cpp | 426 | llviewermenu.cpp |
426 | llviewermenufile.cpp | 427 | llviewermenufile.cpp |
427 | llviewermessage.cpp | 428 | llviewermessage.cpp |
@@ -468,7 +469,7 @@ set(viewer_SOURCE_FILES | |||
468 | llwearable.cpp | 469 | llwearable.cpp |
469 | llwearablelist.cpp | 470 | llwearablelist.cpp |
470 | llweb.cpp | 471 | llweb.cpp |
471 | llwebbrowserctrl.cpp | 472 | llmediactrl.cpp |
472 | llwindlightremotectrl.cpp | 473 | llwindlightremotectrl.cpp |
473 | llwind.cpp | 474 | llwind.cpp |
474 | llwlanimator.cpp | 475 | llwlanimator.cpp |
@@ -633,9 +634,8 @@ set(viewer_HEADER_FILES | |||
633 | llfloatergroups.h | 634 | llfloatergroups.h |
634 | llfloaterhandler.h | 635 | llfloaterhandler.h |
635 | llfloaterhardwaresettings.h | 636 | llfloaterhardwaresettings.h |
636 | llfloaterhtml.h | ||
637 | llfloaterhtmlcurrency.h | 637 | llfloaterhtmlcurrency.h |
638 | llfloaterhtmlhelp.h | 638 | llfloatermediabrowser.h |
639 | llfloaterhtmlsimple.h | 639 | llfloaterhtmlsimple.h |
640 | llfloaterhud.h | 640 | llfloaterhud.h |
641 | llfloaterimagepreview.h | 641 | llfloaterimagepreview.h |
@@ -759,11 +759,13 @@ set(viewer_HEADER_FILES | |||
759 | llpanelinput.h | 759 | llpanelinput.h |
760 | llpanelinventory.h | 760 | llpanelinventory.h |
761 | llpanelland.h | 761 | llpanelland.h |
762 | llpanellandaudio.h | ||
762 | llpanellandmedia.h | 763 | llpanellandmedia.h |
763 | llpanellandobjects.h | 764 | llpanellandobjects.h |
764 | llpanellandoptions.h | 765 | llpanellandoptions.h |
765 | llpanelLCD.h | 766 | llpanelLCD.h |
766 | llpanellogin.h | 767 | llpanellogin.h |
768 | llpanelmediahud.h | ||
767 | llpanelmsgs.h | 769 | llpanelmsgs.h |
768 | llpanelnetwork.h | 770 | llpanelnetwork.h |
769 | llpanelobject.h | 771 | llpanelobject.h |
@@ -870,6 +872,8 @@ set(viewer_HEADER_FILES | |||
870 | llviewerkeyboard.h | 872 | llviewerkeyboard.h |
871 | llviewerlayer.h | 873 | llviewerlayer.h |
872 | llviewermedia.h | 874 | llviewermedia.h |
875 | llviewermediaobserver.h | ||
876 | llviewermediafocus.h | ||
873 | llviewermenu.h | 877 | llviewermenu.h |
874 | llviewermenufile.h | 878 | llviewermenufile.h |
875 | llviewermessage.h | 879 | llviewermessage.h |
@@ -918,7 +922,7 @@ set(viewer_HEADER_FILES | |||
918 | llwearable.h | 922 | llwearable.h |
919 | llwearablelist.h | 923 | llwearablelist.h |
920 | llweb.h | 924 | llweb.h |
921 | llwebbrowserctrl.h | 925 | llmediactrl.h |
922 | llwind.h | 926 | llwind.h |
923 | llwindebug.h | 927 | llwindebug.h |
924 | llwindlightremotectrl.h | 928 | llwindlightremotectrl.h |
@@ -1122,6 +1126,7 @@ if (WINDOWS) | |||
1122 | if (INTEL_MEMOPS_LIBRARY) | 1126 | if (INTEL_MEMOPS_LIBRARY) |
1123 | list(APPEND viewer_LIBRARIES ${INTEL_MEMOPS_LIBRARY}) | 1127 | list(APPEND viewer_LIBRARIES ${INTEL_MEMOPS_LIBRARY}) |
1124 | endif (INTEL_MEMOPS_LIBRARY) | 1128 | endif (INTEL_MEMOPS_LIBRARY) |
1129 | use_prebuilt_binary(dbghelp) | ||
1125 | endif (WINDOWS) | 1130 | endif (WINDOWS) |
1126 | 1131 | ||
1127 | # Add the xui files. This is handy for searching for xui elements | 1132 | # Add the xui files. This is handy for searching for xui elements |
@@ -1344,6 +1349,9 @@ if (WINDOWS) | |||
1344 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat | 1349 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat |
1345 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1350 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1346 | ) | 1351 | ) |
1352 | |||
1353 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | ||
1354 | |||
1347 | if (PACKAGE) | 1355 | if (PACKAGE) |
1348 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) | 1356 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) |
1349 | add_dependencies(package windows-updater windows-crash-logger) | 1357 | add_dependencies(package windows-updater windows-crash-logger) |
@@ -1356,8 +1364,8 @@ target_link_libraries(${VIEWER_BINARY_NAME} | |||
1356 | ${LLIMAGE_LIBRARIES} | 1364 | ${LLIMAGE_LIBRARIES} |
1357 | ${LLIMAGEJ2COJ_LIBRARIES} | 1365 | ${LLIMAGEJ2COJ_LIBRARIES} |
1358 | ${LLINVENTORY_LIBRARIES} | 1366 | ${LLINVENTORY_LIBRARIES} |
1359 | ${LLMEDIA_LIBRARIES} | ||
1360 | ${LLMESSAGE_LIBRARIES} | 1367 | ${LLMESSAGE_LIBRARIES} |
1368 | ${LLPLUGIN_LIBRARIES} | ||
1361 | ${LLPRIMITIVE_LIBRARIES} | 1369 | ${LLPRIMITIVE_LIBRARIES} |
1362 | ${LLRENDER_LIBRARIES} | 1370 | ${LLRENDER_LIBRARIES} |
1363 | ${FREETYPE_LIBRARIES} | 1371 | ${FREETYPE_LIBRARIES} |
@@ -1379,7 +1387,6 @@ target_link_libraries(${VIEWER_BINARY_NAME} | |||
1379 | ${OPENGL_LIBRARIES} | 1387 | ${OPENGL_LIBRARIES} |
1380 | ${FMODWRAPPER_LIBRARY} | 1388 | ${FMODWRAPPER_LIBRARY} |
1381 | ${OPENGL_LIBRARIES} | 1389 | ${OPENGL_LIBRARIES} |
1382 | ${MOZLIB_LIBRARIES} | ||
1383 | ${JSONCPP_LIBRARIES} | 1390 | ${JSONCPP_LIBRARIES} |
1384 | ${SDL_LIBRARY} | 1391 | ${SDL_LIBRARY} |
1385 | ${SMARTHEAP_LIBRARY} | 1392 | ${SMARTHEAP_LIBRARY} |
@@ -1424,6 +1431,8 @@ if (LINUX) | |||
1424 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched | 1431 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched |
1425 | DEPENDS imprudence-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1432 | DEPENDS imprudence-stripped ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1426 | ) | 1433 | ) |
1434 | |||
1435 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_gstreamer010 media_plugin_webkit) | ||
1427 | 1436 | ||
1428 | if (NOT INSTALL) | 1437 | if (NOT INSTALL) |
1429 | add_custom_target(package ALL DEPENDS ${product}.tar.bz2) | 1438 | add_custom_target(package ALL DEPENDS ${product}.tar.bz2) |
@@ -1461,6 +1470,8 @@ if (DARWIN) | |||
1461 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app | 1470 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app |
1462 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1471 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1463 | ) | 1472 | ) |
1473 | |||
1474 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | ||
1464 | 1475 | ||
1465 | if (PACKAGE) | 1476 | if (PACKAGE) |
1466 | add_custom_target(package ALL DEPENDS ${VIEWER_BINARY_NAME}) | 1477 | add_custom_target(package ALL DEPENDS ${VIEWER_BINARY_NAME}) |
@@ -1481,11 +1492,12 @@ if (DARWIN) | |||
1481 | --build=${CMAKE_CURRENT_BINARY_DIR} | 1492 | --build=${CMAKE_CURRENT_BINARY_DIR} |
1482 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app | 1493 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app |
1483 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched | 1494 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched |
1495 | |||
1484 | DEPENDS | 1496 | DEPENDS |
1485 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1497 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1486 | ) | 1498 | ) |
1487 | 1499 | ||
1488 | 1500 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | |
1489 | add_custom_command( | 1501 | add_custom_command( |
1490 | TARGET package POST_BUILD | 1502 | TARGET package POST_BUILD |
1491 | COMMAND ${PYTHON_EXECUTABLE} | 1503 | COMMAND ${PYTHON_EXECUTABLE} |
@@ -1512,3 +1524,78 @@ if (INSTALL) | |||
1512 | endif (INSTALL) | 1524 | endif (INSTALL) |
1513 | 1525 | ||
1514 | ADD_VIEWER_BUILD_TEST(llagentaccess viewer) | 1526 | ADD_VIEWER_BUILD_TEST(llagentaccess viewer) |
1527 | |||
1528 | # Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py | ||
1529 | if (WINDOWS) | ||
1530 | |||
1531 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) | ||
1532 | add_custom_command( | ||
1533 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1534 | COMMAND ${CMAKE_COMMAND} | ||
1535 | ARGS | ||
1536 | -E | ||
1537 | copy_if_different | ||
1538 | ${BUILT_SLPLUGIN} | ||
1539 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} | ||
1540 | COMMENT "Copying SLPlugin executable to the runtime folder." | ||
1541 | ) | ||
1542 | |||
1543 | get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) | ||
1544 | add_custom_command( | ||
1545 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1546 | COMMAND ${CMAKE_COMMAND} | ||
1547 | ARGS | ||
1548 | -E | ||
1549 | copy_if_different | ||
1550 | ${BUILT_WEBKIT_PLUGIN} | ||
1551 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | ||
1552 | COMMENT "Copying WebKit Plugin to the runtime folder." | ||
1553 | ) | ||
1554 | |||
1555 | #get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) | ||
1556 | # add_custom_command( | ||
1557 | # TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1558 | # COMMAND ${CMAKE_COMMAND} | ||
1559 | # ARGS | ||
1560 | # -E | ||
1561 | # copy_if_different | ||
1562 | # ${BUILT_GSTREAMER_PLUGIN} | ||
1563 | # ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | ||
1564 | # COMMENT "Copying Gstreamer Plugin to the runtime folder." | ||
1565 | # ) | ||
1566 | |||
1567 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) | ||
1568 | add_custom_command( | ||
1569 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1570 | COMMAND ${CMAKE_COMMAND} | ||
1571 | ARGS | ||
1572 | -E | ||
1573 | copy_if_different | ||
1574 | ${BUILT_QUICKTIME_PLUGIN} | ||
1575 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | ||
1576 | COMMENT "Copying Quicktime Plugin to the runtime folder." | ||
1577 | ) | ||
1578 | |||
1579 | # Copying the mime_types.xml file to app_settings | ||
1580 | set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") | ||
1581 | set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings") | ||
1582 | add_custom_command( | ||
1583 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1584 | COMMAND ${CMAKE_COMMAND} | ||
1585 | ARGS | ||
1586 | -E | ||
1587 | copy_if_different | ||
1588 | ${mime_types_source}/mime_types_windows.xml | ||
1589 | ${mime_types_dest}/mime_types_windows.xml | ||
1590 | COMMENT "Copying mime_types_windows.xml to the runtime app_settings folder." | ||
1591 | ) | ||
1592 | |||
1593 | endif (WINDOWS) | ||
1594 | |||
1595 | if (DARWIN) | ||
1596 | # Don't do this here -- it's taken care of by viewer_manifest.py | ||
1597 | # add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1598 | # COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin/ | ||
1599 | # DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib | ||
1600 | # ) | ||
1601 | endif (DARWIN) | ||