diff options
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 22 |
1 files changed, 20 insertions, 2 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index a68b745..aaaf74f 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -45,10 +45,13 @@ endif (WINDOWS) | |||
45 | # [$PLOTR$] | 45 | # [$PLOTR$] |
46 | include(libgcrypt) | 46 | include(libgcrypt) |
47 | include(libgpg-error) | 47 | include(libgpg-error) |
48 | include(libotr) | ||
49 | 48 | ||
50 | if (DARWIN OR LINUX) | 49 | if (DARWIN OR LINUX) |
50 | if (STATIC_LIBOTR_ETC) | ||
51 | include(libotr) # to build libotr from source and statically link in libgcrypt and libgpg-error | ||
52 | else (STATIC_LIBOTR_ETC) | ||
51 | include(libotrb) | 53 | include(libotrb) |
54 | endif (STATIC_LIBOTR_ETC) | ||
52 | endif (DARWIN OR LINUX) | 55 | endif (DARWIN OR LINUX) |
53 | # [/$PLOTR$] | 56 | # [/$PLOTR$] |
54 | 57 | ||
@@ -1061,9 +1064,19 @@ if (LINUX) | |||
1061 | LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) | 1064 | LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) |
1062 | SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed") | 1065 | SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed") |
1063 | 1066 | ||
1067 | # [$PLOTR$] | ||
1068 | if (STATIC_LIBOTR_ETC) # defined in .../linden/indra/CMakeLists.txt | ||
1064 | set(viewer_LIBRARIES | 1069 | set(viewer_LIBRARIES |
1065 | Xinerama | 1070 | Xinerama |
1071 | gpg-error | ||
1072 | gcrypt # to build libotr from source and statically link in libgcrypt and libgpg-error | ||
1066 | ) | 1073 | ) |
1074 | else (STATIC_LIBOTR_ETC) # below for dynamically linked, unmodified libotr | ||
1075 | set(viewer_LIBRARIES | ||
1076 | Xinerama | ||
1077 | ) | ||
1078 | endif (STATIC_LIBOTR_ETC) | ||
1079 | # [/$PLOTR$] | ||
1067 | endif (LINUX) | 1080 | endif (LINUX) |
1068 | 1081 | ||
1069 | if (WINDOWS) | 1082 | if (WINDOWS) |
@@ -1426,8 +1439,13 @@ if (WINDOWS) | |||
1426 | ${LIBOTR_LIBRARIES} | 1439 | ${LIBOTR_LIBRARIES} |
1427 | ) | 1440 | ) |
1428 | else (WINDOWS) | 1441 | else (WINDOWS) |
1442 | if (STATIC_LIBOTR_ETC) | ||
1443 | set(otr_link_libs ${LIBOTR_LIBRARIES} | ||
1444 | ) # statically linked libotr, built from source | ||
1445 | else (STATIC_LIBOTR_ETC) | ||
1429 | set(otr_link_libs ${OTR_LIBRARY} | 1446 | set(otr_link_libs ${OTR_LIBRARY} |
1430 | ) | 1447 | ) |
1448 | endif (STATIC_LIBOTR_ETC) | ||
1431 | endif (WINDOWS) | 1449 | endif (WINDOWS) |
1432 | # [/$PLOTR$] | 1450 | # [/$PLOTR$] |
1433 | 1451 | ||