diff options
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 14 |
1 files changed, 13 insertions, 1 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 77de749..dff759e 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1541,11 +1541,23 @@ if (INSTALL) | |||
1541 | include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake) | 1541 | include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake) |
1542 | endif (INSTALL) | 1542 | endif (INSTALL) |
1543 | 1543 | ||
1544 | ADD_VIEWER_BUILD_TEST(llagentaccess viewer) | 1544 | #ADD_VIEWER_BUILD_TEST(llagentaccess viewer) |
1545 | 1545 | ||
1546 | # Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py | 1546 | # Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py |
1547 | if (WINDOWS) | 1547 | if (WINDOWS) |
1548 | 1548 | ||
1549 | get_target_property(BUILT_LLCOMMON llcommon LOCATION) | ||
1550 | add_custom_command( | ||
1551 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1552 | COMMAND ${CMAKE_COMMAND} | ||
1553 | ARGS | ||
1554 | -E | ||
1555 | copy_if_different | ||
1556 | ${BUILT_LLCOMMON} | ||
1557 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} | ||
1558 | COMMENT "Copying llcommon.dll to the runtime folder." | ||
1559 | ) | ||
1560 | |||
1549 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) | 1561 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) |
1550 | add_custom_command( | 1562 | add_custom_command( |
1551 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1563 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD |