aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r--linden/indra/newview/CMakeLists.txt35
1 files changed, 34 insertions, 1 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 954ce7d..0e2ddf2 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -64,6 +64,11 @@ include_directories(
64 ) 64 )
65 65
66set(viewer_SOURCE_FILES 66set(viewer_SOURCE_FILES
67 floaterlogin.cpp
68 hippoGridManager.cpp
69 hippoLimits.cpp
70 hippoRestRequest.cpp
71 jcfloater_animation_list.cpp
67 llagent.cpp 72 llagent.cpp
68 llagentaccess.cpp 73 llagentaccess.cpp
69 llagentdata.cpp 74 llagentdata.cpp
@@ -125,6 +130,7 @@ set(viewer_SOURCE_FILES
125 llfloaterabout.cpp 130 llfloaterabout.cpp
126 llfloateractivespeakers.cpp 131 llfloateractivespeakers.cpp
127 llfloateranimpreview.cpp 132 llfloateranimpreview.cpp
133 llfloaterassetbrowser.cpp
128 llfloaterauction.cpp 134 llfloaterauction.cpp
129 llfloateravatarinfo.cpp 135 llfloateravatarinfo.cpp
130 llfloateravatarpicker.cpp 136 llfloateravatarpicker.cpp
@@ -433,6 +439,7 @@ set(viewer_SOURCE_FILES
433 llwearablelist.cpp 439 llwearablelist.cpp
434 llweb.cpp 440 llweb.cpp
435 llwebbrowserctrl.cpp 441 llwebbrowserctrl.cpp
442 llwindlightremotectrl.cpp
436 llwind.cpp 443 llwind.cpp
437 llwlanimator.cpp 444 llwlanimator.cpp
438 llwldaycycle.cpp 445 llwldaycycle.cpp
@@ -444,6 +451,12 @@ set(viewer_SOURCE_FILES
444 llxmlrpctransaction.cpp 451 llxmlrpctransaction.cpp
445 noise.cpp 452 noise.cpp
446 pipeline.cpp 453 pipeline.cpp
454 primbackup.cpp
455 rlvhandler.cpp
456 rlvhelper.cpp
457 rlvmultistringsearch.cpp
458 rlvextensions.cpp
459 rlvfloaterbehaviour.cpp
447 ) 460 )
448 461
449set(VIEWER_BINARY_NAME "imprudence-bin" CACHE STRING 462set(VIEWER_BINARY_NAME "imprudence-bin" CACHE STRING
@@ -466,7 +479,11 @@ endif (LINUX)
466set(viewer_HEADER_FILES 479set(viewer_HEADER_FILES
467 CMakeLists.txt 480 CMakeLists.txt
468 ViewerInstall.cmake 481 ViewerInstall.cmake
469 482 floaterlogin.h
483 hippoGridManager.h
484 hippoLimits.h
485 hippoRestRequest.h
486 jcfloater_animation_list.h
470 llagent.h 487 llagent.h
471 llagentaccess.h 488 llagentaccess.h
472 llagentdata.h 489 llagentdata.h
@@ -530,6 +547,7 @@ set(viewer_HEADER_FILES
530 llfloaterabout.h 547 llfloaterabout.h
531 llfloateractivespeakers.h 548 llfloateractivespeakers.h
532 llfloateranimpreview.h 549 llfloateranimpreview.h
550 llfloaterassetbrowser.h
533 llfloaterauction.h 551 llfloaterauction.h
534 llfloateravatarinfo.h 552 llfloateravatarinfo.h
535 llfloateravatarpicker.h 553 llfloateravatarpicker.h
@@ -843,6 +861,7 @@ set(viewer_HEADER_FILES
843 llwebbrowserctrl.h 861 llwebbrowserctrl.h
844 llwind.h 862 llwind.h
845 llwindebug.h 863 llwindebug.h
864 llwindlightremotectrl.h
846 llwlanimator.h 865 llwlanimator.h
847 llwldaycycle.h 866 llwldaycycle.h
848 llwlparammanager.h 867 llwlparammanager.h
@@ -854,9 +873,17 @@ set(viewer_HEADER_FILES
854 macmain.h 873 macmain.h
855 noise.h 874 noise.h
856 pipeline.h 875 pipeline.h
876 primbackup.h
857 randgauss.h 877 randgauss.h
858 VertexCache.h 878 VertexCache.h
859 VorbisFramework.h 879 VorbisFramework.h
880 rlvdefines.h
881 rlvevent.h
882 rlvhandler.h
883 rlvhelper.h
884 rlvmultistringsearch.h
885 rlvextensions.h
886 rlvfloaterbehaviour.h
860 ) 887 )
861 888
862source_group("CMake Rules" FILES ViewerInstall.cmake) 889source_group("CMake Rules" FILES ViewerInstall.cmake)
@@ -1042,7 +1069,9 @@ set(viewer_XUI_FILES
1042 skins/default/xui/en-us/floater_about_land.xml 1069 skins/default/xui/en-us/floater_about_land.xml
1043 skins/default/xui/en-us/floater_about.xml 1070 skins/default/xui/en-us/floater_about.xml
1044 skins/default/xui/en-us/floater_active_speakers.xml 1071 skins/default/xui/en-us/floater_active_speakers.xml
1072 skins/default/xui/en-us/floater_animation_list.xml
1045 skins/default/xui/en-us/floater_animation_preview.xml 1073 skins/default/xui/en-us/floater_animation_preview.xml
1074 skins/default/xui/en-us/floater_asset_browser.xml
1046 skins/default/xui/en-us/floater_auction.xml 1075 skins/default/xui/en-us/floater_auction.xml
1047 skins/default/xui/en-us/floater_audio_volume.xml 1076 skins/default/xui/en-us/floater_audio_volume.xml
1048 skins/default/xui/en-us/floater_avatar_picker.xml 1077 skins/default/xui/en-us/floater_avatar_picker.xml
@@ -1224,6 +1253,9 @@ set(viewer_XUI_FILES
1224 skins/default/xui/en-us/panel_voice_options.xml 1253 skins/default/xui/en-us/panel_voice_options.xml
1225 skins/default/xui/en-us/panel_voice_remote_expanded.xml 1254 skins/default/xui/en-us/panel_voice_remote_expanded.xml
1226 skins/default/xui/en-us/panel_voice_remote.xml 1255 skins/default/xui/en-us/panel_voice_remote.xml
1256 skins/default/xui/en-us/panel_windlight_controls.xml
1257 skins/default/xui/en-us/panel_windlight_remote.xml
1258 skins/default/xui/en-us/panel_windlight_remote_expanded.xml
1227 skins/default/xui/en-us/role_actions.xml 1259 skins/default/xui/en-us/role_actions.xml
1228 skins/default/xui/en-us/strings.xml 1260 skins/default/xui/en-us/strings.xml
1229 skins/default/xui/en-us/teleport_strings.xml 1261 skins/default/xui/en-us/teleport_strings.xml
@@ -1415,6 +1447,7 @@ if (WINDOWS)
1415endif (WINDOWS) 1447endif (WINDOWS)
1416 1448
1417target_link_libraries(${VIEWER_BINARY_NAME} 1449target_link_libraries(${VIEWER_BINARY_NAME}
1450 ${NDOF_LIBRARY}
1418 ${LLAUDIO_LIBRARIES} 1451 ${LLAUDIO_LIBRARIES}
1419 ${LLCHARACTER_LIBRARIES} 1452 ${LLCHARACTER_LIBRARIES}
1420 ${LLIMAGE_LIBRARIES} 1453 ${LLIMAGE_LIBRARIES}