diff options
Diffstat (limited to '')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 67 |
1 files changed, 34 insertions, 33 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index ecbeb9b..7496546 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -126,7 +126,7 @@ set(viewer_SOURCE_FILES | |||
126 | jcfloaterareasearch.cpp | 126 | jcfloaterareasearch.cpp |
127 | kokuastreamingaudio.cpp | 127 | kokuastreamingaudio.cpp |
128 | kowopenregionsettings.cpp | 128 | kowopenregionsettings.cpp |
129 | lightshare.cpp | 129 | llettherebelight.cpp |
130 | llagent.cpp | 130 | llagent.cpp |
131 | llagentaccess.cpp | 131 | llagentaccess.cpp |
132 | llagentdata.cpp | 132 | llagentdata.cpp |
@@ -308,6 +308,7 @@ set(viewer_SOURCE_FILES | |||
308 | llmaniprotate.cpp | 308 | llmaniprotate.cpp |
309 | llmanipscale.cpp | 309 | llmanipscale.cpp |
310 | llmaniptranslate.cpp | 310 | llmaniptranslate.cpp |
311 | llmediadataclient.cpp | ||
311 | llmapresponders.cpp | 312 | llmapresponders.cpp |
312 | llmediaremotectrl.cpp | 313 | llmediaremotectrl.cpp |
313 | llmemoryview.cpp | 314 | llmemoryview.cpp |
@@ -537,16 +538,15 @@ set(viewer_SOURCE_FILES | |||
537 | slfloatermediafilter.cpp | 538 | slfloatermediafilter.cpp |
538 | viewerinfo.cpp | 539 | viewerinfo.cpp |
539 | viewertime.cpp | 540 | viewertime.cpp |
540 | windlightsettingsupdate.cpp | ||
541 | wlfloatermanager.cpp | 541 | wlfloatermanager.cpp |
542 | wlfloaterwindlightsend.cpp | 542 | wlfloaterwindlightsend.cpp |
543 | wlretrievesettings.cpp | 543 | wlretrievesettings.cpp |
544 | wlsettingsmanager.cpp | ||
545 | # [/$PLOTR$] | 544 | # [/$PLOTR$] |
546 | otr_wrapper.cpp | 545 | otr_wrapper.cpp |
547 | otr_floater_smp_dialog.cpp | 546 | otr_floater_smp_dialog.cpp |
548 | otr_floater_smp_progress.cpp | 547 | otr_floater_smp_progress.cpp |
549 | # [/$PLOTR$] | 548 | # [/$PLOTR$] |
549 | rcmoapradar.cpp | ||
550 | ) | 550 | ) |
551 | 551 | ||
552 | set(VIEWER_BINARY_NAME "meta-impy-bin" CACHE STRING | 552 | set(VIEWER_BINARY_NAME "meta-impy-bin" CACHE STRING |
@@ -570,7 +570,7 @@ set(viewer_HEADER_FILES | |||
570 | CMakeLists.txt | 570 | CMakeLists.txt |
571 | ViewerInstall.cmake | 571 | ViewerInstall.cmake |
572 | aoremotectrl.h | 572 | aoremotectrl.h |
573 | chatbar_as_cmdline.h | 573 | chatbar_as_cmdline.h |
574 | emeraldboobutils.h | 574 | emeraldboobutils.h |
575 | floaterao.h | 575 | floaterao.h |
576 | floaterbusy.h | 576 | floaterbusy.h |
@@ -590,11 +590,11 @@ set(viewer_HEADER_FILES | |||
590 | jcfloater_animation_list.h | 590 | jcfloater_animation_list.h |
591 | jcfloaterareasearch.h | 591 | jcfloaterareasearch.h |
592 | kokuastreamingaudio.h | 592 | kokuastreamingaudio.h |
593 | lightshare.h | 593 | llettherebelight.h |
594 | lggautocorrectfloater.h | 594 | lggautocorrectfloater.h |
595 | lggautocorrect.h | 595 | lggautocorrect.h |
596 | lggdicdownload.h | 596 | lggdicdownload.h |
597 | lgghunspell_wrapper.h | 597 | lgghunspell_wrapper.h |
598 | llagent.h | 598 | llagent.h |
599 | llagentaccess.h | 599 | llagentaccess.h |
600 | llagentdata.h | 600 | llagentdata.h |
@@ -777,6 +777,7 @@ set(viewer_HEADER_FILES | |||
777 | llmaniprotate.h | 777 | llmaniprotate.h |
778 | llmanipscale.h | 778 | llmanipscale.h |
779 | llmaniptranslate.h | 779 | llmaniptranslate.h |
780 | llmediadataclient.h | ||
780 | llmapresponders.h | 781 | llmapresponders.h |
781 | llmediaremotectrl.h | 782 | llmediaremotectrl.h |
782 | llmemoryview.h | 783 | llmemoryview.h |
@@ -1020,12 +1021,12 @@ set(viewer_HEADER_FILES | |||
1020 | wlfloatermanager.h | 1021 | wlfloatermanager.h |
1021 | wlfloaterwindlightsend.h | 1022 | wlfloaterwindlightsend.h |
1022 | wlretrievesettings.h | 1023 | wlretrievesettings.h |
1023 | wlsettingsmanager.h | ||
1024 | # [$PLOTR$] | 1024 | # [$PLOTR$] |
1025 | otr_wrapper.h | 1025 | otr_wrapper.h |
1026 | otr_floater_smp_dialog.h | 1026 | otr_floater_smp_dialog.h |
1027 | otr_floater_smp_progress.h | 1027 | otr_floater_smp_progress.h |
1028 | # [/$PLOTR$] | 1028 | # [/$PLOTR$] |
1029 | rcmoapradar.h | ||
1029 | ) | 1030 | ) |
1030 | 1031 | ||
1031 | source_group("CMake Rules" FILES ViewerInstall.cmake) | 1032 | source_group("CMake Rules" FILES ViewerInstall.cmake) |
@@ -1373,7 +1374,7 @@ if (WINDOWS) | |||
1373 | 1374 | ||
1374 | # sets the 'working directory' for debugging from visual studio. | 1375 | # sets the 'working directory' for debugging from visual studio. |
1375 | if (NOT UNATTENDED) | 1376 | if (NOT UNATTENDED) |
1376 | if (NOT self.using_express) | 1377 | if (USE_VSTOOL) |
1377 | add_custom_command( | 1378 | add_custom_command( |
1378 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD | 1379 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD |
1379 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe | 1380 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe |
@@ -1385,7 +1386,7 @@ if (WINDOWS) | |||
1385 | ${CMAKE_CURRENT_SOURCE_DIR} | 1386 | ${CMAKE_CURRENT_SOURCE_DIR} |
1386 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." | 1387 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." |
1387 | ) | 1388 | ) |
1388 | endif (NOT self.using_express) | 1389 | endif (USE_VSTOOL) |
1389 | endif (NOT UNATTENDED) | 1390 | endif (NOT UNATTENDED) |
1390 | 1391 | ||
1391 | add_custom_command( | 1392 | add_custom_command( |
@@ -1395,7 +1396,7 @@ if (WINDOWS) | |||
1395 | -E | 1396 | -E |
1396 | copy_if_different | 1397 | copy_if_different |
1397 | ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg | 1398 | ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg |
1398 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message_template.msg | 1399 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message_template.msg |
1399 | COMMENT "Copying message_template.msg to the runtime folder." | 1400 | COMMENT "Copying message_template.msg to the runtime folder." |
1400 | ) | 1401 | ) |
1401 | 1402 | ||
@@ -1406,7 +1407,7 @@ if (WINDOWS) | |||
1406 | -E | 1407 | -E |
1407 | copy_if_different | 1408 | copy_if_different |
1408 | ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml | 1409 | ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml |
1409 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message.xml | 1410 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message.xml |
1410 | COMMENT "Copying message.xml to the runtime folder." | 1411 | COMMENT "Copying message.xml to the runtime folder." |
1411 | ) | 1412 | ) |
1412 | 1413 | ||
@@ -1417,11 +1418,11 @@ if (WINDOWS) | |||
1417 | endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) | 1418 | endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) |
1418 | 1419 | ||
1419 | add_custom_command( | 1420 | add_custom_command( |
1420 | OUTPUT ${CMAKE_CFG_INTDIR}/touched.bat | 1421 | OUTPUT ${VIEWER_CFG_INTDIR}/touched.bat |
1421 | COMMAND ${PYTHON_EXECUTABLE} | 1422 | COMMAND ${PYTHON_EXECUTABLE} |
1422 | ARGS | 1423 | ARGS |
1423 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1424 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1424 | --configuration=${CMAKE_CFG_INTDIR} | 1425 | --configuration=${VIEWER_CFG_INTDIR} |
1425 | --channel=${VIEWER_CHANNEL} | 1426 | --channel=${VIEWER_CHANNEL} |
1426 | --login_channel=${VIEWER_LOGIN_CHANNEL} | 1427 | --login_channel=${VIEWER_LOGIN_CHANNEL} |
1427 | --standalone=${STANDALONE} | 1428 | --standalone=${STANDALONE} |
@@ -1430,15 +1431,15 @@ if (WINDOWS) | |||
1430 | --source=${CMAKE_CURRENT_SOURCE_DIR} | 1431 | --source=${CMAKE_CURRENT_SOURCE_DIR} |
1431 | --artwork=${ARTWORK_DIR} | 1432 | --artwork=${ARTWORK_DIR} |
1432 | --build=${CMAKE_CURRENT_BINARY_DIR} | 1433 | --build=${CMAKE_CURRENT_BINARY_DIR} |
1433 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/package | 1434 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/package |
1434 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat | 1435 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/touched.bat |
1435 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1436 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1436 | ) | 1437 | ) |
1437 | 1438 | ||
1438 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | 1439 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) |
1439 | 1440 | ||
1440 | if (PACKAGE) | 1441 | if (PACKAGE) |
1441 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) | 1442 | add_custom_target(package ALL DEPENDS ${VIEWER_CFG_INTDIR}/touched.bat) |
1442 | add_dependencies(package windows-updater windows-crash-logger) | 1443 | add_dependencies(package windows-updater windows-crash-logger) |
1443 | endif (PACKAGE) | 1444 | endif (PACKAGE) |
1444 | endif (WINDOWS) | 1445 | endif (WINDOWS) |
@@ -1590,8 +1591,8 @@ if (DARWIN) | |||
1590 | --artwork=${ARTWORK_DIR} | 1591 | --artwork=${ARTWORK_DIR} |
1591 | --build=${CMAKE_CURRENT_BINARY_DIR} | 1592 | --build=${CMAKE_CURRENT_BINARY_DIR} |
1592 | --buildtype=${CMAKE_BUILD_TYPE} | 1593 | --buildtype=${CMAKE_BUILD_TYPE} |
1593 | --configuration=${CMAKE_CFG_INTDIR} | 1594 | --configuration=${VIEWER_CFG_INTDIR} |
1594 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app | 1595 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/${product}.app |
1595 | --grid=${GRID} | 1596 | --grid=${GRID} |
1596 | --source=${CMAKE_CURRENT_SOURCE_DIR} | 1597 | --source=${CMAKE_CURRENT_SOURCE_DIR} |
1597 | --standalone=${STANDALONE} | 1598 | --standalone=${STANDALONE} |
@@ -1622,8 +1623,8 @@ if (WINDOWS) | |||
1622 | -E | 1623 | -E |
1623 | copy_if_different | 1624 | copy_if_different |
1624 | ${BUILT_LLCOMMON} | 1625 | ${BUILT_LLCOMMON} |
1625 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} | 1626 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR} |
1626 | COMMENT "Copying llcommon.dll to the runtime folder." | 1627 | COMMENT "Copying llcommon.dll to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}." |
1627 | ) | 1628 | ) |
1628 | 1629 | ||
1629 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) | 1630 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) |
@@ -1634,8 +1635,8 @@ if (WINDOWS) | |||
1634 | -E | 1635 | -E |
1635 | copy_if_different | 1636 | copy_if_different |
1636 | ${BUILT_SLPLUGIN} | 1637 | ${BUILT_SLPLUGIN} |
1637 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} | 1638 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR} |
1638 | COMMENT "Copying SLPlugin executable to the runtime folder." | 1639 | COMMENT "Copying SLPlugin executable to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}." |
1639 | ) | 1640 | ) |
1640 | 1641 | ||
1641 | get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) | 1642 | get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) |
@@ -1646,8 +1647,8 @@ if (WINDOWS) | |||
1646 | -E | 1647 | -E |
1647 | copy_if_different | 1648 | copy_if_different |
1648 | ${BUILT_WEBKIT_PLUGIN} | 1649 | ${BUILT_WEBKIT_PLUGIN} |
1649 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1650 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin |
1650 | COMMENT "Copying WebKit Plugin to the runtime folder." | 1651 | COMMENT "Copying WebKit Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin." |
1651 | ) | 1652 | ) |
1652 | 1653 | ||
1653 | get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) | 1654 | get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) |
@@ -1658,8 +1659,8 @@ if (WINDOWS) | |||
1658 | -E | 1659 | -E |
1659 | copy_if_different | 1660 | copy_if_different |
1660 | ${BUILT_GSTREAMER_PLUGIN} | 1661 | ${BUILT_GSTREAMER_PLUGIN} |
1661 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1662 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin |
1662 | COMMENT "Copying Gstreamer Plugin to the runtime folder." | 1663 | COMMENT "Copying Gstreamer Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin." |
1663 | ) | 1664 | ) |
1664 | 1665 | ||
1665 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) | 1666 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) |
@@ -1670,13 +1671,13 @@ if (WINDOWS) | |||
1670 | -E | 1671 | -E |
1671 | copy_if_different | 1672 | copy_if_different |
1672 | ${BUILT_QUICKTIME_PLUGIN} | 1673 | ${BUILT_QUICKTIME_PLUGIN} |
1673 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1674 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin |
1674 | COMMENT "Copying Quicktime Plugin to the runtime folder." | 1675 | COMMENT "Copying Quicktime Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin." |
1675 | ) | 1676 | ) |
1676 | 1677 | ||
1677 | # Copying the mime_types.xml file to app_settings | 1678 | # Copying the mime_types.xml file to app_settings |
1678 | set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") | 1679 | set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") |
1679 | set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings") | 1680 | set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings") |
1680 | add_custom_command( | 1681 | add_custom_command( |
1681 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1682 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD |
1682 | COMMAND ${CMAKE_COMMAND} | 1683 | COMMAND ${CMAKE_COMMAND} |
@@ -1693,7 +1694,7 @@ endif (WINDOWS) | |||
1693 | if (DARWIN) | 1694 | if (DARWIN) |
1694 | # Don't do this here -- it's taken care of by viewer_manifest.py | 1695 | # Don't do this here -- it's taken care of by viewer_manifest.py |
1695 | # add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1696 | # add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD |
1696 | # COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin/ | 1697 | # COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin/ |
1697 | # DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib | 1698 | # DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib |
1698 | # ) | 1699 | # ) |
1699 | endif (DARWIN) | 1700 | endif (DARWIN) |