aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/mac_crash_logger
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/mac_crash_logger')
-rw-r--r--linden/indra/mac_crash_logger/CMakeLists.txt13
-rw-r--r--linden/indra/mac_crash_logger/CrashReporter.nib/info.nib8
-rw-r--r--linden/indra/mac_crash_logger/llcrashloggermac.cpp4
-rw-r--r--linden/indra/mac_crash_logger/llcrashloggermac.h2
-rw-r--r--linden/indra/mac_crash_logger/mac_crash_logger.cpp2
5 files changed, 13 insertions, 16 deletions
diff --git a/linden/indra/mac_crash_logger/CMakeLists.txt b/linden/indra/mac_crash_logger/CMakeLists.txt
index 371b6fb..daf3e10 100644
--- a/linden/indra/mac_crash_logger/CMakeLists.txt
+++ b/linden/indra/mac_crash_logger/CMakeLists.txt
@@ -3,7 +3,6 @@
3project(mac_crash_logger) 3project(mac_crash_logger)
4 4
5include(00-Common) 5include(00-Common)
6include(Boost)
7include(LLCommon) 6include(LLCommon)
8include(LLCrashLogger) 7include(LLCrashLogger)
9include(LLMath) 8include(LLMath)
@@ -36,7 +35,6 @@ set_source_files_properties(${mac_crash_logger_HEADER_FILES}
36list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_HEADER_FILES}) 35list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_HEADER_FILES})
37 36
38set(mac_crash_logger_RESOURCE_FILES 37set(mac_crash_logger_RESOURCE_FILES
39 Info.plist
40 CrashReporter.nib/ 38 CrashReporter.nib/
41 ) 39 )
42set_source_files_properties( 40set_source_files_properties(
@@ -44,11 +42,6 @@ set_source_files_properties(
44 PROPERTIES 42 PROPERTIES
45 HEADER_FILE_ONLY TRUE 43 HEADER_FILE_ONLY TRUE
46 ) 44 )
47set_source_files_properties(
48 Info.plist
49 PROPERTIES
50 MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
51 )
52SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES}) 45SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES})
53list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES}) 46list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES})
54 47
@@ -56,6 +49,11 @@ add_executable(mac-crash-logger
56 MACOSX_BUNDLE 49 MACOSX_BUNDLE
57 ${mac_crash_logger_SOURCE_FILES}) 50 ${mac_crash_logger_SOURCE_FILES})
58 51
52set_target_properties(mac-crash-logger
53 PROPERTIES
54 MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
55 )
56
59target_link_libraries(mac-crash-logger 57target_link_libraries(mac-crash-logger
60 ${LLCRASHLOGGER_LIBRARIES} 58 ${LLCRASHLOGGER_LIBRARIES}
61 ${LLVFS_LIBRARIES} 59 ${LLVFS_LIBRARIES}
@@ -64,7 +62,6 @@ target_link_libraries(mac-crash-logger
64 ${LLVFS_LIBRARIES} 62 ${LLVFS_LIBRARIES}
65 ${LLMATH_LIBRARIES} 63 ${LLMATH_LIBRARIES}
66 ${LLCOMMON_LIBRARIES} 64 ${LLCOMMON_LIBRARIES}
67 ${BOOST_SIGNALS_LIBRARY}
68 ) 65 )
69 66
70add_custom_command( 67add_custom_command(
diff --git a/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib b/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib
index b541744..06805c0 100644
--- a/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib
+++ b/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib
@@ -5,15 +5,13 @@
5 <key>IBFramework Version</key> 5 <key>IBFramework Version</key>
6 <string>629</string> 6 <string>629</string>
7 <key>IBLastKnownRelativeProjectPath</key> 7 <key>IBLastKnownRelativeProjectPath</key>
8 <string>../macview.xcodeproj</string> 8 <string>../../build-darwin-i386/SecondLife.xcodeproj</string>
9 <key>IBOldestOS</key> 9 <key>IBOldestOS</key>
10 <integer>5</integer> 10 <integer>5</integer>
11 <key>IBOpenObjects</key> 11 <key>IBOpenObjects</key>
12 <array> 12 <array/>
13 <integer>193</integer>
14 </array>
15 <key>IBSystem Version</key> 13 <key>IBSystem Version</key>
16 <string>9B18</string> 14 <string>9E17</string>
17 <key>targetFramework</key> 15 <key>targetFramework</key>
18 <string>IBCarbonFramework</string> 16 <string>IBCarbonFramework</string>
19</dict> 17</dict>
diff --git a/linden/indra/mac_crash_logger/llcrashloggermac.cpp b/linden/indra/mac_crash_logger/llcrashloggermac.cpp
index 8ed2ec7..e257f1b 100644
--- a/linden/indra/mac_crash_logger/llcrashloggermac.cpp
+++ b/linden/indra/mac_crash_logger/llcrashloggermac.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2003&license=viewergpl$ 5 * $LicenseInfo:firstyear=2003&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2003-2008, Linden Research, Inc. 7 * Copyright (c) 2003-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
@@ -133,6 +133,8 @@ OSStatus dialogHandler(EventHandlerCallRef handler, EventRef event, void *userda
133 QuitAppModalLoopForWindow(gWindow); 133 QuitAppModalLoopForWindow(gWindow);
134 result = noErr; 134 result = noErr;
135 break; 135 break;
136 default:
137 result = eventNotHandledErr;
136 } 138 }
137 } 139 }
138 } 140 }
diff --git a/linden/indra/mac_crash_logger/llcrashloggermac.h b/linden/indra/mac_crash_logger/llcrashloggermac.h
index 292579d..ef3be39 100644
--- a/linden/indra/mac_crash_logger/llcrashloggermac.h
+++ b/linden/indra/mac_crash_logger/llcrashloggermac.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2003&license=viewergpl$ 5 * $LicenseInfo:firstyear=2003&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2003-2008, Linden Research, Inc. 7 * Copyright (c) 2003-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/mac_crash_logger/mac_crash_logger.cpp b/linden/indra/mac_crash_logger/mac_crash_logger.cpp
index bf93e0b..55928ec 100644
--- a/linden/indra/mac_crash_logger/mac_crash_logger.cpp
+++ b/linden/indra/mac_crash_logger/mac_crash_logger.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2003&license=viewergpl$ 5 * $LicenseInfo:firstyear=2003&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2003-2008, Linden Research, Inc. 7 * Copyright (c) 2003-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab