diff options
Diffstat (limited to 'linden/indra/llvfs/CMakeLists.txt')
-rw-r--r-- | linden/indra/llvfs/CMakeLists.txt | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/linden/indra/llvfs/CMakeLists.txt b/linden/indra/llvfs/CMakeLists.txt new file mode 100644 index 0000000..9f136f7 --- /dev/null +++ b/linden/indra/llvfs/CMakeLists.txt | |||
@@ -0,0 +1,58 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(llvfs) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(LLCommon) | ||
7 | include(UnixInstall) | ||
8 | |||
9 | include_directories( | ||
10 | ${LLCOMMON_INCLUDE_DIRS} | ||
11 | ) | ||
12 | |||
13 | set(llvfs_SOURCE_FILES | ||
14 | lldir.cpp | ||
15 | lllfsthread.cpp | ||
16 | llvfile.cpp | ||
17 | llvfs.cpp | ||
18 | llvfsthread.cpp | ||
19 | ) | ||
20 | |||
21 | set(llvfs_HEADER_FILES | ||
22 | CMakeLists.txt | ||
23 | |||
24 | lldir.h | ||
25 | lllfsthread.h | ||
26 | llvfile.h | ||
27 | llvfs.h | ||
28 | llvfsthread.h | ||
29 | ) | ||
30 | |||
31 | if (DARWIN) | ||
32 | LIST(APPEND llvfs_SOURCE_FILES lldir_mac.cpp) | ||
33 | LIST(APPEND llvfs_HEADER_FILES lldir_mac.h) | ||
34 | endif (DARWIN) | ||
35 | |||
36 | if (LINUX) | ||
37 | LIST(APPEND llvfs_SOURCE_FILES lldir_linux.cpp) | ||
38 | LIST(APPEND llvfs_HEADER_FILES lldir_linux.h) | ||
39 | |||
40 | if (VIEWER AND INSTALL) | ||
41 | set_source_files_properties(lldir_linux.cpp | ||
42 | PROPERTIES COMPILE_FLAGS | ||
43 | "-DAPP_RO_DATA_DIR=\\\"${APP_SHARE_DIR}\\\"" | ||
44 | ) | ||
45 | endif (VIEWER AND INSTALL) | ||
46 | endif (LINUX) | ||
47 | |||
48 | if (WINDOWS) | ||
49 | LIST(APPEND llvfs_SOURCE_FILES lldir_win32.cpp) | ||
50 | LIST(APPEND llvfs_HEADER_FILES lldir_win32.h) | ||
51 | endif (WINDOWS) | ||
52 | |||
53 | set_source_files_properties(${llvfs_HEADER_FILES} | ||
54 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
55 | |||
56 | list(APPEND llvfs_SOURCE_FILES ${llvfs_HEADER_FILES}) | ||
57 | |||
58 | add_library (llvfs ${llvfs_SOURCE_FILES}) | ||