diff options
Diffstat (limited to 'linden/indra/llplugin')
-rw-r--r-- | linden/indra/llplugin/CMakeLists.txt | 1 | ||||
-rwxr-xr-x | linden/indra/llplugin/llpluginclassmedia.cpp | 7 | ||||
-rwxr-xr-x | linden/indra/llplugin/llpluginclassmediaowner.h | 2 | ||||
-rw-r--r-- | linden/indra/llplugin/llplugincookiestore.cpp | 2 | ||||
-rwxr-xr-x | linden/indra/llplugin/llplugininstance.cpp | 2 | ||||
-rwxr-xr-x | linden/indra/llplugin/llpluginmessage.cpp | 2 | ||||
-rwxr-xr-x | linden/indra/llplugin/llpluginmessagepipe.cpp | 2 | ||||
-rwxr-xr-x | linden/indra/llplugin/llpluginprocesschild.cpp | 2 | ||||
-rwxr-xr-x | linden/indra/llplugin/llpluginprocessparent.cpp | 2 | ||||
-rwxr-xr-x | linden/indra/llplugin/llpluginsharedmemory.cpp | 3 | ||||
-rwxr-xr-x | linden/indra/llplugin/slplugin/slplugin.cpp | 40 |
11 files changed, 56 insertions, 9 deletions
diff --git a/linden/indra/llplugin/CMakeLists.txt b/linden/indra/llplugin/CMakeLists.txt index 7a7f4e5..5dbe07c 100644 --- a/linden/indra/llplugin/CMakeLists.txt +++ b/linden/indra/llplugin/CMakeLists.txt | |||
@@ -20,7 +20,6 @@ include_directories( | |||
20 | ${LLRENDER_INCLUDE_DIRS} | 20 | ${LLRENDER_INCLUDE_DIRS} |
21 | ${LLXML_INCLUDE_DIRS} | 21 | ${LLXML_INCLUDE_DIRS} |
22 | ${LLWINDOW_INCLUDE_DIRS} | 22 | ${LLWINDOW_INCLUDE_DIRS} |
23 | ${LLQTWEBKIT_INCLUDE_DIR} | ||
24 | ) | 23 | ) |
25 | 24 | ||
26 | set(llplugin_SOURCE_FILES | 25 | set(llplugin_SOURCE_FILES |
diff --git a/linden/indra/llplugin/llpluginclassmedia.cpp b/linden/indra/llplugin/llpluginclassmedia.cpp index 5a81c46..f0a44f7 100755 --- a/linden/indra/llplugin/llpluginclassmedia.cpp +++ b/linden/indra/llplugin/llpluginclassmedia.cpp | |||
@@ -33,14 +33,14 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is part of the viewer | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | #include "indra_constants.h" | 39 | #include "indra_constants.h" |
38 | 40 | ||
39 | #include "llpluginclassmedia.h" | 41 | #include "llpluginclassmedia.h" |
40 | #include "llpluginmessageclasses.h" | 42 | #include "llpluginmessageclasses.h" |
41 | 43 | ||
42 | #include "llqtwebkit.h" | ||
43 | |||
44 | static int LOW_PRIORITY_TEXTURE_SIZE_DEFAULT = 256; | 44 | static int LOW_PRIORITY_TEXTURE_SIZE_DEFAULT = 256; |
45 | 45 | ||
46 | static int nextPowerOf2( int value ) | 46 | static int nextPowerOf2( int value ) |
@@ -777,7 +777,7 @@ void LLPluginClassMedia::receivePluginMessage(const LLPluginMessage &message) | |||
777 | mDirtyRect.unionWith(newDirtyRect); | 777 | mDirtyRect.unionWith(newDirtyRect); |
778 | } | 778 | } |
779 | 779 | ||
780 | LL_DEBUGS("PluginClassMedia") << "adjusted incoming rect is: (" | 780 | LL_DEBUGS("PluginClassMediaRect") << "adjusted incoming rect is: (" |
781 | << newDirtyRect.mLeft << ", " | 781 | << newDirtyRect.mLeft << ", " |
782 | << newDirtyRect.mTop << ", " | 782 | << newDirtyRect.mTop << ", " |
783 | << newDirtyRect.mRight << ", " | 783 | << newDirtyRect.mRight << ", " |
@@ -973,6 +973,7 @@ void LLPluginClassMedia::receivePluginMessage(const LLPluginMessage &message) | |||
973 | { | 973 | { |
974 | mClickURL = message.getValue("uri"); | 974 | mClickURL = message.getValue("uri"); |
975 | mClickTarget = message.getValue("target"); | 975 | mClickTarget = message.getValue("target"); |
976 | LL_DEBUGS("PluginClassMedia") << "Click target \"" << mClickTarget << "\"" << LL_ENDL; | ||
976 | mediaEvent(LLPluginClassMediaOwner::MEDIA_EVENT_CLICK_LINK_HREF); | 977 | mediaEvent(LLPluginClassMediaOwner::MEDIA_EVENT_CLICK_LINK_HREF); |
977 | } | 978 | } |
978 | else if(message_name == "click_nofollow") | 979 | else if(message_name == "click_nofollow") |
diff --git a/linden/indra/llplugin/llpluginclassmediaowner.h b/linden/indra/llplugin/llpluginclassmediaowner.h index 9d1f352..0e54f7f 100755 --- a/linden/indra/llplugin/llpluginclassmediaowner.h +++ b/linden/indra/llplugin/llpluginclassmediaowner.h | |||
@@ -41,7 +41,7 @@ | |||
41 | #include <queue> | 41 | #include <queue> |
42 | 42 | ||
43 | class LLPluginClassMedia; | 43 | class LLPluginClassMedia; |
44 | class LLPluginCookieStore; | 44 | //class LLPluginCookieStore; // IMPRUDENCE: this is currently not used |
45 | 45 | ||
46 | class LLPluginClassMediaOwner | 46 | class LLPluginClassMediaOwner |
47 | { | 47 | { |
diff --git a/linden/indra/llplugin/llplugincookiestore.cpp b/linden/indra/llplugin/llplugincookiestore.cpp index 283ba35..6b193de 100644 --- a/linden/indra/llplugin/llplugincookiestore.cpp +++ b/linden/indra/llplugin/llplugincookiestore.cpp | |||
@@ -33,6 +33,8 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is currently not used | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | #include "indra_constants.h" | 39 | #include "indra_constants.h" |
38 | 40 | ||
diff --git a/linden/indra/llplugin/llplugininstance.cpp b/linden/indra/llplugin/llplugininstance.cpp index 67457f2..399f157 100755 --- a/linden/indra/llplugin/llplugininstance.cpp +++ b/linden/indra/llplugin/llplugininstance.cpp | |||
@@ -33,6 +33,8 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is part of the SLPlugin | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | 39 | ||
38 | #include "llplugininstance.h" | 40 | #include "llplugininstance.h" |
diff --git a/linden/indra/llplugin/llpluginmessage.cpp b/linden/indra/llplugin/llpluginmessage.cpp index 6452f4a..0810a04 100755 --- a/linden/indra/llplugin/llpluginmessage.cpp +++ b/linden/indra/llplugin/llpluginmessage.cpp | |||
@@ -33,6 +33,8 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is part of the viewer and the SLPlugin and the libmedia_plugin_* libraries | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | 39 | ||
38 | #include "llpluginmessage.h" | 40 | #include "llpluginmessage.h" |
diff --git a/linden/indra/llplugin/llpluginmessagepipe.cpp b/linden/indra/llplugin/llpluginmessagepipe.cpp index ac3a902..2cad188 100755 --- a/linden/indra/llplugin/llpluginmessagepipe.cpp +++ b/linden/indra/llplugin/llpluginmessagepipe.cpp | |||
@@ -33,6 +33,8 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is part of the viewer and the SLPlugin | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | 39 | ||
38 | #include "llpluginmessagepipe.h" | 40 | #include "llpluginmessagepipe.h" |
diff --git a/linden/indra/llplugin/llpluginprocesschild.cpp b/linden/indra/llplugin/llpluginprocesschild.cpp index a1291c0..0d95cac 100755 --- a/linden/indra/llplugin/llpluginprocesschild.cpp +++ b/linden/indra/llplugin/llpluginprocesschild.cpp | |||
@@ -33,6 +33,8 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is part of the SLPlugin | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | 39 | ||
38 | #include "llpluginprocesschild.h" | 40 | #include "llpluginprocesschild.h" |
diff --git a/linden/indra/llplugin/llpluginprocessparent.cpp b/linden/indra/llplugin/llpluginprocessparent.cpp index 5a66279..26572a0 100755 --- a/linden/indra/llplugin/llpluginprocessparent.cpp +++ b/linden/indra/llplugin/llpluginprocessparent.cpp | |||
@@ -33,6 +33,8 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is part of the viewer | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | 39 | ||
38 | #include "llpluginprocessparent.h" | 40 | #include "llpluginprocessparent.h" |
diff --git a/linden/indra/llplugin/llpluginsharedmemory.cpp b/linden/indra/llplugin/llpluginsharedmemory.cpp index 6becb8d..882a2a1 100755 --- a/linden/indra/llplugin/llpluginsharedmemory.cpp +++ b/linden/indra/llplugin/llpluginsharedmemory.cpp | |||
@@ -33,6 +33,8 @@ | |||
33 | * @endcond | 33 | * @endcond |
34 | */ | 34 | */ |
35 | 35 | ||
36 | /// IMPRUDENCE: this is part of the viewer and the SLPlugin | ||
37 | |||
36 | #include "linden_common.h" | 38 | #include "linden_common.h" |
37 | 39 | ||
38 | #include "llpluginsharedmemory.h" | 40 | #include "llpluginsharedmemory.h" |
@@ -89,7 +91,6 @@ | |||
89 | #include <windows.h> | 91 | #include <windows.h> |
90 | #endif // USE_APR_SHARED_MEMORY | 92 | #endif // USE_APR_SHARED_MEMORY |
91 | 93 | ||
92 | |||
93 | int LLPluginSharedMemory::sSegmentNumber = 0; | 94 | int LLPluginSharedMemory::sSegmentNumber = 0; |
94 | 95 | ||
95 | std::string LLPluginSharedMemory::createName(void) | 96 | std::string LLPluginSharedMemory::createName(void) |
diff --git a/linden/indra/llplugin/slplugin/slplugin.cpp b/linden/indra/llplugin/slplugin/slplugin.cpp index 878577b..4ef24a2 100755 --- a/linden/indra/llplugin/slplugin/slplugin.cpp +++ b/linden/indra/llplugin/slplugin/slplugin.cpp | |||
@@ -35,6 +35,7 @@ | |||
35 | * @endcond | 35 | * @endcond |
36 | */ | 36 | */ |
37 | 37 | ||
38 | /// IMPRUDENCE: this is part of the SLPlugin | ||
38 | 39 | ||
39 | #include "linden_common.h" | 40 | #include "linden_common.h" |
40 | 41 | ||
@@ -53,6 +54,20 @@ | |||
53 | #include <signal.h> | 54 | #include <signal.h> |
54 | #endif | 55 | #endif |
55 | 56 | ||
57 | //imprudence: or we include lldir, or use apache runtime | ||
58 | //though the one is probably bloat and the other we rather want to avoid | ||
59 | #include <stdio.h> // FILENAME_MAX | ||
60 | #ifdef LL_WINDOWS | ||
61 | #include <direct.h> | ||
62 | #define getImpruDir _getcwd | ||
63 | #define DIR_DELIMITER "\\" | ||
64 | #else | ||
65 | #include <unistd.h> | ||
66 | #define getImpruDir getcwd | ||
67 | #define DIR_DELIMITER "/" | ||
68 | #endif | ||
69 | |||
70 | |||
56 | /* | 71 | /* |
57 | On Mac OS, since we call WaitNextEvent, this process will show up in the dock unless we set the LSBackgroundOnly or LSUIElement flag in the Info.plist. | 72 | On Mac OS, since we call WaitNextEvent, this process will show up in the dock unless we set the LSBackgroundOnly or LSUIElement flag in the Info.plist. |
58 | 73 | ||
@@ -187,9 +202,28 @@ int main(int argc, char **argv) | |||
187 | { | 202 | { |
188 | // Set up llerror logging | 203 | // Set up llerror logging |
189 | { | 204 | { |
190 | LLError::initForApplication("."); | 205 | std::string path; |
191 | LLError::setDefaultLevel(LLError::LEVEL_INFO); | 206 | char impruPath[FILENAME_MAX]; |
192 | // LLError::setTagLevel("Plugin", LLError::LEVEL_DEBUG); | 207 | |
208 | if (!getImpruDir(impruPath, sizeof(impruPath))) | ||
209 | { | ||
210 | path = "."; //FIXME: root directory of the system - bad idea | ||
211 | } | ||
212 | else | ||
213 | { | ||
214 | path = std::string(impruPath); | ||
215 | |||
216 | path.append(DIR_DELIMITER); | ||
217 | path.append("app_settings"); | ||
218 | } | ||
219 | LLError::initForApplication(path); | ||
220 | // LLError::setDefaultLevel(LLError::LEVEL_INFO); | ||
221 | // LLError::setPrintLocation(true); | ||
222 | // LLError::setTagLevel("Plugin", LLError::LEVEL_DEBUG); | ||
223 | // LLError::setTagLevel("PluginPipe", LLError::LEVEL_DEBUG); | ||
224 | // LLError::setTagLevel("PluginChild", LLError::LEVEL_DEBUG); | ||
225 | // LLError::setTagLevel("PluginInstance", LLError::LEVEL_DEBUG); | ||
226 | |||
193 | // LLError::logToFile("slplugin.log"); | 227 | // LLError::logToFile("slplugin.log"); |
194 | } | 228 | } |
195 | 229 | ||