diff options
Diffstat (limited to 'linden/indra/llplugin/CMakeLists.txt')
-rw-r--r-- | linden/indra/llplugin/CMakeLists.txt | 87 |
1 files changed, 87 insertions, 0 deletions
diff --git a/linden/indra/llplugin/CMakeLists.txt b/linden/indra/llplugin/CMakeLists.txt new file mode 100644 index 0000000..73cd9a3 --- /dev/null +++ b/linden/indra/llplugin/CMakeLists.txt | |||
@@ -0,0 +1,87 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(llplugin) | ||
4 | |||
5 | if(HAVE_64_BIT) | ||
6 | set(REQUIRE_PIC) | ||
7 | endif(HAVE_64_BIT) | ||
8 | |||
9 | include(00-Common) | ||
10 | include(CURL) | ||
11 | include(LLCommon) | ||
12 | include(LLImage) | ||
13 | include(LLMath) | ||
14 | include(LLMessage) | ||
15 | include(LLRender) | ||
16 | include(LLXML) | ||
17 | include(LLWindow) | ||
18 | |||
19 | include_directories( | ||
20 | ${LLCOMMON_INCLUDE_DIRS} | ||
21 | ${LLIMAGE_INCLUDE_DIRS} | ||
22 | ${LLMATH_INCLUDE_DIRS} | ||
23 | ${LLMESSAGE_INCLUDE_DIRS} | ||
24 | ${LLRENDER_INCLUDE_DIRS} | ||
25 | ${LLXML_INCLUDE_DIRS} | ||
26 | ${LLWINDOW_INCLUDE_DIRS} | ||
27 | ${LLQTWEBKIT_INCLUDE_DIR} | ||
28 | ) | ||
29 | |||
30 | set(llplugin_SOURCE_FILES | ||
31 | llpluginclassmedia.cpp | ||
32 | llplugincookiestore.cpp | ||
33 | llplugininstance.cpp | ||
34 | llpluginmessage.cpp | ||
35 | llpluginmessagepipe.cpp | ||
36 | llpluginprocesschild.cpp | ||
37 | llpluginprocessparent.cpp | ||
38 | llpluginsharedmemory.cpp | ||
39 | ) | ||
40 | |||
41 | set(llplugin_HEADER_FILES | ||
42 | CMakeLists.txt | ||
43 | |||
44 | llpluginclassmedia.h | ||
45 | llpluginclassmediaowner.h | ||
46 | llplugincookiestore.h | ||
47 | llplugininstance.h | ||
48 | llpluginmessage.h | ||
49 | llpluginmessageclasses.h | ||
50 | llpluginmessagepipe.h | ||
51 | llpluginprocesschild.h | ||
52 | llpluginprocessparent.h | ||
53 | llpluginsharedmemory.h | ||
54 | ) | ||
55 | |||
56 | set_source_files_properties(${llplugin_HEADER_FILES} | ||
57 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
58 | |||
59 | if(NOT CMAKE_SIZEOF_VOID_P MATCHES 4) | ||
60 | if(WINDOWS) | ||
61 | add_definitions(/FIXED:NO) | ||
62 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN | ||
63 | add_definitions(-fPIC) | ||
64 | endif(WINDOWS) | ||
65 | endif (NOT CMAKE_SIZEOF_VOID_P MATCHES 4) | ||
66 | |||
67 | list(APPEND llplugin_SOURCE_FILES ${llplugin_HEADER_FILES}) | ||
68 | |||
69 | add_library (llplugin ${llplugin_SOURCE_FILES}) | ||
70 | |||
71 | add_subdirectory(slplugin) | ||
72 | |||
73 | # # Add tests | ||
74 | # include(LLAddBuildTest) | ||
75 | # # UNIT TESTS | ||
76 | # SET(llplugin_TEST_SOURCE_FILES | ||
77 | # llplugincookiestore.cpp | ||
78 | # ) | ||
79 | # | ||
80 | # # llplugincookiestore has a dependency on curl, so we need to link the curl library into the test. | ||
81 | # set_source_files_properties( | ||
82 | # llplugincookiestore.cpp | ||
83 | # PROPERTIES | ||
84 | # LL_TEST_ADDITIONAL_LIBRARIES "${CURL_LIBRARIES}" | ||
85 | # ) | ||
86 | # | ||
87 | # LL_ADD_PROJECT_UNIT_TESTS(llplugin "${llplugin_TEST_SOURCE_FILES}") | ||