diff options
Diffstat (limited to 'linden/indra/llmessage')
-rw-r--r-- | linden/indra/llmessage/CMakeLists.txt | 10 |
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt index b3f2b4c..61b6418 100644 --- a/linden/indra/llmessage/CMakeLists.txt +++ b/linden/indra/llmessage/CMakeLists.txt | |||
@@ -208,13 +208,21 @@ set_source_files_properties(${llmessage_HEADER_FILES} | |||
208 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) | 208 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) |
209 | 209 | ||
210 | add_library (llmessage ${llmessage_SOURCE_FILES}) | 210 | add_library (llmessage ${llmessage_SOURCE_FILES}) |
211 | target_link_libraries( | 211 | set (llmessage_link_LIBRARIES |
212 | llmessage | 212 | llmessage |
213 | ${CURL_LIBRARIES} | 213 | ${CURL_LIBRARIES} |
214 | ${CARES_LIBRARIES} | 214 | ${CARES_LIBRARIES} |
215 | ${OPENSSL_LIBRARIES} | 215 | ${OPENSSL_LIBRARIES} |
216 | ${CRYPTO_LIBRARIES} | 216 | ${CRYPTO_LIBRARIES} |
217 | ${XMLRPCEPI_LIBRARIES} | 217 | ${XMLRPCEPI_LIBRARIES} |
218 | ) | ||
219 | if (LINUX) | ||
220 | list(APPEND llmessage_link_LIBRARIES pthread) | ||
221 | endif (LINUX) | ||
222 | |||
223 | target_link_libraries( | ||
224 | ${llmessage_link_LIBRARIES} | ||
225 | |||
218 | ) | 226 | ) |
219 | 227 | ||
220 | IF (NOT LINUX AND VIEWER) | 228 | IF (NOT LINUX AND VIEWER) |