aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llmessage
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/llmessage')
-rw-r--r--linden/indra/llmessage/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt
index b3f2b4c..61b6418 100644
--- a/linden/indra/llmessage/CMakeLists.txt
+++ b/linden/indra/llmessage/CMakeLists.txt
@@ -208,13 +208,21 @@ set_source_files_properties(${llmessage_HEADER_FILES}
208list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) 208list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES})
209 209
210add_library (llmessage ${llmessage_SOURCE_FILES}) 210add_library (llmessage ${llmessage_SOURCE_FILES})
211target_link_libraries( 211set (llmessage_link_LIBRARIES
212 llmessage 212 llmessage
213 ${CURL_LIBRARIES} 213 ${CURL_LIBRARIES}
214 ${CARES_LIBRARIES} 214 ${CARES_LIBRARIES}
215 ${OPENSSL_LIBRARIES} 215 ${OPENSSL_LIBRARIES}
216 ${CRYPTO_LIBRARIES} 216 ${CRYPTO_LIBRARIES}
217 ${XMLRPCEPI_LIBRARIES} 217 ${XMLRPCEPI_LIBRARIES}
218)
219if (LINUX)
220 list(APPEND llmessage_link_LIBRARIES pthread)
221endif (LINUX)
222
223target_link_libraries(
224 ${llmessage_link_LIBRARIES}
225
218 ) 226 )
219 227
220IF (NOT LINUX AND VIEWER) 228IF (NOT LINUX AND VIEWER)