diff options
Diffstat (limited to '')
-rw-r--r-- | linden/indra/llmessage/CMakeLists.txt | 4 | ||||
-rw-r--r-- | linden/indra/llmessage/llassetstorage.cpp | 12 | ||||
-rw-r--r-- | linden/indra/llmessage/llassetstorage.h | 6 | ||||
-rw-r--r-- | linden/indra/llmessage/llcurl.cpp | 4 | ||||
-rw-r--r-- | linden/indra/llmessage/llcurl.h | 2 | ||||
-rw-r--r-- | linden/indra/llmessage/llhttpassetstorage.cpp | 2 | ||||
-rw-r--r-- | linden/indra/llmessage/llhttpassetstorage.h | 2 | ||||
-rw-r--r-- | linden/indra/llmessage/llhttpnode.cpp | 18 | ||||
-rw-r--r-- | linden/indra/llmessage/llhttpnode.h | 10 | ||||
-rw-r--r-- | linden/indra/llmessage/llpumpio.cpp | 1 | ||||
-rw-r--r-- | linden/indra/llmessage/llregionpresenceverifier.cpp | 1 | ||||
-rw-r--r-- | linden/indra/llmessage/llsdappservices.cpp | 4 | ||||
-rw-r--r-- | linden/indra/llmessage/llsdhttpserver.cpp | 4 |
13 files changed, 37 insertions, 33 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt index 4723281..a5e4249 100644 --- a/linden/indra/llmessage/CMakeLists.txt +++ b/linden/indra/llmessage/CMakeLists.txt | |||
@@ -218,7 +218,7 @@ IF (NOT LINUX AND VIEWER) | |||
218 | # These can not be found when we try to run the tests, so we had to disable them, for the viewer build. | 218 | # These can not be found when we try to run the tests, so we had to disable them, for the viewer build. |
219 | # TODO: Can someone with viewer knowledge figure out how to make these find the correct so. | 219 | # TODO: Can someone with viewer knowledge figure out how to make these find the correct so. |
220 | #ADD_BUILD_TEST(llhttpclientadapter llmessage) | 220 | #ADD_BUILD_TEST(llhttpclientadapter llmessage) |
221 | ADD_BUILD_TEST(lltrustedmessageservice llmessage) | 221 | #ADD_BUILD_TEST(lltrustedmessageservice llmessage) |
222 | ADD_BUILD_TEST(lltemplatemessagedispatcher llmessage) | 222 | #ADD_BUILD_TEST(lltemplatemessagedispatcher llmessage) |
223 | ENDIF (NOT LINUX AND VIEWER) | 223 | ENDIF (NOT LINUX AND VIEWER) |
224 | 224 | ||
diff --git a/linden/indra/llmessage/llassetstorage.cpp b/linden/indra/llmessage/llassetstorage.cpp index 16a96b7..0ab1081 100644 --- a/linden/indra/llmessage/llassetstorage.cpp +++ b/linden/indra/llmessage/llassetstorage.cpp | |||
@@ -1028,12 +1028,12 @@ LLSD LLAssetStorage::getPendingDetails(LLAssetStorage::ERequestType rt, | |||
1028 | { | 1028 | { |
1029 | const request_list_t* requests = getRequestList(rt); | 1029 | const request_list_t* requests = getRequestList(rt); |
1030 | LLSD sd; | 1030 | LLSD sd; |
1031 | sd["requests"] = getPendingDetails(requests, asset_type, detail_prefix); | 1031 | sd["requests"] = getPendingDetailsImpl(requests, asset_type, detail_prefix); |
1032 | return sd; | 1032 | return sd; |
1033 | } | 1033 | } |
1034 | 1034 | ||
1035 | // virtual | 1035 | // virtual |
1036 | LLSD LLAssetStorage::getPendingDetails(const LLAssetStorage::request_list_t* requests, | 1036 | LLSD LLAssetStorage::getPendingDetailsImpl(const LLAssetStorage::request_list_t* requests, |
1037 | LLAssetType::EType asset_type, | 1037 | LLAssetType::EType asset_type, |
1038 | const std::string& detail_prefix) const | 1038 | const std::string& detail_prefix) const |
1039 | { | 1039 | { |
@@ -1116,11 +1116,11 @@ LLSD LLAssetStorage::getPendingRequest(LLAssetStorage::ERequestType rt, | |||
1116 | const LLUUID& asset_id) const | 1116 | const LLUUID& asset_id) const |
1117 | { | 1117 | { |
1118 | const request_list_t* requests = getRequestList(rt); | 1118 | const request_list_t* requests = getRequestList(rt); |
1119 | return getPendingRequest(requests, asset_type, asset_id); | 1119 | return getPendingRequestImpl(requests, asset_type, asset_id); |
1120 | } | 1120 | } |
1121 | 1121 | ||
1122 | // virtual | 1122 | // virtual |
1123 | LLSD LLAssetStorage::getPendingRequest(const LLAssetStorage::request_list_t* requests, | 1123 | LLSD LLAssetStorage::getPendingRequestImpl(const LLAssetStorage::request_list_t* requests, |
1124 | LLAssetType::EType asset_type, | 1124 | LLAssetType::EType asset_type, |
1125 | const LLUUID& asset_id) const | 1125 | const LLUUID& asset_id) const |
1126 | { | 1126 | { |
@@ -1139,7 +1139,7 @@ bool LLAssetStorage::deletePendingRequest(LLAssetStorage::ERequestType rt, | |||
1139 | const LLUUID& asset_id) | 1139 | const LLUUID& asset_id) |
1140 | { | 1140 | { |
1141 | request_list_t* requests = getRequestList(rt); | 1141 | request_list_t* requests = getRequestList(rt); |
1142 | if (deletePendingRequest(requests, asset_type, asset_id)) | 1142 | if (deletePendingRequestImpl(requests, asset_type, asset_id)) |
1143 | { | 1143 | { |
1144 | llinfos << "Asset " << getRequestName(rt) << " request for " | 1144 | llinfos << "Asset " << getRequestName(rt) << " request for " |
1145 | << asset_id << "." << LLAssetType::lookup(asset_type) | 1145 | << asset_id << "." << LLAssetType::lookup(asset_type) |
@@ -1150,7 +1150,7 @@ bool LLAssetStorage::deletePendingRequest(LLAssetStorage::ERequestType rt, | |||
1150 | } | 1150 | } |
1151 | 1151 | ||
1152 | // virtual | 1152 | // virtual |
1153 | bool LLAssetStorage::deletePendingRequest(LLAssetStorage::request_list_t* requests, | 1153 | bool LLAssetStorage::deletePendingRequestImpl(LLAssetStorage::request_list_t* requests, |
1154 | LLAssetType::EType asset_type, | 1154 | LLAssetType::EType asset_type, |
1155 | const LLUUID& asset_id) | 1155 | const LLUUID& asset_id) |
1156 | { | 1156 | { |
diff --git a/linden/indra/llmessage/llassetstorage.h b/linden/indra/llmessage/llassetstorage.h index c094ef4..83cfdf6 100644 --- a/linden/indra/llmessage/llassetstorage.h +++ b/linden/indra/llmessage/llassetstorage.h | |||
@@ -315,15 +315,15 @@ public: | |||
315 | void markAssetToxic( const LLUUID& uuid ); | 315 | void markAssetToxic( const LLUUID& uuid ); |
316 | 316 | ||
317 | protected: | 317 | protected: |
318 | virtual LLSD getPendingDetails(const request_list_t* requests, | 318 | virtual LLSD getPendingDetailsImpl(const request_list_t* requests, |
319 | LLAssetType::EType asset_type, | 319 | LLAssetType::EType asset_type, |
320 | const std::string& detail_prefix) const; | 320 | const std::string& detail_prefix) const; |
321 | 321 | ||
322 | virtual LLSD getPendingRequest(const request_list_t* requests, | 322 | virtual LLSD getPendingRequestImpl(const request_list_t* requests, |
323 | LLAssetType::EType asset_type, | 323 | LLAssetType::EType asset_type, |
324 | const LLUUID& asset_id) const; | 324 | const LLUUID& asset_id) const; |
325 | 325 | ||
326 | virtual bool deletePendingRequest(request_list_t* requests, | 326 | virtual bool deletePendingRequestImpl(request_list_t* requests, |
327 | LLAssetType::EType asset_type, | 327 | LLAssetType::EType asset_type, |
328 | const LLUUID& asset_id); | 328 | const LLUUID& asset_id); |
329 | 329 | ||
diff --git a/linden/indra/llmessage/llcurl.cpp b/linden/indra/llmessage/llcurl.cpp index 12321fe..202332c 100644 --- a/linden/indra/llmessage/llcurl.cpp +++ b/linden/indra/llmessage/llcurl.cpp | |||
@@ -120,7 +120,7 @@ LLCurl::Responder::~Responder() | |||
120 | } | 120 | } |
121 | 121 | ||
122 | // virtual | 122 | // virtual |
123 | void LLCurl::Responder::error( | 123 | void LLCurl::Responder::errorWithContent( |
124 | U32 status, | 124 | U32 status, |
125 | const std::string& reason, | 125 | const std::string& reason, |
126 | const LLSD&) | 126 | const LLSD&) |
@@ -161,7 +161,7 @@ void LLCurl::Responder::completed(U32 status, const std::string& reason, const L | |||
161 | } | 161 | } |
162 | else | 162 | else |
163 | { | 163 | { |
164 | error(status, reason, content); | 164 | errorWithContent(status, reason, content); |
165 | } | 165 | } |
166 | } | 166 | } |
167 | 167 | ||
diff --git a/linden/indra/llmessage/llcurl.h b/linden/indra/llmessage/llcurl.h index 3e9c0d4..32637b2 100644 --- a/linden/indra/llmessage/llcurl.h +++ b/linden/indra/llmessage/llcurl.h | |||
@@ -85,7 +85,7 @@ public: | |||
85 | return((200 <= status) && (status < 300)); | 85 | return((200 <= status) && (status < 300)); |
86 | } | 86 | } |
87 | 87 | ||
88 | virtual void error( | 88 | virtual void errorWithContent( |
89 | U32 status, | 89 | U32 status, |
90 | const std::string& reason, | 90 | const std::string& reason, |
91 | const LLSD& content); | 91 | const LLSD& content); |
diff --git a/linden/indra/llmessage/llhttpassetstorage.cpp b/linden/indra/llmessage/llhttpassetstorage.cpp index dfdad59..49dbdbd 100644 --- a/linden/indra/llmessage/llhttpassetstorage.cpp +++ b/linden/indra/llmessage/llhttpassetstorage.cpp | |||
@@ -626,7 +626,7 @@ LLSD LLHTTPAssetStorage::getPendingRequest(LLAssetStorage::ERequestType rt, | |||
626 | const request_list_t* running = getRunningList(rt); | 626 | const request_list_t* running = getRunningList(rt); |
627 | if (running) | 627 | if (running) |
628 | { | 628 | { |
629 | LLSD sd = LLAssetStorage::getPendingRequest(running, asset_type, asset_id); | 629 | LLSD sd = LLAssetStorage::getPendingRequestImpl(running, asset_type, asset_id); |
630 | if (sd) | 630 | if (sd) |
631 | { | 631 | { |
632 | sd["is_running"] = true; | 632 | sd["is_running"] = true; |
diff --git a/linden/indra/llmessage/llhttpassetstorage.h b/linden/indra/llmessage/llhttpassetstorage.h index 5786c5d..231437d 100644 --- a/linden/indra/llmessage/llhttpassetstorage.h +++ b/linden/indra/llmessage/llhttpassetstorage.h | |||
@@ -62,6 +62,8 @@ public: | |||
62 | 62 | ||
63 | virtual ~LLHTTPAssetStorage(); | 63 | virtual ~LLHTTPAssetStorage(); |
64 | 64 | ||
65 | using LLAssetStorage::storeAssetData; // Unhiding virtuals... | ||
66 | |||
65 | virtual void storeAssetData( | 67 | virtual void storeAssetData( |
66 | const LLUUID& uuid, | 68 | const LLUUID& uuid, |
67 | LLAssetType::EType atype, | 69 | LLAssetType::EType atype, |
diff --git a/linden/indra/llmessage/llhttpnode.cpp b/linden/indra/llmessage/llhttpnode.cpp index 2ba900a..440b91f 100644 --- a/linden/indra/llmessage/llhttpnode.cpp +++ b/linden/indra/llmessage/llhttpnode.cpp | |||
@@ -98,19 +98,19 @@ namespace { | |||
98 | } | 98 | } |
99 | 99 | ||
100 | // virtual | 100 | // virtual |
101 | LLSD LLHTTPNode::get() const | 101 | LLSD LLHTTPNode::simpleGet() const |
102 | { | 102 | { |
103 | throw NotImplemented(); | 103 | throw NotImplemented(); |
104 | } | 104 | } |
105 | 105 | ||
106 | // virtual | 106 | // virtual |
107 | LLSD LLHTTPNode::put(const LLSD& input) const | 107 | LLSD LLHTTPNode::simplePut(const LLSD& input) const |
108 | { | 108 | { |
109 | throw NotImplemented(); | 109 | throw NotImplemented(); |
110 | } | 110 | } |
111 | 111 | ||
112 | // virtual | 112 | // virtual |
113 | LLSD LLHTTPNode::post(const LLSD& input) const | 113 | LLSD LLHTTPNode::simplePost(const LLSD& input) const |
114 | { | 114 | { |
115 | throw NotImplemented(); | 115 | throw NotImplemented(); |
116 | } | 116 | } |
@@ -121,7 +121,7 @@ void LLHTTPNode::get(LLHTTPNode::ResponsePtr response, const LLSD& context) cons | |||
121 | { | 121 | { |
122 | try | 122 | try |
123 | { | 123 | { |
124 | response->result(get()); | 124 | response->result(simpleGet()); |
125 | } | 125 | } |
126 | catch (NotImplemented) | 126 | catch (NotImplemented) |
127 | { | 127 | { |
@@ -134,7 +134,7 @@ void LLHTTPNode::put(LLHTTPNode::ResponsePtr response, const LLSD& context, cons | |||
134 | { | 134 | { |
135 | try | 135 | try |
136 | { | 136 | { |
137 | response->result(put(input)); | 137 | response->result(simplePut(input)); |
138 | } | 138 | } |
139 | catch (NotImplemented) | 139 | catch (NotImplemented) |
140 | { | 140 | { |
@@ -147,7 +147,7 @@ void LLHTTPNode::post(LLHTTPNode::ResponsePtr response, const LLSD& context, con | |||
147 | { | 147 | { |
148 | try | 148 | try |
149 | { | 149 | { |
150 | response->result(post(input)); | 150 | response->result(simplePost(input)); |
151 | } | 151 | } |
152 | catch (NotImplemented) | 152 | catch (NotImplemented) |
153 | { | 153 | { |
@@ -160,7 +160,7 @@ void LLHTTPNode::del(LLHTTPNode::ResponsePtr response, const LLSD& context) cons | |||
160 | { | 160 | { |
161 | try | 161 | try |
162 | { | 162 | { |
163 | response->result(del(context)); | 163 | response->result(simpleDel(context)); |
164 | } | 164 | } |
165 | catch (NotImplemented) | 165 | catch (NotImplemented) |
166 | { | 166 | { |
@@ -170,7 +170,7 @@ void LLHTTPNode::del(LLHTTPNode::ResponsePtr response, const LLSD& context) cons | |||
170 | } | 170 | } |
171 | 171 | ||
172 | // virtual | 172 | // virtual |
173 | LLSD LLHTTPNode::del(const LLSD&) const | 173 | LLSD LLHTTPNode::simpleDel(const LLSD&) const |
174 | { | 174 | { |
175 | throw NotImplemented(); | 175 | throw NotImplemented(); |
176 | } | 176 | } |
@@ -388,7 +388,7 @@ LLHTTPNode::Response::~Response() | |||
388 | { | 388 | { |
389 | } | 389 | } |
390 | 390 | ||
391 | void LLHTTPNode::Response::status(S32 code) | 391 | void LLHTTPNode::Response::statusUnknownError(S32 code) |
392 | { | 392 | { |
393 | status(code, "Unknown Error"); | 393 | status(code, "Unknown Error"); |
394 | } | 394 | } |
diff --git a/linden/indra/llmessage/llhttpnode.h b/linden/indra/llmessage/llhttpnode.h index 17ffd66..87f0c48 100644 --- a/linden/indra/llmessage/llhttpnode.h +++ b/linden/indra/llmessage/llhttpnode.h | |||
@@ -83,10 +83,10 @@ public: | |||
83 | //@{ | 83 | //@{ |
84 | public: | 84 | public: |
85 | 85 | ||
86 | virtual LLSD get() const; | 86 | virtual LLSD simpleGet() const; |
87 | virtual LLSD put(const LLSD& input) const; | 87 | virtual LLSD simplePut(const LLSD& input) const; |
88 | virtual LLSD post(const LLSD& input) const; | 88 | virtual LLSD simplePost(const LLSD& input) const; |
89 | virtual LLSD del(const LLSD& context) const; | 89 | virtual LLSD simpleDel(const LLSD& context) const; |
90 | 90 | ||
91 | /** | 91 | /** |
92 | * @brief Abstract Base Class declaring Response interface. | 92 | * @brief Abstract Base Class declaring Response interface. |
@@ -116,7 +116,7 @@ public: | |||
116 | /** | 116 | /** |
117 | * @brief Return no body, just status code and 'UNKNOWN ERROR'. | 117 | * @brief Return no body, just status code and 'UNKNOWN ERROR'. |
118 | */ | 118 | */ |
119 | virtual void status(S32 code); | 119 | virtual void statusUnknownError(S32 code); |
120 | 120 | ||
121 | virtual void notFound(const std::string& message); | 121 | virtual void notFound(const std::string& message); |
122 | virtual void notFound(); | 122 | virtual void notFound(); |
diff --git a/linden/indra/llmessage/llpumpio.cpp b/linden/indra/llmessage/llpumpio.cpp index 3e3f0b3..8ef2b16 100644 --- a/linden/indra/llmessage/llpumpio.cpp +++ b/linden/indra/llmessage/llpumpio.cpp | |||
@@ -43,6 +43,7 @@ | |||
43 | #include "llmemtype.h" | 43 | #include "llmemtype.h" |
44 | #include "llstl.h" | 44 | #include "llstl.h" |
45 | #include "llstat.h" | 45 | #include "llstat.h" |
46 | #include "llfasttimer.h" | ||
46 | 47 | ||
47 | // These should not be enabled in production, but they can be | 48 | // These should not be enabled in production, but they can be |
48 | // intensely useful during development for finding certain kinds of | 49 | // intensely useful during development for finding certain kinds of |
diff --git a/linden/indra/llmessage/llregionpresenceverifier.cpp b/linden/indra/llmessage/llregionpresenceverifier.cpp index 24410a7..04eba34 100644 --- a/linden/indra/llmessage/llregionpresenceverifier.cpp +++ b/linden/indra/llmessage/llregionpresenceverifier.cpp | |||
@@ -30,6 +30,7 @@ | |||
30 | * $/LicenseInfo$ | 30 | * $/LicenseInfo$ |
31 | */ | 31 | */ |
32 | 32 | ||
33 | #include "linden_common.h" | ||
33 | #include "llregionpresenceverifier.h" | 34 | #include "llregionpresenceverifier.h" |
34 | #include "llhttpclientinterface.h" | 35 | #include "llhttpclientinterface.h" |
35 | #include <sstream> | 36 | #include <sstream> |
diff --git a/linden/indra/llmessage/llsdappservices.cpp b/linden/indra/llmessage/llsdappservices.cpp index dc135c5..b87c0cd 100644 --- a/linden/indra/llmessage/llsdappservices.cpp +++ b/linden/indra/llmessage/llsdappservices.cpp | |||
@@ -56,7 +56,7 @@ public: | |||
56 | desc.source(__FILE__, __LINE__); | 56 | desc.source(__FILE__, __LINE__); |
57 | } | 57 | } |
58 | 58 | ||
59 | virtual LLSD get() const | 59 | virtual LLSD simpleGet() const |
60 | { | 60 | { |
61 | LLSD result; | 61 | LLSD result; |
62 | LLApp* app = LLApp::instance(); | 62 | LLApp* app = LLApp::instance(); |
@@ -82,7 +82,7 @@ public: | |||
82 | desc.source(__FILE__, __LINE__); | 82 | desc.source(__FILE__, __LINE__); |
83 | } | 83 | } |
84 | 84 | ||
85 | virtual LLSD get() const | 85 | virtual LLSD simpleGet() const |
86 | { | 86 | { |
87 | return LLApp::instance()->getOptionData( | 87 | return LLApp::instance()->getOptionData( |
88 | LLApp::PRIORITY_RUNTIME_OVERRIDE); | 88 | LLApp::PRIORITY_RUNTIME_OVERRIDE); |
diff --git a/linden/indra/llmessage/llsdhttpserver.cpp b/linden/indra/llmessage/llsdhttpserver.cpp index 00fc170..7d06c29 100644 --- a/linden/indra/llmessage/llsdhttpserver.cpp +++ b/linden/indra/llmessage/llsdhttpserver.cpp | |||
@@ -62,7 +62,7 @@ public: | |||
62 | desc.source(__FILE__, __LINE__); | 62 | desc.source(__FILE__, __LINE__); |
63 | } | 63 | } |
64 | 64 | ||
65 | virtual LLSD get() const | 65 | virtual LLSD simpleGet() const |
66 | { | 66 | { |
67 | LLSD result = "hello"; | 67 | LLSD result = "hello"; |
68 | return result; | 68 | return result; |
@@ -86,7 +86,7 @@ public: | |||
86 | desc.source(__FILE__, __LINE__); | 86 | desc.source(__FILE__, __LINE__); |
87 | } | 87 | } |
88 | 88 | ||
89 | virtual LLSD post(const LLSD& params) const | 89 | virtual LLSD simplePost(const LLSD& params) const |
90 | { | 90 | { |
91 | return params; | 91 | return params; |
92 | } | 92 | } |