aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/llmessage/CMakeLists.txt')
-rw-r--r--linden/indra/llmessage/CMakeLists.txt26
1 files changed, 24 insertions, 2 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt
index fd22de9..0f3e159 100644
--- a/linden/indra/llmessage/CMakeLists.txt
+++ b/linden/indra/llmessage/CMakeLists.txt
@@ -7,6 +7,8 @@ include(LLCommon)
7include(LLMath) 7include(LLMath)
8include(LLMessage) 8include(LLMessage)
9include(LLVFS) 9include(LLVFS)
10include(LLAddBuildTest)
11include(Tut)
10 12
11include_directories (${CMAKE_CURRENT_SOURCE_DIR}) 13include_directories (${CMAKE_CURRENT_SOURCE_DIR})
12 14
@@ -34,6 +36,7 @@ set(llmessage_SOURCE_FILES
34 llhost.cpp 36 llhost.cpp
35 llhttpassetstorage.cpp 37 llhttpassetstorage.cpp
36 llhttpclient.cpp 38 llhttpclient.cpp
39 llhttpclientadapter.cpp
37 llhttpnode.cpp 40 llhttpnode.cpp
38 llhttpsender.cpp 41 llhttpsender.cpp
39 llinstantmessage.cpp 42 llinstantmessage.cpp
@@ -57,6 +60,7 @@ set(llmessage_SOURCE_FILES
57 llpacketring.cpp 60 llpacketring.cpp
58 llpartdata.cpp 61 llpartdata.cpp
59 llpumpio.cpp 62 llpumpio.cpp
63 llregionpresenceverifier.cpp
60 llsdappservices.cpp 64 llsdappservices.cpp
61 llsdhttpserver.cpp 65 llsdhttpserver.cpp
62 llsdmessagebuilder.cpp 66 llsdmessagebuilder.cpp
@@ -65,7 +69,9 @@ set(llmessage_SOURCE_FILES
65 llsdrpcserver.cpp 69 llsdrpcserver.cpp
66 llservicebuilder.cpp 70 llservicebuilder.cpp
67 llservice.cpp 71 llservice.cpp
72 llstoredmessage.cpp
68 lltemplatemessagebuilder.cpp 73 lltemplatemessagebuilder.cpp
74 lltemplatemessagedispatcher.cpp
69 lltemplatemessagereader.cpp 75 lltemplatemessagereader.cpp
70 llthrottle.cpp 76 llthrottle.cpp
71 lltransfermanager.cpp 77 lltransfermanager.cpp
@@ -73,6 +79,7 @@ set(llmessage_SOURCE_FILES
73 lltransfersourcefile.cpp 79 lltransfersourcefile.cpp
74 lltransfertargetfile.cpp 80 lltransfertargetfile.cpp
75 lltransfertargetvfile.cpp 81 lltransfertargetvfile.cpp
82 lltrustedmessageservice.cpp
76 llurlrequest.cpp 83 llurlrequest.cpp
77 lluseroperation.cpp 84 lluseroperation.cpp
78 llxfer.cpp 85 llxfer.cpp
@@ -85,7 +92,6 @@ set(llmessage_SOURCE_FILES
85 message_prehash.cpp 92 message_prehash.cpp
86 message_string_table.cpp 93 message_string_table.cpp
87 net.cpp 94 net.cpp
88 network.cpp
89 partsyspacket.cpp 95 partsyspacket.cpp
90 patch_code.cpp 96 patch_code.cpp
91 patch_dct.cpp 97 patch_dct.cpp
@@ -115,7 +121,10 @@ set(llmessage_HEADER_FILES
115 llhost.h 121 llhost.h
116 llhttpassetstorage.h 122 llhttpassetstorage.h
117 llhttpclient.h 123 llhttpclient.h
124 llhttpclientinterface.h
125 llhttpclientadapter.h
118 llhttpnode.h 126 llhttpnode.h
127 llhttpnodeadapter.h
119 llhttpsender.h 128 llhttpsender.h
120 llinstantmessage.h 129 llinstantmessage.h
121 llinvite.h 130 llinvite.h
@@ -144,6 +153,7 @@ set(llmessage_HEADER_FILES
144 llqueryflags.h 153 llqueryflags.h
145 llregionflags.h 154 llregionflags.h
146 llregionhandle.h 155 llregionhandle.h
156 llregionpresenceverifier.h
147 llsdappservices.h 157 llsdappservices.h
148 llsdhttpserver.h 158 llsdhttpserver.h
149 llsdmessagebuilder.h 159 llsdmessagebuilder.h
@@ -152,9 +162,11 @@ set(llmessage_HEADER_FILES
152 llsdrpcserver.h 162 llsdrpcserver.h
153 llservice.h 163 llservice.h
154 llservicebuilder.h 164 llservicebuilder.h
165 llstoredmessage.h
155 lltaskname.h 166 lltaskname.h
156 llteleportflags.h 167 llteleportflags.h
157 lltemplatemessagebuilder.h 168 lltemplatemessagebuilder.h
169 lltemplatemessagedispatcher.h
158 lltemplatemessagereader.h 170 lltemplatemessagereader.h
159 llthrottle.h 171 llthrottle.h
160 lltransfermanager.h 172 lltransfermanager.h
@@ -162,6 +174,7 @@ set(llmessage_HEADER_FILES
162 lltransfersourcefile.h 174 lltransfersourcefile.h
163 lltransfertargetfile.h 175 lltransfertargetfile.h
164 lltransfertargetvfile.h 176 lltransfertargetvfile.h
177 lltrustedmessageservice.h
165 llurlrequest.h 178 llurlrequest.h
166 lluseroperation.h 179 lluseroperation.h
167 llvehicleparams.h 180 llvehicleparams.h
@@ -176,7 +189,6 @@ set(llmessage_HEADER_FILES
176 message.h 189 message.h
177 message_prehash.h 190 message_prehash.h
178 net.h 191 net.h
179 network.h
180 partsyspacket.h 192 partsyspacket.h
181 patch_code.h 193 patch_code.h
182 patch_dct.h 194 patch_dct.h
@@ -197,3 +209,13 @@ target_link_libraries(
197 ${CRYPTO_LIBRARIES} 209 ${CRYPTO_LIBRARIES}
198 ${XMLRPCEPI_LIBRARIES} 210 ${XMLRPCEPI_LIBRARIES}
199 ) 211 )
212
213IF (NOT LINUX AND VIEWER)
214 # When building the viewer the tests links against the shared objects.
215 # These can not be found when we try to run the tests, so we had to disable them, for the viewer build.
216 # TODO: Can someone with viewer knowledge figure out how to make these find the correct so.
217 #ADD_BUILD_TEST(llhttpclientadapter llmessage)
218 ADD_BUILD_TEST(lltrustedmessageservice llmessage)
219 ADD_BUILD_TEST(lltemplatemessagedispatcher llmessage)
220ENDIF (NOT LINUX AND VIEWER)
221