aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--linden/indra/llmessage/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt
index 0f3e159..88233b9 100644
--- a/linden/indra/llmessage/CMakeLists.txt
+++ b/linden/indra/llmessage/CMakeLists.txt
@@ -201,13 +201,21 @@ set_source_files_properties(${llmessage_HEADER_FILES}
201list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) 201list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES})
202 202
203add_library (llmessage ${llmessage_SOURCE_FILES}) 203add_library (llmessage ${llmessage_SOURCE_FILES})
204target_link_libraries( 204set (llmessage_link_LIBRARIES
205 llmessage 205 llmessage
206 ${CURL_LIBRARIES} 206 ${CURL_LIBRARIES}
207 ${CARES_LIBRARIES} 207 ${CARES_LIBRARIES}
208 ${OPENSSL_LIBRARIES} 208 ${OPENSSL_LIBRARIES}
209 ${CRYPTO_LIBRARIES} 209 ${CRYPTO_LIBRARIES}
210 ${XMLRPCEPI_LIBRARIES} 210 ${XMLRPCEPI_LIBRARIES}
211)
212if (LINUX)
213 list(APPEND llmessage_link_LIBRARIES pthread)
214endif (LINUX)
215
216target_link_libraries(
217 ${llmessage_link_LIBRARIES}
218
211 ) 219 )
212 220
213IF (NOT LINUX AND VIEWER) 221IF (NOT LINUX AND VIEWER)