aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llmedia
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/llmedia')
-rw-r--r--linden/indra/llmedia/CMakeLists.txt6
-rw-r--r--linden/indra/llmedia/llmediabase.h2
-rw-r--r--linden/indra/llmedia/llmediaemitter.h2
-rw-r--r--linden/indra/llmedia/llmediaimplcommon.cpp2
-rw-r--r--linden/indra/llmedia/llmediaimplcommon.h2
-rw-r--r--linden/indra/llmedia/llmediaimplexample1.cpp2
-rw-r--r--linden/indra/llmedia/llmediaimplexample1.h2
-rw-r--r--linden/indra/llmedia/llmediaimplexample2.cpp4
-rw-r--r--linden/indra/llmedia/llmediaimplexample2.h2
-rw-r--r--linden/indra/llmedia/llmediaimplfactory.cpp2
-rw-r--r--linden/indra/llmedia/llmediaimplfactory.h2
-rw-r--r--linden/indra/llmedia/llmediaimplgstreamer.cpp26
-rw-r--r--linden/indra/llmedia/llmediaimplgstreamer.h56
-rw-r--r--linden/indra/llmedia/llmediaimplgstreamervidplug.cpp2
-rw-r--r--linden/indra/llmedia/llmediaimplgstreamervidplug.h2
-rw-r--r--linden/indra/llmedia/llmediaimplllmozlib.cpp2
-rw-r--r--linden/indra/llmedia/llmediaimplllmozlib.h2
-rw-r--r--linden/indra/llmedia/llmediaimplquicktime.cpp2
-rw-r--r--linden/indra/llmedia/llmediaimplquicktime.h2
-rw-r--r--linden/indra/llmedia/llmediaimplregister.h2
-rw-r--r--linden/indra/llmedia/llmediamanager.cpp2
-rw-r--r--linden/indra/llmedia/llmediamanager.h2
-rw-r--r--linden/indra/llmedia/llmediaobserver.h2
23 files changed, 71 insertions, 59 deletions
diff --git a/linden/indra/llmedia/CMakeLists.txt b/linden/indra/llmedia/CMakeLists.txt
index ea0ce1a..c7b5cd1 100644
--- a/linden/indra/llmedia/CMakeLists.txt
+++ b/linden/indra/llmedia/CMakeLists.txt
@@ -71,3 +71,9 @@ set_source_files_properties(${llmedia_HEADER_FILES}
71list(APPEND llmedia_SOURCE_FILES ${llmedia_HEADER_FILES}) 71list(APPEND llmedia_SOURCE_FILES ${llmedia_HEADER_FILES})
72 72
73add_library (llmedia ${llmedia_SOURCE_FILES}) 73add_library (llmedia ${llmedia_SOURCE_FILES})
74target_link_libraries(
75 llmedia
76 ${GSTREAMER_LIBRARIES}
77 ${GSTREAMER_PLUGINS_BASE_LIBRARIES}
78 ${QUICKTIME_LIBRARY}
79 )
diff --git a/linden/indra/llmedia/llmediabase.h b/linden/indra/llmedia/llmediabase.h
index bf54a22..a158553 100644
--- a/linden/indra/llmedia/llmediabase.h
+++ b/linden/indra/llmedia/llmediabase.h
@@ -6,7 +6,7 @@
6 * 6 *
7 * $LicenseInfo:firstyear=2005&license=viewergpl$ 7 * $LicenseInfo:firstyear=2005&license=viewergpl$
8 * 8 *
9 * Copyright (c) 2005-2008, Linden Research, Inc. 9 * Copyright (c) 2005-2009, Linden Research, Inc.
10 * 10 *
11 * Second Life Viewer Source Code 11 * Second Life Viewer Source Code
12 * The source code in this file ("Source Code") is provided by Linden Lab 12 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaemitter.h b/linden/indra/llmedia/llmediaemitter.h
index e06a5ff..a5e0554 100644
--- a/linden/indra/llmedia/llmediaemitter.h
+++ b/linden/indra/llmedia/llmediaemitter.h
@@ -6,7 +6,7 @@
6 * 6 *
7 * $LicenseInfo:firstyear=2005&license=viewergpl$ 7 * $LicenseInfo:firstyear=2005&license=viewergpl$
8 * 8 *
9 * Copyright (c) 2005-2008, Linden Research, Inc. 9 * Copyright (c) 2005-2009, Linden Research, Inc.
10 * 10 *
11 * Second Life Viewer Source Code 11 * Second Life Viewer Source Code
12 * The source code in this file ("Source Code") is provided by Linden Lab 12 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplcommon.cpp b/linden/indra/llmedia/llmediaimplcommon.cpp
index 48b3973..3ac5079 100644
--- a/linden/indra/llmedia/llmediaimplcommon.cpp
+++ b/linden/indra/llmedia/llmediaimplcommon.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplcommon.h b/linden/indra/llmedia/llmediaimplcommon.h
index 8a726f1..a712824 100644
--- a/linden/indra/llmedia/llmediaimplcommon.h
+++ b/linden/indra/llmedia/llmediaimplcommon.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplexample1.cpp b/linden/indra/llmedia/llmediaimplexample1.cpp
index 977d508..910bbf7 100644
--- a/linden/indra/llmedia/llmediaimplexample1.cpp
+++ b/linden/indra/llmedia/llmediaimplexample1.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplexample1.h b/linden/indra/llmedia/llmediaimplexample1.h
index b78a887..19b8ed6 100644
--- a/linden/indra/llmedia/llmediaimplexample1.h
+++ b/linden/indra/llmedia/llmediaimplexample1.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplexample2.cpp b/linden/indra/llmedia/llmediaimplexample2.cpp
index 13036f9..7bda982 100644
--- a/linden/indra/llmedia/llmediaimplexample2.cpp
+++ b/linden/indra/llmedia/llmediaimplexample2.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
@@ -45,7 +45,7 @@ static LLMediaImplRegister sLLMediaImplExample2Reg( "LLMediaImplExample2", new L
45LLMediaImplExample2Maker::LLMediaImplExample2Maker() 45LLMediaImplExample2Maker::LLMediaImplExample2Maker()
46{ 46{
47 // Register to handle the scheme 47 // Register to handle the scheme
48 mSchema.push_back( "example2" ); 48 mSchema.push_back( "example2." );
49} 49}
50 50
51/////////////////////////////////////////////////////////////////////////////// 51///////////////////////////////////////////////////////////////////////////////
diff --git a/linden/indra/llmedia/llmediaimplexample2.h b/linden/indra/llmedia/llmediaimplexample2.h
index 475915d..ad76088 100644
--- a/linden/indra/llmedia/llmediaimplexample2.h
+++ b/linden/indra/llmedia/llmediaimplexample2.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplfactory.cpp b/linden/indra/llmedia/llmediaimplfactory.cpp
index 0ca7757..6f8787e 100644
--- a/linden/indra/llmedia/llmediaimplfactory.cpp
+++ b/linden/indra/llmedia/llmediaimplfactory.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplfactory.h b/linden/indra/llmedia/llmediaimplfactory.h
index fb99c2f..663efd8 100644
--- a/linden/indra/llmedia/llmediaimplfactory.h
+++ b/linden/indra/llmedia/llmediaimplfactory.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplgstreamer.cpp b/linden/indra/llmedia/llmediaimplgstreamer.cpp
index 5978ba3..d1bab29 100644
--- a/linden/indra/llmedia/llmediaimplgstreamer.cpp
+++ b/linden/indra/llmedia/llmediaimplgstreamer.cpp
@@ -5,7 +5,7 @@
5 * 5 *
6 * $LicenseInfo:firstyear=2007&license=viewergpl$ 6 * $LicenseInfo:firstyear=2007&license=viewergpl$
7 * 7 *
8 * Copyright (c) 2007-2008, Linden Research, Inc. 8 * Copyright (c) 2007-2009, Linden Research, Inc.
9 * 9 *
10 * Second Life Viewer Source Code 10 * Second Life Viewer Source Code
11 * The source code in this file ("Source Code") is provided by Linden Lab 11 * The source code in this file ("Source Code") is provided by Linden Lab
@@ -591,9 +591,6 @@ bool LLMediaImplGStreamer::navigateTo (const std::string urlIn)
591 591
592 mState = GST_STATE_READY; 592 mState = GST_STATE_READY;
593 593
594 // navigateTo implicitly plays, too.
595 play();
596
597 return true; 594 return true;
598} 595}
599 596
@@ -792,6 +789,13 @@ bool LLMediaImplGStreamer::play()
792 if (!mPlaybin || mState == GST_STATE_NULL) 789 if (!mPlaybin || mState == GST_STATE_NULL)
793 return true; 790 return true;
794 791
792
793 if( getState() == GST_STATE_PLAYING )
794 {
795 LL_DEBUGS("MediaImpl") << "... but already playing." << LL_ENDL;
796 return true;
797 }
798
795 // Clean up the existing thread, if any. 799 // Clean up the existing thread, if any.
796 if( mPlayThread != NULL && mPlayThread->isStopped()) 800 if( mPlayThread != NULL && mPlayThread->isStopped())
797 { 801 {
@@ -813,9 +817,6 @@ bool LLMediaImplGStreamer::play()
813 817
814void LLMediaImplGStreamer::startPlay() 818void LLMediaImplGStreamer::startPlay()
815{ 819{
816 GstElement *pipeline = (GstElement *)gst_object_ref(GST_OBJECT(mPlaybin));
817 gst_object_unref(pipeline);
818
819 GstStateChangeReturn state_change; 820 GstStateChangeReturn state_change;
820 821
821 state_change = gst_element_set_state(mPlaybin, GST_STATE_PLAYING); 822 state_change = gst_element_set_state(mPlaybin, GST_STATE_PLAYING);
@@ -894,18 +895,19 @@ bool LLMediaImplGStreamer::seek(double time)
894// virtual 895// virtual
895bool LLMediaImplGStreamer::setVolume(float volume) 896bool LLMediaImplGStreamer::setVolume(float volume)
896{ 897{
897 // XXX hack to make volume volume changes less othen 898 // we try to only update volume as conservatively as
898 // bug in gstreamer 0.10.21 899 // possible, as many gst-plugins-base versions up to at least
899 if(mVolume == volume) 900 // November 2008 have critical race-conditions in setting volume - sigh
900 return true; 901 if (mVolume == volume)
902 return true; // nothing to do, everything's fine
901 903
902 LL_DEBUGS("MediaImpl") << "setVolume(" << volume << ") : " << getpid() << LL_ENDL;
903 mVolume = volume; 904 mVolume = volume;
904 if (mPlaybin) 905 if (mPlaybin)
905 { 906 {
906 g_object_set(mPlaybin, "volume", mVolume, NULL); 907 g_object_set(mPlaybin, "volume", mVolume, NULL);
907 return true; 908 return true;
908 } 909 }
910
909 return false; 911 return false;
910} 912}
911 913
diff --git a/linden/indra/llmedia/llmediaimplgstreamer.h b/linden/indra/llmedia/llmediaimplgstreamer.h
index 32e6bd1..baefdaf 100644
--- a/linden/indra/llmedia/llmediaimplgstreamer.h
+++ b/linden/indra/llmedia/llmediaimplgstreamer.h
@@ -5,7 +5,7 @@
5 * 5 *
6 * $LicenseInfo:firstyear=2007&license=viewergpl$ 6 * $LicenseInfo:firstyear=2007&license=viewergpl$
7 * 7 *
8 * Copyright (c) 2007-2008, Linden Research, Inc. 8 * Copyright (c) 2007-2009, Linden Research, Inc.
9 * 9 *
10 * Second Life Viewer Source Code 10 * Second Life Viewer Source Code
11 * The source code in this file ("Source Code") is provided by Linden Lab 11 * The source code in this file ("Source Code") is provided by Linden Lab
@@ -57,6 +57,8 @@ class LLMediaImplMaker;
57class LLMediaImplGStreamer: 57class LLMediaImplGStreamer:
58 public LLMediaImplCommon 58 public LLMediaImplCommon
59{ 59{
60 friend class LLGstPlayThread;
61
60 public: 62 public:
61 LLMediaImplGStreamer (); 63 LLMediaImplGStreamer ();
62 virtual ~LLMediaImplGStreamer (); 64 virtual ~LLMediaImplGStreamer ();
@@ -95,33 +97,35 @@ class LLMediaImplGStreamer:
95 /* virtual */ int getTextureFormatType() const; 97 /* virtual */ int getTextureFormatType() const;
96 /* virtual */ int getTextureFormatInternal() const; 98 /* virtual */ int getTextureFormatInternal() const;
97 /* virtual */ bool seek( double time ); 99 /* virtual */ bool seek( double time );
98 /* virtual */ bool setVolume( float volume ); 100 /* virtual */ bool setVolume( float volume );
99 101
100 void startPlay(); 102 LLMediaEmitter< LLMediaObserver > getEventEmitter() const {return mEventEmitter;};
101 103
104 protected:
105
106 void startPlay();
102 107
103 LLMediaEmitter< LLMediaObserver > getEventEmitter() const {return mEventEmitter;};
104 108
105 private: 109 private:
106 110
107 // misc 111 // misc
108 bool unload(); 112 bool unload();
109 bool pause(); 113 bool pause();
110 bool stop(); 114 bool stop();
111 bool play(); 115 bool play();
112 116
113 static gboolean bus_callback (GstBus *bus, 117 static gboolean bus_callback (GstBus *bus,
114 GstMessage *message, 118 GstMessage *message,
115 gpointer data); 119 gpointer data);
116 unsigned char* mediaData;
117 int mMediaRowbytes;
118 120
119 int mTextureFormatPrimary; 121 unsigned char* mediaData;
120 int mTextureFormatType; 122 int mMediaRowbytes;
123 int mTextureFormatPrimary;
124 int mTextureFormatType;
121 125
122 // GStreamer-specific 126 // GStreamer-specific
123 GMainLoop *mPump; // event pump for this media 127 GMainLoop *mPump; // event pump for this media
124 GstElement *mPlaybin; 128 GstElement *mPlaybin;
125 GstSLVideo *mVideoSink; 129 GstSLVideo *mVideoSink;
126 GstState mState; 130 GstState mState;
127 GstState getState() const { return mState; } 131 GstState getState() const { return mState; }
@@ -131,12 +135,12 @@ class LLMediaImplGStreamer:
131 135
132class LLMediaImplGStreamerMaker : public LLMediaImplMaker 136class LLMediaImplGStreamerMaker : public LLMediaImplMaker
133{ 137{
134public: 138 public:
135 LLMediaImplGStreamerMaker(); 139 LLMediaImplGStreamerMaker();
136 LLMediaImplGStreamer* create() 140 LLMediaImplGStreamer* create()
137 { 141 {
138 return new LLMediaImplGStreamer(); 142 return new LLMediaImplGStreamer();
139 } 143 }
140}; 144};
141 145
142///////////////////////////////////////////////////////////////////////// 146/////////////////////////////////////////////////////////////////////////
diff --git a/linden/indra/llmedia/llmediaimplgstreamervidplug.cpp b/linden/indra/llmedia/llmediaimplgstreamervidplug.cpp
index eaf2c84..0fa2800 100644
--- a/linden/indra/llmedia/llmediaimplgstreamervidplug.cpp
+++ b/linden/indra/llmedia/llmediaimplgstreamervidplug.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplgstreamervidplug.h b/linden/indra/llmedia/llmediaimplgstreamervidplug.h
index 88caf3b..eef10ca 100644
--- a/linden/indra/llmedia/llmediaimplgstreamervidplug.h
+++ b/linden/indra/llmedia/llmediaimplgstreamervidplug.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplllmozlib.cpp b/linden/indra/llmedia/llmediaimplllmozlib.cpp
index b0d3eb5..05d7220 100644
--- a/linden/indra/llmedia/llmediaimplllmozlib.cpp
+++ b/linden/indra/llmedia/llmediaimplllmozlib.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplllmozlib.h b/linden/indra/llmedia/llmediaimplllmozlib.h
index 4f6b0b7..18b1c6a 100644
--- a/linden/indra/llmedia/llmediaimplllmozlib.h
+++ b/linden/indra/llmedia/llmediaimplllmozlib.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplquicktime.cpp b/linden/indra/llmedia/llmediaimplquicktime.cpp
index 8f7686d..5bd530d 100644
--- a/linden/indra/llmedia/llmediaimplquicktime.cpp
+++ b/linden/indra/llmedia/llmediaimplquicktime.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplquicktime.h b/linden/indra/llmedia/llmediaimplquicktime.h
index de8e9e2..c8de1dd 100644
--- a/linden/indra/llmedia/llmediaimplquicktime.h
+++ b/linden/indra/llmedia/llmediaimplquicktime.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaimplregister.h b/linden/indra/llmedia/llmediaimplregister.h
index a4b802f..fcc3ab7 100644
--- a/linden/indra/llmedia/llmediaimplregister.h
+++ b/linden/indra/llmedia/llmediaimplregister.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediamanager.cpp b/linden/indra/llmedia/llmediamanager.cpp
index 7fe0df3..59dc8a0 100644
--- a/linden/indra/llmedia/llmediamanager.cpp
+++ b/linden/indra/llmedia/llmediamanager.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediamanager.h b/linden/indra/llmedia/llmediamanager.h
index ef721b2..f618f4c 100644
--- a/linden/indra/llmedia/llmediamanager.h
+++ b/linden/indra/llmedia/llmediamanager.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/llmedia/llmediaobserver.h b/linden/indra/llmedia/llmediaobserver.h
index 079cb29..e6da4f6 100644
--- a/linden/indra/llmedia/llmediaobserver.h
+++ b/linden/indra/llmedia/llmediaobserver.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2007&license=viewergpl$ 5 * $LicenseInfo:firstyear=2007&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2007-2008, Linden Research, Inc. 7 * Copyright (c) 2007-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab