aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llimage
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/llimage')
-rw-r--r--linden/indra/llimage/CMakeLists.txt1
-rw-r--r--linden/indra/llimage/llimage.cpp23
-rw-r--r--linden/indra/llimage/llimage.h3
-rw-r--r--linden/indra/llimage/llimagebmp.cpp3
-rw-r--r--linden/indra/llimage/llimagebmp.h3
-rw-r--r--linden/indra/llimage/llimagedxt.cpp3
-rw-r--r--linden/indra/llimage/llimagedxt.h3
-rw-r--r--linden/indra/llimage/llimagej2c.cpp13
-rw-r--r--linden/indra/llimage/llimagej2c.h3
-rw-r--r--linden/indra/llimage/llimagejpeg.cpp3
-rw-r--r--linden/indra/llimage/llimagejpeg.h3
-rw-r--r--linden/indra/llimage/llimagepng.cpp3
-rw-r--r--linden/indra/llimage/llimagepng.h3
-rw-r--r--linden/indra/llimage/llimagetga.cpp5
-rw-r--r--linden/indra/llimage/llimagetga.h3
-rw-r--r--linden/indra/llimage/llimageworker.cpp3
-rw-r--r--linden/indra/llimage/llimageworker.h3
-rw-r--r--linden/indra/llimage/llmapimagetype.h3
-rw-r--r--linden/indra/llimage/llpngwrapper.cpp3
-rw-r--r--linden/indra/llimage/llpngwrapper.h3
20 files changed, 56 insertions, 34 deletions
diff --git a/linden/indra/llimage/CMakeLists.txt b/linden/indra/llimage/CMakeLists.txt
index 1a4d92b..5fa7472 100644
--- a/linden/indra/llimage/CMakeLists.txt
+++ b/linden/indra/llimage/CMakeLists.txt
@@ -14,6 +14,7 @@ include_directories(
14 ${LLMATH_INCLUDE_DIRS} 14 ${LLMATH_INCLUDE_DIRS}
15 ${LLVFS_INCLUDE_DIRS} 15 ${LLVFS_INCLUDE_DIRS}
16 ${PNG_INCLUDE_DIRS} 16 ${PNG_INCLUDE_DIRS}
17 ${ZLIB_INCLUDE_DIRS}
17 ) 18 )
18 19
19set(llimage_SOURCE_FILES 20set(llimage_SOURCE_FILES
diff --git a/linden/indra/llimage/llimage.cpp b/linden/indra/llimage/llimage.cpp
index d4489fc..88edc99 100644
--- a/linden/indra/llimage/llimage.cpp
+++ b/linden/indra/llimage/llimage.cpp
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
@@ -1136,7 +1137,7 @@ file_extensions[] =
1136 { "dxt", IMG_CODEC_DXT }, 1137 { "dxt", IMG_CODEC_DXT },
1137 { "png", IMG_CODEC_PNG } 1138 { "png", IMG_CODEC_PNG }
1138}; 1139};
1139#define NUM_FILE_EXTENSIONS sizeof(file_extensions)/sizeof(file_extensions[0]) 1140#define NUM_FILE_EXTENSIONS LL_ARRAY_SIZE(file_extensions)
1140 1141
1141static std::string find_file(std::string &name, S8 *codec) 1142static std::string find_file(std::string &name, S8 *codec)
1142{ 1143{
@@ -1512,7 +1513,9 @@ BOOL LLImageFormatted::load(const std::string &filename)
1512 resetLastError(); 1513 resetLastError();
1513 1514
1514 S32 file_size = 0; 1515 S32 file_size = 0;
1515 apr_file_t* apr_file = ll_apr_file_open(filename, LL_APR_RB, &file_size); 1516 LLAPRFile infile ;
1517 infile.open(filename, LL_APR_RB, NULL, &file_size);
1518 apr_file_t* apr_file = infile.getFileHandle();
1516 if (!apr_file) 1519 if (!apr_file)
1517 { 1520 {
1518 setLastError("Unable to open file for reading", filename); 1521 setLastError("Unable to open file for reading", filename);
@@ -1521,7 +1524,6 @@ BOOL LLImageFormatted::load(const std::string &filename)
1521 if (file_size == 0) 1524 if (file_size == 0)
1522 { 1525 {
1523 setLastError("File is empty",filename); 1526 setLastError("File is empty",filename);
1524 apr_file_close(apr_file);
1525 return FALSE; 1527 return FALSE;
1526 } 1528 }
1527 1529
@@ -1539,8 +1541,7 @@ BOOL LLImageFormatted::load(const std::string &filename)
1539 { 1541 {
1540 res = updateData(); 1542 res = updateData();
1541 } 1543 }
1542 apr_file_close(apr_file); 1544
1543
1544 return res; 1545 return res;
1545} 1546}
1546 1547
@@ -1548,16 +1549,16 @@ BOOL LLImageFormatted::save(const std::string &filename)
1548{ 1549{
1549 resetLastError(); 1550 resetLastError();
1550 1551
1551 apr_file_t* apr_file = ll_apr_file_open(filename, LL_APR_WB); 1552 LLAPRFile outfile ;
1552 if (!apr_file) 1553 outfile.open(filename, LL_APR_WB);
1554 if (!outfile.getFileHandle())
1553 { 1555 {
1554 setLastError("Unable to open file for writing", filename); 1556 setLastError("Unable to open file for writing", filename);
1555 return FALSE; 1557 return FALSE;
1556 } 1558 }
1557 1559
1558 ll_apr_file_write(apr_file, getData(), getDataSize()); 1560 outfile.write(getData(), getDataSize());
1559 apr_file_close(apr_file); 1561 outfile.close() ;
1560
1561 return TRUE; 1562 return TRUE;
1562} 1563}
1563 1564
diff --git a/linden/indra/llimage/llimage.h b/linden/indra/llimage/llimage.h
index 321eda8..bd609b6 100644
--- a/linden/indra/llimage/llimage.h
+++ b/linden/indra/llimage/llimage.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagebmp.cpp b/linden/indra/llimage/llimagebmp.cpp
index ddc8825..ceded29 100644
--- a/linden/indra/llimage/llimagebmp.cpp
+++ b/linden/indra/llimage/llimagebmp.cpp
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagebmp.h b/linden/indra/llimage/llimagebmp.h
index 9c0c611..c4d6fd8 100644
--- a/linden/indra/llimage/llimagebmp.h
+++ b/linden/indra/llimage/llimagebmp.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagedxt.cpp b/linden/indra/llimage/llimagedxt.cpp
index fe66ee3..1ce4517 100644
--- a/linden/indra/llimage/llimagedxt.cpp
+++ b/linden/indra/llimage/llimagedxt.cpp
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagedxt.h b/linden/indra/llimage/llimagedxt.h
index 3d81414..bc2d652 100644
--- a/linden/indra/llimage/llimagedxt.h
+++ b/linden/indra/llimage/llimagedxt.h
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagej2c.cpp b/linden/indra/llimage/llimagej2c.cpp
index fe5d656..1b93c21 100644
--- a/linden/indra/llimage/llimagej2c.cpp
+++ b/linden/indra/llimage/llimagej2c.cpp
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
@@ -418,7 +419,9 @@ BOOL LLImageJ2C::loadAndValidate(const std::string &filename)
418 resetLastError(); 419 resetLastError();
419 420
420 S32 file_size = 0; 421 S32 file_size = 0;
421 apr_file_t* apr_file = ll_apr_file_open(filename, LL_APR_RB, &file_size); 422 LLAPRFile infile ;
423 infile.open(filename, LL_APR_RB, NULL, &file_size);
424 apr_file_t* apr_file = infile.getFileHandle() ;
422 if (!apr_file) 425 if (!apr_file)
423 { 426 {
424 setLastError("Unable to open file for reading", filename); 427 setLastError("Unable to open file for reading", filename);
@@ -427,7 +430,6 @@ BOOL LLImageJ2C::loadAndValidate(const std::string &filename)
427 else if (file_size == 0) 430 else if (file_size == 0)
428 { 431 {
429 setLastError("File is empty",filename); 432 setLastError("File is empty",filename);
430 apr_file_close(apr_file);
431 res = FALSE; 433 res = FALSE;
432 } 434 }
433 else 435 else
@@ -435,7 +437,8 @@ BOOL LLImageJ2C::loadAndValidate(const std::string &filename)
435 U8 *data = new U8[file_size]; 437 U8 *data = new U8[file_size];
436 apr_size_t bytes_read = file_size; 438 apr_size_t bytes_read = file_size;
437 apr_status_t s = apr_file_read(apr_file, data, &bytes_read); // modifies bytes_read 439 apr_status_t s = apr_file_read(apr_file, data, &bytes_read); // modifies bytes_read
438 apr_file_close(apr_file); 440 infile.close() ;
441
439 if (s != APR_SUCCESS || (S32)bytes_read != file_size) 442 if (s != APR_SUCCESS || (S32)bytes_read != file_size)
440 { 443 {
441 delete[] data; 444 delete[] data;
@@ -447,7 +450,7 @@ BOOL LLImageJ2C::loadAndValidate(const std::string &filename)
447 res = validate(data, file_size); 450 res = validate(data, file_size);
448 } 451 }
449 } 452 }
450 453
451 if (!mLastError.empty()) 454 if (!mLastError.empty())
452 { 455 {
453 LLImage::setLastError(mLastError); 456 LLImage::setLastError(mLastError);
diff --git a/linden/indra/llimage/llimagej2c.h b/linden/indra/llimage/llimagej2c.h
index ad514eb..23f6ef5 100644
--- a/linden/indra/llimage/llimagej2c.h
+++ b/linden/indra/llimage/llimagej2c.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagejpeg.cpp b/linden/indra/llimage/llimagejpeg.cpp
index afb3368..fa0dd3f 100644
--- a/linden/indra/llimage/llimagejpeg.cpp
+++ b/linden/indra/llimage/llimagejpeg.cpp
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagejpeg.h b/linden/indra/llimage/llimagejpeg.h
index 0914fd7..884d071 100644
--- a/linden/indra/llimage/llimagejpeg.h
+++ b/linden/indra/llimage/llimagejpeg.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagepng.cpp b/linden/indra/llimage/llimagepng.cpp
index f2d6376..b5de104 100644
--- a/linden/indra/llimage/llimagepng.cpp
+++ b/linden/indra/llimage/llimagepng.cpp
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagepng.h b/linden/indra/llimage/llimagepng.h
index 0387982..083dda7 100644
--- a/linden/indra/llimage/llimagepng.h
+++ b/linden/indra/llimage/llimagepng.h
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimagetga.cpp b/linden/indra/llimage/llimagetga.cpp
index 853a0dc..a6721bf 100644
--- a/linden/indra/llimage/llimagetga.cpp
+++ b/linden/indra/llimage/llimagetga.cpp
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
@@ -104,7 +105,7 @@ LLImageTGA::LLImageTGA(const std::string& file_name)
104 105
105LLImageTGA::~LLImageTGA() 106LLImageTGA::~LLImageTGA()
106{ 107{
107 delete mColorMap; 108 delete [] mColorMap;
108} 109}
109 110
110BOOL LLImageTGA::updateData() 111BOOL LLImageTGA::updateData()
diff --git a/linden/indra/llimage/llimagetga.h b/linden/indra/llimage/llimagetga.h
index b522930..e237cc5 100644
--- a/linden/indra/llimage/llimagetga.h
+++ b/linden/indra/llimage/llimagetga.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimageworker.cpp b/linden/indra/llimage/llimageworker.cpp
index d570ad1..532e996 100644
--- a/linden/indra/llimage/llimageworker.cpp
+++ b/linden/indra/llimage/llimageworker.cpp
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llimageworker.h b/linden/indra/llimage/llimageworker.h
index a133f77..879fcf5 100644
--- a/linden/indra/llimage/llimageworker.h
+++ b/linden/indra/llimage/llimageworker.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llmapimagetype.h b/linden/indra/llimage/llmapimagetype.h
index 0e17aaa..762d28b 100644
--- a/linden/indra/llimage/llmapimagetype.h
+++ b/linden/indra/llimage/llmapimagetype.h
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llpngwrapper.cpp b/linden/indra/llimage/llpngwrapper.cpp
index 2b0f7b6..0dd991a 100644
--- a/linden/indra/llimage/llpngwrapper.cpp
+++ b/linden/indra/llimage/llpngwrapper.cpp
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/llimage/llpngwrapper.h b/linden/indra/llimage/llpngwrapper.h
index 87ddb9e..2e6c1dc 100644
--- a/linden/indra/llimage/llpngwrapper.h
+++ b/linden/indra/llimage/llpngwrapper.h
@@ -16,7 +16,8 @@
16 * There are special exceptions to the terms and conditions of the GPL as 16 * There are special exceptions to the terms and conditions of the GPL as
17 * it is applied to this Source Code. View the full text of the exception 17 * it is applied to this Source Code. View the full text of the exception
18 * in the file doc/FLOSS-exception.txt in this software distribution, or 18 * in the file doc/FLOSS-exception.txt in this software distribution, or
19 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 19 * online at
20 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
20 * 21 *
21 * By copying, modifying or distributing this software, you acknowledge 22 * By copying, modifying or distributing this software, you acknowledge
22 * that you have read and understood your obligations described above, 23 * that you have read and understood your obligations described above,