diff options
Diffstat (limited to 'linden/indra/llimage/CMakeLists.txt')
-rw-r--r-- | linden/indra/llimage/CMakeLists.txt | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/linden/indra/llimage/CMakeLists.txt b/linden/indra/llimage/CMakeLists.txt new file mode 100644 index 0000000..5593b4a --- /dev/null +++ b/linden/indra/llimage/CMakeLists.txt | |||
@@ -0,0 +1,50 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(llimage) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(LLCommon) | ||
7 | include(LLImage) | ||
8 | include(LLMath) | ||
9 | include(LLVFS) | ||
10 | |||
11 | include_directories( | ||
12 | ${LLCOMMON_INCLUDE_DIRS} | ||
13 | ${LLMATH_INCLUDE_DIRS} | ||
14 | ${LLVFS_INCLUDE_DIRS} | ||
15 | ${PNG_INCLUDE_DIRS} | ||
16 | ) | ||
17 | |||
18 | set(llimage_SOURCE_FILES | ||
19 | llimagebmp.cpp | ||
20 | llimage.cpp | ||
21 | llimagedxt.cpp | ||
22 | llimagej2c.cpp | ||
23 | llimagejpeg.cpp | ||
24 | llimagepng.cpp | ||
25 | llimagetga.cpp | ||
26 | llimageworker.cpp | ||
27 | llpngwrapper.cpp | ||
28 | ) | ||
29 | |||
30 | set(llimage_HEADER_FILES | ||
31 | CMakeLists.txt | ||
32 | |||
33 | llimage.h | ||
34 | llimagebmp.h | ||
35 | llimagedxt.h | ||
36 | llimagej2c.h | ||
37 | llimagejpeg.h | ||
38 | llimagepng.h | ||
39 | llimagetga.h | ||
40 | llimageworker.h | ||
41 | llmapimagetype.h | ||
42 | llpngwrapper.h | ||
43 | ) | ||
44 | |||
45 | set_source_files_properties(${llimage_HEADER_FILES} | ||
46 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
47 | |||
48 | list(APPEND llimage_SOURCE_FILES ${llimage_HEADER_FILES}) | ||
49 | |||
50 | add_library (llimage ${llimage_SOURCE_FILES}) | ||