diff options
Diffstat (limited to 'linden/indra/llaudio/CMakeLists.txt')
-rw-r--r-- | linden/indra/llaudio/CMakeLists.txt | 43 |
1 files changed, 22 insertions, 21 deletions
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt index 0a668f9..1a0527c 100644 --- a/linden/indra/llaudio/CMakeLists.txt +++ b/linden/indra/llaudio/CMakeLists.txt | |||
@@ -4,6 +4,7 @@ project(llaudio) | |||
4 | 4 | ||
5 | # Current starting point for CMake. Seems rather arbitrary - MC | 5 | # Current starting point for CMake. Seems rather arbitrary - MC |
6 | include(00-Common) | 6 | include(00-Common) |
7 | include(LLAudio) | ||
7 | include(Audio) | 8 | include(Audio) |
8 | include(OPENAL) | 9 | include(OPENAL) |
9 | include(FMOD) | 10 | include(FMOD) |
@@ -12,9 +13,9 @@ include(LLCommon) | |||
12 | include(LLMath) | 13 | include(LLMath) |
13 | include(LLMessage) | 14 | include(LLMessage) |
14 | include(LLVFS) | 15 | include(LLVFS) |
15 | include(LLMedia) | ||
16 | 16 | ||
17 | include_directories( | 17 | include_directories( |
18 | ${LLAUDIO_INCLUDE_DIRS} | ||
18 | ${FMOD_INCLUDE_DIR} | 19 | ${FMOD_INCLUDE_DIR} |
19 | ${LLCOMMON_INCLUDE_DIRS} | 20 | ${LLCOMMON_INCLUDE_DIRS} |
20 | ${LLMATH_INCLUDE_DIRS} | 21 | ${LLMATH_INCLUDE_DIRS} |
@@ -26,43 +27,43 @@ include_directories( | |||
26 | ${VORBIS_INCLUDE_DIRS} | 27 | ${VORBIS_INCLUDE_DIRS} |
27 | ${OPENAL_LIB_INCLUDE_DIRS} | 28 | ${OPENAL_LIB_INCLUDE_DIRS} |
28 | ${FREEAULT_LIB_INCLUDE_DIRS} | 29 | ${FREEAULT_LIB_INCLUDE_DIRS} |
29 | ${LLMEDIA_INCLUDE_DIRS} | ||
30 | ${GSTREAMER_INCLUDE_DIRS} | ||
31 | ) | 30 | ) |
32 | 31 | ||
33 | set(llaudio_SOURCE_FILES | 32 | set(llaudio_SOURCE_FILES |
34 | audioengine.cpp | 33 | llaudioengine.cpp |
35 | listener.cpp | 34 | lllistener.cpp |
36 | llaudiodecodemgr.cpp | 35 | llaudiodecodemgr.cpp |
37 | vorbisdecode.cpp | 36 | llvorbisdecode.cpp |
38 | vorbisencode.cpp | 37 | llvorbisencode.cpp |
39 | ) | 38 | ) |
40 | 39 | ||
41 | set(llaudio_HEADER_FILES | 40 | set(llaudio_HEADER_FILES |
42 | CMakeLists.txt | 41 | CMakeLists.txt |
43 | 42 | ||
44 | audioengine.h | 43 | llaudioengine.h |
45 | listener.h | 44 | lllistener.h |
46 | llaudiodecodemgr.h | 45 | llaudiodecodemgr.h |
47 | vorbisdecode.h | 46 | llvorbisdecode.h |
48 | vorbisencode.h | 47 | llvorbisencode.h |
49 | windgen.h | 48 | llwindgen.h |
50 | ) | 49 | ) |
51 | 50 | ||
52 | if (FMOD) | 51 | if (FMOD) |
53 | list(APPEND llaudio_SOURCE_FILES | 52 | list(APPEND llaudio_SOURCE_FILES |
54 | audioengine_fmod.cpp | 53 | llaudioengine_fmod.cpp |
55 | listener_fmod.cpp | 54 | lllistener_fmod.cpp |
55 | llstreamingaudio_fmod.cpp | ||
56 | ) | 56 | ) |
57 | 57 | ||
58 | list(APPEND llaudio_HEADER_FILES | 58 | list(APPEND llaudio_HEADER_FILES |
59 | audioengine_fmod.h | 59 | llaudioengine_fmod.h |
60 | listener_fmod.h | 60 | lllistener_fmod.h |
61 | llstreamingaudio_fmod.h | ||
61 | ) | 62 | ) |
62 | 63 | ||
63 | if (LINUX) | 64 | if (LINUX) |
64 | if (${CXX_VERSION} MATCHES "4.[23]") | 65 | if (${CXX_VERSION} MATCHES "4.[23]") |
65 | set_source_files_properties(audioengine_fmod.cpp | 66 | set_source_files_properties(llaudioengine_fmod.cpp |
66 | COMPILE_FLAGS -Wno-error=write-strings) | 67 | COMPILE_FLAGS -Wno-error=write-strings) |
67 | endif (${CXX_VERSION} MATCHES "4.[23]") | 68 | endif (${CXX_VERSION} MATCHES "4.[23]") |
68 | endif (LINUX) | 69 | endif (LINUX) |
@@ -70,13 +71,13 @@ endif (FMOD) | |||
70 | 71 | ||
71 | if (OPENAL) | 72 | if (OPENAL) |
72 | list(APPEND llaudio_SOURCE_FILES | 73 | list(APPEND llaudio_SOURCE_FILES |
73 | audioengine_openal.cpp | 74 | llaudioengine_openal.cpp |
74 | listener_openal.cpp | 75 | lllistener_openal.cpp |
75 | ) | 76 | ) |
76 | 77 | ||
77 | list(APPEND llaudio_HEADER_FILES | 78 | list(APPEND llaudio_HEADER_FILES |
78 | audioengine_openal.h | 79 | llaudioengine_openal.h |
79 | listener_openal.h | 80 | lllistener_openal.h |
80 | ) | 81 | ) |
81 | endif (OPENAL) | 82 | endif (OPENAL) |
82 | 83 | ||