diff options
Diffstat (limited to 'linden/indra/llaudio/CMakeLists.txt')
-rw-r--r-- | linden/indra/llaudio/CMakeLists.txt | 10 |
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt index 8a26e54..70041e7 100644 --- a/linden/indra/llaudio/CMakeLists.txt +++ b/linden/indra/llaudio/CMakeLists.txt | |||
@@ -6,6 +6,7 @@ include(00-Common) | |||
6 | include(Audio) | 6 | include(Audio) |
7 | include(OPENAL) | 7 | include(OPENAL) |
8 | include(FMOD) | 8 | include(FMOD) |
9 | include(OPENAL) | ||
9 | include(LLCommon) | 10 | include(LLCommon) |
10 | include(LLMath) | 11 | include(LLMath) |
11 | include(LLMessage) | 12 | include(LLMessage) |
@@ -76,7 +77,6 @@ if (OPENAL) | |||
76 | audioengine_openal.h | 77 | audioengine_openal.h |
77 | listener_openal.h | 78 | listener_openal.h |
78 | ) | 79 | ) |
79 | |||
80 | endif (OPENAL) | 80 | endif (OPENAL) |
81 | 81 | ||
82 | set_source_files_properties(${llaudio_HEADER_FILES} | 82 | set_source_files_properties(${llaudio_HEADER_FILES} |
@@ -85,3 +85,11 @@ set_source_files_properties(${llaudio_HEADER_FILES} | |||
85 | list(APPEND llaudio_SOURCE_FILES ${llaudio_HEADER_FILES}) | 85 | list(APPEND llaudio_SOURCE_FILES ${llaudio_HEADER_FILES}) |
86 | 86 | ||
87 | add_library (llaudio ${llaudio_SOURCE_FILES}) | 87 | add_library (llaudio ${llaudio_SOURCE_FILES}) |
88 | |||
89 | target_link_libraries( | ||
90 | llaudio | ||
91 | ${VORBISENC_LIBRARIES} | ||
92 | ${VORBISFILE_LIBRARIES} | ||
93 | ${VORBIS_LIBRARIES} | ||
94 | ${OGG_LIBRARIES} | ||
95 | ) | ||