diff options
Diffstat (limited to '')
-rw-r--r-- | linden/indra/llaudio/CMakeLists.txt | 19 |
1 files changed, 19 insertions, 0 deletions
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt index b662023..aa15a9d 100644 --- a/linden/indra/llaudio/CMakeLists.txt +++ b/linden/indra/llaudio/CMakeLists.txt | |||
@@ -9,6 +9,7 @@ include(LLCommon) | |||
9 | include(LLMath) | 9 | include(LLMath) |
10 | include(LLMessage) | 10 | include(LLMessage) |
11 | include(LLVFS) | 11 | include(LLVFS) |
12 | include(LLMedia) | ||
12 | 13 | ||
13 | include_directories( | 14 | include_directories( |
14 | ${FMOD_INCLUDE_DIR} | 15 | ${FMOD_INCLUDE_DIR} |
@@ -20,6 +21,10 @@ include_directories( | |||
20 | ${VORBISENC_INCLUDE_DIRS} | 21 | ${VORBISENC_INCLUDE_DIRS} |
21 | ${VORBISFILE_INCLUDE_DIRS} | 22 | ${VORBISFILE_INCLUDE_DIRS} |
22 | ${VORBIS_INCLUDE_DIRS} | 23 | ${VORBIS_INCLUDE_DIRS} |
24 | ${OPENAL_LIB_INCLUDE_DIRS} | ||
25 | ${FREEAULT_LIB_INCLUDE_DIRS} | ||
26 | ${LLMEDIA_INCLUDE_DIRS} | ||
27 | ${GSTREAMER_INCLUDE_DIRS} | ||
23 | ) | 28 | ) |
24 | 29 | ||
25 | set(llaudio_SOURCE_FILES | 30 | set(llaudio_SOURCE_FILES |
@@ -38,6 +43,7 @@ set(llaudio_HEADER_FILES | |||
38 | llaudiodecodemgr.h | 43 | llaudiodecodemgr.h |
39 | vorbisdecode.h | 44 | vorbisdecode.h |
40 | vorbisencode.h | 45 | vorbisencode.h |
46 | windgen.h | ||
41 | ) | 47 | ) |
42 | 48 | ||
43 | if (FMOD) | 49 | if (FMOD) |
@@ -59,6 +65,19 @@ if (FMOD) | |||
59 | endif (LINUX) | 65 | endif (LINUX) |
60 | endif (FMOD) | 66 | endif (FMOD) |
61 | 67 | ||
68 | if (OPENAL) | ||
69 | list(APPEND llaudio_SOURCE_FILES | ||
70 | audioengine_openal.cpp | ||
71 | listener_openal.cpp | ||
72 | ) | ||
73 | |||
74 | list(APPEND llaudio_HEADER_FILES | ||
75 | audioengine_openal.h | ||
76 | listener_openal.h | ||
77 | ) | ||
78 | |||
79 | endif (OPENAL) | ||
80 | |||
62 | set_source_files_properties(${llaudio_HEADER_FILES} | 81 | set_source_files_properties(${llaudio_HEADER_FILES} |
63 | PROPERTIES HEADER_FILE_ONLY TRUE) | 82 | PROPERTIES HEADER_FILE_ONLY TRUE) |
64 | 83 | ||