diff options
Diffstat (limited to '')
-rw-r--r-- | linden/indra/libotr/CMakeLists.txt | 31 |
1 files changed, 15 insertions, 16 deletions
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt index f0561d8..ca818a1 100644 --- a/linden/indra/libotr/CMakeLists.txt +++ b/linden/indra/libotr/CMakeLists.txt | |||
@@ -1,8 +1,11 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | project(libgpg-error) | 3 | project(otr) |
4 | project(libgcrypt) | 4 | |
5 | project(libotr) | 5 | include(00-Common) |
6 | include(libgpg-error) | ||
7 | include(libgcrypt) | ||
8 | include(Linking) | ||
6 | 9 | ||
7 | if (WINDOWS) | 10 | if (WINDOWS) |
8 | include_directories( | 11 | include_directories( |
@@ -16,11 +19,10 @@ else (WINDOWS) | |||
16 | include_directories( | 19 | include_directories( |
17 | ${LIBGPG-ERROR_INCLUDE_DIRS} | 20 | ${LIBGPG-ERROR_INCLUDE_DIRS} |
18 | ${LIBGCRYPT_INCLUDE_DIRS} | 21 | ${LIBGCRYPT_INCLUDE_DIRS} |
19 | ../libgcrypt/libgcrypt-1.2.2/src | ||
20 | ) | 22 | ) |
21 | endif (WINDOWS) | 23 | endif (WINDOWS) |
22 | 24 | ||
23 | set(libotr_SOURCE_FILES | 25 | set(otr_SOURCE_FILES |
24 | libotr-3.2.0/src/auth.c | 26 | libotr-3.2.0/src/auth.c |
25 | libotr-3.2.0/src/b64.c | 27 | libotr-3.2.0/src/b64.c |
26 | libotr-3.2.0/src/context.c | 28 | libotr-3.2.0/src/context.c |
@@ -34,7 +36,7 @@ set(libotr_SOURCE_FILES | |||
34 | libotr-3.2.0/src/userstate.c | 36 | libotr-3.2.0/src/userstate.c |
35 | ) | 37 | ) |
36 | 38 | ||
37 | set(libotr_HEADER_FILES | 39 | set(otr_HEADER_FILES |
38 | CMakeLists.txt | 40 | CMakeLists.txt |
39 | 41 | ||
40 | libotr-3.2.0/src/auth.h | 42 | libotr-3.2.0/src/auth.h |
@@ -53,19 +55,16 @@ set(libotr_HEADER_FILES | |||
53 | libotr-3.2.0/src/version.h | 55 | libotr-3.2.0/src/version.h |
54 | ) | 56 | ) |
55 | 57 | ||
56 | set_source_files_properties(${libotr_HEADER_FILES} | 58 | set_source_files_properties(${otr_HEADER_FILES} |
57 | PROPERTIES HEADER_FILE_ONLY TRUE) | 59 | PROPERTIES HEADER_FILE_ONLY TRUE) |
58 | 60 | ||
59 | list(APPEND libotr_SOURCE_FILES ${libotr_HEADER_FILES}) | 61 | list(APPEND libotr_SOURCE_FILES ${otr_HEADER_FILES}) |
60 | 62 | ||
61 | add_library (libotr ${libotr_SOURCE_FILES}) | 63 | add_library (otr ${otr_SOURCE_FILES}) |
62 | target_link_libraries(libotr | 64 | target_link_libraries(otr |
63 | gcrypt | 65 | ${LIBGCRYPT_LIBRARIES} |
64 | gpg-error | 66 | ${LIBGPG-ERROR_LIBRARIES} |
65 | ) | 67 | ) |
66 | 68 | ||
67 | # Not sure if either or both are needed, does not seem to hurt. | 69 | add_dependencies(otr gcrypt) |
68 | # Still does not make things build in the right sequence. sigh | ||
69 | add_dependencies(libotr EP_libgcrpt) | ||
70 | add_dependencies(libotr libgcrypt) | ||
71 | 70 | ||