aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/libotr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--[-rwxr-xr-x]linden/indra/libotr/CMakeLists.txt122
1 files changed, 61 insertions, 61 deletions
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt
index 974a68f..f81e71a 100755..100644
--- a/linden/indra/libotr/CMakeLists.txt
+++ b/linden/indra/libotr/CMakeLists.txt
@@ -1,61 +1,61 @@
1# -*- cmake -*- 1# -*- cmake -*-
2 2
3project(libotr) 3project(libotr)
4 4
5if (WINDOWS) 5if (WINDOWS)
6 include_directories( 6 include_directories(
7 ../gpg.vs/inc.vs 7 ../gpg.vs/inc.vs
8 ../gpg.vs/libgpg-error-1.1.vs/custom 8 ../gpg.vs/libgpg-error-1.1.vs/custom
9 ../gpg.vs/libgcrypt-1.2.2.vs/custom 9 ../gpg.vs/libgcrypt-1.2.2.vs/custom
10 ../libgpg-error/libgpg-error-1.0/src 10 ../libgpg-error/libgpg-error-1.0/src
11 ../libgcrypt/libgcrypt-1.2.2/src 11 ../libgcrypt/libgcrypt-1.2.2/src
12 ) 12 )
13else (WINDOWS) 13else (WINDOWS)
14 include_directories( 14 include_directories(
15 ../libgpg-error/libgpg-error-1.0/src 15 ../libgpg-error/libgpg-error-1.0/src
16 ../libgcrypt/libgcrypt-1.2.2/src 16 ../libgcrypt/libgcrypt-1.2.2/src
17 ) 17 )
18endif (WINDOWS) 18endif (WINDOWS)
19 19
20set(libotr_SOURCE_FILES 20set(libotr_SOURCE_FILES
21 libotr-3.2.0/src/auth.c 21 libotr-3.2.0/src/auth.c
22 libotr-3.2.0/src/b64.c 22 libotr-3.2.0/src/b64.c
23 libotr-3.2.0/src/context.c 23 libotr-3.2.0/src/context.c
24 libotr-3.2.0/src/dh.c 24 libotr-3.2.0/src/dh.c
25 libotr-3.2.0/src/mem.c 25 libotr-3.2.0/src/mem.c
26 libotr-3.2.0/src/message.c 26 libotr-3.2.0/src/message.c
27 libotr-3.2.0/src/privkey.c 27 libotr-3.2.0/src/privkey.c
28 libotr-3.2.0/src/proto.c 28 libotr-3.2.0/src/proto.c
29 libotr-3.2.0/src/sm.c 29 libotr-3.2.0/src/sm.c
30 libotr-3.2.0/src/tlv.c 30 libotr-3.2.0/src/tlv.c
31 libotr-3.2.0/src/userstate.c 31 libotr-3.2.0/src/userstate.c
32 ) 32 )
33 33
34set(libotr_HEADER_FILES 34set(libotr_HEADER_FILES
35 CMakeLists.txt 35 CMakeLists.txt
36 36
37 libotr-3.2.0/src/auth.h 37 libotr-3.2.0/src/auth.h
38 libotr-3.2.0/src/b64.h 38 libotr-3.2.0/src/b64.h
39 libotr-3.2.0/src/context.h 39 libotr-3.2.0/src/context.h
40 libotr-3.2.0/src/dh.h 40 libotr-3.2.0/src/dh.h
41 libotr-3.2.0/src/mem.h 41 libotr-3.2.0/src/mem.h
42 libotr-3.2.0/src/message.h 42 libotr-3.2.0/src/message.h
43 libotr-3.2.0/src/privkey-t.h 43 libotr-3.2.0/src/privkey-t.h
44 libotr-3.2.0/src/privkey.h 44 libotr-3.2.0/src/privkey.h
45 libotr-3.2.0/src/proto.h 45 libotr-3.2.0/src/proto.h
46 libotr-3.2.0/src/serial.h 46 libotr-3.2.0/src/serial.h
47 libotr-3.2.0/src/sm.h 47 libotr-3.2.0/src/sm.h
48 libotr-3.2.0/src/tlv.h 48 libotr-3.2.0/src/tlv.h
49 libotr-3.2.0/src/userstate.h 49 libotr-3.2.0/src/userstate.h
50 libotr-3.2.0/src/version.h 50 libotr-3.2.0/src/version.h
51 ) 51 )
52 52
53set_source_files_properties(${libotr_HEADER_FILES} 53set_source_files_properties(${libotr_HEADER_FILES}
54 PROPERTIES HEADER_FILE_ONLY TRUE) 54 PROPERTIES HEADER_FILE_ONLY TRUE)
55 55
56list(APPEND libotr_SOURCE_FILES ${libotr_HEADER_FILES}) 56list(APPEND libotr_SOURCE_FILES ${libotr_HEADER_FILES})
57 57
58add_library (libotr ${libotr_SOURCE_FILES}) 58add_library (libotr ${libotr_SOURCE_FILES})
59target_link_libraries( 59target_link_libraries(
60 libotr 60 libotr
61 ) 61 )