aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/libgcrypt/libgcrypt-1.2.2/cipher/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/libgcrypt/libgcrypt-1.2.2/cipher/Makefile.in')
-rwxr-xr-xlinden/indra/libgcrypt/libgcrypt-1.2.2/cipher/Makefile.in554
1 files changed, 554 insertions, 0 deletions
diff --git a/linden/indra/libgcrypt/libgcrypt-1.2.2/cipher/Makefile.in b/linden/indra/libgcrypt/libgcrypt-1.2.2/cipher/Makefile.in
new file mode 100755
index 0000000..1832741
--- /dev/null
+++ b/linden/indra/libgcrypt/libgcrypt-1.2.2/cipher/Makefile.in
@@ -0,0 +1,554 @@
1# Makefile.in generated by automake 1.9.4 from Makefile.am.
2# @configure_input@
3
4# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
5# 2003, 2004 Free Software Foundation, Inc.
6# This Makefile.in is free software; the Free Software Foundation
7# gives unlimited permission to copy and/or distribute it,
8# with or without modifications, as long as this notice is preserved.
9
10# This program is distributed in the hope that it will be useful,
11# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
12# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
13# PARTICULAR PURPOSE.
14
15@SET_MAKE@
16
17# Makefile for cipher modules
18# Copyright (C) 1998, 1999, 2000, 2001, 2002,
19# 2003 Free Software Foundation, Inc.
20#
21# This file is part of Libgcrypt.
22#
23# Libgcrypt is free software; you can redistribute it and/or modify
24# it under the terms of the GNU Lesser General Public License as
25# published by the Free Software Foundation; either version 2.1 of
26# the License, or (at your option) any later version.
27#
28# Libgcrypt is distributed in the hope that it will be useful,
29# but WITHOUT ANY WARRANTY; without even the implied warranty of
30# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
31# GNU Lesser General Public License for more details.
32#
33# You should have received a copy of the GNU Lesser General Public
34# License along with this program; if not, write to the Free Software
35# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
36
37# Process this file with automake to produce Makefile.in
38
39SOURCES = $(libcipher_la_SOURCES) $(EXTRA_libcipher_la_SOURCES)
40
41srcdir = @srcdir@
42top_srcdir = @top_srcdir@
43VPATH = @srcdir@
44pkgdatadir = $(datadir)/@PACKAGE@
45pkglibdir = $(libdir)/@PACKAGE@
46pkgincludedir = $(includedir)/@PACKAGE@
47top_builddir = ..
48am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
49INSTALL = @INSTALL@
50install_sh_DATA = $(install_sh) -c -m 644
51install_sh_PROGRAM = $(install_sh) -c
52install_sh_SCRIPT = $(install_sh) -c
53INSTALL_HEADER = $(INSTALL_DATA)
54transform = $(program_transform_name)
55NORMAL_INSTALL = :
56PRE_INSTALL = :
57POST_INSTALL = :
58NORMAL_UNINSTALL = :
59PRE_UNINSTALL = :
60POST_UNINSTALL = :
61build_triplet = @build@
62host_triplet = @host@
63target_triplet = @target@
64subdir = cipher
65DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in ChangeLog
66ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
67am__aclocal_m4_deps = $(top_srcdir)/m4/libtool.m4 \
68 $(top_srcdir)/acinclude.m4 $(top_srcdir)/configure.ac
69am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
70 $(ACLOCAL_M4)
71mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
72CONFIG_HEADER = $(top_builddir)/config.h
73CONFIG_CLEAN_FILES =
74LTLIBRARIES = $(noinst_LTLIBRARIES)
75am__DEPENDENCIES_1 =
76am_libcipher_la_OBJECTS = cipher.lo pubkey.lo ac.lo md.lo primegen.lo \
77 random.lo
78libcipher_la_OBJECTS = $(am_libcipher_la_OBJECTS)
79DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
80depcomp = $(SHELL) $(top_srcdir)/depcomp
81am__depfiles_maybe = depfiles
82COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
83 $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
84LTCOMPILE = $(LIBTOOL) --tag=CC --mode=compile $(CC) $(DEFS) \
85 $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
86 $(AM_CFLAGS) $(CFLAGS)
87CCLD = $(CC)
88LINK = $(LIBTOOL) --tag=CC --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
89 $(AM_LDFLAGS) $(LDFLAGS) -o $@
90SOURCES = $(libcipher_la_SOURCES) $(EXTRA_libcipher_la_SOURCES)
91DIST_SOURCES = $(libcipher_la_SOURCES) $(EXTRA_libcipher_la_SOURCES)
92ETAGS = etags
93CTAGS = ctags
94DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
95ACLOCAL = @ACLOCAL@
96AMDEP_FALSE = @AMDEP_FALSE@
97AMDEP_TRUE = @AMDEP_TRUE@
98AMTAR = @AMTAR@
99AR = @AR@
100AUTOCONF = @AUTOCONF@
101AUTOHEADER = @AUTOHEADER@
102AUTOMAKE = @AUTOMAKE@
103AWK = @AWK@
104CC = @CC@
105CCAS = @CCAS@
106CCASFLAGS = @CCASFLAGS@
107CCDEPMODE = @CCDEPMODE@
108CFLAGS = @CFLAGS@
109CPP = @CPP@
110CPPFLAGS = @CPPFLAGS@
111CROSS_COMPILING_FALSE = @CROSS_COMPILING_FALSE@
112CROSS_COMPILING_TRUE = @CROSS_COMPILING_TRUE@
113CXX = @CXX@
114CXXCPP = @CXXCPP@
115CXXDEPMODE = @CXXDEPMODE@
116CXXFLAGS = @CXXFLAGS@
117CYGPATH_W = @CYGPATH_W@
118DEFS = @DEFS@
119DEPDIR = @DEPDIR@
120ECHO = @ECHO@
121ECHO_C = @ECHO_C@
122ECHO_N = @ECHO_N@
123ECHO_T = @ECHO_T@
124EGREP = @EGREP@
125EXEEXT = @EXEEXT@
126F77 = @F77@
127FFLAGS = @FFLAGS@
128GCRYPT_CIPHERS = @GCRYPT_CIPHERS@
129GCRYPT_DIGESTS = @GCRYPT_DIGESTS@
130GCRYPT_PUBKEY_CIPHERS = @GCRYPT_PUBKEY_CIPHERS@
131GCRYPT_RANDOM = @GCRYPT_RANDOM@
132GPG_ERROR_CFLAGS = @GPG_ERROR_CFLAGS@
133GPG_ERROR_CONFIG = @GPG_ERROR_CONFIG@
134GPG_ERROR_LIBS = @GPG_ERROR_LIBS@
135HAVE_LD_VERSION_SCRIPT_FALSE = @HAVE_LD_VERSION_SCRIPT_FALSE@
136HAVE_LD_VERSION_SCRIPT_TRUE = @HAVE_LD_VERSION_SCRIPT_TRUE@
137INSTALL_DATA = @INSTALL_DATA@
138INSTALL_PROGRAM = @INSTALL_PROGRAM@
139INSTALL_SCRIPT = @INSTALL_SCRIPT@
140INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
141LDFLAGS = @LDFLAGS@
142LIBGCRYPT_CIPHERS = @LIBGCRYPT_CIPHERS@
143LIBGCRYPT_CONFIG_API_VERSION = @LIBGCRYPT_CONFIG_API_VERSION@
144LIBGCRYPT_CONFIG_CFLAGS = @LIBGCRYPT_CONFIG_CFLAGS@
145LIBGCRYPT_CONFIG_LIBS = @LIBGCRYPT_CONFIG_LIBS@
146LIBGCRYPT_DIGESTS = @LIBGCRYPT_DIGESTS@
147LIBGCRYPT_LT_AGE = @LIBGCRYPT_LT_AGE@
148LIBGCRYPT_LT_CURRENT = @LIBGCRYPT_LT_CURRENT@
149LIBGCRYPT_LT_REVISION = @LIBGCRYPT_LT_REVISION@
150LIBGCRYPT_PUBKEY_CIPHERS = @LIBGCRYPT_PUBKEY_CIPHERS@
151LIBGCRYPT_THREAD_MODULES = @LIBGCRYPT_THREAD_MODULES@
152LIBOBJS = @LIBOBJS@
153LIBS = @LIBS@
154LIBTOOL = @LIBTOOL@
155LN_S = @LN_S@
156LTLIBOBJS = @LTLIBOBJS@
157MAINT = @MAINT@
158MAINTAINER_MODE_FALSE = @MAINTAINER_MODE_FALSE@
159MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@
160MAKEINFO = @MAKEINFO@
161MPI_MOD_LIST_LO = @MPI_MOD_LIST_LO@
162MPI_MOD_LIST_O = @MPI_MOD_LIST_O@
163MPI_SFLAGS = @MPI_SFLAGS@
164NOEXECSTACK_FLAGS = @NOEXECSTACK_FLAGS@
165OBJEXT = @OBJEXT@
166PACKAGE = @PACKAGE@
167PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
168PACKAGE_NAME = @PACKAGE_NAME@
169PACKAGE_STRING = @PACKAGE_STRING@
170PACKAGE_TARNAME = @PACKAGE_TARNAME@
171PACKAGE_VERSION = @PACKAGE_VERSION@
172PATH_SEPARATOR = @PATH_SEPARATOR@
173RANLIB = @RANLIB@
174SET_MAKE = @SET_MAKE@
175SHELL = @SHELL@
176STRIP = @STRIP@
177VERSION = @VERSION@
178ac_ct_AR = @ac_ct_AR@
179ac_ct_CC = @ac_ct_CC@
180ac_ct_CXX = @ac_ct_CXX@
181ac_ct_F77 = @ac_ct_F77@
182ac_ct_RANLIB = @ac_ct_RANLIB@
183ac_ct_STRIP = @ac_ct_STRIP@
184am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
185am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
186am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
187am__fastdepCXX_TRUE = @am__fastdepCXX_TRUE@
188am__include = @am__include@
189am__leading_dot = @am__leading_dot@
190am__quote = @am__quote@
191am__tar = @am__tar@
192am__untar = @am__untar@
193bindir = @bindir@
194build = @build@
195build_alias = @build_alias@
196build_cpu = @build_cpu@
197build_os = @build_os@
198build_vendor = @build_vendor@
199datadir = @datadir@
200exec_prefix = @exec_prefix@
201host = @host@
202host_alias = @host_alias@
203host_cpu = @host_cpu@
204host_os = @host_os@
205host_vendor = @host_vendor@
206includedir = @includedir@
207infodir = @infodir@
208install_sh = @install_sh@
209libdir = @libdir@
210libexecdir = @libexecdir@
211localstatedir = @localstatedir@
212mandir = @mandir@
213mkdir_p = @mkdir_p@
214oldincludedir = @oldincludedir@
215prefix = @prefix@
216program_transform_name = @program_transform_name@
217sbindir = @sbindir@
218sharedstatedir = @sharedstatedir@
219sysconfdir = @sysconfdir@
220target = @target@
221target_alias = @target_alias@
222target_cpu = @target_cpu@
223target_os = @target_os@
224target_vendor = @target_vendor@
225EXTRA_DIST = Manifest
226INCLUDES = -I$(top_srcdir)/src
227noinst_LTLIBRARIES = libcipher.la
228GCRYPT_MODULES = @GCRYPT_CIPHERS@ @GCRYPT_PUBKEY_CIPHERS@ @GCRYPT_DIGESTS@ \
229 @GCRYPT_RANDOM@
230
231libcipher_la_DEPENDENCIES = $(GCRYPT_MODULES)
232libcipher_la_LIBADD = $(GCRYPT_MODULES)
233AM_CFLAGS = @GPG_ERROR_CFLAGS@
234libcipher_la_SOURCES = \
235cipher.c pubkey.c ac.c md.c \
236bithelp.h \
237primegen.c \
238random.c random.h \
239rand-internal.h \
240rmd.h
241
242EXTRA_libcipher_la_SOURCES = \
243arcfour.c \
244blowfish.c \
245cast5.c \
246crc.c \
247des.c \
248dsa.c \
249elgamal.c \
250md4.c \
251md5.c \
252rijndael.c \
253rmd160.c \
254rndlinux.c \
255rndegd.c \
256rndunix.c \
257rndw32.c \
258rsa.c \
259serpent.c \
260sha1.c \
261sha256.c \
262sha512.c \
263tiger.c \
264twofish.c \
265rfc2268.c
266
267all: all-am
268
269.SUFFIXES:
270.SUFFIXES: .c .lo .o .obj
271$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__configure_deps)
272 @for dep in $?; do \
273 case '$(am__configure_deps)' in \
274 *$$dep*) \
275 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh \
276 && exit 0; \
277 exit 1;; \
278 esac; \
279 done; \
280 echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu cipher/Makefile'; \
281 cd $(top_srcdir) && \
282 $(AUTOMAKE) --gnu cipher/Makefile
283.PRECIOUS: Makefile
284Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
285 @case '$?' in \
286 *config.status*) \
287 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
288 *) \
289 echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
290 cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
291 esac;
292
293$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
294 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
295
296$(top_srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
297 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
298$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
299 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
300
301clean-noinstLTLIBRARIES:
302 -test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
303 @list='$(noinst_LTLIBRARIES)'; for p in $$list; do \
304 dir="`echo $$p | sed -e 's|/[^/]*$$||'`"; \
305 test "$$dir" != "$$p" || dir=.; \
306 echo "rm -f \"$${dir}/so_locations\""; \
307 rm -f "$${dir}/so_locations"; \
308 done
309libcipher.la: $(libcipher_la_OBJECTS) $(libcipher_la_DEPENDENCIES)
310 $(LINK) $(libcipher_la_LDFLAGS) $(libcipher_la_OBJECTS) $(libcipher_la_LIBADD) $(LIBS)
311
312mostlyclean-compile:
313 -rm -f *.$(OBJEXT)
314
315distclean-compile:
316 -rm -f *.tab.c
317
318@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ac.Plo@am__quote@
319@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arcfour.Plo@am__quote@
320@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/blowfish.Plo@am__quote@
321@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/cast5.Plo@am__quote@
322@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/cipher.Plo@am__quote@
323@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crc.Plo@am__quote@
324@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/des.Plo@am__quote@
325@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/dsa.Plo@am__quote@
326@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/elgamal.Plo@am__quote@
327@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/md.Plo@am__quote@
328@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/md4.Plo@am__quote@
329@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/md5.Plo@am__quote@
330@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/primegen.Plo@am__quote@
331@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pubkey.Plo@am__quote@
332@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/random.Plo@am__quote@
333@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rfc2268.Plo@am__quote@
334@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rijndael.Plo@am__quote@
335@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rmd160.Plo@am__quote@
336@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rndegd.Plo@am__quote@
337@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rndlinux.Plo@am__quote@
338@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rndunix.Plo@am__quote@
339@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rndw32.Plo@am__quote@
340@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rsa.Plo@am__quote@
341@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/serpent.Plo@am__quote@
342@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/sha1.Plo@am__quote@
343@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/sha256.Plo@am__quote@
344@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/sha512.Plo@am__quote@
345@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/tiger.Plo@am__quote@
346@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/twofish.Plo@am__quote@
347
348.c.o:
349@am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
350@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
351@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
352@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
353@am__fastdepCC_FALSE@ $(COMPILE) -c $<
354
355.c.obj:
356@am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ `$(CYGPATH_W) '$<'`; \
357@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
358@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
359@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
360@am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
361
362.c.lo:
363@am__fastdepCC_TRUE@ if $(LTCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
364@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Plo"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
365@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
366@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
367@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
368
369mostlyclean-libtool:
370 -rm -f *.lo
371
372clean-libtool:
373 -rm -rf .libs _libs
374
375distclean-libtool:
376 -rm -f libtool
377uninstall-info-am:
378
379ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
380 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
381 unique=`for i in $$list; do \
382 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
383 done | \
384 $(AWK) ' { files[$$0] = 1; } \
385 END { for (i in files) print i; }'`; \
386 mkid -fID $$unique
387tags: TAGS
388
389TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
390 $(TAGS_FILES) $(LISP)
391 tags=; \
392 here=`pwd`; \
393 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
394 unique=`for i in $$list; do \
395 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
396 done | \
397 $(AWK) ' { files[$$0] = 1; } \
398 END { for (i in files) print i; }'`; \
399 if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
400 test -n "$$unique" || unique=$$empty_fix; \
401 $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
402 $$tags $$unique; \
403 fi
404ctags: CTAGS
405CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
406 $(TAGS_FILES) $(LISP)
407 tags=; \
408 here=`pwd`; \
409 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
410 unique=`for i in $$list; do \
411 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
412 done | \
413 $(AWK) ' { files[$$0] = 1; } \
414 END { for (i in files) print i; }'`; \
415 test -z "$(CTAGS_ARGS)$$tags$$unique" \
416 || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
417 $$tags $$unique
418
419GTAGS:
420 here=`$(am__cd) $(top_builddir) && pwd` \
421 && cd $(top_srcdir) \
422 && gtags -i $(GTAGS_ARGS) $$here
423
424distclean-tags:
425 -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
426
427distdir: $(DISTFILES)
428 @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
429 topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
430 list='$(DISTFILES)'; for file in $$list; do \
431 case $$file in \
432 $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
433 $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
434 esac; \
435 if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
436 dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
437 if test "$$dir" != "$$file" && test "$$dir" != "."; then \
438 dir="/$$dir"; \
439 $(mkdir_p) "$(distdir)$$dir"; \
440 else \
441 dir=''; \
442 fi; \
443 if test -d $$d/$$file; then \
444 if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
445 cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
446 fi; \
447 cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
448 else \
449 test -f $(distdir)/$$file \
450 || cp -p $$d/$$file $(distdir)/$$file \
451 || exit 1; \
452 fi; \
453 done
454check-am: all-am
455check: check-am
456all-am: Makefile $(LTLIBRARIES)
457installdirs:
458install: install-am
459install-exec: install-exec-am
460install-data: install-data-am
461uninstall: uninstall-am
462
463install-am: all-am
464 @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
465
466installcheck: installcheck-am
467install-strip:
468 $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
469 install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
470 `test -z '$(STRIP)' || \
471 echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
472mostlyclean-generic:
473
474clean-generic:
475
476distclean-generic:
477 -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
478
479maintainer-clean-generic:
480 @echo "This command is intended for maintainers to use"
481 @echo "it deletes files that may require special tools to rebuild."
482clean: clean-am
483
484clean-am: clean-generic clean-libtool clean-noinstLTLIBRARIES \
485 mostlyclean-am
486
487distclean: distclean-am
488 -rm -rf ./$(DEPDIR)
489 -rm -f Makefile
490distclean-am: clean-am distclean-compile distclean-generic \
491 distclean-libtool distclean-tags
492
493dvi: dvi-am
494
495dvi-am:
496
497html: html-am
498
499info: info-am
500
501info-am:
502
503install-data-am:
504
505install-exec-am:
506
507install-info: install-info-am
508
509install-man:
510
511installcheck-am:
512
513maintainer-clean: maintainer-clean-am
514 -rm -rf ./$(DEPDIR)
515 -rm -f Makefile
516maintainer-clean-am: distclean-am maintainer-clean-generic
517
518mostlyclean: mostlyclean-am
519
520mostlyclean-am: mostlyclean-compile mostlyclean-generic \
521 mostlyclean-libtool
522
523pdf: pdf-am
524
525pdf-am:
526
527ps: ps-am
528
529ps-am:
530
531uninstall-am: uninstall-info-am
532
533.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
534 clean-libtool clean-noinstLTLIBRARIES ctags distclean \
535 distclean-compile distclean-generic distclean-libtool \
536 distclean-tags distdir dvi dvi-am html html-am info info-am \
537 install install-am install-data install-data-am install-exec \
538 install-exec-am install-info install-info-am install-man \
539 install-strip installcheck installcheck-am installdirs \
540 maintainer-clean maintainer-clean-generic mostlyclean \
541 mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
542 pdf pdf-am ps ps-am tags uninstall uninstall-am \
543 uninstall-info-am
544
545
546# We need to lower the optimization for this module.
547tiger.o: $(srcdir)/tiger.c
548 `echo $(COMPILE) -c $(srcdir)/tiger.c | sed -e 's/-O[2-9s]*/-O1/g' `
549
550tiger.lo: $(srcdir)/tiger.c
551 `echo $(LTCOMPILE) -c $(srcdir)/tiger.c | sed -e 's/-O[2-9s]*/-O1/g' `
552# Tell versions [3.59,3.63) of GNU make to not export all variables.
553# Otherwise a system limit (for SysV at least) may be exceeded.
554.NOEXPORT: